FUJI Electric Co., Ltd
MICREX-F Series

Ethernet Driver

Supported version  TOP Design Studio V1.4.4.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. supported addresses Page 10

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “FUJI Electric Co., Ltd — MICREX-F Series" is as follows:

Series CPU Link I/F Communication method System setting Cable
3. TOP . .
F120S Ethernet . Twisted pair cable
MICREX-F FFU170B communication
F150S (TCP/UDP) ; *Note 1)
setting

*Note 1) Twisted pair cable
- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.
- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a

direct cable.

W Connection configuration

+ 1:1 (one TOP and one external device) connection

1)

L [Hue '

+ 1:N (one TOP and multiple external devices) connection

) ) .

HUB ' |
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device [ = |

PLC select [Ethernet]

Filter : [ pail ~] Search
@ Model () Vendor

Vendor Model
T 5 oo
OPTICON 3
&% MICREXF Series
PATLITE

Giddings & Lewis Motion Control
DELTA TAU Data Systems
KEYENCE Corporation

CEYON Technology

Digital Electronics Corporation
BINAR Elektronic AB
HONEYWELL

ATLAS COPCO

ROOTECH

IDEC Corporation

| ENZE h
4 Eack | B Next ® Cancel
Select Device H
PLC Setting[ MICREX-F Series ]
Alias Name BindIP: lAuto v
Interface : |Ethernet ~
Protocol : |PC Link {Ascii) ~

String Save Mode @ |First LH HL Change

[] use Redundancy

Primary Option

g (92 3| [es E| o0 = [ &
Ethernet Protocal
Timeout msec

Send Wait P B
FileRegister

@ Back v oK ® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “FUJI Electric Co., Ltd".
PLC Select an external device to connect to TOP.

Interface Protocol

MICREX-F Series Ethernet Set Users

Supported Protocol
PC Link (Ascii) PC Link (Binary)

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

ERI2 e B X
Touch Qperation Panel

TO,

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Ethernet]

— Set the TOP communication interface in TOP Design Studio.

Project Opticn X
- Change HMIH] || |\ Add PLC (2] T change PLcicl | [ Delete PLCID]
[ D a0 o Date / Time Sync.  Screen Option || Unit Convert
Opﬁs_nlxdu'é)smng Project Option | Screen Change | HmiSetup | Global Lock & Touch | Project Style  Splash | PLC Buffer Sync.
-4 FieldBus
-4 RFID (0) Use HMI Setup
i Device Setting _ . R =
< COM1 () = o Initialization Edit
5% CoM2 () Project Setting ~
¥ COM3 (0) HMIDisable=0
Ethernet (1) Project Name=New project
-4 PLC1 : MICREX-F Series Start Mode =Menu
Wiregless (0} EE&%UEEE sl
atch Use=
8 UsBDevice (0) Latch Set=0n0
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage =1
DatabaseMessage=1
SystemMessage=1
DisplayLocklcon=0
DisplayPermissionIcon=0
DarkDraw=0
DrawTouchPos=0
TOPID=1
AutoRun=0
Language =English
Project Advanced Setting
HMIDisable =0
RunSleep=50
EffectSleep=50
Communicationsleep=1
ProjectLoadType=1
InitDataPrevscreen=1
ErrorLogWrite=0
BlinkTime =0
‘WatchDog=0
SDCoverOption=0
TaskMonitor=1
CommSleepChglse =0
CommSleepChg=1000
MomentaryBitActionTime =20
CommunicationRatio=0
Ethernet
HMIDisable =0
ETH1=1
IP1=192.168.0.100
Subnet1=255,255.255.0 v
Apply Close
Control Panel (e Ethernet b4
g | 1 T ! .
System Devices [uﬂ Service (=% Option -Port
Ethernet Port @ ETH1 0 -
amam P =2 ., . Li -
A ink Speed : Auto <
1l i~
FLC Security Dat e/ Tine Display Touch Sound MAC Address 00:00:00:00:00:00
IP Address :|  182.168.0.100
N _ _— Subnet Mask :[  255,255.255.0
e &— (@) =~
i & = , AN -~ Gateway !| 192 .168.0.1
J -
Ethernet Serial HOM | Init ial i Sensar Wi-Fi Default Gateway
—zat jon
DNS (1) ¢
I:I = “-\ =gy DNS (2)
— F T
e L_ _A . Ping .
= - Ethernet
Diagnost ic File Ping Keypad Top Menu MFLAH
e it s Prinary IP i 192.168.0.100 ~
Cable Status
[System] Bridae Hode CJUse Bridge
el SR o e Check duplicate | Apply | Cancel
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Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match.
“Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting

M [ Project > Project Property > Device Setting > ETHERNET > "PLC1 : MICREX-F Series"]
— Set the options of the MICREX-F Series communication driver in TOP Design Studio.

TOP ooz e
Touch Qperation Panel

Project Opticn

B crance HM)

TOP Setting
-3 5YS : RD1520%
Option Module Setting

W ~cdPic il ST Change PLCICI

PLC Setting[ MICREX-F Series ]

Interface : |Ethernet

% Device Setting Protocol @ | PC Link (Asdi)

¥ COM1 (D)

¥ COM2 (D)
58 COM3 (0)
i [ use Redundancy
8% PLC1 : MICREX-F Series J AND ~

USBDevice {0)

E3 Delete PLCDI

Alias Name : [PLC1

String Save Mode : |First LH HL Change

Primary Option

BindIP: Auto

g [1o2 =] (68 2] |o

= =
SINEE]

Ethernet Protocol

Port

Timeout 300 < | msec

Send Wait msec

FileRegister Unuse

Apply Close

* The above settings are examples recommended by the company.
Items Settings Remarks
Interface Select the TOP communication interface. Refer to "2. External
Protocol Select the TOP communication protocol. device selection”.
IP Enter the IP address of the external device.

Ethernet Protocol

Selects the Ethernet Protocol between the TOP and an external device.

Fixed

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.

File Register

Enables or disables the file register device.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

B [Main Screen > Control Panel > Ethernet]

= Ethernet

Run

YNC
Yiewer

Screen
shot

o
@ Svstem et
Ethernet Port

Epe Pl
|

n ! Link Speed :| Auto ~ j’))
I MAC Address @ 00:15:10:05:38:C5
PLC 5 IP Address :[  1392.168.0.50 Sound
Subnet Mask @[  255.255.255.0
R Gateway :[  192.168.0.1 7~
[ “ [ Default Gateway -
Ethernet OMS (1) ;|
| DNS (2) | |
m T -Fthernet m
i Primary IP [ 192.168.0.50 v]
Diagnost ic MRAK
Cable Status :  ETHI Connected | [*Mal¥sis

Bridge Mode :

O Use Bridoe

[System] l[jheck duplicate] ‘ Ao |y | Cance| l ’m

(

4_‘

Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

TO,

PLE

| PLCTCHICREXF Series) |~/
| Ethernet Rd
| PC Link (Binary) |+
[ Auto -]

[192}2] [18812] [0 2] [1

=

LTee I~

b
o il
@ System Oriver(ETH)
Run
Interface
‘ !h' | Protocol
PLC * Bind IP
LG IP
1eRer [‘n‘] ﬂ Ethernet
o [T
1 ﬁ Ethernet sf Port
. '

e n Timeout
Screen m | Send Wait
shot L , ,

= FileRegis
Diagnost ic
Ma
[Svstem] l Diagnostic

Ping Test

* The above settings are examples recommended by the company.

ERI2 e B X
Touch Qperation Panel

v
l App |y ”Cancell

—ill

Items Settings Remarks
Interface Select the TOP communication interface. Refer to "2. External
Protocol Select the TOP communication protocol. device selection”.
IP Enter the IP address of the external device.
Ethernet Protocol Selects the Ethernet Protocol between the TOP and an external device. Fixed
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.
File Register Enables or disables the file register device.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (ETH1/ETH2) settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module
name) oK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway oK NG
Check address range 4. Supported addresses
OK NG (For details, please refer to the PLC

vendor's manual.)
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4. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Description Bit Word Size Remarks
B I/O relay B000.00 - B511.15 B00O - B511 16 bit
M Auxiliary relay M000.00 — M511.15 M000 — M511 16 bit
K Keep relay K00.00 — K63.15 KOO — K63 16 bit
F Special relay F0000.00 — F4095.15 FOO00 — F4095 16 bit
A Announce relay A0000.00 - A4095.15 A0000 - A4095 16 bit
D Different relay D00.00 — D63.15 D00 - D63 16 bit
W9 Current value of 0.1 sec timer - W9.000 — W9.511 32 bit
TS Set value of timer - TS000 — TS511 32 bit
TR Current value of timer - TROOO — TR511 32 bit
(& Set value of counter - CS000 - CS255 32 bit
CR Current value of counter - CR0O00 — CR255 32 bit
DB Data memory - BD0000 — BD4095 32 bit
WL No. 1 block WL000.00 — WL511.15 WL000 — WL511 16 bit
W21 P-link station No. 2 block W21.0000.00 — W21.4095.15 W21.0000 - W21.4095 16 bit
W22 0 memory No. 3 block W22.0000.00 — W22.4095.15 W22.0000 — W22.4095 16 bit
W23 No. 4 block W23.0000.00 — W23.4095.15 W23.0000 — W23.4095 16 bit
W24 Direct I/O W24.000.00 — W24.255.15 W24.000 — W24.255 16 bit
W25 Analog work area - W25.000 - W25.511 32 bit
W26 Last value of differential relay W26.00.00 - W26.63.15 W26.00 — W26.63 16 bit
W30
- File memory W30.0000.00 — W109.4095.15 W30.0000 — W109.4095 16 bit
W109
W120 No. 1 block | W120.0000.00 - W120.4095.15 | W120.0000 — W120.4095 16 bit
W121 P-link station No. 2 block | W121.0000.00 - W121.4095.15 | W121.0000 — W121.4095 16 bit
W122 1 memory No. 3 block | W122.0000.00 - W122.4095.15 [ W122.0000 — W122.4095 16 bit
W123 No. 4 block | W123.0000.00 - W123.4095.15 [ W123.0000 — W123.4095 16 bit
W125 Calender - W125.0 - W125.5 16 bit
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