FUJI Electric Co., Ltd
MICREX-SX Series

Ethernet Driver

Supported version  TOP Design Studio V1.4.4.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. supported addresses Page 10

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “FUJI Electric Co., Ltd — MICREX-SX Series” is as follows:

Series CPU Link I/F Communication method System setting Cable
CPU port
SPH3000
MICREX-SX SPH300 NP1L-RS[] Ethernet com:';uTnoit:F;tion Twisted pair cable
SPH2000 ( General Purpose (TCP/UDP) —_— *Note 1)
SPH200 Communication setting
Module )

*Note 1) Twisted pair cable
- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.
- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a

direct cable.

W Connection configuration

- 1:1 (one TOP and one external device) connection

1)

L [Hue '

* 1:N (one TOP and multiple external devices) connection

B . T

HUB ' |
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2. External device selection

W Select a TOP model and a port, and then select an external device.

Select Device [ = |

PLC select [Ethernet]

Filter - [ [al] ~] Search
@ Model () Vendor

Vendor Model

oPTIcaN & MICREX-F Series

PATLITE

Giddings & Lewis Motion Control
DELTA TAU Data Systems
KEYENCE Corporation

CEYON Technology

Digital Electronics Corporation
BINAR Elektronic AB
HONEYWELL

ATLAS COPCO

ROOTECH

IDEC Corporation

| ENZE h
4 Eack | B Next ® Cancel
Select Device H
PLC Setting[ MICREX-SX Series ]
Alias Name ; |PLC1 BindIP: lAuto v
Interface : |Ethernet ~
Protocol : |Loader Command ~
String Save Mode @ |First LH HL Change
[] use Redundancy
AND v
. a
he
Primary Option
i s =
Ethernet Protocol
Port
Timeout msec
Send Wait msec
Comm. Address
@ Back v oK ® Cancel

Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “FUJI Electric Co., Ltd".
PLC Select the external device to be connected to the TOP.

Protocol

Interface

MICREX-SX Series Ethernet Loader Command

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that
of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Ethernet]
— Set the TOP communication interface in TOP Design Studio.

Project Option X
- Change HMI[H] ' Add PLC[Al | THTal Change PLCICl | [ Delete PLC[D]

TOP Setti
I = !e! an! IZU!( Date / Time Sync.  Screen Option Unit Convert

Opﬁg_”lz";d“'é)sﬂﬁng Project Option | Screen Change | HmiSetup = Global Lock & Touch | Project Style | Splash  PLC Buffer Sync.
-4 FieldBus

. BFID [D_) Use HMI Setup
@ Device Setting e — Initialization Edit

® COM2 (0)

Project Setting ~
¥ COM3 (0) HMIDisable=0
Ethernet (1) Project Mame=New project
{4 PLC1: MICREX-SX Series Start Mode=bleru |
v rt Screen No,=
: L= U"EIESS_ O] Latch Use=0
.4 USBDevice (0) Latch Set=0~0

Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
SystemMessage=1
DisplayLockIcon=0
DisplayPermigsionIcon=0
DarkDraw =0
DrawTouchPos=0
TOPID=1

AutoRun=0
Language=English

Project Advanced Setting
HMIDisable=0
RunSleep=50
EffectSleep=50
CommunicationSleep=1
ProjectloadType=1
InitDataPrevScreen=1
ErrorLog\Write =0
BlinkTime=0
WatchDog=0
SDCoverOption=0
TaskMonitor=1
CommSleepChgUse=0
CommSleepChg=1000
MomentaryBitActionTime =20
CommunicationRatio=0

Ethernet
HMIDisable=0
ETH1=1
1P1=192, 168.0. 100
Subnet1=255.255.255.0 v
Apply Close
Control Panel fe) Ethernet X
System Devices @Service ==, 0ption -Port
Ethernet Port : ETH1 ~ 0 <
M ] T ] ‘ Link Speed : Auto -
i O 7- o=l
PLC Security Date/Time Display Touch Sound MAC Address g 00-00-00-00-00:00

IP Address :|  192.168.0.100
§ O o) o= Subnet Mask :|  255.255.255.0
I [ S8 o | y A = Gateway | 192.166.0.1

Ethernet serial HOM| Initiali Sensor Wi-Fi Default Gateway
—zat ion
DNS (1) :]
E.5 N LS || so:
o
L_—-‘. ®/cng -Ethernet
Diagnost ic File Fing Keypad Top Henu HPAH
g Ry Analysis Primary I[P 192, 168.0.100 -
Cable Status
[System] Bridage Mode : [ Use Bridge

Get HMI Setup Ok Cancel Check duplicate| Apply | Cancel
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Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match.
“Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting

M [ Project > Project Property > Device Setting > ETHERNET(1) > "PLC1 : MICREX-SX Series"]

— Set the options of the MICREX-SX Series communication driver in TOP Design Studio.

TOP ooz e
Touch Qperation Panel

Praject Option

-(hange HMI[H
-

TOP Setting

{3 5Y5 : RD1520X
Option Module Setting
8 FieldBus (0)

o RFID (0)

Device Setting

1o® COM1(0)

fa® COM2 (D)

® COM3 (1)

PLC1 : MICREX-5X Series

e

USBDevice (0)

' Add PLC (A1 | THITal Change PLCICI

[ Delete PLCID]

PLC Setting[ MICREX-SX Series ]

Alias Name

Interface :

Protocol :

String Save Mode

:|[PLC1 BindIP: |Auto
Ethernet ~
Loader Command ~

+ |First LHHL Change

[J use Redundancy

Primary Option
P
Ethernet Protocol
Port
Timeout
Send Wait

Comm, Address

4

Apply Close

* The above settings are examples recommended by the company.
Items Settings Remarks
Interface Select the TOP communication interface. Refer to "2. External
Protocol Select the TOP communication protocol. device selection”.
IP Enter the IP address of the external device.

Ethernet Protocol

Selects the Ethernet Protocol between the TOP and an external device.

Fixed

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device
and sending the next command request.

Comm. Address

Enters the SX Bus Station number of the external device.
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

B [Main Screen > Control Panel > Ethernet]

Jﬁ. Ethernet
@ System p Part . Option
Run Ethernet Port : ETHI -] 0 |~

)
n ! Link Speed :| Auto | q’))
‘ I MAC Address : 00:15:10:05:38:C5

PLC 5 IP Address :[  192.168.0.50 Sound
N Subnet Mask :[  255.255.255.0
Yiever [.J'l-.] . Gateway :[  192.168.0.1 S
[N . [ Defau It Gateway -~
Ethernet ONS €10 :|
ONS (2) ¢

- Ethernet m

Primary IP [192.155.0.50 v]

Screen
shot

Diagnost ic

(=] »

MR
Cable Status ETH1 Connected Analysis

Bridge Mode : [[]Use Bridae

| cancel ]%(

__-‘

[System] || Check duplicate |

Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51

Subnet Mask 255.255.255.0 255.255.255.0

Gateway 192.168.0.1 192.168.0.1

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.

Items Description

IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.

Gateway Enter the gateway of the network.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

Oriver(ETH)

PLCTCMICREN-3X Series) v]

ERI2 e B X
Touch Qperation Panel

Interface | Ethernet Rd
Protocol | Loader Command Rd
Eind IF | Auto Bd
P IEASREIS SRS

[.ﬁ;‘m‘] Ethernet | TCP |~

S Port 1024 |5
Timeout msec

m send Wait msec
Comm . Adc D=

Disgnost ic

[System] l Diagnostic HDing Tesi]

[ ADDIy]!Cancel]

* The above settings are examples recommended by the company.

Items Settings Remarks
Interface Select the TOP communication interface. Refer to "2. External
Protocol Select the TOP communication protocol. device selection”.
IP Enter the IP address of the external device.
Ethernet Protocol Selects the Ethernet Protocol between the TOP and an external device. Fixed
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.
Comm. Address Enters the SX Bus Station number of the external device.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (ETH1/ETH2) settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) .
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module
name) oK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway oK NG
Check address range 4. Supported addresses
oK NG (For details, please refer to the PLC

vendor's manual.)
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4. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Word Double word Remarks
Input Memory 1X000.00 — 1X511.15 IW000 — IW511 ID000 - ID510
Output Memory QX000.00 - QX511.15 QWO000 - QWS511 QD000 - QD510
Standard Memory MX1.0.0 — MX1.4999999.15 MW1.0 - MW1.4999999 MD1.0 — MD1.4999998
Retain Memory MX3.0.0 — MX3.3388607.15 MW3.0 - MW3.3388607 MD3.0 - MD3.3388606
System Memory MX10.0.0 — MX10.65535.15 MW10.0 - MW10.65535 MD10.0 - MD10.65534
External device connection manual for TOP Design Studio 10 /10



