MITSUBISHI Electric Corporation
MELSEC A Series
CPU Direct Driver

Supported version  TOP Design Studio V1.0 or higher {Rl

TOP

"
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We would like to thank our customers for using M2I's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSEC A CPU Direct” is as follows:

Link I/F Communication method Communication setting

AnN CPU 3. TOP communication
MELSEC-A AnS CPU CPU port RS-232C setting 5. Cable table
AOJ2H CPU 4. External device setting

W Connection configuration

+ 1:1 (one TOP and one external device) connection
k[].]

__

External device connection manual for TOP Design Studio 2/ 1



TO BRI HE B X
Touch Qperation Panel

2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM1]

Filter : |[A\I] v| Search : l:l

@ Model (O Vendor

Vendor Model
M2I Corporation QD

MITSUBISHI Electric Corporation

OMRON Industrial Automation

MELSEC Q Series

LA

MELSEC FX Series

;" MELSEC AnN/AnS Series
LS Industrial Systems
MELSEC AnA/AnU Series
MODBUS Organization
MELSERVO ]2 Series
SIEMENS AG.

MELSERVO 13 Series
Rockwell Automation

GE Fanuc Automation MELSERVO 14 Series

PANASONIC Electric Works MELSEC FX2N-10/20GM Series

Y ASKAWA Electric Corporation MELSEC iQ-F Series

LA A A A

YOKOGAWA Electric Corperation
Schneider Electric Industries

KDT Systems

<

RS Autnmation

M8 Back | W Next *® Cancel

PLC Setting[ MELSEC AnN/AnS Series ]
Alizs Mame : |PLC1

Interface : | CPU Direct ~

Protocol : | CPU Direct ~ Comm Manual
String Save Mode @ |First LH HL Change

[J use Redundancy

Primary Option

Timeout msec
Send Wait m msec

4@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.

Select “MITSUBISHI Electric Corporation”.

PLC Select an external device to connect to TOP.

| Interface | Protocol
MELSEC A Series CPU Direct CPU Direct

Supported Protocol (CPU type)
AnN CPU | Ans cPu | Aos2H cpu

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Opticn

-3 TOP Setting
: 20%
~ -l Option Module Setting

Date / Time Sync.

Project Option

Screen Change

Screen Option

HmiSetup

- Change HMIE] || | Add PLC 1) T Change PLCIC) | [£]  Delete PLCID)
—

Unit Convert

Global Lock & Touch = Project Style  Splash

Initialization I Edit I

PLC Buffer Sync.

i..qg USBDevice (0)

- Fieldsus (0)

g e
v -igg Device Setting -

~ 58 COM1(D) mi S2lup Option

i LW PLCL: MELSEC AnN/AnS ¢ Project Seting

; ¥ Com2 (0) HMIDisable =0

1158 COM3 (0) Project Name=New project

{4 Ethernet (0) Start Mode =Menu

9 Wireless (0) f::;i‘:sr:ig No.=1

Latch Set=0~0

Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1

~

Control Panel
Svstem mDevices IService 1= 0ption
o Serial I
-
il l ‘ Serial Port:  COM1 <
PLEC SEcurity Dat e/ Time Signal Level
(® RS-232C O RS-42204) (O RS-485(2)
Baud Rate: 9600 =
(1] (1] —
T ol | &=/ Data Bit: 3 -
Et hernet Serial HOM | Stop Bit: i -
—_ Parity Bit: (Odd o
I e % Flow: [(ff
L A . Ping
DgEss i File Es Auto Search  Loopback Test
Manager
Apply Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C .
RS-232C Fixed
(CPU port)
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit Odd Fixed

X The communication interface for Melsec A Series CPU Direct is fixed to the above configuration values.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > "PLC1 : MELSEC-A Series"]

ERI2 e B X
Touch Qperation Panel

TOP (|

— Set the options of the MELSEC A Series CPU Direct communication driver in TOP Design Studio.

Project Option

“ AddPLC[A] | THITal Change PLCIC)

m Delete PLC[D]

- Change HMIH]
W

TOP Setting
-3 5Y5 ¢ RD1520%
Option Module Setting
-4 FieldBus (0)
- RFID (0)
W - Device Setting

8 Ethernet (0)
® Wireless (0)
9 USBDevice (0)

Y A String Save Mode
- j PLC1 : MELSEC AnM/AnS E]

PLC Setting[ MELSEC AnN/AnS Series ]

Alizs Name : [PLC1 |
Interface : | CPU Direct ~
Protocol : | CPU Direct ~

: [First LH HL Change

[ use Redundancy

Primary Option

Timeout 200 &1 | msec
Send Wait msec
Retry 5 z

CPU Type

AnS[AQIZH -~

Comm Manual

£ >

Apply Close
Items Settings Remarks
Interface Select “CPU Direct". Refer to “2. External
Protocol Select “CPU Direct".

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device

and sending the next command request.

CPU Type

Select the CPU type for the external device.
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conitroll Panel

- Serial

Serial Port: [CUI#H |*l

Signal Level
@ AS-232C (O RS-42204) O PS-485(2)

Baud Rate: [ 9600

|
l
[lﬁlrlllll smms | © Data Bit: | 8 v=
l
l

|
|
Stop Bit: | 1 -
|
|

Dat]

-

Ethernet Serial
Parity Bit: [None -
m = ¥ Flow: | 0ff -
hy o
Diagnost ic File lAuto Search] lLoopbaCk Testl
Manager

| Apply ” Cancel l =

[System] Close

r

Items TOP External device Remarks

Signal Level (port) RS-232C )
RS-232C Fixed

(CPU port)

Baud Rate 9600 Fixed

Data Bit 8 Fixed

Stop Bit 1 Fixed

Parity Bit Odd Fixed

X The communication interface for Melsec A Series CPU Direct is fixed to the above configuration values.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

Run

i PLG

@ System| Dr iver(COMI) [ PLCT(MELSEC AnN/&nS Ser ies) -]

Interface | CPU Direct -
Iil Protocol | CPU Direct Rd
FLC Timeout 300 3 msec

Send Wait msec

] { = .
CPU Type AnS/ A0~

Ethernet

il

Diagnost ic

ERI2 e B X
Touch Qperation Panel

o

[System] [ Diagnostic [ App |y HCancel l

Items Settings Remarks
Interface Select "CPU Direct”. Refer to "2. External
Protocol Select “CPU Direct". device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device

and sending the next command request.

CPU Type

Select the CPU type for the external device.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (COM1/COM?2) settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) .
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

The communication interface for Melsec-A Series CPU Direct is fixed to the target configuration values indicated by the

“communication interface setting” in this user manual.
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of "Mitsubishi Electric Corporation”)

TOP

TOP422C

(e { |

|

Use the dedicated cable “TOP422C” (sold by M2l Corp.) to connect the TOP and the MELSEC-A Series CPU

A Direc

W RS-232C (1:1 connection)

CcoM Cable cross section
Pin Signal Pin Cable connection
arrangementNote 1) name number Cable color
1 5 Ccb 1 Red
RD 2 | Yellow
g g SD 3 Green
Based on DTR 4 Blue
communication 5G > White
cable connector DSR 6 Black TOP422C
front, RTS 7 Dedicated cable
D-SUB 9 Pin male cTs 8 (25 pin)
(male, convex) 9 Cable cross section

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Type Remarks Bit-designated address Word-designated address
Input Bit X0000 - X07FF X0000 - X07F0
Output Bit Y0000 - YO7FF Y0000 - YO7FO
LINK relay Bit BOOOO - BO3FF

LINK register Word WO0000 - WO3FO
Special relay Bit FOO00 - F0255 FOO00 - F0240
LATCH relay Bit L0000 - L2047 L0000 - L2032
Internal relay Bit MO0000 - M2047 MO0000 - M2032
Special relay Bit M9000 - M9255 M9000 - M9240
Timer - Coil Bit TCO000 - TC255

Timer - Contact Bit TS000 - TS255

Timer-Current value Word TNOOO - TN255
Counter - Coil Bit CC000 - CC255

Counter - Contact Bit CS000 - CS255

Counter-Current value Word CNOOO - CN255
Data register Word D0000.0 — D1023.15 D0000 - D1023
File register Word R0000.0 — R8191.15 R0000 — R8191
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