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YOKOGAWA Electric Corporation 

µR Series  

Ethernet Driver 
 Supported version TOP Design Studio V1.4.7 or higher  

 

 

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 10 

 Describes how to set up communication for external devices. 

5. Supported addresses Page 11 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “YOKOGAWA Electric Corporation - µR Series Ethernet” is as follows. 

 

Series Link I/F 
Communication 

method 
Communication setting Cable 

µR10000 

µR20000 

Ethernet 

(/C7 Option) 

Ethernet 

(TCP) 

3. TOP communication 

setting 

4. External device setting 

Twisted pair cable*Note 1) 

*Note 1) Twisted pair cable 

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 

 

■ Connectable configuration 

ㆍ1:1 connection (one TOP and one external device) connection 
 

                         

 

 

ㆍ1:N (one TOP and multiple external devices) connection 
 

                                     ∙∙∙      
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 
 

 
 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device. 

Select “YOKOGAWA Electric Corporation”. 

Model Select external device. 
 

Model Interface Protocol 

µR Series Ethernet Setting/Measurement 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project] → [Property] → [TOP Setting] → [HMI Setup] → [Use HMI Setup Check] → [Edit] → [Ethernet] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 
 

Items TOP External device Remarks 

IP Address 192.168.0.100 192.168.0.50 *Note *Note 2) 

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

* The above settings are examples recommended by the company. 

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 
 

Items Description 

IP Address Set the IP address of the TOP. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [Project] → [Properties] → [PLC settings > Ethernet > PLC1 : µR Series] 

– Set the options of the communication driver of µR Series Ethernet in TOP Design Studio. 
 

 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device. *Note 1) 

Port Enter the Ethernet communication port number of an external device. *Note 2) 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Login Select whether or not to set up an external device login.  

Username Enter the user’s name. *Note 3) 

Password Enter the password.  

*Note 1) µR’s Setting/Measurement Server Ethernet protocol is TCP. 

*Note 2) µR’s Setting/Measurement Server port no. is 34260. 

*Note 3) If login is set to ‘not-used’, access with the selected item from etither the administrator or the user. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Ethernet ]  
 

 

 

Items TOP External device Remarks 

IP Address 192.168.0.100 192.168.0.50 *Note *Note 2) 

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

* The above settings are examples recommended by the company. 

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 
 

Items Description 

IP Address Set the IP address of the TOP. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 

 

  



 

 External device connection manual for TOP Design Studio 7 / 11 

(2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device. *Note 1) 

Port Enter the Ethernet communication port number of an external device. *Note 1) 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Login Select whether or not to set up an external device login.  

Username Enter the user’s name. *Note 2) *Note 3) 

Password Enter the password. *Note 3) 

*Note 1) µR’s Setting/Measurement Server uses TCP, port number 34260. 

*Note 2) If login is set to ‘not-used’, access with the selected item from etither the administrator or the user. 

*Note 3) It can be entered in TOP Design Studio. 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check whether the port (ETH1/ETH2) settings you want to use are the same as those of the external device in [Control panel > 

Ethernet]. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

For more detailed setting methods than described in this example, refer to the manufacturer’s user manual. 

 

① Press the (MENU) key for 3 seconds to change to the Setting Mode. 

② Press the △▽(DISP) key and the ◁▷(FUNC) key together for 3 seconds to change to Basic Setting Mode screen. 

③ Select the Basic=Ethernet item with the △▽(DISP) key and press the    key to change to the Ethernet setting screen. 

④ Press the     key in the Ethernet=Local IP item to change to the IP setting screen. 

⑤ Enter the IP, subnet mask and gateway of the recorder using △▽(DISP) key and ◁▷(FUNC) key. 

⑥ Select the Ethernet=Login item. 

⑦ Set Login=Not (unused) or Login=Use (used). 

⑧ When setting Login=Use, select Ethernet=LoginSetting item to set the usernamd and password of an administrator and a user. 

⑨ Press ESC/? to return to the Basic Setting screen. 

⑩ Select the Basic=End item, and then select the End=Store to save the settings. 
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

(1) Monitoring address (Write disabled) 
 

Address Channel Data Size Remarks 

MEASURED_DATA 01 ~ 24 Recently measured value 16 bits *Note 1) 

COMPUTED_DATA 0A ~ 1P Recently calculated value 32 bit *Note 1) 

MEASURED_STATUS 01 ~ 24 Recent channel status 16 bits *Note 2) 

COMPUTED_STATUS 0A ~ 1P Recent channel status 16 bits *Note 2) 

ALARM_LEVEL1 01 ~ 1P Recent alarm status (level 1) 16 bits *Note 3) 

ALARM_LEVEL2 01 ~ 1P Recent alarm status (level 2) 16 bits *Note 3) 

ALARM_LEVEL3 01 ~ 1P Recent alarm status (level 3) 16 bits *Note 3) 

ALARM_LEVEL4 01 ~ 1P Recent alarm status (level 4) 16 bits *Note 3) 

*Note 1) If the channel status is not (MEASURED/COMPUTED_STATUS) 0, the measured/calculated value of the corresponding channel displays the last 

read value. 

*Note 2) Recorder status according to channel status bits 
 

Bit Status 

0 +Over 

1 -Over 

2 Burnout (when setting Up) 

3 Burnout (when setting Down) 

4~15 Reserved 
 

*Note 3) Status according to alarm value 
 

Value Status 

0 None. 

1 H (high limit alarm) 

2 L (low limit alarm) 

3 h (difference high limit alarm) 

4 l (difference low limit alarm) 

5 R (high limit on rate of change alarm) 

6 r (low limit on rate of change alarm) 

7 T (delay high limit alarm) 

8 t (delay low limit alarm) 

 

(2) Command address 
 

Address Contents Remarks 

RECORDING_START Start recording  

RECORDING_STOP Stop recording  

COMPUTATION_STAR Start computation  

COMPUTATION_STOP Stop computation  

COMPUTATION_RESET Reset computation  
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※ How to use the command address 

The command address is Write-only, and can be used by registering the operation of an object by turning the bit of the 

command address On or OFF or entering the temporary value. 

 

Ex) Start recording by pressing a square object. 

1. After registering the square object, set “Condition” in “Effects and Actions” to [Event > Touch down]. 

2. Set the action to [Bit > Enter the recording_start address > ON]. 

(Set the maximum number of runs to 1, set the cycle, and set the delay to zero.) 

3. Press the square object in TOP and send the RECORDING_START command. 
 

 

 
 

 


