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1. System configuration

The system configuration of TOP and “SENGENUITY:WSR-T2" is as follows:

Communication

System settin
method y J ‘

Series ‘ Module Link I/F ‘

3.1 Settings
SENGENUITY:WSR-T2 - - RS-485 example 1

(Page 4)

5.1. Cable table 1
(Page 9)

B Connectable configuration

+ 1:1 connection (one MASTER and one TOP) connection

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422/485 communication.

External device connection manual for TOP Design Studio 2/ 12



TOP ooz e
Touch Qperation Panel

2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM2]
Filter : |[A\I] v| Search : l:l

@ Model (O Vendor

Vendor
TOHO Electronics Inc. L

IAI Corporation

MKP

TEMCOLINE Ca., Ltd.
LINMOT

CHINO Corporation
KOLVER 5rl

PELCO

FASTECH Co., Ltd.
HYOSUNG

NMEA

AJINEXTEK Co., Ltd,

TFC Standard Y

M8 Back | W Next *® Cancel

Select Device n

PLC Setting[ WSR-T2 ]

Alizs Mame : |PLC1

Interface : | Computer Link ~

Protocol : | WsrT2 Link. ~ Comm Manual
String Save Mode @ |First LH HL Change

[J use Redundancy
AND ~

Primary Option
Timeout msec
Send Wait

Retry 5 =

NODE ID SYS ADDR

4@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "SENGENUITY".
PLC Select an external device to connect to TOP.

Interface Protocol

WSR-T2 Computer Link WsrT2 Link

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [ Project > Project Property > TOP Setting ] — [ Project Options > “Use HMI Setup” Check > Edit > Serial ]

— Set the TOP communication interface in TOP Design Studio.

Project Option

- Change HMI[H]

— Add PLC[A] | TRl Change PLCICI

[ TOP Setting
TROL520%

~ - Option Module Setting
-4 FieldBus (0)
48 RFID (0)
v - Device Setting
1% COM1 (0)
v ¥ COM2 (1)
-4 PLCL : WSR-T2 [0]
1% COM3 (0)
4 Ethernet (0)
@ Wireless (0)
-4 UsBDevice (0)

E3 Delete PLCID)

Date / Time Sync.  Screen Option Unit Convert

Project Option = Screen Change HmiSetup = Global Lock & Touch  Project Style | Splash | PLC Buffer Sync.

—
FTSEE e Initialization Edit
Project Setting ~
HMIDisable =0

Project Name=New project
Start Mode=Menu

Start Screen No. =1

Latch Use=0

Latch Set=0n~0

Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1

Control Panel

System mDevices ?Service =\ Option

m Serjal X
o
| - Serial Port: COM2 v
FLC Security Dat e Time Signal Level
(®) RS-232C O Rs-42204) (O Rs-485(2)
[.J-LI] Baud Rate: 38400 '
..- sl B—
i Data Bit: & -
Et hernet Serial HOM | Stop Bit: i -
e Parity Bit: None M
I [TI % Flow: [ff
L_ al . Ping
Bl i File B Auto Search  Loopback Test
Manager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS-485 RS-485
Baud Rate 115200
Data Bit 8
Stop Bit 1
Parity Bit NONE
* The above settings are examples recommended by the company.
Items Description
Signal Level Select the serial communication method between the TOP and an external device.
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Project > Project Property > PLC Settings > COM > "PLC1 : SENGENUITY WSR-T2 ]

Set the options of the communication driver in TOP Design Studio.

e RLC =)

Driver [PLC2(WSR-T2) ~ | [com -
Interface: [CDmputer Link v]
Pratocal: [PC Link v]
TimeOut (ms) 5000
SendWait (ms) 0
Retry 5
StationMo 7

Cancel ] [ bpply

Items Settings Remarks
Interface Select "Computer Link". Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device

and sending the next command request.
Retry Retry attempts
StationNO StationNO system buffer Address
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [ Main Screen > Control Panel > Serial ]

Conikroll Panel

oE Serial
Bun . : g —
Serial Port: | COM?2 |'l
!Il'l G Signal Level
@ RS-232C O RS-422(4) O RS-485(2) l
PLC Security
Baud Rate: | 38400 -
YHC
i . Data Bit: 3 =
Yiewer [|J-|'l|] = = [ | l
s T Stop Bit: | 1 -
] Ethernet Serial
L E Parity Bit: [None H
Amma —
Screen m . : Flow: [ Of f |vl
shot
g [Auto Search] lLoopbaCk Testl
Diagnost ic File
Manager
l Apply “ Cancel l —
[System] Close r
Items TOP External device Remarks
Signal Level (port) RS-485 RS-485
Baud Rate 115200
Data Bit 8
Stop Bit 1
Parity Bit none

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Main Screen > Control Panel > PLC ]

Run

B
o — PLC

@Syste Dr i ver (COM2) [PLm(WSR—Tz) -]

Interface | Computer Link Rd
!Iill Protocol | WsrT2 Link -
PLC Timeout 300 |3 msec
send Wait msec
] | Pt —
[~]
Et hernet MNODE 1D = ﬂ
Diagnost ic

ERI2 e B X
Touch Qperation Panel

o

[System] Diagnostic dpply “ Cancel ]
Items Settings Remarks
Interface Select “Computer Link". Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device. device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device

and sending the next command request.

Retry

Retry attempts

StationNO

StationNO system buffer Address
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC ].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Refer to the vendor’s user manual to identically configure the communication settings of the external device to that of the TOP.
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.
(The cable diagram described in this section may differ from the recommendations of “SENGENUITY WSR-T2")

m RS-485
External
TOP COM )
. device
) 3 : Cable connection
Pin Signal Pin ;
Signal name
arrangement*Note 1) name number
1 5 RDA 1 A+
(6) s) 5 5
Q Q 3
§ 9 RDB 4 —
Based on
. SG 5
communication
SDA 6
cable connector
front, l
D-SUB 9 Pin male 8
(male, convex) SDB 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

B 1:N connection — Refer to 1:1 connection to connect in the following way.

TOP Cable connection and signal External device Cable connection and signal External device
Signal name direction Signal name direction Signal name
RDA SDA SDA
RDB SDB SDB
SDA — RDA — RDA
SDB RDB RDB
SG SG SG
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6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Command Bit address range Word address range R/W Device description
SETADDR - 0~5000 W Set WSR-T2 Address
\ - 0~5000 R Value Interrogation

CAL_SEN - 0~5000 W Calibrate Sensor
SAVE_CAL - 0~5000 w Store Calibration
WS_PARA - 0~5000 W Sensor Parameters
RS_PARA - 0~5000 R Sensor Parameters
Command Detailed usage method

SETADDR | Currently unsupported

Vi Value Interrogation: read-only
VI 30
SYS 30 = SENSOR NO
SYS 31 = PARAM NO (0 fixed)
SYS 32 = STATUS
SYS 33 = TEMP

Run the command by referring to the information in SYS 30-33. Save the information obtained by
communication below.

SYS 34 = MAG

SYS 35 = STDDEV

CAL_SEN | Calibrate Sensor : Write-only
CAL_SEN 40
SYS 40 = SENSOR NO
SYS 41 = PARAM NO (0 fixed)
SYS 42 = TEMP
SYS 43 = AVERAGE/SUCCESS

Run the command by referring to the information in SYS 40-43. Save the information obtained by

communication below.
SYS 44 = STDDEV
SYS 45 = MAG
SYS 46 = STATUS
SYS 47 = SUCCESS

SAVE_CAL | Store Calibration : Write-only
SAVE_CAL 50
SYS 50 = SENSOR NO
SYS 51 = PARAM NO (0 fixed)
SYS 52 = FIRST SENSOR
SYS 53 = LAST SENSOR

Run the command by referring to the information in SYS 50-53. Save the information obtained by

communication below.
SYS 54 = FIRST SENSOR
SYS 55 = LAST SENSOR
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WS_PARA

Sensor Parameters : Write-only
WS_PARA 60
SYS 60 = SENSOR NO
SYS 61 = PARAM NO (0~2)
Run writing of the information in SYS 61-62 and the values in the address below.
For PARAM 2
SYS 62 = MAG_THRES
SYS 63 = PA_LEVEL
SYS 64 = PPS_LEVEL
SYS 65 = ANTENNA
SYS 66 = ALC
SYS 67 = MAG_TARGET
For PARAM 1
SYS 62 = CUR_LO(msb)
SYS 63 = CUR_LO(Isb)
SYS 64 = CUR_HI(msb)
SYS 65 = CUR_Hl(Isb)
For PARAM 0
SYS 62 = MIN_LO(msb)
SYS 63 = MIN _LO(Isb)
SYS 64 = MAX_HI(msb)
SYS 65 = MAX _Hl(Isb)

RS_PARA

Sensor Parameters : Read-only
WS_PARA 60
SYS 60 = SENSOR NO
SYS 61 = PARAM NO (0 fixed)
Run the command by referring to the information in SYS 61-62. Save the information obtained by
communication below.
SYS 62 = MAG_THRES
SYS 63 = PA_LEVEL
SYS 64 = PPS_LEVEL
SYS 65 = ANTENNA
SYS 66 = ALC
SYS 67 = MAG_TARGET
SYS 68 = CUR_LO(msb)
SYS 69 = CUR_LO(Isb)
SYS 70= CUR_HI(msb)
SYS 71 = CUR_HI(Isb)
SYS 72 = MIN_LO(msb)
SYS 73 = MIN _LO(lIsb)
SYS 74 = MAX_HI(msb)
SYS 75 = MAX _Hl(Isb)
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