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TOP

"

CONTENTS

We want to thank our customers who use the Touch Operation Panel.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.

External device connection manual for TOP Design Studio 1/ 1



1. System configuration
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The system configuration of TOP and “KDT Systems Co,. Ltd. — CIMON PLC Series CPU Direct” is as follows:

Link I/F

Communication method

System setting

XP

CM1-XP1A/R
CM1-XP2A
CM1-XP3A

CpP

CM1-CP3A
CM1-CP3B
CM1-CP3P
CM1-CP3U
CM1-CP4A
CM1-CP4B
CM1-CP4C
CM1-CP4D
CM1-CP4U

BP

CM2-BP32MD
CM2-BP16MD

LOADER Port
on CPU unit

RS-232C

3. TOP communication

setting
4. External device setting

5. Cable table

W Connection configuration

+ 1:1 (one TOP and one external device) connection

L[]

_
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM1]

Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor Model

A
LS Industrial Systems ‘, CIMON PLC Seri

MODBUS Organization

SIEMEMS AG.

Rockwell Automation

GE Fanuc Automation
PAMASONIC Electric Works
‘YASKAWA Electric Corporation
YOKOGAWA Electric Corparation
Schneider Electric Industries

RS Automation

HITACHI IES

FATEK Automation Corporation

NFI TA Flertranics

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ CIMON PLC Series ]

Alizs Mame @ |PLCL

Interface : | Serial ~

Protocol : | Loader ~ Comm Manual
String Save Mode : |First LH HL Change

[ use Redundancy

Primary Option

Timeout msec
Send Wait msec

Retry 5

=
:

@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “KDT Systems”.
PLC Select an external device to connect to TOP.

| Interface | Protocol
CIMON PLC Series CPU Direct CPU Direct

Supported CPU type
CP Series ‘ BP Series ‘ XP Series

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option =
-Char\ge HMIH] 'Aﬂd PLCA] | Pl Change PLCicl | [T Delete PLCID)
—
Em%'lsmx Date / Time Sync.  Screen Option Unit Convert
V--;ﬂh:nlgﬁodul&semng Project Option = Screen Change = HmiSetup | Global Lock & Touch  Project Style  Splash = PLC Buffer Sync.
M \:_"' Eiwé;;elt?;;g Hmi Setup Option Initialization Edit
A% PLC1 : CIMON PLC Series Project Settng "
B® COM2 (0) HMIDisable =0
=¥ COM3 (0) Project r\:jamelvTNew project
thernet (0) Start Mode =Menu
; \E"ﬂrelesst[un) f::g‘icsr:ig Ne.=1
@ USBDevice (0) Latch Set=0~0
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage =1
DatabaseMessage=1
Centrel Panel
. [
System m Devices | = Serial X
_t 7 Serial Port:  COM1 ©
i} '
Signal Level
PLC Security Date/Time (® RS-232C O Rs-422(4) O Rs-485(2)
Baud Rate: 38400 v
E Data Bit: & <
(1] a —
) & === :
Stop Bit: i @
Et hernet Serial HOK | . .
Parity Bit: MNone <
Flow: [ff
l — Auto Search  Loopback Test
. Ping
Diagnost ic File Fing
Manager Apply Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 38400 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device. (COM3 supports only RS-485.)
Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > “PLC1 : CIMON PLC Series"]

— Set the options of the CIMON PLC Series CPU Direct communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' AddPLC[A] | THITal Change PLCial | [T Delete PLCID]

v L} TOPSettng PLC Setting[ CIMON PLC Series |
i L. sYS:RD1520%
Option Module Setting Alizs Mame: : |PLC1
Interface : | Serial e
. -m RFID (0)
v {4 Device Setting Protocol : |Loader ~ Comm Manual
R String Save Mode : [First LH HL e
I % PLC1 : CIMON PLC Series
COM2 (0)
=% COM3 (0) [] use Redundancy
W Ethernet (0) AMD e
& Wireless (0) - - -
W USBDevice (0) Bl
Co Edi
Primary Option
Timeout 200 &1 | msec
Send Wait msec
£ >
Apply Close
Items Settings Remarks
Interface Select “CPU Direct". Refer to "2. External
Protocol Select “CPU Direct".

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external
device and sending the next command request.

Station No

Enter the prefix of an external device.

CPU Type

Select the CPU type for the external device.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conit:roll Panel

sernal

Run
Serial Port: [CUM1 "]
I Signal Level
‘ o Ssair i @ RS-232C O RS-422(4) (O RS-485(2) ]
Baud Rate: | 38400 -
¥YNC
Viever MR L Data Bit: |8 -
: =~ Ethernet Serial Stop Bit: [ 1 ‘vw
| . S
=R Parity Bit: [None ‘V]
Screen =3 Flow: | 0ff - g
Ji%ﬁ:n m L”I J [ | ] y
| || piagnostic File [Auto Searchl [Loopback Test] I’
Manager
' ' Apply HCancel }
,. [System] GTose
OPR OPRX 0800 04:45:02 P
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 38400 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

B [Main Screen > Control Panel > PLC]

Conit:roll Panel

:T‘l‘ sernal
Serial Port: [COM1 J
Signal Level
[}.\ RS-232C O RS-422(4) O RS-485(2) }
Baud Rate: | 38400 ~|
\'ive“!gr Data Bit: [8 I J
: ata Bit: v
| ] | e Stop Bit: | 1 -]
Ethernet Serial ’ b
Parity Bit: | None -] 5
een Flow: [Uff v]
w
. Diagnost ic File [Auto Search] [Loopback Test]
. Manager
 Apply | Cancel | |——
[System]

CTOoS€E

TOPRX — TOPRX0800S A 2021-08-31 04:45:02 PH
Items Settings Remarks
Interface Select “"CPU Direct". Refer to "2. External
Protocol Select “"CPU Direct". device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.

Station No Enter the prefix of an external device.

CPU Type Select the CPU type for the external device.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Loader port communication interface of the “CIMON PLC Series” is fixed as the target configuration value mentioned in the example

on “3. TOP communication setting”.
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “KDT Systems Co., Ltd.")

W RS-232C (1:1 connection)

TOP External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangementNote 1) name number number name arrangementNote 1)
cD 1 1 2
1 2 RD 2 2 TXD "'5///{’ '
SD 3 3 oo | | o
6 5 DTR 4 " 1]1[]]\[{
Based on SG 5 5 G 6
communication DSR 6 6 Based on
cable connector RTS 7 communication
front, cTS 8 cable connector
D-SUB 9 Pin male 9 front,
(male, convex) 6 pin male RJ12
(male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses

TO,

ERI2 e B X
Touch Qperation Panel

The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Address Word Address Remarks
Input relay X00000- X1023F X00000 — X10230
Output relay Y00000 — Y1023F Y00000 - Y10230
Sub relay M00000 — M4095F MO00000 — M40950
Keep relay K00000 — K4095F K00000 — K40950
Link relay L00000 — L4095F L00000 — L40950
Timer contact TO00O - T4095 —
current — TCO000 — TC4095
setting — TS0000 — TS4095
Counter  contact C0000 - C4095 —
current — CC0000 — CC4095
setting — CS0000 — CS4095
Data register D00000.00 - D32766.15 D00000 - D32766
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