HBTECH - TCeye(Monitoring)

Ethernet Driver

Supported version  TOP Design Studio V1.0 or higher {Rl

TOP

J

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2l TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the “TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.
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1. System configuration

The system configuration of TOP and "HBTECH - Monitor” is as follows:

3. TOP communication setting Twisted pair

TCeye(Monitoring) - Ethernet (TCP) - -
4.1. External device setting 1 cable*Note 1)

*Note 1) Twisted pair cable

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a
direct cable.

W Connectable configuration

+ 1:1 connection (one TOP and one external device) connection
(<1

— HuB
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device [ = |

PLC select [Ethernet]

Filter : [ [alD | Search
@ Model () Vendor

Wendor
BINAR Elektronic AB &

HONEYWELL

ATLAS COPCO
ROCOTECH

IDEC Corporation
LENZE

BECKHOFF Automation

FASTECH Co., Ltd.

ODvA
HYOSUNG
HE TECH
DNP
FAMUC Co., Ltd.
RONSTER d
[ 4 Eack | B Mext *® Cancel
Select Device H
PLC Setting[ TCeye(Monitoring) ]
Alias Name ; |PLC1 BindIP: lAuto ~
Interface @ |Ethernet ~
Protocol @ | TCeye{Monitor) ~ Comm Manual

[J use Redundancy

Primary Option

P |192 :Hlss :Hn :|‘1 :| .
Ethernet Protocol TCP
Timeout msec
Send Wait msec
Spot Count 14 = [MIM Spot:13], [MAX Spot: 14]
Spot X Pos Start Address s¥s ~ (00100 |25 [x14WORD |
Spot ¥ Pos Start Address == wlon1zn  |== M| [x14WORD] b
4 Back v oK ® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “TCeye (Monitoring)".
PLC Select the external device to be connected to the TOP.

Interface Protocol

TCeye Ethernet TCeye(Monitor)

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

TO,

ERI2 e B X
Touch Qperation Panel

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > "Use HMI Setup” Check > Edit > Ethernet]

— Set the TOP communication interface in TOP Design Studio.

Project Option X
B cranoe i) W ~aapic i T Change PLcial | [T] Delete PLCID
‘;E;;se;;gﬂ'llzm{ Date / Time Sync. | Screen Optien  Unit Convert
qﬂﬁﬁ_"l";";d“‘;;erﬁﬂg Project Option | Screen Change | HmiSetup | Global Lock & Touch | Project Style | Splash = PLC Buffer Sync.
¥ ?EEVEEO;EITD”)Q s IR T Initialization Edit
g% COM2 (D) Project Setting -
g COM3 (0) HMDisable =0
o e ; Sircmodentens T
) || [Sersaeerneiey
W UsBDevice (0) Latch Set=0~0
Communication Error Message=0
USBErrorMessage =0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
System [EllDevices Ui Service ="' Qption
fwl Ethernet *
- -Port
______ Eth t Port ' ETHI )]
ErnNe or : hd -
i F(o
Link Speed : Auto v
PLC Security Dat e/Time
WAC Address @ 00:00:00:00:00:00
IP hddress :|  192.168.0.50
Subnet Mask :|  255.255.255.0
o » B Gateway :|  192.168.0.1
% S oEme )
""I" Default Gateway
Ethernet Serial HOH | DNS (1) ¢
DNS (2] ¢
- Ethernet
I - .-\\ Prinary IP :  192.168.0.50 ~
| S—— L | -
= Ping Cable Status :
Diagnost ic File Pin
c Manager . Eridge Mode : [1lUse Bridge
Check duplicate | Apply | Cancel
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP 192 . 168 . 0 . 0) should match.

*Note 2) Do not use duplicate IP addresses over the same network.

* The above settings are examples recommended by the company.

Items

Description

IP Address

Set an IP address to be used by the TOP to use over the network.

Subnet Mask

Enter the subnet mask of the network.

Gateway

Enter the gateway of the network.

External device connection manual for TOP Design Studio

4/ 8



TO,

(2) Communication option setting

M [Project > Project Property > Device Setting > ETHERNET > “PLC1: TCeye (Monitoring)”]

— Set the options of the TCeye (Monitoring) communication driver in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

Project Option X
- Change HMI[H] ' AddPLCIA] | THITal Change PLCIC | [T Delete PLCID)
w -] TOP Setting o oo
: PLC Setting[ TCeye(Monitorin
| L[ s5YS:RD1520% gl TCeye( 9) ]
Option Module Setting Alizs Mame ¢ |PLC1 BindIP: |Auto ~
& FieldBus (0) Interface : |Ethernet s
- RFID (0)
. Device Setting Protocol : | TCeye(Monitor) ~ Comm Manual
-rg® COM3 ()
net (1) [ use Redundancy
- PLC1 : TCeye(Monitoring AND w
{5 Wireless o0 c -
¥ USBDevice (0) o - i
Condition Edi
Primary Option
A
P [2 | 68 B0 FH [ F
Ethernet Protocol TCP
Port 5000 z
Timeout 2000 &1 | msec
Send Wait msec
Spot Count 14 = [MIN Spot: 13], [MAX Spot: 14]
Spot ¥ Pos Start Address ays +[oo100 % ?:. [ x14WORD ]
Spot ¥ Pos Start Address ays +[oo120 [ :-i" [ x14WORD ]
Spot Alarm Temperature Start Address ays +[oo1a0 [ :-E_I [ x14WORD ]
Spot Original Data Start Address avs ~[oo160 [ ) [ x14 WORD ]
Spot Temperature Data Start Address avs ~|oo180 |2 :-E_I [ x14 WORD ]
Spot State Start Address svs « |ooz00 E ;_:I [ x14WORD ]
L Spot State Value: (0:Momal), (1:Warning), {2:Alarm)
< > - - P T —] ~
Apply Close
* The above settings are examples recommended by the company.
Items Settings Remarks
Interface Select “Ethernet”. Refer to “2. External
Protocol Select "TCeye (Monitor)". device selection”.
IP Enter the IP address of the external device.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.

Capture Signal

Configure the Capture Signal Address.

Spot Counter Configure the Spot Counter Address. Fixed
Spot X Pos Start Address Configure the Spot X Pos start address.

Spot Alarm Temp Start Address Configure the Sport Alarm Temp start address.

Spot Meta Data Start Address Configure the Spot Meta Data start address.

Spot State Start Address Configure the Spot State start address.

Area Counter Configure the Area Counter. Fixed
Area Max Spot X Start Address Configure the Area Max Spot X start address.

Area Max Spot Y Start Address Configure the Area Max Spot Y start address.

Area Alarm Temp Start Address Configure the Area Alarm Temp start address.

Area Original Data Start Address Configure the Area Original Data start address.

Area Meta Data Start Address Configure the Area Meta Data start address.

Spot State Start Address Configure the Spot State start address.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

B [Main Screen > Control Panel > Ethernet]

@ Svstem Det [ v
Run Ethernet Port | ETHI |~|[0 ||| b—
W] Link Seeed :| Auto |
‘ MAC Address i 00:15:1D:05:38:C5
FLe seeority O IP Address :|  192.168.0.50
o Subnet Mask [ 255.255.255.0
Viewer . Gateway || 192 .168.0.1
o] | = B Defeult Gateway
n E Ethernet Serial DMS (1) :l
n
T R DN (20 :|
S | i -Ethernet
R IS
Primary IP : [192.155.0.50 v]
Diagnost ic File
Manager Cable Status @ ETH1 Connected
/| Bridge Mode [ Use Bridge | =—J
[System] [Check dup| icatel l Ao | v ] Cance| lse
|
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.

* The above settings are examples recommended by the company.

Items

Description

IP Address

Set an IP address to be used by the TOP to use over the network.

Subnet Mask

Enter the subnet mask of the network.

Gateway

Enter the gateway of the network.
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Touch Qperation Panel
(2) Communication option setting

M [Main Screen > Control Panel > PLC]

"& . PLC
() sstd DriverETH)  [PLCI(Toeve(Monitor ina)) -
A ——— | Interface | Ethernet R
! | Protocol | TCeve(Monitor) -~
‘ Bind IP [Auto [~
- P nezigf heslsf (o =0 5
Yiewer I:IJ-"I] Ethernet LTCP_ |~
e i Port 5000 |5
(] Et hernet
- ﬁ Timeout 3000 3 msec
g Send Wait 0 3 msec
Screen
Disgrostic | Spot Count [ & [MIN Spot:13]
4 |
[System l Diagnostic ]Fing Tesi]

| Aeply || Cancel |

i

* The above settings are examples recommended by the company.

|

Items Settings Remarks

Interface Select "Ethernet”. Refer to "2. External
Protocol Select “TCeye (Monitor)". device selection”.
P Enter the IP address of the external device.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.

Capture Signal

Configure the Capture Signal Address.

Spot Counter Configure the Spot Counter Address. Fixed
Spot X Pos Start Address Configure the Spot X Pos start address.

Spot Alarm Temp Start Address Configure the Sport Alarm Temp start address.

Spot Meta Data Start Address Configure the Spot Meta Data start address.

Spot State Start Address Configure the Spot State start address.

Area Counter Configure the Area Counter. Fixed

Area Max Spot X Start Address

Configure the Area Max Spot X start address.

Area Max Spot Y Start Address

Configure the Area Max Spot Y start address.

Area Alarm Temp Start Address

Configure the Area Alarm Temp start address.

Area Original Data Start Address

Configure the Area Original Data start address.

Area Meta Data Start Address

Configure the Area Meta Data start address.

Spot State Start Address

Configure the Spot State start address.
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3.3 Communication diagnostics

TO BRI HE B X
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B Check the interface setting status between the TOP and an external device.

- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.

- Check if the ETH port settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not

- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

OK

Communication setting normal

Time Out Error

Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix OK NG ) )
Other detailed settings oK NG 4. External device setting
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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