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SIEMENS AG.

SIMETIC S7-200 Series

PPI Driver
Compatible version OS Over 4.0

XDesignerPlus Over 4.0.0.0 

CONTENTS 
Thank you for using M2I’s "Touch Operation Panel(M2I TOP) Series". 

Please read out this manual and make sure to learn connection 

method and process of TOP – External device”

1. System configuration Page 2

It explains device for connection, setup of, cable and structural 

system.

Please choose proper system referring to this point.

2. Selecting TOP model and 

external devices
 Page 3

Select TOP model and external device..

3. Example of system settings Page 4

It explains setup example for communication connection 

between the device and external terminal. 

Select example according to the system you choose in “1. 

System structure”

4. Communication settings details Page 6

It explains the way of configuring TOP communication. 

If external setup is changed, make sure to have same setup of 

TOP with external device by referring to this chapter.

5. Cable diagram Page 9

Explains cable specifications required for access.

Select proper cable specifications according to the system you 

chose in “1. System configuration”.

6. Support address Page 10

Check available addresses to communicate with external devices 

referring to this chapter.
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Series CPU Comm. Method System settings Cable

SIMETIC

S7-200

CPU214

CPU215

CPU216

CPU221 

CPU222 

CPU224 

CPU226

CPU Integrated Port 

0/1
RS-485 ( 2 wire )

Setting Example 1

( Page 4)

Cable Diagram 1

( Page 9 )

1. System configuration
The system configuration of TOP and “SIEMENS AG. - SIMETIC S7-200 PPI” is as below.

■ Connection configuration

ㆍ1:1 connection (TOP 1 vs. external device) 
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Setting details Contents

TOP Series

Series Version name

XTOP / HTOP V4.0

Select the name of a TOP series that is to be connected to PLC.

Before downloading the settings, install the OS version specified in the table below according to 

TOP series.

Name Select the model name of TOP product.

External device Manufacturer Select the manufacturer of external devices to be connected to TOP.

Select “SIEMENS AG”.

PLC Select the model series of external devices to be connected to TOP.

Please select “SIMETIC S7-200 Series PPI”. 

Please check, in the “1. System configuration”, if the relevant external device is available to set a 

system configuration.

2. Selecting TOP model and external devices
Select the external devices to connect to TOP.
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Details TOP “SIMETIC S7-200 Series” Remark

Serial level (port/channel) RS-485 ( 2 wire, COM2 ) RS-485 ( PORT 1 ) User settings

Address(PLC Address) 1 2 User settings

Serial baud rate [BPS] 187500 User settings

Serial data bit [Bit] 8 Fixed Value

Serial stop bit [Bit] 1 Fixed Value

Serial parity bit [Bit] Even Fixed Value

■  [ Project > Project property > Project > Settings > TOP Name ]

Set the communication interface of TOP tool.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

■ External device settings

Setup communication driver of “SIMETIC S7-200 Series PPI”.

- MPI NODE : Node Number of S7-200

- LOCAL NODE : Node Number of TOP

- PROTOCOL : Select the protocol method for TOP to approach S7-200.

3. Example of system settings
The setup of communication interface between TOP and SIEMTIC S7 is recommended as below.

3.1 Example of settings 1

The system is set as below.

(1) XDesignerPlus setup

After setting the below details in [Project > Project Settings], download the detailed settings using TOP tool.



6 / 12

Please do not use the same node address in the same network.

(2) External device settings

After executing the details below from S7-200 series ladder software "STEP 7 Micro/WIN 32", Download through "File > Download". 

Please refer the PLC user manual for more detailed information if you need.

■ PLC CPU type setting 

1. Select [Type] menu after right click on [PLC] from the left project window.

2. Click "OK" after selecting type of PLC which is connected with [PLC Type] window.

3. Connect "PORT0 of PLC" with PC through “PC/PPI cable”(S7-200 ladder cable). Double click [Double-Click to Refresh] from 

[Communication] Dialog box in the Project.

4. As [Search for Addresses] Dialog box comes out, automatically search the PLC. When search is over, dialog box will be 

automatically disappear and searched result of PLC information will be indicated on the left side, click "OK".

5. Set the information of "PORT 1" as below in the [Communication Ports] from [System Block] dialog box in the Project.

6. Download setting information to PLC.
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■  [ Project > Project property > Project > Settings > TOP Name ]

Set the communication interface of TOP tool.

- From right window, [ HMI Setup > check Use HMI Setup > Device Manager ] 

- From right window [ HMI Setup > check Use HMI Setup > PLC Setup ] 

■ External device settings

Setup communication driver of “SIEMTIC S7 MPI Direct”.

Details Contents

Signal level External device – select serial communication method between TOPs. (COM1 supplies RS-232C 

only)

Baud rate External device – select serial communication speed between TOPs.

Data bit External device – select serial communication data bit between TOPs.

Stop bit External device – select serial communication stop bit between TOPs.

Parity bit External device – select serial communication parity bit check method between TOPs.

Time out [ x100 mSec ] Set up TOP’s waiting time from external device at [0 - 5000] x 1mSec.

Transmitting Delay Time [ x10 

mSec]

Receiving Wait Time [ x10 

Set up TOP’s waiting time between response receiving – next command request transmission from 

external device at [ 0 – 5000 ] x 1 mSec.

4. Communication settings details
Communication settings are available at XDesignerPlus or TOP main menu. Communication settings must be identical with the 

external devices.

4.1 XDesignerPlus settings details

Select [Project > Project property] to show the below window.

■ Communication Interface Settings
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mSec]

PLC address [0~65535] Address of other device. Select between [0 - 65535].
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PLC setup

PLC Address : 00 Communication Interface

Timeout : 1000 [mSec] Settings

Delay time of transmission : 0 [mSec]

TOP COM 2/1 : RS - 485 , 187500 , 8 , 1 , EVEN

 TOP COM 2/1 setup   communication test

Details Contents

PLC address [0~65535] Address of other device. Select between [0 - 65535].

Timeout [ x1 mSec ] Set up TOP’s waiting time from external device at [0 - 5000] x 1mSec.

Delay time of transmission [ 

x1 mSec ]

Set up TOP’s waiting time between response receiving – next command request transmission 

from external device at [ 0 – 5000 ] x 1 mSec.

TOP COM 2/1 TOP’s Interface setup to external device.

Port Settings

* Serial communication COM 1 Port

 + COM-1 Port Communication Interface

  - Baud rate : 187500 [BPS] Settings

  - Data bit : 8 [BIT]

  - Stop bit : 1 [BIT]

  - Parity bit : EVEN [BIT]

  - Signal level : RS – 232C

 + COM-2 Port COM-2 Port

  - Baud rate : 187500 [BPS] Communication Interface 

  - Data bit : 8 [BIT] Settings

  - Stop bit : 1 [BIT]

  - Parity bit : EVEN [BIT]

  - Signal level : RS – 485

Details Contents

Baud rate External device – select serial communication speed between TOPs.

Data bit External device – select serial communication data bit between TOPs.

Stop bit External device – select serial communication stop bit between TOPs.

Parity bit External device – select serial communication parity bit check method between TOPs.

Signal level External device – select serial communication method between TOPs.

4.2 TOP main menu setup item

 - When a buzzer is on during the power reset, touch 1 spot at the upper LCD to move to "TOP Management Main" display.

- Set up driver interface at TOP according to below Step1 → Step2.

(Press “TOP COM 2/1 setup” in Step 1 to change setup at Step 2.)

Step 1. [ PLC setup ] .Setup driver interface.

Step 1–Reference.

Step 2. [ PLC setup ] >[ TOP COM2/COM1 setup ] – Setup relevant port’s serial parameter.

Step 2–Reference.
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OK! Communication setting succeeded

Time Out Error! Communication setting error

- Error in the setting situation of Cable and TOP / External device

(reference : Communication Diagnosis sheet)

Designer Version O.S Version

Details Contents Confirm

System 

configuration

Name of CPU
OK NG

Name of confront port that is 

communicating
OK NG

System Connection Method 1:1 1:N N:1 OK NG

Connection 

Cable

Name of Cable
OK NG

PLC setup Setup address OK NG

Serial baud rate                               [BPS] OK NG

Serial data bit                               [BIT] OK NG

Serial Stop bit                               [BIT] OK NG

Serial parity bit                               [BIT] OK NG

Assigned Address Limit OK NG

TOP setup Setup port COM 1 COM 2 OK NG

Name of Driver OK NG

Confront Address Project Property Setup OK NG

Diagnosing Communication OK NG

Serial baud rate                               [BPS] OK NG

Serial data bit                               [BIT] OK NG

Serial Stop bit                               [BIT] OK NG

Serial parity bit                               [BIT] OK NG

4.3 Communication diagnosis

■ TOP - Confirming interface setting condition between external devices 

- Move to Menu by clicking the top side of LCD screen as resetting the power of TOP.

- Confirms if Port [COM 2 or COM 1] setting that is willing to use in [Communication Settings] matches with the setting of external 

devices.

■ Diagnosis of error of communication status

- PLC Setup > TOP [ COM 2 or COM 1 ] click "Communication Diagnosis" button.

- Diagnosis dialog box will pop up on the screen, you can judge by following information that are shown on box no. 3 section.

■ Communication Diagnosis Sheet 

- Please refer to the information below if you have a problem between external devices and communication connection.
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XTOP COM2

Cable Connection

External device

pin arangement * 

caution 1)

Name 

of 

Signal

Pin 

Number

Pin 

Number

Name 

of 

Signal

pin arangement * 

caution 1)

Front View of

D-SUB 9 Pin male 

(Male, convex)

RDA 1

Front View of

D-SUB 9 Pin male 

(Male, convex)

2 2

3 3 TRX+

RDB 4 4

SG 5 5 SG

SDA 6 6

7 7

8 8 TRX–

SDB 9 9

XTOP COM2

Cable Connection

External device

pin arangement * 

caution 1)

Name 

of 

Signal

Pin 

Number

Pin 

Number

Name 

of 

Signal

pin arangement * 

caution 1)

Front View of

D-SUB 15 Pin 

male(Male convex)

– 1 1

Front View of

D-SUB 9 Pin male 

(Male, convex)

2

3 TRX+

– 10 4

RDA 11 5 SG

RDB 12 6

SDA 13 7

SDB 14 8 TRX–

SG 15 9

5. Cable diagram 
This Chapter is to introduce the Cable diagram for regular communication between TOP and relative devices. (The Cable diagram 

which are going to be introduced in this chapter might be different than what "SIEMENS AG." recommends.)

5.1 Cable diagram 1

■ 1 : 1 Connection

(A) XTOP COM 2 Port (9 pin)

1*Caution1) Pin arrangement is shown from connecting face in cable connection connecter.(2~9)

(B) XTOP COM 2 Port (15 pin)

*Caution1) Pin arrangement is shown from connecting face in cable connection connecter.
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Device Bit address Word address Double Word address*C4*C5) Property

Variables V00000.0 - V05118.7 VW00000 - VW05118 VD00000 - VW05116 R/W

Input *caution1) I00000.0 - I00015.7 IW00000 - IW00014 ID00000 - IW00012 R/W

Output *caution2) Q00000.0 - Q00015.7 QW00000 - QW00014 QD00000 - QW00012 R/W

Internal Marker M00000.0 - M00031.7 MW00000 - MW00030 MD00000 - MD00028 R/W

Timer *caution3) - T00000 - T00255 - R

Counter *주3) - C00000 - C00255 - R

                             R:read / W:write

*Caution1) Input Device (I,IW) might not be able to input read on the address of IW0 ~ IW2 because depends on the type of CPU, it 
becomes subordinate in the integrated I/O. Please refer to the PLC Manual.
*Caution2) Output Device (Q, QW, QD) can write value only in the Run Mode. Output value will be reset if it's STOP Mode.
*Caution3) Device Restricted to Read only
*Caution 4) Regarding on Word device, 32 but Data will be saved in the order of from High / Low, 16 bit each.

(Example) VW00000 (32bit data, 0x12345678) è VW00000(16bit, 0x1234) VW00002(16bit, 0x5678)
*Caution5) Checks "Word Swap" function when Double word address is being used.

6. Support address
Devices that are usable with TOP is as below. 

There might be difference in the range of device (address) by type / series of CPU module TOP series supports the maximum 

address range that external device series use Please refer each CPU module user manual carefully for devices that you desired to use 

to prevent not getting out of range.


