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HYOSUNG  

MODBUS Slave 

MODBUS Serial Slave Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

 

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 11 

 Describes how to set up communication for external devices. 

5. Cable table Page 12 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 14 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

This driver is the “Serial Slave Driver” among the “MODBUS Protocol” of “HYOSUNG”.  

Depending on the external device (MODBUS Slave Protocol supported), you may set the “command code”, “protocol frame format” 

etc., of the driver separately. In this case, set the detailed settings according to the external device side based on the communication 

method. 

The system configuration with an external device supported by this driver is as follows: 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

HYOSUNG MODBUS Slave Device 

RS-232C 3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table RS-422 (4 wire) 

RS-485 (2 wire) 

 

 

■ Connectable configuration 

 

ㆍ1:1 connection (one MASTER and one TOP) connection 

 

ㆍ1:N connection (one MASTER and multiple TOPs) connection 

 

ㆍ1 : N connection (multiple Masters and 1 TOP) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “HYOSUNG”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

HYOSUNG MODBUS Slave Serial Set Users 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 

Supported Protocol 

MODBUS RTU MODBUS ASCII 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project> Project property> TOP Settings] → [Project Options > “HMI Setting Use” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C 

RS-422/485 

RS-232C 

RS-422/485 
 

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Project > Project property> PLC setting > COM > “PLC1 : MODBUS Slave] 

– Set the options of the MODBUS Serial Slave driver in TOP Design Studio. 

 
 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) 
Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

Station Num Set the TOP (Slave) prefix.  

AccessMemoryRange 

0 Devie 0 Device ADDRESS Range Setting  

1 Devie 1 Device ADDRESS Range Setting  

3 Devie 3 Device ADDRESS Range Setting  

4 Devie 4 Device ADDRESS Range Setting  

PacketCountSystemBuffer 

ReadPacketCount ReadPacket  Count  

WritePacketCount WritPacket  Count  

[32BIT SWAP ] Not used, used  
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[32BIT SWAP] Changing Unuse to Use will activate the options below. 

 

 

 

 

 

- 32 BIT SWAP MODE 

Big Endian Format(4 3 2 1) 

Big Endian With byte-swapped(3 4 1 2) 

Little Endian Format(1 2 3 4) 

Little Endian With byte-swapped(2 1 4 3) 

Put the 4 forms of data on the master and the default value is Little Endian With byte-swapped (2 

1 4 3). 

- SwapAddressRange  

The swap sytembuffer range. If you don’t intend to use it 

use 1 to 0 

 

- SwapAddressCount 

You can choose individually, and not scope. Choose from 1-9. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Main Scree > Control Panel> Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C 

RS-422/485 

RS-232C 

RS-422/485 
 

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Main Screen > Control Panel > PLC] 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) 
Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

Station Num Set the TOP (Slave) prefix.  

AccessMemoryRange 

0 Devie 0 Device ADDRESS Range Setting  

1 Devie 1 Device ADDRESS Range Setting  

3 Devie 3 Device ADDRESS Range Setting  

4 Devie 4 Device ADDRESS Range Setting  

PacketCountSystemBuffer 

ReadPacketCount ReadPacket  Count  

WritePacketCount WritPacket  Count  

[32BIT SWAP ] Not used, used  

 

 

 

 

 

 

 

 

 

 

 

[32BIT SWAP] Changing Unuse to Use will activate the options below. 
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- 32 BIT SWAP MODE 

Big Endian Format(4 3 2 1) 

Big Endian With byte-swapped(3 4 1 2) 

Little Endian Format(1 2 3 4) 

Little Endian With byte-swapped(2 1 4 3) 

Put the 4 forms of data on the master and the default value is Little Endian With byte-swapped (2 

1 4 3). 

- SwapAddressRange  

The swap sytembuffer range. If you don’t intend to use it 

use 1 to 0 

 

- SwapAddressCount 

You can choose individually, and not scope. Choose from 1-9. 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 
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- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- From [Control panel> Serial], confirm that the COM port settings you want to use are the same as the external device 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

Refer to the user manual of the external device to set “HYOSUNG MODBUS Serial Slave Driver” in the external device I/F. 
 

 

- Take caution when selecting RTU/ASCII mode in Protocol Frame format. 

- Check the contents of the address map on the external device side and use the communication 

address according to its contents. 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagrams described in this section may differ from the external device vendor’s recommendations.) 
 

■ RS-232C (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1   

 

RD 2 SD 

SD 3 RD 

DTR 4 DTR 

SG 5 SG 

DSR 6 DSR 

RTS 7 RTS 

CTS 8 CTS 

 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA(+) 1  SDA(+)  

 2 SDB(-) 

 3 RDA(+) 

RDB(-) 4 RDB(-) 

SG 5 SG 

SDA(+) 6  

 7 

 8 

SDB(-) 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA(+) 1  SDA(+)  

 2 SDB(-) 

 3 RDA(+) 

RDB(-) 4 RDB(-) 

SG 5 SG 

SDA(+) 6  

 7 

 8 

SDB(-) 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

 

 

☞ Continued on next page. 
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■ RS-485 (1:1 connection) 

COM3 

Cable connection 

PLC 

Pin arrangement 
Signal 

name 

Signal 

name 
 

 

+  SDA(+)  

- SDB(-) 

SG RDA(+) 

 

RDB(-) 

SG 

 

 

 

■ RS-422 (1:N connection) – Refer to 1:1 connection to connect in the following way. 

TOP Cable connection and signal 

direction 

PLC Cable connection and signal 

direction 

PLC 

Signal name Signal name Signal name 

RDA(+) 

 

SDA(+) 

 

SDA(+) 

RDB(-) SDB(-) SDB(-) 

SDA(+) RDA(+) RDA(+) 

SDB(-) RDB(-) RDB(-) 

SG SG SG 

 

 

■ RS-485 (1:N/N:1 connection) – Refer to 1:1 connection to connect in the following way. 

TOP Cable connection and signal 

direction 

PLC Cable connection and signal 

direction 

PLC 

Signal name Signal name Signal name 

RDA(+)  SDA(+)  SDA(+) 

RDB(-) SDB(-) SDB(-) 

SDA(+) RDA(+) RDA(+) 

SDB(-) RDB(-) RDB(-) 

SG SG SG 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

 
Bit Address Word Address 32 bits Remarks 

Coil 00000.00 – 10239.15 00000 – 10239 

L/H 

 

Discrete Input 00000.00 – 10239.15 00000 – 10239 *Note 1) 

Input Register 00000.00 – 10239.15 00000 – 10239 *Note 1) 

Holding Register 00000.00 – 10239.15 00000 – 10239  

*Note 1) Cannot be written (Read-only) 

Maximum SYSTEM BUFFER is 10239 

 

■ “HYOSUNG MODBUS Slave Driver” Support Command (Function) Table 

Descriptions Code Descriptions Code Descriptions Code 

Read Coils 01 Diagnostics  

(Homing) 

08 Write File Record (Homing) 15 

Read Discrete Inputs 02 Get Comm Event Counter  

(Homing) 

0B Mask Write Register (Homing) 16 

Read Holding Registers 03 Get Comm Event Log  

(Homing) 

0C Read/Write Multiple registers 

(Homing) 

17 

Read Input Registers 04 Write Multiple Coils 

 

0F Read FIFO Queue 

(Homing) 

18 

Write Single Coil 05 Write Multiple registers 

 

10 Encapsulated I/F Transport 

(Homing) 

2B 

Write Single Register 06 Report Slave ID  

(Homing) 

11  

Read Exception Status  

(Homing) 

07 Read File Record (Homing) 14 

 


