Rockwell Automation, Inc.
Control/Compact Logix Series
DF1 Driver

Supported version TOP Design Studio V1.0 or higher {Rl

CONTENTS

We would like to thank our customers for using M2I's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Cable table Page 11

Describes the cable specifications required for connection.

6. Supported addresses Page 12

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of the driver "Rockwell Automation — Control/CompactLogix Series DF1” is as follows:

Communication

Series CPU Link I/F System setting Cable
method
) ) ) 3.1 Settings example 1 5.1. Cable table 1
ControlLogix Logix5550 CPU Direct RS-232C
(Page 4) (Page 9)
1769-L20
1769-L30 )
. 3.1 Settings example 1 5.1. Cable table 1
CompactlLogix 1769-L31 Channel 0 RS-232C @ 2 . 9
age age
1769-L32E
1769-L35E

W Connectable configuration
TOP — External device (1:1)

] Wi

T
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2. External device selection

W Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM1]

Fiter : [T <] Search
@ Model (O Vendor
Vendor

Rodkwell Automation

RS Automation
HANYOUMG MUX
SAMWONTECH
IAI Corporation

KOLVER 5rl

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ Control/ CompactLogix Series ]

Alizs Mame @ |PLCL

Interface : | Serial ~
Protocol : |DF1 ~ Comm Manual
String Save Mode : @ Change
[ use Redundancy
AND ~
Primary Option
Timeout 300 &|| msec
Send Wait msec
Error Detection BCC ~
Source ID
Destination ID (Remote) l:l
NAK Retries
ENQ Retries 3 =
@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "Rockwell Automation, Inc”.
PLC Select an external device to connect to TOP.

Interface

Protocol

DF1 Driver

Control/Compact Logix Series Serial

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [ Project > Project Property > TOP Setting ] — [ Project Option > “Use HMI Setup” Check > Edit > Serial ]

— Set the TOP communication interface in TOP Design Studio.

Project Option

- Change HMI[H]

3 TOP Setting
I—mFm'lll. 40X

~ @l Option Module Setting
W FieldBus (0)
W RFID (0}
v -igy, Device Setting
~ g8 COM1 (1)

W Ao pic Tl Change FLCIC]

Date / Time Sync.

Project Option

Screen Option

Screen Change

Use HMI Setup

E3 Delete PLCIDY

Unit Convert

HmiSetup  Global Lock & Touch

Project Style

Infrared Device(IrDA)

Splash = PLC Buffer Sync.

Initialization | Edit |

-4 PLC1 : Control/Compactic
-1g¥ COM2 (0)
-1g¥ COM3 (0)
-l Ethernet (0)
-~ Wireless (0)
-4 USBDevice {0)
-l NFCDevice (0)

Project Setting
HMIDisable=0

Project Name=New project
Start Mode=Menu

Start Screen No. =1

Latch Use=0

Latch Set=0~0
Communication Error Message =0
USEErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1

~

Control Panel

System m[)evices :naService ~F! Option

i Serial G
SN
14 - Serial Port: | COM -
PLC Security Oat e Time Signal Level
(®) R5-232C (O R5-42204) (O R5-485(2)
[.J-L.‘] Baud Rate: 33400 =
o o e
] of e = Data Bit: [3 .
Et hernet Serial HOM | Stop Bit: i -
—— Parity Bit: MNone -
I L= & Flow: (fi
L A . Ping
Disgnost ic File Ping Auto Search Loopback Test
Manager
Apply || Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C
RS-232C RS-422 RS-485
RS-422/485
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
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M [Project > Project Property > Device Setting > COM> “PLC1 : Control/Compact Logix Series"]

— Set the options of the DF1 communication driver in TOP Design Studio.

Project Option X
- Change HMI[H] ' AddPLC[A] | THITal Change PLCial | [T Delete PLCID]
~ [} TOP Setting - = i
PLC Setting[ Control/CompactlLogix Series
- 5¥5 : RD1240X gl / pactlog ]
# Option Module Setting Alizs Mame: : |PLC1 |
W Fieldgus (0) Interface : |Serial ~
-4 RFID (0)
v g Device Setting Protocol : | DF1 7 Comm Manual
M String Save Mode : |First LH HL Change
H PLC1 : Control/Compact]
[m]0 8]
coM3 () [] use Redundancy
W Ethernet (0) AMD e
TimeOut 5 s
Condition Edit
Primary Option
Timeout 200 &1 | msec
Send Wait
DF1 Mode
Error Detection
Source ID
Destination ID (Remote)
MAK Retries
ENQ Retries
< >
Apply Close
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [ Main Screen > Control Panel > Serial ]

Controll Fanel

serral

.10 Serial Port: [ COM1 \'] ]
Signal Level
@ RS-232C O Rs-422(4) O Rs-485(2) ]
PLC Security
Baud Rate: | 38400 ~|
¥YNC .
i N— Data Bit: | 8 v
Yiewer [r'-H] = = [ \ ]
s T Stop Bit: |1 =)
'] Ethernet Serial
' Parity Bit: | None ~|
LR -

R e Flow: (Off -
~_ shot ! i >
\""@Q\ [Auto Search] [Loopback Test] V

=y Diagnost ic File
Manager
7 [ Apply “ Cancel ] —
,. [System] Close

OPR OPRX 0800 1 08 : p
Items TOP External device Remarks
Signal Level RS-232C

RS-232C RS-422 RS-485

(port) RS-422/485
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device. (COM3 supports only RS-485.)
Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Main Screen > Control Panel > PLC ]

@ @ System Driver(COMI) l PLC1(Control/CompactlLogix Series)
Hn Interface | Serial 4
m Protocol | DF1 |~
‘ . Timeout 1300 |3 msec
Send Wait msec
tlotor [r"H] DF1 Mode
‘ I Error Det
e ' | et Source 1L y
N l Destinati IV
w m NAK Retri 3 B
) Diagnost ic ENQ Retri g
[Systea] Diagnostic ] ’ App |y “Cancel ]/

TOPRX - TOPRX0800S

2021-08-31
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (COM1/COM2/COM3) settings you want to use in [Control Panel > Serial] are the same as those of the external

device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC ].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

OK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

[tems Contents Check Remarks
System How to connect the system oK NG ) )
) ) - 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) OK NG . -
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting
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Set as below using “Control/CompactLogix Series” Ladder Software “RSLogix5000". For more detailed setting method than that

described in this example, refer to the PLC user manual.

- Take caution when selecting RTU/ASCII mode in Protocol Frame format.

A - Check the contents of the address map on the external device side and use the communication

address according to its contents.

1. In "RSLogix5000" project window, bring up the [Controller Properties] pop-up window.

2. Configure the [Serial Port] tab settings as shown below.

Setup Items Setup Description Remarks
Mode System
BaudRate 38400
Data Bits 8
Parity Bits None
Stop Bits 1
Control Line No Handshake
RTS Send Delay 0
TRS Off Delay 0
3. Configure the [System Protocol] tab settings as shown below.
Setup Items Setup Description Remarks
Protocol DF1 Slave
Station Address 0
Transmit 3
Slave Poll 3000
EOT Suppression No Check
Error Detection BCC
Enable Duplicate Detection No Check
4. Download configurations to PLC.
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagrams described in this section may differ from the external device vendor’s recommendations.)

W RS-232C (1:1 connection)

COM PLC
Pin Signal Pin Cable connection Signal
arrangement*Note 1) | name | number name
1 5 CD 1 CcDh
s s o= -
Based on DTR 4 DTR 9 6
communication G 5 SG Based on communication
cable connector DSR 6 DSR cable connector front,
front, RTS 7 RTS D-SUB 9 Pin male (female,
D-SUB 9 Pin male CTS 8 CTS convex)
(male, convex) 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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TOR =32 I
6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

M [New Tag] : Create tag (Tag Name, Data Type Setting)
1. Run [Controller Tags] > [New Tag].
2. In [New Tag] dialog box, set Tag Name, Data Type

Iltems Contents Remarks

Tag Name The name of the tag used in RSLogix5000 (User Define).

You must map the File Number to the appropriate tag to communicate with the TOP.

M [Map PLC/SLC Messages] Reference

Data type BOOL : 32bit Data

DINT : Double Word Data
INT : Word Data

REAL : Float Data

New Tag Hew Tag
Desciption: Cancel Diescription: Cancel
Help Help
Tope: Base i Type: Base -
Alias For: ‘ Blias For: |
DataType:  [INT[1000] J Bt To ’WJ
seope[BOREST T seps (BRG]
Style: [Decimal =l Sigle: |Float -l
r r~

M [Map PLC/SLC Messages] : File Number mapping in tag
3. In "RSLogix5000" menu, run [Logic] > [Map PLC/SLC Messages...].
4. In [PLC 2,3,5 / SLC Mapping] dialog box [New Tag]dialog box created Tag Name, map File Number.

PLC2,3,5 / SLC Mapping
PLC 3.5 / 5LC Mapping
File Number .-3| Name | Cancel
|7 N7
s o3 L
g F&

Delete Map
FLLC 2 Mapping

TagMame: N7 j

The supported address ranges by the “Tag File Number Setting" described above are as follows:

DEVICE Bit Adrress Word Address 32bit Remarks
BOOL B000:000.00~B999:999.00 B000:000~B999:999 L/H
DINT B000:000.00~B999:999.00 B000:000~B999:999
INT N000:000.00~B999:999.00 N000:000~B999:999
REAL - F000:000~B999:999
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