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MITSUBISHI Electric Corporation 

MELSEC Q Series  

CPU Direct Driver 
 Supported version TOP Design Studio V1.0 or higher  
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1. System configuration 

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSEC Q CPU Direct” is as follows: 
 

Series CPU Link I/F 
Communication 

method 

Communication 

setting 
Cable 

MELSEC Q 

00/00J/01 CPU 

Q00 

Q01 

Q00J 
 

QnH CPU 

Q02 

Q02H 

Q06H 

Q12H 

Q25H 
 

QnU CPU 

Q00UJ 

Q00U 

Q01U 

Q02U 

Q03UD 

Q04UDH 

Q06UDH 

Q10UDH 

Q13UDH 

Q20UDH 

Q26UDH 

CPU port RS-232C 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table 

QJ71C24 

QJ71C24-R2 

QJ71C24N 

QJ71C24N-R2 

QJ71C24N-R4 

RS-232C 

RS-422/485 

MELSEC iQ-R All CPUs 

RJ71C24 

RJ71C24-R2 

RJ71C24-R4 

RS-232C 

RS-422/485 

 

■ Connectable configuration 

ㆍ1:1 connection 
 

                      

 



 

 External device connection manual for TOP Design Studio 3 / 12 

2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Please select “MITSUBISHI Electric Corporation”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

MELSEC Q Series CPU Direct Set Users 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP system menu. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project] → [Property] → [TOP Setting] → [HMI Setup] → [Use HMI Setup Check] → [Edit] → [Serial] 

– Set the TOP communication interface in TOP Design Studio. 

 
 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-232C 

RS-422/485 

RS-232C 

RS-422/485 
 

Baud Rate 115200  

Data Bit 8  

Stop Bit 1  

Parity Bit Odd  

* The above settings are examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Project] → [Project Property] → [Device Setting > COM > MELSEC Q Series] 

– Set the options of the MELSEC Q Series CPU Direct communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “CPU Direct”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time to wait for a response from an external device.  

SendWait (ms) Set the waiting time before sending a data request to an external device.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Control Panel] → [Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C 

RS-422/485 

RS-232C 

RS-422/485 
 

Baud Rate 115200  

Data Bit 8  

Stop Bit 1  

Parity Bit Odd  

* The above settings are examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Control Panel] → [PLC] 
 

 

Items Settings Remarks 

Interface Select “CPU Direct”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time to wait for a response from an external device.  

SendWait (ms) Set the waiting time before sending a data request to an external device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check that the settings of the connected ports in [Control Panel] → [Serial] are the same as the settings of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel] → [PLC]. 

- Check whether communication is connected or not. 
 

Communication 

diagnostics 

succeeded 

Communication setting normal 

Error message Communication setting abnormal 

- Check the cable, TOP, and external device settings. (Refer to Communication diagnostics sheet.) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 
 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range OK NG 6. Supported addresses 
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4. External device setting 
 

4.1. CPU port 
 

ㆍ The loader port communication interface for MELSEC-Q Series do not require a separate configuration. 

ㆍ Communication speed automatically adjusts to the TOP’s configuration. 

 

4.2. Serial communication module 
 

ㆍ Configure the switch set value of channels as 0. 
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5. Cable table  

This chapter introduces a cable diagram for normal communication between the TOP-R and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “Mitsubishi Electric Corporation”) 

 

5.1. CPU port 
 

■ RS-232C (1:1 connection) 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 RD 

 

Based on 

communication 

cable connector 

front, 

D-SUB 6 Pin male 

(male, convex) 

RD 2 2 SD 

SD 3 3 SG 

DTR 4 4  

SG 5 5 DSR 

DSR 6 6 DTR 

RTS 7  

CTS 8 

 

9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

5.2. Serial communication module 
 

■ RS-232C (1:1 connection) 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 CD 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 RD 

SD 3 3 SD 

DTR 4 4 DTR 

SG 5 5 SG 

DSR 6 6 DSR 

RTS 7 7 RTS 

CTS 8 8 CTS 

 9 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 (1:1 connection) 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDA  

 2 SDB 

 3 RDA 

RDB 4 RDB 

SG 5 SG 

SDA 6  

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.  
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■ RS-485 (1:1 connection) 

TOP 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDA  

  2 SDB 

 3 RDA 

RDB 4 RDB 

SG 5 SG 

SDA 6  

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Bit Address Word Address Word Address NOTE 32 BIT 

Input Relay X0000 ~ X1FFF (HEX) X0000 ~ X1FF0 (HEX) X***0 *Note 1) 

L/H *Note 3) 

Output Relay Y0000 ~ Y1FFF (HEX) Y0000 ~ Y1FF0 (HEX) Y***0 *Note 1) 

Internal Relay M0000 ~ M61439 M0000 ~ M61424 M0000 + 16*n *Note 2) 

Special Relay SM0000 ~ SM2047 SM0000 ~ SM2032 SM0000 + 16*n *Note 2) 

Latch Relay L0000 ~ L32767 L0000 ~ L32752 L0000 + 16*n *Note 2) 

Annunciator F0000 ~ F32767 F0000 ~ F32752 F0000 + 16*n *Note 2) 

Edge Relay V0000 ~ V32767 V0000 ~ V32752 V0000 + 16*n *Note 2) 

Step Relay S0000 ~ S8191 S0000 ~ S8176 S0000 + 16*n *Note 2) 

Link Relay B0000 ~ BEFFF (HEX) B0000 ~BEFF0 (HEX) B***0 *Note 1) 

Special Link Relay SB0000 ~ SB7FF0 (HEX) SB0000 ~ SB7FF0 (HEX) SB***0 *Note 1) 

Timer 

(contact) 
TS00000 ~ TS25471 TS00000 ~ TS25456  

Timer 

(coil) 
TC00000 ~ TC25471 TC00000 ~ TC25456  

Aggregate Timer 

(contact) 
SS00000 ~ SS25471 SS00000 ~ SS25456  

Aggregate Timer 

(coil) 
SC00000 ~ SC25471 SC00000 ~ SC25456  

Counter 

(contact) 
CS00000 ~ CS25471 CS00000 ~ CS25456  

Counter 

(coil) 
CC00000 ~ CC25471 CC00000 ~ CC25456  

Timer 

(current value) 
TN00000.0 ~ TN25471.15 TN00000 ~ TN25471  

Aggregate Timer 

(current value) 
SN00000.0 ~ SN25471.15 SN00000 ~ SN25471  

Counter 

(current value) 
CN00000.0 ~CN25471.15 CN00000 ~ CN25471  

Data Register 
D0000000.0 ~ D4212223.15 D0000000 ~ D4212223 Binary Protocol 

D000000.0 ~ D999999.15 D000000 ~ D999999 ASCII Protocol 

Special Data 

Register 
SD0000.0 ~ SD2255.15 SD0000 ~ SD2255  

File Register  Custom range  

*Note 1) For bit addresses with hexadecimal “0~F” notations, use the initial 0 bit as the word address 

*Note 2) When using a bit address that uses decimals, use a word address in units of “16” 

*Note 3) The lower 16 BIT data of 32 BIT data is saved in the address whose screen has been registered, and the upper 16 BIT data is saved in the 

address next to the address whose screen has been registered. 

   Ex. When saving 32BIT data hexadecimal data 12345678 in address D00100, it is saved to 16BIT device address as follows: 

Items 32BIT 16BIT 

Address D00100 D00100 D00101 

Input data 

(hexadecimal) 
12345678 5678 1234 

 


