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1. System configuration

The system configuration of TOP and “HITACHI H Series” is as follows:

Communication

System settin
method y 9 ‘

Series ‘ Link I/F

CPU Port RS-232C
3. TOP communication
settin
HITACHI H-Series Seng . 5. Cable table
4. External device -
COMM-H RS-232C

setting
COMM-2H RS-422

H Connectable configuration

+ 1:1 connection

“[F

+ 1:N connection
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2. External device selection

W Select a TOP model and a port, and then select an external device.

Select Device n
PLC select [COM2]
Filter : | [am w | Search :
@ Model () vendor
Wendor Model
MODEBUS Organization - & EH-150/MICRO-EH Series
. -
SIEMENS AG #7 nsere

Rockwell Automation

GE Fanuc Automation
PAMNASONIC Electric Works
YASKAWA Electric Corporation
YOKOGAWA Electric Corporation
schneider Electric Industries
KDT Systems

RS Automation

FATEK Automation Corporation

DELTA Electronics

<

KOY0 Flertranic Tndustries

[ 4 Eack | » MNext ® Cancel
Select Device n

PLC Setting[ FDA Series ]

Alias Name : |PLC1

Interface : | Serial ~

Protocol : | COMM w0 Comm Manual
String Save Mode @ |First LH HL Change

[] use Redundancy

AND ~
TimeQut 5 :
Condition Edli
Primary Option
Timeout 300 4| msec
send Wait msec

Retry

Hardware Flow Control

4@ Back « oK ® Cancel
Settings Contents
TOP Model Check the display and process of TOP to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "HITACHI IES".
PLC Select an external device to connect to TOP.
Select “"H Series".
Please check the system configuration in Chapter 1 to see if the external device you want to
connect is a model whose system can be configured.
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [HMI Setup > "Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option

- Change HMIH] - AddPLC[Al | TRl ChangePLCIC] | [T Delete
TOP Seti
Em;!’r%lzzux Date / Time Sync. | Screen Option

HmiSetup

PLCID)

Unit Convert

Global Lock & Touch

Project Style  Splash

Initialization

PLC Buffer Sync.

I Edit I
~

~ - @l Option Module Setting Project Option =~ Screen Change
W FieldBus (0)
- RFID (0) Use HMI Setup
- Device Setting
Cemcomi@ || mreemom
~ g COM2 (1) Project Setting
W PLC1: H Series [0] HMIDisable=0

Project Name =New project
Start Mode=Menu

Start Screen No.=1

Latch Use=0

Latch Set=0~0

Communication Error Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1

158 COM3 (0)
W Ethernet (0)

g Wireless ()
W9 UsBDevice (0)

Control Panel

System mDevices Bl scrvice =F Option

s Serial L —
——_ -
T £~ Serial Port: COM? -
PLC Security Dat &/Time Signal Level
® R5-232C (O R5-42204) (O R5-485(2)
Baud Rate: 13200 o
'- o |—
11 Data Bit: 7 -
Et hernet Serial HOM 1 Stop Bit: i -
B Parity Bit: Even v
— % Flow: (ff
L_A ® Ping
a . o - Auto Search  Loopback Test
iagnost ic File Fing
Manager
Apply Cancel
Items TOP External device Remarks
i RS-232C
Signal Level RS-232C RS-422 RS-485
RS-422
Baud Rate 19200
Data Bit 7
Stop Bit 1
Parity Bit EVEN
* The above settings are examples recommended by the company.
Items Description
Signal Level Select the serial communication method between the TOP and an external device.
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > “PLC1: H Series”]

— Set the options of the HITACHI Series communication interface in TOP Design Studio.

Project Option

- Change HMI[H]

W Acd PLC Al Tl Change PLCIC)

~ ] TOFP Setting
| L[ 5YS:RD1220
Option Module Setting
B FieldBus (0)
- RFID (0)
v Device Setting

-rg® COM1 (D)

LC1: H Series [0]

U U
8 Ethernet (0)
™ Wireless (0)
i USBDevice (0)

[ Delete PLCID)

PLC Setting[ H Series ]

Alizs Name : [PLC1

Interface : | Serial ~

Protocol : | COMM ~
String Save Mode : (First LH HL Change

[] use Redundancy

AND
e -
(= -
Conditior Edi
Primary Option

Timeout m msec
Send Wait msec
Retry 5 z
Station Mo,

Hardware Flow Control g

Comm Manual

Apply Close
Items Settings Remarks
Interface Select “Serial”.
Protocol Select "COMM".
TimeOut Set the time for the TOP to wait for a response from an external device.
SendWait Set the waiting time between TOP's receiving a response from an external
device and sending the next command request.
Retry Configure the amount of redelivery attempts from TOP to external device.
Station No. Prefix

Hardware Flow Control

Set whether flow control exists in hardware.

Check CTS *Note 1)

*Note 1) Confirm used communication port pin CTS.
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

M Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

ar Serial

Donal

]

Serial Port: lCUME

Siagnal Level
i RS-232C () RS-422(4) () RS-485(2)

PLC Security Da

l

|

Baud Rate: | 19200 -

Data Bit: |7 -

[ﬁj?llf] emm:| § Stop Bit: | 1 ~|

stermet | Seriel Parity Bit: | Even -

— Flow: |07 ¢ -]

m Q q lAuto Searchl [Loopback Testl
Diagrnost ic File
Manager

‘ Apply H Cancel l

[System]

Close f

Items TOP External device | Remarks
Signal Level (port) RS-232C RS-422 RS-485 R-232C
RS-422
Baud Rate 19200
Data Bit 7
Stop Bit 1
Parity Bit EVEN
* The above settings are setting examples recommended by the company.
Items Description
Signal Level Select the serial communication method between the TOP and an external device.
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

@ a
@ System
Run A

Em)

PLC

™

Ethernet

m 1

Diagnost ic

Jiil] PLC

Driver(COM2) | PLET(H Series) ~|

Interface | Serial Rd
Protocol | COMM Rd
Timeout 300 15 msec

Send Wait 0 3 msec

Retry =

Station Mo, o =

Hardware Flow

[System] l

Ciagnostic

TO,

ERI2 e B X
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| &eply || Cancel |

S |
Items Settings Remarks
TimeOut Set the time for the TOP to wait for a response from an external device.
SendWait Set the waiting time between TOP's receiving a response from an external
device and sending the next command request.
Retry Configure the amount of redelivery attempts from TOP to external device.
Station No. Prefix

Hardware Flow Control

Set whether flow control exists in hardware.

Check CTS *Note 1)

*Note 1) Confirm used communication port pin CTS.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

OK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting
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For more detailed setting method than that described in this example, refer to the PLC user manual.

1. For communication with CPU (H20 - H64)

DIP Switch
1 2 Transmission Speed (bps)
OFF OFF 2400 S Gt Rotary Switch
OFF ON 4800 x10 x1
ON OFF 9600 Remote Master F F
ON ON 19200 CPU Link Prefix
3 (HL) Description Host Link Channel
OFF CPU Link
ON Host Link or Remote Master
2. For communication with CPU misc.
- no other CPU module settings.
3. For communication with COMM-H/COMM-2H card.
DIP Switch Value Description
1 ON : 8bit OFF : 7bit Data Bit
2400 4800 9600 19200 19200
2 ON OFF ON OFF ON
3 ON OFF OFF ON ON Baud Rate (bps)
4 OFF ON ON ON ON
5 ON: Use OFF: Not used Enable or disable parity
6 ON : Even OFF : Odd Parity Bit
7 ON : 2bit OFF : 1bit Stop Bit
8 ON: Use OFF: Not used Enable or disable Check CTS (Hardware flow control)
Rotary Switch | Value Description
x10
Prefix
x1
1~4 | Transmission control procedure: 1
MODE
7,9 | Transmission control procedure: 2

¥ Transmission Control Procedure (Procedure) 2 fixed
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “H-Series")

m RS-232C [COMM-H/ COMM-2H, CPU Port]

TOP External device
. . Pin . . . .
Pin Signal Cable connection Pin Signal Pin
numbe
arrangement*Note 1) name number name arrangement*Note 1)
r
1 5
© © RD 2 2 SD
Q = SD 3 3 RD
6 9
Based on 4 RS
communication SG 5 5 CS
cable connector
front, 7 DR
D-SUB 9 Pin male | CTS*Note 2) 8 PHL
(male, convex) SG
14 PV12

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
*Note 2) GND in COM1 port

m RS-422 [COMM-H/ COMM-2H]

TOP External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement*Note 1)
1 5 RDA 1 1 TXDP
Q O
6 9
Based on RDB 4 4 RXDP
communication RXDN
cable connector SDA 6
front,
D-SUB 9 Pin male
(male, convex) SDB 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

m RS-422 [COMM-H/COMM-2H] 1:N connection

TOP
Signal name
RDA
RDB
SDA
SDB

External

device

Signal name

External

device

Signal name

RXDP

RXDP

RXDN

RXDN

TXDP

TXDP

TXDN
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit address Word address Remarks
X X0000 ~ X4007 WX000 ~ WX400 External input
Y Y0100 ~ Y4021 WY010 ~ WY401 External output
R R0O000 ~ RO7BF WR000 ~ WRFFF Internal output
M MO0000 ~ M3FFF WMO000 ~ WM3FF Data area
L LOO0O ~ L3FFF WLO000 ~ WL3FF Link area
TC TC0000.00 ~ TC2047.15 TCO000 ~ TC2047 Timer/Counter current value
CL CL0000.00 ~ CL2047.15 CLO00O ~ CL2047 Counter clear
CuU CUO0000 ~ CU2047 - Up counter
RCU RCU0000 ~ RCU2047 - Ring counter
CTuU CTU0000 ~ CTU2047 - Updown counter - Up input
CTD CTD0000 ~ CTD2047 - Updown counter - Down input
D TDO000 ~ TD1023 - Delay timer
SS SS0000 ~ SS1023 - Single short timer
WDT WDT0000 ~ WDT1023 - Watchdog timer
MS MS0000 ~ MS1023 - Monostable timer
TMR TMR0000 ~ TMR1023 - Watchdog timer
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