
 

 External device connection manual for TOP Design Studio 1 / 13 

 

LS Industrial Systems Co., Ltd. 

STARVERT Inverter Series 

LSBus Driver  
 Supported version TOP Design Studio V1.0 or higher  
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We want to thank our customers who use the Touch Operation Panel. 
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1. System configuration 

The system configuration of TOP and “STARVERT Inverter” is as follows: 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

STARVERT 

SV-iS7 Built-in communication port RS-485 

3. TOP 

communication 

setting 

4. External device 

setting 

5.1. Cable table 1 

SV-iG5A 
Built-in communication port RS-485 5.1. Cable table 1 

RS485 option baud RS-485 5.2. Cable table 2 

SV-iP5A 
Built-in communication port RS-485 5.1. Cable table 1 

RS485 option baud RS-485 5.2. Cable table 2 

SV-iC5 RS485 option baud RS-485 5.2. Cable table 2 

SV-iV5 RS485 option baud RS-485 5.2. Cable table 2 

SV-iG5 Built-in communication port RS-485 5.1. Cable table 1 

SV-iS5 RS485 option baud RS-485 5.2. Cable table 2 

SV-iH RS485 option baud RS-485 5.2. Cable table 2 

SV-iV RS485 option baud RS-485 5.2. Cable table 2 

SV-iS3 RS485 communication card RS-485 5.2. Cable table 2 

 

■ Connectable configuration 

ㆍ1:1 (one TOP and one external device) connection – configuration which is possible in RS232C/422/485 communication. 

 

 

 

 

 

 

ㆍ1:N (one TOP and multiple external devices) connection – configuration which is possible in RS422/485 communication. 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “LS Industrial Systems”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

STARVERT Series Computer Link STARVERT Link 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project Property > TOP Setting ] → [ Project Options > “Use HMI Setup” Check > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C 

RS-422/485 

RS-232C 

RS-422/485 
 

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Project > Project Property > PLC Settings > CO1 > “STARVERT Series”] 

– Set the options of the Computer Link communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main Screen > Control Panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C 

RS-422/485 

RS-232C 

RS-422/485 
 

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main Screen > Control Panel > PLC ] 
 

  

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

 

Set the communication interface of the external device by operating the keypad on the front of the inverter. For more information, 

refer to the inverter user manual. 

 

■ SV-iS7 
 

1. Turn the inverter to ON. 

2. Operate the keypad to change the COM group as shown below. 

Group Code no. Function notation 

Settings 

Notation 

value 
Contents 

COM 

01 Int485 St ID 

(Integrated communication inverter ID) 

1 Set prefix when using RS-485 communication. 

0~250 

02 Int485 Proto 

(Integrated communication protocol) 

2 Set communication protocol. 

0 ModBus RTU 

1 - Reserved - 

2 LS Inverter-only protocol 

03 Int485 BaudR 

(Integrated communication speed) 

5 Set communication speed. 

0        1200 bps 

1 2400 bps 

2 4800 bps 

3 9600 bps 

4 19200 bps 

5 38400 bps 

04 Int485 Mode 

(Set integrated communication frame) 

0 Set communication transmission format. 

 Data Bit Stop Bit Parity Bit 

0 8 bit 1 bit NONE 

1 8 bit 2 bit NONE 

2 8 bit 1 bit EVEN 

3 8 bit 1 bit ODD 

05 
Resp Delay 

(After receiving, sending delay_ 
5 0 ~ 1000   [mSec] 

DRV 

06 
Cmd Source*Note 1)  

(Operation command method) 
3 Int 485 (communication operation) 

07 
Freq Ref Src*Note 1) 

(Frequency Settings Method) 
7 Int 485 (communication operation) 

    *Note 1) DRV-06 and 07 are not required settings, but these must be set in order to change operating commands and 

frequencies for parameters in the common area of the TOP.
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■ SV-iG5A 
 

1. Turn the inverter to ON. 

2. Operate the keypad to change the COM group as shown below. 

Group 
Code 

no. 
Function details 

Settings 

Notation 

value 

Contents 

Input/Output 

I59 Communication protocol setting 1 Set communication protocol. 

0 MODBUS RTU 

1 LS Inverter-only protocol 

I60 Inverter Prefix 1 Set prefix when using RS-485 communication. 

1~32 

I61 Communication speed 4 Set communication speed. 

0        1200 bps 

1 2400 bps 

2 4800 bps 

3 9600 bps 

4 19200 bps 

I65 Set data/parity/stop bit 0 Set communication transmission format. 

 Data Bit Stop Bit Parity Bit 

0 8 bit 1 bit NONE 

1 8 bit 2 bit NONE 

2 8 bit 1 bit EVEN 

3 8 bit 1 bit ODD 

Operation 
Drv Operation command method*Note 1) 3 RS-485 communication operation 

Frq Frequency Settings Method*Note 1) 7 RS-485 communication settings 

*Note 1) Operation-drv and frq are not required settings, but these must be set in order to change operating commands and 

frequencies for parameters in the common area of the TOP. 

 

 

 

■ Other “Starvert Series”Device Settings 
 

When purchasing a product, set the following parameters according to the proper situation in the enclosed user manual.  

- Communication protocol setting 

- Inverter Prefix 

- Communication speed 

- Set data/parity/stop bit 

- Operation command method 

- Frequency Settings Method 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “LS Industrial Systems”) 

 

5.1. Cable table 1 
 

■ 1:1 connection 
 

TOP COM Port (9 pin) 

TOP COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  MO 

 

 2 CM 

 3 P1 

RDB 4 

(Omit) 
 5 

SDA 6 

 7 

 8 S+ 

SDB 9 S– 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ 1:N connection – Refer to 1:1 connection to connect in the following way. 

 

TOP Cable connection and signal 

direction 

PLC Cable connection and signal 

direction 

PLC 

Signal name Signal name Signal name 

RDA  SDA  SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 
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5.2. Cable table 2 
 

 

■ 1:1 connection 
 

TOP COM Port (9 pin) 

TOP COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  P 

 

6PIN terminal block 

 2 N 

 3 G 

RDB 4 S 

 5 T1 

SDA 6 T2 

 7  

 8  

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ 1:N connection – Refer to 1:1 connection to connect in the following way. 

 

TOP Cable connection and signal 

direction 

PLC Cable connection and signal 

direction 

PLC 

Signal name Signal name Signal name 

RDA  SDA  SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Category Address Parameter Remarks 

General area 0000 – 04FF LS inverter pre-model common area Hexadecimal Address Notation 

0500 – 09FF Factor area Hexadecimal Address Notation 

Area per type 1000 – 1FFF SV-iS7, SV-IG parameter Hexadecimal Address Notation 

2000 – 2FFF SV-IS3 Hexadecimal Address Notation 

3000 – 3FFF SV-IV Hexadecimal Address Notation 

4000 – 4FFF SV-IH Hexadecimal Address Notation 

5000 – 5FFF SV-IS5 Hexadecimal Address Notation 

6000 – 6FFF SV-IG5 Hexadecimal Address Notation 

7000 – 7FFF SV-IV5 Hexadecimal Address Notation 

8000 – 8FFF SV-IC5 Hexadecimal Address Notation 

9000 – 9FFF SV-IP5A Hexadecimal Address Notation 

A000 – AFFF SV-IG5A Hexadecimal Address Notation 

 


