SIEMENS AG.
SIMETIC S7 Series
ETHERNET (FETCH/WRIETE) Driver

Compatible version  OS Over 4.0 H
TOP||TOI

XDesignerPlus ~ Over 4.0.0.0

CONTENTS

Thank you for using M2I's j°Touch Operation Panel(M2I TOP) Series;.

Please read out this manual and make sure to learn connection

method and process of TOP — External device”

1. System configuration Page 2

It explains device for connection, setup of, cable and structural
system.

Please choose proper system referring to this point.

2. Selecting TOP model and

Page 4
external devices
4] Select TOP model and external device..
3. Example of system settings Page 5

It explains setup example for communication connection
between the device and external terminal.
Select example according to the system you choose in “1.

System structure”

'h/l—

. Communication settings details Page 8

It explains the way of configuring TOP communication.
If external setup is changed, make sure to have same setup of

TOP with external device by referring to this chapter.

<—

5. Support address Page 10

Check available addresses to communicate with external devices

referring to this chapter.
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1. System configuration

The system configuration of TOP and “SIEMENS AG - SIEMETIC S7 Series ETHERNET(FETCH/WRITE)" is as below.

Series CPU Link I/F Method System settings Cable

SIMETIC CPU312 IFM
S7-300 CPU313

CPU314

CPU314 IFM
CPU315
CPU315(F)-2 DP
CPU315(F)-2 PN/DP
CPU316
CPU316-2 DP
CPU317-2 DP
CPU317F-2
CPU318-2
CPU317-2 PN/DP
CPU319-3 PN/DP

FSPS| s
CPU614 Ethernet 3113 1esott§1I dl N
CPU388 TP . e |ng wiste palr

Example 1 cable*Cautionl)
(Page 5)

CP 343-1 Lean
CP 343-11T
CP 343-1

SIMETIC CPU412-1 FETCH/WRITE
S7-400 CPU412-2 DP
CPU413-1
CPU413-2 DP
CPU414-1
CPU414-2 DP
CPU414-3 DP CP 443-1 Lean
CPU416-1 CP 443-11T
CPU416-2 DP CP 443-1
CPU416-3 DP
CPU417-4
CPU414-3PN/DP
CPU416-3PN/DP
CPU417
CPU486

*Cautionl) Twisted pair cable
- This means STP(Shielded Twisted Pair cable) or UTP (Unshielded Twisted Pair cable) category 3,4,5.

- You can connect to configurational device such as hub, transceiver depends on the configuration and in this case, use direct cable.
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W Possible Connecting Configuration

+1:1 connection(l TOP and 1 External Device)

—— HUB

- 1 : N Connection (1 TOP and several external devices) Connection

HUB

TO,

hgtgl= e EfXmg

Touch Operation Panel
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2. Selecting TOP model and external devices

Select the external devices to connect to TOP.

Z2AE 44X
Hrl § PLEC Lirt
Series HTOP Series Vendor SIEMERNS MG,
Maodel RTOP1STH-SASSD PLC Model  SIMETIC 57 Series ETHERMET(FETCHAMRITE)
PLC
Wendar ioclel
| 21 Corporation | PROFIBUS DP Slave
MITSUBIZHI Electric Corporation | PROFIBILS DP Slave(EX Packet)
CMRON Inclustrial Automation SIMETIC 57 Seties 3964(RIFERS 2
L= Industrial Systems _ SIMETIC =Y Zeries CPU ETHERMET(OP Communication)
MODBUS Crganization SIMETIC 57 Series ETHERMET(FETCHAWRITE)
SIEMEMNS &G, E l SIMETIZ 57 Series MPI Direct
| Rockwell Autamation (AR SIMETIC =7 Series MPI with P adaptor
ZE Fanuc Automation SIMETIC S7-200 Series PRI
PARNASOMIC Electric Wiorks
YASKAWA Electric Corporstion _
Y OROGAWE Electric Corporatio i
Schneider Electric Industries
HKDT Systems
RS Automation SAMSUMNG)
HITACHI IES
FATER Automation Corparation
DELTA Electronics
KoY O Electronic Industries
WIZOR Electric Corporation
Camfile Technology
DongbulDASARDBEOT)
. ROBOSTAR -
Back || hext Zol || e
Setting details Contents
TOP Series Select the name of a TOP series that is to be connected to PLC.
Before downloading the settings, install the OS version specified in the table below according to
TOP series.
Series Version name
XTOP / HTOP V4.0
Name Select the model name of TOP product.

External device Manufacturer | Select the manufacturer of external devices to be connected to TOP.
Select "SIEMENS AG".

PLC Select the model series of external devices to be connected to TOP.
Please select “SIEMETIC S7 Series ETHERNET(FETCH/WRITE)".

Please check, in the "1. System configuration”, if the relevant external device is available to set a
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system configuration.
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3. Example of system settings

TO,

hgtgl= e EfXmg

Touch Operation Panel

The setup of communication interface between TOP and SIEMTIC S7 is recommended as below.

3.1 Example of settings 1

Set the system as below.

Details TOP SIEMTIC S7 Series Remark
IP Address*Caution1)Caution2) 192.168.0.50 192.168.0.51 User settings
Subnet Mask 255.255.255.0 255.255.255.0 User settings
Protocol TCP TCP User settings
Port 1000 Read Port 2000 User settings
Write Port 2001

*Cautionl) The network address (the 3 front digits of IP 192.168.000) TOP and external device must be identical.

*Caution2) Please do not use the same IP address in the same network.

(1) XDesignerPlus setup

After setting the below details in [Project > Project Settings], download the detailed settings using TOP tool.

=~ F‘_rujec:t
(- TOP Setting
i L. NTOP1STH-SAISD

EI PLC Setting
- COM2 (0)

----- COM1 (0)

- Ethernet (1)
i L.pLCi: SIMETIC 57 Seri

- FieldBus (0}

.. USB Device (1)
[+ CF Card Setting

.. CFCard

B [ Project > Project property > Project > Settings > TOP Name ]

Set the communication interface of TOP tool.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ]

HIl Setup I Sepcial Buffer Sync |

[¥] Use HMI Setup

System Setup | PLC Setup | Device Manager l Interface |

- IP address : 182
- Subnet mask : 255
- Gateway : 192

Ak Ak APF

* Metwaork

50
< 0

Ak Ak 4P
o]
o
o
Ak AP 4)
Ak Ak AP

T

- From right window [ HMI Setup > check Use HMI Setup > PLC Setup ]

HMI Setup | Sepcial Buffer Sync |

[} Use HMI Setup

| System Setup I PLC Setup I Device Manager

Interface |

{PLC1) SIMETIC 57 Series ETHERNET(FETCH/WRITE}

PLCIP: 192 % 168
Read Port : 2000
Write Port : 2001
TOP Port 1000

W External device settings
This sets the option
ETHERNET(FETCH/WRITE)".

IP Address (PLC) : 182
Read Port (0~65535) 1 2000

Write Port (0~65535) ¢ 2001

-
-

Ak Ak AP

-
-

0 Aist =
Time Out 1000
‘Wait before send : 0
Protocol : TGP
communication driver for “SIEMETIC
PLC Commi Info
68 g £1:51 &
Y
=
-

- IP Address (PLC): Type the IP address that the external device was given.

-
» NEEC,
-
> nsec,

-

S7  Series

-Reading port / writing port: Choose the port number that will be used for ethernet

communication.
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(2) External device settings

Setup as below using SIEMTIC S7 Ladder Software [STEP 7]. Please refer the PLC user manual for more detailed information if you

need.

A Please do not use the same IP address in the same network.

1. Create a new project in [New Project] at upper bar of main menu of [SIMETIC Manager].

2. Select menu [Insert] > [Station] > [1 SIMETIC 400 Station] or [2 SIMETIC 300 Station]. — Add CPU

3. Double click added “[SIMETIC 400(1)]" or [SIMETIC 300(1)] CPU > Relevant CPU [Hardware] — New [HW Config] window appears.
4. Open "[SIMATIC 400] > [RACK-400]" or “[SIMATIC 300] > [RACK-300]" at left tree window in [HW Config], select Base unit model,
and register it using Drag & Drop to the right bottom.

5. Select [SIMATIC 400] > [PS-400] or [PS-300] and then appropriate power supply unit, and drag & drop it to the current Rack.

6. Select [SIMATIC 400] > [CPU-400] or [CPU-300] and then appropriate CPU unit and drag& drop it to the current Rack.

(If [Properties] — PROFIBUS interface DP] windows appears, press [Cancel] to finish).

7. Select either [SIMATIC 300] > [CP-300] > [Industrial Ethernet] or [SIMATIC 400] > [CP-400] > [Industrial Ethernet] to choose

currently using ethernet communication unit and drag & drop to current Rack. ( A new [Properties] window will be appeared after
Drag & Drop.) From [Parameters] Tap in [Properties] window, input [IP address] and [Subnet mask] of Ethernet communication

module, and click [New...] key to register the information.

Properties - Ethernet interface CP 343-1 PN (BO/S4)

General  Parameters ]
[~ Set MAC address / use |50 protocol

MAC address: — lfasubnetis selected,

the next available addresses are suggestad,
= IF

IP address! 197 168,050 Latoway
= Do not use router
Subnet mask: [R5, 755, 2550

" Use router

Address: ]
Subnet:
—-— not networked — Mew,..

Properties, .,
Delate

Cancel ‘ Help ‘

8. From main menu [Options] > select [Configure Network]. (Network setting program “NetPro” will start running.

9. On the "NetPro", Register Fetch Passive (Read Port Setting) and Write Passive (Write Port Setting).
4@ Fetch Passive (Read Port Setting)
(1) Right click “NetPro” CPU image, select [Insert New Connection] and ([Insert New Connection] window will pop up)

(2) From [Insert New Connection] window, select [Type] > [TCP connection] and [Station] > [Unspecified] and click [Ok].

( A new [Properties] window will be appeared.)
(3) From [Properties] window [Address] tap IP and Port, [Options] Tap [Mode] > Register “Fetch passive”.

ﬁ’ o] es - TCP co Wﬁ Properties - TCP connection
General Information Addresses | Options | Oversiew | S0 d General Information | Addresses | | Overview |
Parts frarn 1025 through BRR35 are available, Local
(For further ports, refer to online help) .
Mode: |Fetch passive |
Local Remate
P {dech: 192,168, 0.51 JISE,WEB‘U.EU
PORT {deci: ]EDUU ]IUDU

0K Cancel ‘ Help QK I Cancel Help

(Caution) Do not duplicate Local Port Number.
(4) Save the setting by clicking [OK].

= Continue on the next page.
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@ Write Passive (Read Port Setting)

(1) Right click “NetPro” CPU image, select [Insert New Connection] and ([Insert New Connection] window will pop up)

(2) From [Insert New Connection] window, select [Type] > [TCP connection] and [Station] > [Unspecified] and click [Ok].

( A new [Properties] window will be appeared.)

(3) From [Properties] window [Address] tap IP and Port, [Options] Tap [Mode] > Register “Fetch passive”.

T

Properties - TCP connection ' Properties - TCP connection
General Information dd Options | Owerview | S0 nmaton | General Information | Addresses Owerview | S00e fign |
Ports from 1025 through 65535 are available, Local
(For further ports, refer to online helpy .
Maode: |Write passive x|
for 1657 fid
Local Femote
IP {dech: (192,168, 0,51 [192 168 0,50
PORT {dacy: {2 |1000

Cancel ‘ Help QK I Cancel Help

(Caution) Do not duplicate Local Port Number.
(4) Save the setting by clicking [OK].

10. Check the setting information of Fetch Passive / Write Passive from [Properties] > [Overview] tap.

Properties - TCP connection

General Information | Addresses | Options  Overdew | e (|
LConnections:
L. | Mame..| B/S| Remote ., [ Local .. | Rem.,. | Operating ... | Stat
oo, TCFc,.. 074 1921660, 2000 1000 Fetch pass,.. OF
oo, TCPc.. 0/ 1821680, 2001 1000 ‘rite passive  OK
€ ' k.
o
Print Configuration Print ]

Cancel ‘ Help J

11. Main Menu [Station] > select [Save And Compile] to error checking and save settings, download the saved information to PLC.

12. Reset the power of PLC after downloading.
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4. Communication settings details
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Communication settings are available at XDesignerPlus or TOP main menu. Communication settings must be identical with the

external devices.

4.1 XDesignerPlus settings details

Select [Project > Project property] to show the below window.

= F‘_rujeu:t
|§|-- TOP Setting
L KTOP1STH-SASSD

B [ Project > Project property > Project > Settings > TOP Name ]

Set the communication interface of TOP tool.

- PLC Sefting
L. COM2Z (0}

L. COM1 (0)

El- Ethernet (1)

‘e PLCY : SIMETIC 57 Seri

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ]

HMI Setup | Sepcial Butfer Sync. |

[¥] Use HMI Setup

Syatem Setup | PLC Setup | Device Manager I Interface |

- FigldBus (0}

L. USE Device (0)
[ CF Card Setting

L. CFCard

B Communication Interface Settings

* Network
_IP address - 192 A6 = 0 & 50 =
- Subnet mask: 255 = 255 & 255 A g A
- Gateway 192 * 88 = 0 A 3

- From right window [ HMI Setup > check Use HMI Setup > PLC Setup ]

HMI Setup | Sepcial Buffer Sync- |

[¥} Use HMI Setup

| System Setup I PLC Setup I Device Manager | Interface |

{PLC1) SIMETIC 57 Series ETHERMET(FETCH/WRITE)

PLC IP 192 * 188 2g 4.5 =
Read Port : 2000 = Time Out ;
Writs Port : 2001 = Wait before zend
TOP Paort ; 1000 & Protocol :
W External device settings
~ This sets the option of communication driver for

ETHERNET(FETCH/WRITE)".
PLC Comm info

IP Address (PLC) 192 L] M68 D %51 x
Read Port (0~G5535) ¢ 2000 =
Write Port (0~65535) 1 2001 ot

1000 * nsec.

0 : TiEEC.

TCP -
"SIEMETIC S7  Series

Details

Contents

IP Address

Setup the IP address that TOP receives in the network.

Subnet mask

Input subnet mask of network

Gateway

Input subnet mask of network

PLC IP address

Input IP address that external device gets received.

Read Port / Write Port

Choose port number that will be used for ethernet communication of external device.

TOP port

Port number will be automatically setup if ethernet commucation with external device is in

progress.

PLC address [0~65535]

Address of other device. Select between [0 - 65535].

Ethernet time out

Set up TOP's waiting time from external device at [0 - 99] x 100mSec.

Delay time of transmission [ x1

Set up TOP's waiting time between response receiving — next command request transmission
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mSec ] from external device at [ 0 — 5000 ] x 1 mSec.
Protocol Choose the protocol type that are authorized to use following external devices and setup port
number.
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4.2 TOP main menu setup item

- When a buzzer is on during the power reset, touch 1 spot at the upper LCD to move to "TOP Management Main" display.

- Set up driver interface at TOP according to below Stepl — Step2.
(Press "TOP ethernet setup” in Step 1 to change setup at Step 2.)

Step 1. [ PLC setup ] .Setup driver interface.

PLC setup
PLCIP:192.168.0.51 Communication Interface
Protocol : TCP Settings

PLC Read Port : 2000

PLC Write Port : 2001

TOP Port : 1000

PLC Address : 00

Timeout : 1000 [mSec]

Delay time of transmission : 0 [mSec]

TOPIP:192.168.0.50

1OP Ethernet setting cohmunication diagnosis

Step 1-Reference.

Details Contents

PLC IP It is an IP address that external device was given.

Protocol Choose the protocol type that are authorized to use following external devices and setup port
number.

PLC Read Port It is the port address that will be used for ethernet of external device.

PLC Write Port It is the port address that will be used for ethernet of external device.

TOP port Port number will be automatically setup if ethernet commucation with external device is in
progress.

PLC address [0~65535] Address of other device. Select between [0 - 65535].

Timeout [ x1 mSec ] Set up TOP's waiting time from external device at [0 - 5000] x 1mSec.

Delay Time before | Set up TOP's waiting time between response receiving — next command request transmission

transmitting [ x1 mSec] from external device at [ 0 — 5000 ] x 1 mSec.

TOP IP Setup the IP address that TOP receives in the network.

Step 2. [PLC Setup] > [TOP Ethernet Setup] - Setup the serial parameter of correspond port.

Port Settings

* Ethernet Communication Ethernet Port
+ Network setting Communication Interface
-MAC:00-15-1ID-00 - 30-52 (each device has different address) Settings

- IP Address : 192. 168 . 0. 50
- Subnet mask : 255 255 . 255 .0

- Gateway : 192168 .0.1

Step 2-Reference.

Details Contents

MAC Physical official address in the network.

IP Address Setup the IP address that TOP receives in the network.

Subnet mask An address that divides the network ID and host ID regarding of IP address.
Gateway An address that connects a network to another network.
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4.3 Communication diagnosis
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B TOP - Confirming interface setting condition between external devices

- Move to Menu by clicking the top side of LCD screen as resetting the power of TOP.

- [Main Menu >Communication setting] Confirm if detail in number 20~24 is identical to the setup information of “BSetup exercise

1"

- PLC Setup > Click the button in "Communication diagnosis" of TOP Ethernet.

- Diagnosis dialog box will pop up on the screen, you can judge by following information that are shown on box no. 3 section.

OK!

Communication setting succeeded

Time Out Error!

Communication setting error

- Error in the setting situation of Cable and TOP / External device

(reference : Communication Diagnosis sheet)

B Communication Diagnosis Sheet

- Please refer to the information below if you have a problem between external devices and communication connection.

Details Contents Confirm
TOP Version Information xDesignerPlus : OS:
Name of Driver OK NG
External device IP Address
. . oK NG
information
(xDesignerPlus Subnet mask oK NG
Project setting) Gateway OK | NG
TOP Information Protocol UDP/IP TCP/IP OK NG
(Main Device IP Address
) OK NG
Menu Setting)
Subnet mask OK NG
Gateway OK NG
Other specified setting info OK | NG
System System Connection Method
o 11 1N N:1 OK | NG
configuration
Name of cable (Hub usage) Direct (Use Hub) Cross (No Hub) OK NG
External Name of CPU
] OK NG
device
Name of communication device OK NG
Protocol(mode) OK NG
Other specified setting info OK | NG
IP Address (Local) (Destination) OK NG
Port number (Local) (Destination) OK NG
Subnet mask OK NG
Gateway oK NG
Address range confirm (other docs) OK NG

/ 15



5. Support address
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Devices that are usable with TOP is as below.

There might be difference in the range of device (address) by type / series of CPU module TOP series supports the maximum

address range that external device series use Please refer each CPU module user manual carefully for devices that you desired to use

to prevent not getting out of range.

Bit address Word address 32 bits Remark
Input Relay 100000.0 — E00000.0 — IW00000 — EW00000 — —
* cautionl) 100127.7 E00127.7 IW00126 EW00126
Output Relay Q00000.0 A00000.0 — QWO00000 — AWO00000 - —
* caution2) A00127.7 QWO00126 AW00126
Q00127.7
Data Block DB00001 : DBX00000 — DB00001 : DBW00000 — H/L —
DB65535 : DBX65533.7 DB65535 : DBW65532 *cautiondcaution5)
Internal Memory M00000.0 - M00511.7 MWO00000 - MWO00510 —
. . — TO0000 - T00255 Not
Timer*caution3)
writable
. — C00000 — Z00000 - Not
Counter*caution3)
C00255 Z00255 writable

*Caution1) Input Device (I,IW) might not be able to input read on the address of IW0 ~ IW2 because depends on the type of CPU, it

becomes subordinate in the integrated 1/0O. Please refer to the PLC Manual.

*Caution2) Output Device (Q, QW, QD) can write value only in the Run Mode. Output value will be reset if it's STOP Mode.

*Caution3) Device Restricted to Read only

For displaying the timer, use the calculatation tag, and then devide the timer value to two piece.

At the following example, the inner buffer 1001 means the current timer value and the inner buffer 1002 means the unit.

It means Unit) 0:10ms, 1:100ms, 2:1sec, 3:10sec

Calculation

Preview

Display the inner buffer 1001, 1002.

Intemal

> 1001

Type Casting

Mathing

_Condition | Operation | Information
OPERATION
scandelay 1 5 x600ms -
Mo Operation | DataType | Expression
1 [lworp |lpEC _ |liSYS)1001 = TOOOO & 4095
2

WORD | DEC

(5Y5)1002 = TO000 == 12

*Caution 4) Regarding on Word device, 32 but Data will be saved in the order of from High / Low, 16 bit each.

(Example) VW00000 (32bit data, 0x12345678) =» VWO00000(16bit, 0x1234) VW00002(16bit, 0x5678)

*Caution5) Checks "Word Swap" function when 32BIT address is being used.

Data Size

1 18bit

@) 32bit

[#] word Swap
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