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HIGEN MOTOR Co.,Ltd 

FDA Servo Series 

 Supported version TOP Design Studio V1.4 or higher  

 

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Cable table Page 10 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 12 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “HIGEN MOTOR Co., Ltd. – FDA Series Servo Drive” is as follows: 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

FDA 

FDA70□□ 

CN3 Port 

(COM Port) 
RS–232C 

3.1 Settings example 1 

(Page 4) 

5.1. Cable table 1 

(Page 9) 

CN3 Port 

(COM Port) 

RS-485 

(2 wire) 

3.2 Settings example 2 

(Page 5) 

5.3. Cable table 3 

(Page 11) 

FDA60□□ 

CN3 Port 

(COM Port) 
RS–232C 

3.1 Settings example 1 

(Page 4) 

5.2. Cable table 2 

Page 10 

CN4 Port 

(COM Port) 

RS-485 

(2 wire) 

3.2 Settings example 2 

(Page 5) 

5.4. Cable table 4 

(Page 12) 

 

■ Connectable configuration 

 

ㆍ1:1 (one TOP and one external device) connection – configuration which is possible in RS232C/422/485 communication. 

 
 

ㆍ1:N (one TOP and multiple external devices) connection – configuration which is possible in RS422/485 communication. 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “HIGEN MOTOR Co., Ltd”. 
PLC Select an external device to connect to TOP. 

 

Select “FDA Series Servo”.  

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project Property > TOP Setting ] → [ Project Options > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 

 

 

 

 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C/RS-485 RS-232C/RS-485  

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit NONE  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Project > Project Property > PLC Setting > COM > “PLC1 : FDA Series Servo”] 

– Set the options of the HIGEN MOTOR Co., Ltd communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface “Computer Link 
Fixed 

Protocol Modbus Rtu 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

FDASERVO6000 0 : FDA7000    1 : FDA6000  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main Screen > Control Panel > Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C/RS-485 RS-232C/RS-485  

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit NONE  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main Screen > Control Panel > PLC ] 
 

 

Items Settings Remarks 

Interface “Computer Link 
Fixed 

Protocol Modbus Rtu 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

FDASERVO6000 0 : FDA7000    1 : FDA6000  
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3.3 Communication diagnostics 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication diagnostics OK NG 

Serial Parameter Transmission Speed OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External 

device 

CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission Speed OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 

 

■ FDA 7000 Series 

ㆍ P01–15 :Communication speed “10” Settings 

P01–15 setting 

value 

RS–232C RS–485 P01–15 setting 

value 

RS–232C RS–485 

00 9600 9600 08 38400 9600 

01 9600 19200 09 38400 19200 

02 9600 38400 10 38400 38400 

03 9600 57600 11 38400 57600 

04 19200 9600 12 57600 9600 

05 19200 19200 13 57600 19200 

06 19200 38400 14 57600 38400 

07 19200 57600 15 57600 57600 
 

ㆍ  P01–18 : Terminal Prefix (Station ID) “1” configuration 

Item Description Remark 

P01–18 1 Prefix Station ID 
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4. External device setting 

 

Configure the communication setting of the external device by referring to its user manual. 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. (The cable 

diagram described in this section may differ from the recommendations of “HIGEN MOTOR Co., Ltd.”) 

 

■ 1:1 connection 

(A) TOP COM Port (9 pin) RS 232 

TOP COM 

Cable connection 

Servo Drive (CN3 port, 20PIN) 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1    

 
 

10120–3000VE(3M) 

RD 2   

SD 3 6 SG 

DTR 4   

SG 5   

DSR 6 9 SD 

RTS 7 10 RD 

CTS 8   

 9   

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

(A) TOP COM Port (9 pin) RS 485 

TOP COM 

Cable connection 

Servo Drive (CN3 port, 20PIN) 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  7 P 

 
 

10120–3000VE(3M) 

 2 8 N 

 3   

RDB 4   

 5   

SDA 6   

 7   

 8 19 SG 

SDB 9   

 

■ 1:1 connection 

 

(A) TOP COM Port (9 pin) 

TOP COM 

Cable connection 

Servo Drive (CN3 port, 15PIN) 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1    

 

RD 2 2 GND 

SD 3 13 TXD 

DTR 4 14 RXD 

SG 5   

DSR 6   

RTS 7   

CTS 8   

 9   

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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■ 1:1 connection 
 

(A) TOP COM Port (9 pin) 

TOP COM 

Cable connection 

Servo Drive (CN3 port) 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  1 GND 

USB–A Type 

 

 2 2 TRXD– 

 3 3 TRXD+ 

RDB 4 4  

SG 5  

SDA 6 

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 
 

 ㆍ TOP DESIGN STUDIO Device marking method : Refer to FDA Series User Manual “Address Map” table 

Address Menu Data Type Menu name (variable 

name) 

Property Initial 

value 

Min Max Unit 

40011 0x000A  StE–01 INT Display Select R 1203 100 1330 – 

(1) How to select a device: Select “INT/FLT” according to “Data Type” in table.  

For FLT, select “Float” data class in TOP DESIGN STUDIO. 

For INT, select “DEC” data class and data size “32bit” in TOP DESIGN STUDIO. 

However, for Alarm Address/ Jog Key Address select ALM/RST device. 

(2) How to select address: Select 4 digits as indicated after “4” in address. 

(3) Caution relevant to "Properties": Please be careful with the use of devices dedicated to R (Read)/W (Write). 
 

5.1 FDA 7000 Series 

■ Standard type 

Device Bit Address Word Address Remarks 

Integer Data Type INT0011.00 – INT2205.15 INT 0011 – INT 2205  

Float Data Type ––––– FLT 0011 – FLT 2205  

JOG Key Jog Mode ––––– INT 1001  

Auto Jog Mode ––––– INT 1003  

Key Jog Speed ––––– FLT 1002  

Jog Speed, Time/REV ––––– FLT 1003 – FLT 1019  

Jog Key  JOG ON ––––– INT 2201 *Note 1) 

 JOG OFF ––––– INT 2202 *Note 1) 

 Clockwise (CW) ––––– INT 2203 *Note 1) 

 Counter Clockwise (CCW) ––––– INT 2204 *Note 1) 

 Stop ––––– INT 2205 *Note 1) 

ALM Current alarm request ––––– ALM0 *Note 2) 

RST Current alarm clear RST0 ––––– *Note 1) 

*Note 1) Write-only device 

*Note 2) Read-only Device 

5.2 FDA 6000 Series 

■ Standard type 

Device Bit Address Word Address Remarks 

Integer Data Type INT0011.00 – INT2205.15 INT 0011 – INT 2205  

Float Data Type ––––– FLT 0011 – FLT 2205  

JOG Auto Jog Speed ––––– FLT 0701 – FLT 0703  

 Auto Jog Time ––––– INT 0704 – INT 0706  

ALM Current alarm request ––––– ALM0 *Note 2) 

RST Current alarm clear RST0 ––––– *Note 1) 

*Note 1) Write-only device 

*Note 2) Read-only Device 

 

 

 

 

 

■ Location Determination Type 
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Device Bit Address Word Address Remarks 

Integer Data Type INT0011.00 – INT2205.15 INT 0011 – INT 2205  

Float Data Type ––––– FLT 0011 – FLT 2205  

JOG Jog Speed ––––– FLT 0605 – FLT 0606  

 INC Jog Value ––––– FLT 0607 – FLT 0608  

ALM Current alarm request ––––– ALM0 *Note 2) 

RST Current alarm clear RST0 ––––– *Note 1) 

*Note 1) Write-only device 

*Note 2) Read-only Device 

 


