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YASKAWA Electric Corporation  

Machine Controller MP900 Series  

Serial Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 10 

 Describes how to set up communication for external devices. 

5. Cable table Page 12 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 17 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “YASKAWA Electric Corporation – MP900 Series Serial” is as follows. 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

MP900 

MP920 

PORT1, PORT2  

on the CPU unit 
RS-232C 

3. TOP 

communication 

setting 

4. External device 

setting 

5.1. Cable table 1 
CN1, CN2  

on “217IF” 
RS-232C 

CN3  

on “217IF” 

RS-422 

(4 wire) 

3. TOP 

communication 

setting 

4. External device 

setting 

5.2. Cable table 2 
RS-485 

(2 wire) 

MP930 
PORT1, PORT2  

on the CPU unit 
RS-232C 

3. TOP 

communication 

setting 

4. External device 

setting 

5.1. Cable table 1 

MP940 

PORT1  

on the CPU unit 
RS-232C 3. TOP 

communication 

setting 

4. External device 

setting 

5.3. Cable table 3 
PORT2  

on the CPU unit 

RS-422 

(4 wire) 

RS-485 

(2 wire) 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Please select "YASKAWA Electric Corporation". 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

Mp900 Serial Set Users 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 

Supported Protocol 

MEMOBUS ASCII MEMOBUS RTU 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 
 

 
 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C RS-422 RS-485 

RS-232C 

RS-422/485 
 

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit Even  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Project > Project properties > PLC settings > COM > “PLC1 : Mp900”] 

– Set the options of the communication driver of MP900 Series Serial in TOP Design Studio. 
 

 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select the serial communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Slave Address No Enter the prefix number of an external device (Slave).  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C RS-422 RS-485 

RS-232C 

RS-422/485 
 

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit Even  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select the serial communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Slave Address No Enter the prefix number of an external device (Slave).  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

Set as below using “MP Series” Ladder Software “MPE720”. For more detailed setting method than that described in this example, 

refer to the PLC user manual. 
 

 
– In case of setting “Automatically Reception” of “Procedure Ⅱ” to “Enable” in the setting procedure 

below, it is possible to connect without “Procedure Ⅲ”. 

  

– The example of “Procedure Ⅲ: Ladder Program” is an example of communication setting for one port 

on the external device side. In case of simultaneous communication of multiple ports, a separate 

ladder program is required. Please contact the manufactorer for details. 
 

■ Operation Ⅰ : “PC and PLC connection method” : set communications as follows(Operation Ⅱ, Operation Ⅲ), but before 

connect PC and PLC. 

1. Run “Communication Manager” program. 

( Path : Start → Program → “YE_Applications” → “Communication Manager” ) 

2. Run "Logical Port Setting" to set the port type and details. 

( Path : File → Setting… ) 

3. After PC and PLC are connected, save, and follow below operation. 
 

■ Operation Ⅱ : “MPE720” Create Project : (root) > [Group Folder] > [Order Folder] > [Controller Folder] Register 

1. To register the device you want to use in “MPE720”, follow “[Group Folder] > 

[Order Folder] > [Controller Folder]” path. 

(Caution) In the "MPE720" left project window, Right–Click, and follow the parent 

path through the [New] entry. 

2.Register the Controller Type for the device you wish to use in the Controller 

Configuration window, which appears when registering a new [Controller Folder] 

3. Double-click the newly registered [Controller Folder] to bring up the [Log on to 

the controller] window and enter "User Name" and "Password" to form project 

folders as shown on the left. 
 

■ Operation Ⅲ : “Communication Setting” : [Engineering Manager] – [Module Configuration] window  

4. Double-click [Definition Folder] – [Module Configuration] to display the [Engineering Manager] – [Module Configuration] window. 

5. Register the [Module Type] of the corresponding [Rack] – [Slot] position in the [Module Configuration] window. 

6. Double-click the corresponding [Slot] area to display the setting window. Matters to be set are as follows. 

 

Items Settings Remarks 

Transmission Protocol MEMOBUS Fixed 

Master/Slave Slave Fixed 

Device Address 1 Set Users 

Serial I/F RS-232 User setting *Note 1) 

Transmission Mode RTU User setting *Note 2) 

Data Length 8Bit Set Users 

Parity even Set Users 

Stop Bit 1Stop Set Users 

Baud Rate 19.2K Set Users 

Sending Disable Set Users 

Automatically Reception Disable User setting *Note 3) 

Slave I/F Register Settings ––– Set Users 

*Note 1) Select the communication method of the external device (RS-

232C/RS-422/RS-485). 

*Note 2) Select the communication mode (ASCII/RTU) you want to use. 

*Note 3) When setting Disable, you must register a separate Ladder 

Software. 

If enabled, a separate Ladder Software is not required. However, the 

communication speed may be slow. 
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■ Operation Ⅳ : Ladder Program : MSG-RCV function 

7. Register the [MSG–RCV] function ( [Instruction Pallete] menu – [System] tab ) on the [Ladder Works] Software. Refer to the 

example below. For more detailed setting method, refer to the Ladder Software manual. 

 

 

Connecting Port Address 

Port 1 SB006940 / SB006941 

Port 2 SB006950 / SB006951 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this chapter may differ from the recommendations of “YASKAWA Electric Corporation”.) 
 

5.1. Cable table 1 

■ RS-232C [MP920/930 CPU embedded PORT1, PORT2] (1 : 1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 FG 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 SD 

SD 3 3 RD 

DTR 4 4 RS 

SG 5 5 CS 

DSR 6 6 N/C 

RTS 7 7 SG 

CTS 8 8 N/C 

 9 9 N/C 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-232C [CN1, CN2 on 2171F] (1 : 1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 FG 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 SD 

SD 3 3 RD 

DTR 4 4 RS 

SG 5 5 CS 

DSR 6 6 DR 

RTS 7 7 SG 

CTS 8 8 N/C 

 9 9 ER 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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5.2. Cable table 2 
 

■ RS-422 [CN3 on 2171F] (1 : 1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  1 RX– 

Based on 

communication 

cable connector 

front, 

MR–8 (Plug) 

 2 2 RX+ 

 3 3 SH 

RDB 4 4 RXR 

 5 5 TXR 

SDA 6 6 TX– 

 7 7 TX+ 

 8 8 N/C 

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
 

■ RS-485 [CN3 on 2171F] (1 : 1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  1 RX– 

Based on 

communication 

cable connector 

front, 

MR–8 (Plug) 

 2 2 RX+ 

 3 3 SH 

RDB 4 4 RXR 

 5 5 TXR 

SDA 6 6 TX– 

 7 7 TX+ 

 8 8 N/C 

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
 

■ RS-485 [CN3 on 2171F] (1 : 1 connection) 

COM 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

+  1 RX– 

Based on 

communication 

cable connector 

front, 

MR–8 (Plug) 

- 2 RX+ 

SG 3 SH 

 4 RXR 

 5 TXR 

 6 TX– 

 7 TX+ 

 8 N/C 

  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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■ RS-422 1 : N connection - Refer to 1:1 connection to connect in the following method. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA 

 

SDA 

 

SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 

 

■ RS-485 1 : N connection - Refer to 1:1 connection to connect in the following method. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA  SDA  SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 
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5.3 Cable table 3 
 

■ RS-232C [MP940 CPU embedded PORT1] (1 : 1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 TXD 

Based on 

communication 

cable connector 

front, 

MR–8 (Plug) 

RD 2 3 RXD 

SD 3 6 CTS 

DTR 4 12 RTS 

SG 5 14 GND 

DSR 6  

RTS 7 

CTS 8 

 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 [MP940 CPU embedded PORT2] (1 : 1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  1 TX+ 

Based on 

communication 

cable connector 

front, 

MR–14 (Plug) 

 2 2 TX– 

 3 3 RX+ 

RDB 4 4 RX– 

 5 7 RXR 

SDA 6 11 TXR 

 7 14 GND 

 8 
 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 [MP940 CPU embedded PORT2] (1 : 1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  1 TX+ 

Based on 

communication 

cable connector 

front, 

MR–14 (Plug) 

 2 2 TX– 

 3 3 RX+ 

RDB 4 4 RX– 

 5 6 RX– 

SDA 6 8 TX+ 

 7 9 TX– 

 8 10 RX+ 

SDB 9 14 GND 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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■ RS-485 [MP940 CPU embedded PORT2] (1 : 1 connection) 

COM 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

+  1 TX+ 

Based on 

communication 

cable connector 

front, 

MR–8 (Plug) 

- 2 TX– 

SG 3 RX+ 

 4 RX– 

 6 RX– 

 8 TX+ 

 9 TX– 

 10 RX+ 

 14 GND 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 1 : N connection - Refer to 1:1 connection to connect in the following method. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA 

 

SDA 

 

SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 

 

■ RS-485 1 : N connection - Refer to 1:1 connection to connect in the following method. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA  1 TX+  1 TX+ 

RDB 2 TX– 2 TX– 

SDA 6 RX– 6 RX– 

SDB 10 RX+ 10 RX+ 

SG 14 GND 14 GND 

(Caution) For 1:N connection, short the pin arrangement of (1) and (2) items out of 14 pins for terminating devices.   (1) 4–7–9     (2) 3–8 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Bit Address Word Address 32bit Remarks 

MB Coil MB000000 ~ MB65535F MB00000 ~ MB65535 L/H  

IB Discrete Input IB00000 ~ IBFFFFF IB0000 ~ IBFFFF *Note 1) 

IW Input register - IW0000 ~ IWFFFF *Note 1) 

MW Holding Register - MW00000 ~ MW65535  

*Note 1) Cannot be written 


