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Servo&Control Systems 

: Ultra Sonic Flow Meter 

 
 Supported version TOP Design Studio V1.4.3 or higher  
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We want to thank our customers who use the Touch Operation Panel. 
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1. System configuration 

The system configuration of TOP and “SNC- Flow Meter” is as follows. 

 

Series CPU Link I/F 
Communication 

method 

Communication 

setting 
Cable 

Flow Meter - - RS–485 

3. TOP 

communication 

setting 

5.1. Cable table 

1 

 

■ Connection configuration 

 

ㆍ1:1 (one TOP and one external device) connection – configuration which is possible in RS232C/422/485 communication. 

 

 

ㆍ1:N (one TOP and multiple external devices) connection – configuration which is possible in RS422/485 communication. 

 



 

 External device connection manual for TOP Design Studio 3 / 13 

2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “OTHERS Manufacture”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

Flow Meter Flow Meter Flow Meter protocol 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 

Items TOP External device Remarks 

Signal Level (port) RS-485 RS-485  

Baud Rate 57600 Fixed 

Data Bit 8 Fixed 

Stop Bit 1 Fixed 

Parity Bit None Fixed 

* The above settings are examples recommended by the company. 

 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Project > Project properties > PLC settings > COM > “Flow Meter”] 

– Set the options of the Computer Link communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-485 RS-485  

Baud Rate 57600 Fixed 

Data Bit 8 Fixed 

Stop Bit 1 Fixed 

Parity Bit None Fixed 

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

  

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Station number Set the station number of the communication target device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

 

Configure the communication setting of the external device by referring to its user manual. 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this chapter may differ from the recommendations of “SNC-Flow Meter”.) 

 

■ 1:1 connection 
 

TOP COM Port (9 pin) 

TOP COM 
Cable connection 

PLC 

Pin arrangement*Note 1) Signal name Pin number Signal name 

 

Based on communication 

cable connector front, 

D-SUB 9 Pin male (male, 

convex) 

RDA 1  DA(Pin 1) 

 2 DB(Pin 2) 

 3  

RDB 4 

SG 5 

SDA 6 

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
 

 

 

 

TOP COM 

Cable connection 

External 

device 

Pin arrangement 
Signal 

name 
Signal name 

 

╋  DA(Pin 1) 

— DB(Pin 2) 

 

 

 

 

 

 

 

 

 

 
■ 1:N connection – Refer to 1:1 connection to connect in the following way. 

 

TOP 
Cable connection and signal direction 

PLC Cable connection and signal 

direction 

PLC 

Signal name Signal name Signal name 

RDA 

 

DA    DA 

RDB DB DB 

SDA 
 

 

SDB 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

- General command 

Command Property Detailed description Minimum 

value 

Maximum 

value 

Initial 

value 

R000 Read-only Instantaneous flow (Unit: mL/min) -2000 2000 0 

R001 Read-only Accumulated flow (Unit: mL/min) 0 99999 0 

R006 Write-only Zero adjustment command 0 1 0 

R007 Write-only Accumulation reset command 0 1 0 

R008 Read-only Status 0 63 - 

R010 Read/Write Weighing minus detection value (Unit: mL) -127 127 -40 

R015 Read/Write Low Cut (Unit: mL/min) – Top % setting 1 255 40 

R016 Read/Write 

Open Collector Output 1 

0: Comparative output (instantaneous flow rate, upper 

limit) mL/min 

1: Comparative output (instantaneous flow rate, lower 

limit) mL/min 

2: Comparative output (accumulated flow rate, upper 

limit) mL/min 

3: Comparative output (accumulated flow rate, lower 

limit) mL/min 

4: Total clear when it is 0 (For LCD PR) 

5: Average data move ON (For photo) 

6: Average data move OFF (For photo) 

0 5 0 

R017 Read/Write 

Open Collector Output 2 

0: Comparative output (instantaneous flow rate, upper 

limit) mL/min 

1: Comparative output (instantaneous flow rate, lower 

limit) mL/min 

2: Comparative output (accumulated flow rate, upper 

limit) mL/min 

3: Comparative output (accumulated flow rate, lower 

limit) mL/min 

4: Fail output 

0 4 0 

R018 Read/Write Comparative output 1 (Unit: mL/min or mL) lower limit 2000 0 100 

R019 Read/Write Comparative output 2 (Unit: mL/min or mL) upper limit 2000 0 1000 

R020 Read/Write 

Input setting  

0: No function  

1: Zero adjustment  

2: Accumulation reset 

3: Instantaneous comparison -> Out1 output (For LCD 

PR) 

0 3 0 
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Command Property Detailed description Minimum 

value 

Maximum 

value 

Initial 

value 

R025 Read/Write 

D0 - Maintain fail data (1: maintain) Burnout 

D1 – TKK OLD (19200) 

D2 – Flow Fast Operation 

D3 – Measure Delay No Change 

D4 – Pulse Start High/Low 

D5 – TOFCO Protocol 

D7 – Always 1 

0 255 0 

R031 Read/Write Communication Error (2Sec/Step, 0 o’clock not checked) 0 25 2 

R032 Read/Write High-speed communication Delay (1mSec/Step) 0 250 10 

R040 Read/Write Full Scale Pulse (Pulse) 50 9999 8000 

R041 Read/Write Compensation Value (Pulse) 50 9999 100 

R042 Read/Write Max Flow Rate Value(10 mL / Step) TKK 1 6000 200 

R044 Read/Write Auto Zero (Pulse) 0 9999 30 

R050 Read/Write Discharge error ON time setting (125mSec/Step) 127 127 30 

R051 Read/Write Discharge error OFF time setting (125mSec/Step) 127 127 30 

R055 Read/Write Flow rate display mode (0:1 mL, 1:0.1 mL) 0 1 0 

  *In case of an error, the instantaneous flow rate is output as 29999 (response). 

 

- Analog commands 

Command Property Detailed description Minimum 

value 

Maximum 

value 

Initial 

value 

R060 Read/Write Analog calibration mode setting 0 1 0 

R061 Read/Write 20mA (maximum flow rate) value 0 65535 54710 

R062 Read/Write 0~24mA analog output test value 0 65535 0 

R063 Read/Write 4mA (Zero flow rate) value 0 65535 10954 

R064 Read/Write Analog factor 100 999 437 

 

- Serial Number & program Version 

Command Property Detailed description Minimum 

value 

Maximum 

value 

Initial 

value 

R080 Read/Write Flow Serial No1 (A02S: Product name) 0 65535  

R081 Read/Write Flow Serial No2 (1001: year/month) 0 65535  

R082 Read/Write Flow Serial No3 (No.) 0 65535  

R083 Read/Write Match Serial No1 (S) 0 65535  

R084 Read/Write Match Serial No2 (year/month) 0 65535  

R085 Read/Write Match Serial No3 (No.) 0 65535  

R086 Read/Write Amp Serial No1 (A01SN) 0 65535  

R087 Read/Write Amp Serial No2 (No.) 0 65535  

R098 Read-only Version 100 999  

R099 Read-only Date 0908 9999  

 

  



 

 External device connection manual for TOP Design Studio 13 / 13 

- Amp Hardware Test Command 

Command Property Detailed description Minimum 

value 

Maximum 

value 

Initial 

value 

R300 Read/Write Hardware Test Mode 0 1 0 

R301 Read-only DIP S/W Value (0b11XXXXXX) - - - 

R302 Read-only Zero Key, Zero Input(0b110000XX) - - - 

 

- Parameter Cal Command 

Command Property Detailed description Minimum 

value 

Maximum 

value 

Initial 

value 

R100 Read/Write Zero point Value (Origin) -2000 2000 0 

R101 Read-only Fluctuating zero value -2000 2000 0 

R103 Read/Write Input amplification ratio (Vth) 0 127 32 

R105 Read/Write Calibration Delay Time Value 20 999 136 

R116 Read/Write K Factor (flow rate) 100 9999 1000 

R117 Read/Write Specific Gravity 100 9999 1000 

R118 Read/Write Kinematic Viscosity 100 9999 1000 

 

- Calibration command 

Command Property Detailed description Minimum 

value 

Maximum 

value 

Initial 

value 

R110 Read/Write Zero point value (ORG) -2000 2000 0 

R112 Read-only Precision value (Error) 0 125 0 

R113 Read/Write Input amplification ratio (ORG) 0 127 32 

R115 Read/Write Calibration Delay Time Value(ORG) 20 999 136 

R190 Read-only Frequency value (R190~R193) 8500 15000  

R200 Read-only Current Time Value (Current value - Zero value) 0 32000 0 

R201 Read/Write CAL 1 value 0 9999 2000 

R216 Read/Write CAL 16 value 0 9999 2000 

R251 Read/Write CAL 1 Factor 2500 5000 3200 

R266 Read/Write CAL 16 Factor 2500 5000 3200 

 

- Save command 

Command Property Detailed description Minimum 

value 

Maximum 

value 

Initial 

value 

R800 Write-only Parameter Save    

R801 Write-only Calibration Save    

R802 Write-only Total Initial    

 


