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Supported version  TOP Design Studio V1.4.9.85 or higher {Rl
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1. System configuration

The system configuration of TOP and “Keyence KV Series Ethernet” is as follows:

Series CPU Link I/F Communication method Communication setting Cable

KV-700 Series
KV-1000 Series

KV Series . 3. TOP communication )
KV-3000 Series Ethernet - Twisted
Ethernet . Ethernet port setting .
KV-5000 Series (TCP/UDP) ; ) pair cable™ete D
(MC Protocol) 4. External device setting

KV-7000 Series
KV-8000 Series

*Note 1) Twisted pair cable
- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.
- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a direct cable.

B Connection configuration

+ 1:1 connection

HUB i

+ 1:N connection

M{;‘ M.." ......... M.."
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2. External device selection

H Select a TOP model and a port, and then select an external device.

PLC select [Ethernet]

Filter : | [all ~ |

@ Model (O Vendor

Vendor Model

PATLITE ~ :’ KV-700/1000/3000/5000/7000/3000

Giddings & Lewis Motion Control

DELTA TAU Data Systems
CEYON Technology

Digital Electronics Corporation
EINAR Elektronic AB
HOMEYWELL

ATLAS COPCO

ROOTECH

IDEC Corporation

LENZE

BECKHOFF Automation
FASTFCH Cn.. | t. Y
M8 Back | W Next *® Cancel
Select Device [ = |
PLC Setting[ Kv-700/1000/3000/5000/7000/8000 ]
Alizs Mame : BindIP: Auto ~
Interface : | CPU Ethernet ~
Protocol : |MC Protocal 3E (Binary) — ~ Comm Manual
String Save Mode @ |First LH HL Change
[J use Redundancy
AND ~
Primary Option
¥ IR
Ethernet Protocol
Port
Timeout
Send Wait
4@ Back + OK * Cancel
Settings Contents
TOP Model Check the display and process of TOP to select the touch model.

External device

Vendor Select the vendor of the external device to be connected to TOP.
Select "KEYENCE > KV-700/1000/3000/5000/7000/8000".
PLC Select an external device to connect to TOP.

Protocol
MC Protocol

Interface

KEYENCE KV Series Ethernet Ethernet

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communi

cation setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication inte

rface setting

M [Project > Project Property > TOP Setting] — [ HMI Setup > “Use HMI Setup” Check > Edit > Ethernet]

— Set the TOP communication interface in TOP Design Studio.

Project Option *
-Change HMI[H] 'Md PLC[A] | THTW] Change PLCICI | [ Delete PLCID)
I —1
03 Tor Serf’"g 0k Date / Time Sync. = Screen Option | Unit Convert
“"I__ﬁ“;;:;f:'é)smﬂg Project Option ~ Screen Change  HmiSetup  Global Lock & Touch  Project Style  Splash  PLC Buffer Sync.
v -af.’fivzz;it?%g Hmi Setup Option Initialization Edit
T COM2 () Project Setting ~
~-fg¥ COM3 (0) HMIDisable=0
v g Ethernet Fl) Zgﬁﬁ:inleh;ﬂiw project
ey | s saeenner=y
-4 USBDevice (0) Latch Set=0n0
Communication Error Message=0
USBErrorMessage =0
StorageErrorMessage=1
DatabaseMessage=1
Control Fanel
P ] ; )
] System Devices [a- %) Ethernet X
-Port -
B P | e Ethernet Port © ETH1 > [0 -
il l ? = Link Speed : Auto <
PLLC Security Dat esTime MAC Address 00:00:00:00:00:00
IP Address :|  192.168.0,100
Subnet Mask :  255.255.255.0
- L Gateway : 192.168.0.1
cwwe ) |
""I" Default Gateway
Ethernet Serial HOM | I DNS (1) ]
- DNS (2) ¢
- — -Ethernet
=i h\ Prinary IP © 192.168.0.100 ~
L_A . Ping || cable Status :
——
Diagnost ic File Fing I : ] :
ErEERr Bridae Mode [JUse Bridae _
Check duplicate | Apply | Cancel
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.1
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR 192 . 168 . 0 . 0) should match.

*Note 2) Do not use duplicate IP addresses over the same network.

* The above settings are examples recommended by the company.

Items

Description

IP Address

Set an IP address to be used by the TOP to use over the network.

Subnet Mask

Enter the subnet mask of the network.

Gateway

Enter the gateway of the network.
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(2) Communication option setting
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M [Project > Project Property > Device Settings > Ethernet > PLC1 : KV-700/1000/3000/5000/7000/8000]
Set the options of the communication driver in TOP Design Studio.

Project Option

- Change HMI[H]

W Acd PLC Al Tl Change PLCIC)

[ Delete PLCID)

v D TOP Setting

- RFID (0)

Device Setting
-rg¥ COM1 (0)
¥ COM2 (0)
-fg¥ COM3 (D)

[ 5YS : RD1220X
#8 Option Module Setting
- FieldBus (0)

8 Ethernet (1)
- PLC1: KV-700,1000/3000 AND w
Wireless (0)

----- ¥ USBDevice (0)

PLC Setting[ KV-700/1000/3000/ 5000/ 7000/8000 ]
Alizs Name : [PLC1 |

BindIP : |Auta

Interface : | CPU Ethernet ~

Protocol : |MC Protocol 3E (Binary)
String Save Mode : (First LH HL Change

[] use Redundancy

Ak

Primary Option

P [2 | 68 B0 FH [ F
Ethernet Protocol

Timeout msec

Send Wait msec

Comm Manual

Apply Close
Items Settings Remarks
Interface Select "Ethernet”. Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device. device selection”.
IP Enter the IP address of the external device.

Ethernet Protocol

Select the Ethernet protocol between the TOP and an external device.

Port

Enter the Ethernet communication port number of the external device. Default port
is 5000.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device
and sending the next command request.

Retry

Set the number of times the TOP sends a request when it fails to receive a

response from an external device.

ubp
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

B [Main Screen > Control Panel > Ethernet]

"ﬁ. Ethernet

Bun

YHC
Yiewer

(i

Ethernet

Diagnost ic

[System]

[l s T Y

- Port
Ethernet Port : ETHI |~ 0 |+
Link Speed :| Auto |

MAC Address

00:15:10:05:38:C5

[P Address 192 .168.0.100
Subnet Mask 255,255 .255.0
Gateway 192.168.0.1
[E Default Gateway
ONS (10
DNS (20
- Ethernet
Primary IP : [192.158.0.100 .l

Cable status
Bridge Mode :

ETH1 Connected

O Use Bridge

lCheck duplicate] l Apop | v l Cancel ]

Dption

MRAM
Analysis

Close

rf

el

Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting

B [Main Screen > Control Panel > PLC]

=
o o PLC

@ System| Driver(ETH)  PLCI(KY-700/1000/3000/5000/7000/8000): v]
Run —
Interface | CPU Ethernet -
I ' Protocol | MG Protocol 3E (Bir |~
‘ FLC g Bind IP [ Auto [+
vHE P lezfs] (ealsd o B [ &
Yiewer Y
Ethernet -TCP
LLTH s A E
1 E Ethernet or 9000 [+
Timeout 1000 |5 msec
m i| Send Wait 0 [3imsec
Diagnost ic |
[System] [ Diagnostic HDing Testl l Aop |y “ Cancel ]
I
Items Settings Remarks
Interface Select "Ethernet”. Refer to “2. External
Protocol Select the communication protocol between the TOP and an external device. device selection”.
IP Enter the IP address of the external device.
Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.
Port Enter the Ethernet communication port number of the external device. Default port
is 5000.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device
and sending the next command request.
Retry Set the number of times the TOP sends a request when it fails to receive a response UDP
from an external device.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (ETH1/ETH2) settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting
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Configure the Unit Editor's setup unit as shown in the figure below,

e Unit Editor - Edit mode

= B et

File(F)

LR

R500
-507

Edit(E) Convert(P)

W o6 B2

1
EV-EDZ1WV

View(V) Option{Q) Window(W) Help(H)
Ll Wy o
Unit
5 t unit(l Setup uniti2) |
TE$= 0 L@ By i Be @
El Base
Leading OM Ho.
Numbker of DMs in use

Leading relay HNo.
Humber of relays

Bzud rate

{ch unit setting)

in use

Setting method of IP address

\Ng @

[1] EV-EPz1V

»

DM10000
230

R30000

m

840
100/10Mbps sutom. . .

Fixed IP address(*)

IP address

Subnet mask

192 _168.0.51 4

255.255.255.0

Default gateway a.0.0.0
ONS server 0.0.0.0
Beceive timecut[s] 10
Feep RAliwve[s] &00
E Port NHo.
Port No. (EV5,EV CCM+,DB) 8500
Port MNo. {uplink) 8501
Port No. (VI) 8502
Port No. (system expansion) 8504
Port MNo. (system expansion ) 850&
Simple PLC link port Ho. (UDE) 5001
MC protocol port Ho. (TCE) 5000
-HC protocol port No. (UDE) 5000 | i
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5. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Address Word Address Remarks
Data Memory DM0000.00 — DM65534.15 DMO0000 — DM65534
Control Memory CMO0000.00 - CM7599.15 CMO0000 - CM7599
Expansion Data Memory EM00000.00 — EM65534.15 EMO00000 — EM65534
File Register — Current Bank FM00000.00 — FM32767.15 FM00000 — FM32767
Link Register WO0000.0 — W7FFF.F WO0000 — W7FFF
File Register
_ Consecutive Number mode ZF000000.00 — ZF524287.15 ZF000000 — ZF524287
Input/Output R0O00000 — R199915 R0O000 — R1999
Control Relay CRO000 - CR7915 CROO - CR79
Internal Auxiliary Relay MR000000 — MR399915 MR0000 — MR3999
Latch Relay LRO0000 — LR99915 LROOO — LR999
Link Relay BOOOO — B7FFF
Timer Contact TCO000 - TC3999 —
Current value — TO000 — T3999 *Note 1)
Counter Contact CC0000 — CC3999 —
Current value — C0000 - C3999 *Note 1)

*Note 1) If the current value is greater than 65535, only this value will be displayed.
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