Booster Boiler

Supported version TOP Design Studio V1.4.4 or higher {Rl
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1. System configuration

The system configuration of TOP and “Booster — Booster Boiler” is as follows:

. Communication Communication
Series .
method setting
. 3. TOP communication Twisted pair
Booster — Booster Boiler TCP ; .
setting Cable™ete D

*Note 1) Twisted pair cable

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a
direct cable.

W Connectable configuration
+ 1:1 connection (one TOP and one external device) connection

] | T

— [ HuB

+ 1:N connection (one TOP and multiple external devices) connection

] T m;[ ......... MR-

| HUB |—
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [Ethernet]

Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor Model

A
BECKHOFF Automation ‘, Booster Boiler

FASTECH Co., Ltd.

ODvA

HYOSUNG

HB TECH

DNP

FAMUC Co., Ltd.

Robots and Design

CoDeSys Automation Alliance
Cognex Corparation

S&E

Peripheral Device

4_Back | B Next *® Cancel

Select Device [ = |
PLC Setting[ Booster Boiler ]
Alizs Mame @ |PLCL BindIP: lAuto v
Interface : |Ethernet ~
Protocol : |Booster Boiler ~ Comm Manual

String Save Mode : |First LH HL Change

[ use Redundancy

AND v
Condition : Edi
Primary Option
i (92 3| (18 E] o B[ & =
Ethernet Protocol TCP

Timeout msec
Send Wait msec

Status Data Address avs - 'W‘: [ x50 WORD ]

Modem Number Address avs V’W‘: ?;\' [ %6 WORD ]

Boiler Number sv5 v|osio [F5

Boiler Type(Recive Data Use) ’Yes—\f| L4

@ Back + OK * Cancel
Settings Contents

TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.

Select "BOOSTER".

PLC Select the external device to be connected to the TOP.

Interface Protocol

Booster Boiler Ethernet Booster Boiler

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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TO,

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Ethernet]

— Set the TOP communication interface in TOP Design Studio.

Project Option

- Change HMI[H]

. Add PLC [4] "m Change PLC[C] m Delete PLC[D]

igmap;;—“’fmm Date / Time Sync. | Screen Option || Unit Convert
b 'ﬁiﬁ;_”lz";du‘éfemng Project Option  Screen Change  HmiSetup = Global Lock & Touch  Project Style  Splash | PLC Buffer Sync.
8 RFID (0) Use HMI Setup
M "-_“':Eivieo’iit?gf RS esi Initialization | Edit |
~f§¥ COMZ (D) Project Setting ~
g COM3 (D) HMIDisable=0
v g Ethernet (1) Project Name=New project
-4 PLC1: Booster Boiler Start Made=Menu
- {g® Wirless (0) E;B&SUCS’EEZE Ne.=1
-4 USBDevice (0) Latch Set=0n~0
Communication Errar Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
" . B ~
System Devices M @ ethemet i
-Port
Ethernet Port ' ETH1 |0 -
- | T
11 l 7 o H Link Speed : Auto M
PLE Security  Date/Time MAC Address @  O0:00:00:00:00:00
IP Address :|  192.168.0.50
Subnet Mask :  255.255.255.0
- Gateway @  182.168.0.1
"I"" .._-_' tj' [ Default Gateway
Ethernet Serial HOM | DNS (1) ]
DNS (2) i
— - Ethernet
E—_] “\ Primary IP © 192.168.0.50 ~
e O
| S— Ping Cable Status :
Diagnost ic File Fing : :
Manager Bridae Mode : [JUse Bridge
Check duplicate | Apply || Cancel
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.255.50 192.168.255.1
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting

M [Project > Project Property > Device Setting > ETHERNET > "PLC1 : Booster Boiler” ]

— Set the options of the Booster Boiler communication driver in TOP Design Studio.

Project Option

- Change HMIH]
W

“ AddPLC[A] | THITal Change PLCIC)

m Delete PLC[D]

TOP Setting
-3 5Y5 ¢ RD1520%
Option Module Setting
-4 FieldBus (0)

W RFID (0)

=% COM3 (0)
Ethernet (1

PLC1 : Booster Boiler

PLC Setting[ Booster Boiler ]
Alizs Name : [PLC1

BindIP : |Auto

Interface : |Ethernet ~

Protocol : | Booster Boiler ~

String Save Mode : (First LH HL Change

[ use Redundancy

Wireless (0)
9 USBDevice (0)

Primary Option

P |192 :| |168 :| |0 :| |1

Ak

Ethernet Protocol TCP

Port 10195 =
Timeout msec

Send Wait msec

Status Data Address sy « 05000 E ?j [ x50 WORD ]
5YS v (05100 275

5YS v|os110 27
Boiler Type{Recdve Data Use)

L Boiler Type Data Address avs ~|os120 |2 ;j

Modem Mumber Address [ %6 WORD ]

Boiler Mumber

Comm Manual

Apply Close
Items Settings Remarks

Interface Select “Ethernet”. Refer to "2. External
Protocol Select “Booster Boiler”. device selection”.
IP Enter the IP address of the external device.

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device. Fixed

Port Enter the Ethernet communication port number of an external device. Fixed

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.

Status Data Address

Configure an address that contains booster boiler status information.

Modem Address

Set the modem address.

Boiler Number

Set the boiler product number address

Boiler Type

(Recive Data Use)

Determine whether to send the boiler data as the received type or a custom type.

(For custom type, configure as Boiler Type Data Address shown below)

Boiler Type
Data Address

If “No" is selected for boiler type (receive data use), send the boiler data as the

SYS address value configured by the user.
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* This is a setting method when "Use HMI Setup” in the setting items in "3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting
B [Main Screen > Control Panel > Ethernet]

¥YNC
Yiewer

Scrééh‘"

o
o
@ System
!mll Q
PLC S
°
M| =
Ethernet
q
Diagnostic
4
[System]

Ethernet:

-Port

Ethernet Port
Link Speed

| ETHI

;| Auto

Fle |+
)

MAC Address

00:15:10:00:00: 00

IP Address :| 192.168.0.100
Subnet Mask :[ 255.255.255.0
Gateway :|  192.168.0.1
[ Default Gateway
DNS (1)
DNS (2) ¢
- Ethernet

Cable Status
Bridge Mode :

Primary IP : [192.158.0.100 v}

ETH1 Mot connected

[ Use Bridge

[Check duplicatel [ App |y 1 Cancel J

MRAM
Analysis

TOPRX - TOPRX0800S A  2021-08-31 04:18:32 PH
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.255.50 192.168.255.1
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR 192 . 168 . 0 . 0) should match.

*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

Run

¥YNC
Yiewer

Scr éé n

TOPRX - TOPRX0800S A

Dr iver (ETH) [ PLCI(Booster Boiler)

Diagnostic H’ing Test]

2021-08-31

ERI2 e B X
Touch Qperation Panel

Interface | Ethernet Rd
Protocol | Booster Boi ler 4
Bind IP [ Auto [~]
N o P o2l sslg 0 B 1 B
Ethernet
ol FGEE 10195
[ﬁl?l'ﬁ‘] d Timeout msec
kbamRet 1 Send Wait 0 |2 msec
| Status Data AddSYS:05000:16:16:DEC:R [ x50 WOF
m E Moclem Number AdSYS:05100:16:16:DEC:R [ xB WORC
Disgnostic | Boiler Mumber SYS:05110:16:16:DEC:R
Boiler Type(Rec /
Boiler Type D SYS:05120:16:16:DEC:R
[System]

[ App |y HCanceIJ

04:19:38 PH

Items Settings Remarks
Interface Select “Ethernet”. Refer to "2. External
Protocol Select “Booster Boiler”. device selection”.
IP Enter the IP address of the external device.
Ethernet Protocol Select the Ethernet protocol between the TOP and an external device. Fixed
Port Enter the Ethernet communication port number of an external device. Fixed
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device
and sending the next command request.
Status Data Address Configure an address that contains booster boiler status information.
Modem Address Set the modem address.
Boiler Number Set the boiler product number address
Boiler Type Determine whether to send the boiler data as the received type or a custom type.
(Recive Data Use) (For custom type, configure as Boiler Type Data Address shown below)
Boiler Type If "No” is selected for boiler type (receive data use), send the boiler data as the SYS
Data Address address value configured by the user.
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3.3 Communication diagnostics

TO BRI HE B X
Touch Qperation Panel

B Check the interface setting status between the TOP and an external device.

- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.

- Check if the ETH port settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not

- Touch "Communication diagnostics" in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

OK

Communication setting normal

Time Out Error

Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix OK NG ) )
Other detailed settings oK NG 4. External device setting
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. Supported addresses

The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the
address range supported by the device you want to use.

Device Address range Description Remarks

DATETIMEO: year
DATETIME1: month
DATETIME2: day

DATETIME DATETIMEQO ~ DATETIMES
DATETIMES: hour
DATETIME4: minute
DATETIMES: second
Write-
START STARTO ~ STARTO Communication start trigger |
only

*Note) The DATATIME device must be registered on the drawing for communication to occur.
*DATATIME information reception server time

*Note) Communication occurs only when the START device write operation takes place.
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