BINAR ELEKTRONIK :
Bifas UHS Series Etherent

Supported version  TOP Design Studio V1.4.4 or higher {Rl

TOP

J
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We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes connectable devices and network configurations.

2. External device selection Page 3

Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

‘ Describes how to set up communication for external devices.

5. Supported addresses Page 10

Check for addresses that can communicate with an external

device.
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1. System configuration

The system configuration of TOP and “BINAR ELEKTRONIK - Bibas UHS3 Series Etherent” is as follows:

. . Communication Communication
Series CPU Link I/F )
method setting
. 3. TOP . .
Bifas UHS . Twisted pair
) - - TCP communication .
Series - cable™ete D
setting

*Note 1) Twisted pair cable

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a
direct cable.

W Connectable configuration
+ 1:1 connection (one TOP and one external device) connection

] | T

— [ HuB

+ 1:N connection (one TOP and multiple external devices) connection

] T m;[ ......... MR-

| HUB |—
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2. External device selection
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H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [Ethernet]

Filter : | [all ~ ‘

@ Model (O Vendor

Vendor Model
OMRON Industrial Automation

77
@7 BFas UHS Series

MODBUS Organization

BIMNAR. Elektronic AB

4_Back | B Next *® Cancel

Select Device [ = |
PLC Setting[ BiFas UHS Series ]
Alizs Mame: : BindIP: lAuto v
Interface : Ethernet ~

Protocol : |MC Protocol 1E (Binary) — ~

Comm Manual
String Save Mode : |First LH HL Change
[ use Redundancy
AND ~
Primary Option
P b 3o Fp 3P &
Ethernet Protocol TCP
Timeout msec
Send Wait msec
PcNo 255
@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "OTHERS Manufacture”.
PLC

Select the external device to be connected to the TOP.

Interface

Protocol

Bifas UHS Series Ethernet MC Protocol 1E(binary)

Please check the system configuration in Chapter 1 to see if the external device you want to
connect is a model whose system can be configured.
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3. TOP communication setting
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TO, (|

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > "Use HMI Setup” Check > Edit > Ethernet]

— Set the TOP communication interface in TOP Design Studio.

Project Option X
- Change HiILH] | | Add PLC [ ST Change Pl | [ Delete PLCID)
%m Date / Time Sync. | Screen Option | Unit Convert
M '.“fizﬁgl';lz";::‘éfemng Project Option | Screen Change HmiSetup | Global Lock & Touch | Project Style | Splash | PLC Buffer Sync.
-8 RFID {0}
V'f.:f::"‘éeo’iiﬁ[’gf Initialization | Edit |
~§¥ COMZ (0) Project Setting -~
g% COM3 (0) HMIDisable=0
v . Ethernet (1) Project Name=New project
-8 PLC1: Bifas UHS Series Start Mode=Menu
-~ Wireless {0) E::;SUZ::B‘ =L
-8 USBDevice (0) Latch Set=0m~0
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
" .
System Devices | ™ Ethemet X
-Port
Ethernet Port @ ETHI - 0 -
11 l 7 " Link Speed : Auto v
PLE Security Date/Time WAC Address @ 00:00:00:00:00:00
IP Address :|  192.168.0.100
Subnet Mask :  255.255.255.0
_ Gateway :  192,168.0,1
"I"" .'_-_' t/' ] Default Gateway
Et hernet Serial HOK | DNS (1) 3/
DNS (2) ¢
p— -Ethernet
E—_| % Primary IP :© 192.1BR.0.100 ~
e O]
| — Ping Cable Status :
Diagnost ic File Ping . :
Manager Bridge Mode : [lUse Bridae
Check duplicate| Apply | Cancel
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.255.50 192.168.255.1
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR, 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting

M [Project > Project Property > Device Setting > Ethernet > “"PLC1 : Bifas UHS Series"]

— Set the options of the Bifas UHS Series communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' Add PLC[A] | THiTal Change PICIO | 1] Delete PLCID]

TOP Setting

- FieldBus (0)
- RFID (0)
Device Setting

+¥ COM3 (0)

Wireless (0)
9 USBDevice (0)

-[J 5Y5 : RD1520%
Option Module Setting

PLC1: BiFas UHS Series

PLC Setting[ BiFas UHS Series ]

Alizs Name : [PLC1 | BndP: aue ~

Interface : |Ethernet ~

Protocol : |MC Protocol 1E (Binary)
String Save Mode : (First LH HL Change

[ use Redundancy

Primary Option

¥ o Bl =l ]

-

Ak

Ethernet Protocol

Port

II|Z| _'
[=]
bl

Comm Manual

Timeout 300 4| msec
Send Wait msec
PcNo 255 z
Apply Close

Items Settings Remarks
Interface Select “Ethernet”. Refer to “2. External
Protocol Select “MC Protocol 1E(Binary)". device selection”.
IP Enter the IP address of the external device.

Ethernet Protocol

Select the Ethernet Protocol between the TOP and an external device.

Fixed

Port

Enter the Ethernet communication port number of the external device.

Fixed

TimeOut (ms)

Set the time for the TOP to wait for a responCse from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device
and sending the next command request.

Pc No

Configure PC number.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting
B [Main Screen > Control Panel > Ethernet]

¥YNC
Yiewer

Scrééh‘"

o
o
@ System
!mll Q
PLC S
°
11111108
Ethernet
q
Diagnostic
4
[System]

Ethernet:

-Port

Ethernet Port
Link Speed

| ETHI

;| Auto

Fle |+
)

MAC Address

00:15:10:00:00: 00

IP Address :| 192.168.0.100
Subnet Mask :[ 255.255.255.0
Gateway :|  192.168.0.1
[ Default Gateway
DNS (1)
DNS (2) ¢
- Ethernet

Cable Status
Bridge Mode :

Primary IP : [192.158.0.100 v}

ETH1 Mot connected

[ Use Bridge

[Check duplicatel [ App |y 1 Cancel J

MRAM
Analysis

TOPRX - TOPRX0800S A  2021-08-31 03:52:53 PH
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.255.50 192.168.255.1
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR 192 . 168 . 0 . 0) should match.

*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

ERI2 e B X
Touch Qperation Panel

"‘6 o0 PG
w Driver(ETH) | PLCI(BiFas UHS Series) |~|
Run Interface | Ethernet v
n Protocol | MC Protocol 1E (Bir|~]
‘ s g Bind IP [ Auto [~]
e IP 0 B0 Bl B0 [
Yiewer «| Ethernet [ TCP_|~]
g=ag [ﬁIIIF] . Port E
: - rthermet Timeout (300 [ msec
- N 1 Send Wait msec
e i i P o & B
Diagnost ic
[Systes] [ Diagnostic HDing Test]

TOPRX - TOPRX0800S

[ App |y HCancel ‘

|/ I

2021-08-31 03:53:-08 PH

Items Settings Remarks
Interface Select “Ethernet”. Refer to "2. External
Protocol Select "MC Protocol 1E(Binary)". device selection”.
IP Enter the IP address of the external device.
Ethernet Protocol Select the Ethernet Protocol between the TOP and an external device. Fixed
Port Enter the Ethernet communication port number of the external device. Fixed
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device
and sending the next command request.
Pc No Configure PC number.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (ETH1/ETH2) settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) .
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix OK NG ) )
Other detailed settings oK NG 4. External device setting
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

- Refer to the manual of the external device and configure the communication options.
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5. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device

Bit Address

Word Address

Word Address NOTE

32 BIT

Input Relay

X0000 ~ X1FFF (e

X0000 ~ X1FFO e

X***Q *Note 1)

Output Relay

Y0000 ~ Y1FFF e

Y0000 ~ Y1FFO (e

Y***(Q *Note 1)

M0000.0 ~ M8176.15

M0000 ~ M8191

Internal Relay

M9000.0 ~M9240.15

M9000 ~ M9225

Latch Relay

L0000 ~ L8176

L0000 ~ L8191

Annunciator

FO000 ~ F1FFF e

FO000 ~ F1FFO (ex

Link Relay BO0O0OO ~ B1FFF (HEX) BOOOO ~B1FFO (HEX)
Special Link Relay SBO00O ~ SB7FFO (Hex SBO000 ~ SB7FFO (Hex
Timer
TS0000 ~ TS2047

(contact)
Timer

. TC0000 ~ TC2547
(coil)

Aggregate Timer

(contact)

SS0000 ~ SS2547

Aggregate Timer

(coil)

SC0000 ~ SC2547

Counter

(contact)

CS0000 ~ CS1023

Counter

(coil)

CC0000 ~ CC1023

Timer

(current value)

TNOOOO ~ TN2047

Counter

(current value)

CNOO0O ~ CN1023

Data Register

D00000.0 ~ D8191.15

D0000 ~ D8191

D09000.0 ~ D9255.15

D0000 ~ D9255

Special Data

. SD0000.0 ~ SD2255.15 SD0000 ~ SD2255
Register
File Register R0000.0 ~R8191.15

L/H *Note 3)

Link register

WO0000.0 ~ W1FFF g

WO0000 ~ W1FFOgex

W***(Q *Note 1)

*Note 1) For bit addresses with hexadecimal “0~F" notations, use the initial O bit as the word address

“Note 2) When using a bit address that uses decimals, use a word address in units of “16"

*Note 3) The lower 16 BIT data of 32 BIT data is saved in the address whose screen has been registered, and the upper 16 BIT data

is saved in the address next to the address whose screen has been registered.
Ex. When saving 32 BIT data hexadecimal data 12345678 in address D00100, it is saved to 16 BIT device address as follows:

Items 32BIT 16BIT
Address D00100 D00100 D00101
Input data
12345678 5678 1234
(hexadecimal)
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