Atlas Copco
POWER FOCUS

Serial Driver

Supported version TOP Design Studio V1.4.11.18 or higher{Rl

TOP

"
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We would like to thank our customers for using M2l's "Touch Operation

Panel (M2 TOP) Series". Read this manual and familiarize yourself with
the connection method and procedures of the “TOP and external
device”.
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‘ Describes connectable devices and network configurations.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

‘ Describes how to set the TOP communication.
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’ Describes how to set up communication for external devices.
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’ Describe the cable specifications required for connection.

6. Supported addresses Page 11

Describes the addresses which can communicate with an external

device.
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1. System configuration

The following driver is "POWER FOCUS" of “ATLASCOPCO".
The system configuration with an external device supported by this driver is as follows:

. . Communication .
Series CPU Link I/F System setting Cable
method

3.1 Settings example 1 5.1. Cable table 1
(Page 4) (Page 9)

POWER FOCUS RS-232C

W Connection configuration

+ 1:1 (one TOP and one external device) connection
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2. External device selection

W Select a TOP model and a port, and then select an external device.

Select Device [ = |

PLC select [COM1]

Filter - [ [al] ~] Search
@ Model () Vendor

Vendor
TOHNICHT &

Giddings & Lewis Motion Control & MT FOCUS

DELTA TAU Data Systems

KEYENCE Corporation

Digital Electronics Corporation
HONEYWELL

MISUMI

PARKER HAMMIFIN Corporation
TOSHIBA

TOSHIBA MACHINE Co., Ltd

GREEM POWER

ROQTECH
KN Cornoration s
4 Eack | B Next ® Cancel
Select Device [ = |

PLC Setting[ POWER FOCUS ]

Alias Name : |PLC1

Interface : | Serial ~

Protocol : | OpenProtocol ~ Comm Manual
String Save Mode @ |First LH HL Change

[ use Redundancy

C
4

Primary Option
Timeout 300 =
Send Wait msec
MIDOO52 Revision :
MIDO0G1 Revision :

4@ Back « oK ® Cancel
Settings Contents
TOP Model Check the display and process of TOP to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "AtlasCopco”.
PLC Select an external device to connect to TOP.

Interface Protocol

POWER FOCUS Serial OpenProtocol

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option x

- Change HMI[H] ’ AddPLCAl | THTM Change PLCIC | [Z] Delete PLCID)

1 TOP Settir
1251';'%'!10\' Date / Time Sync. | Screen Option  Unit Convert

v-- Opﬁon‘z‘lodulte )Sem“g Project Option | Screen Change | HmiSetup | Global Lock & Touch = Project Style  Splash | PLC Buffer Sync.
~ 4§ FieldBus (0,
-8 RFID (0) Use HMI Setup
v - Device Setting
~ 158 COM1 (1) Hmi Setup Option Initialization Edit

-4 PLC1: POWER FOCUS

Project Setting =
-5 CoM2 (1) HMIDisable =0
g COM3 (0) Praject Name=MNew praoject
-4 Ethernet (0) Start Mode=Menu
o Wir Start Screen No.=1
o \hreless. ()] Catth Used
-4 USBDevice (D) Latch Set=0n0

Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1

Control Panel

@' System m[)evlces - %

il l . Serial Port: | COMI1 .

ﬂ Signal Level
PLC Security Date/Ting (@ RS-232C (O RS-422(4) O RS-485(2)
Baud Rate: 9600 -
[ U L '\__/_ Data Bit: & -
Et hernet Serial HOM | Stop Bit: 1 .
Parity Bit: HMone .

:l E '% Flow: 0ff

Fingl  Auto Search  Loopback Test
Diagnost ic File Ping
Manager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C Fixed
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > “PLC1 : POWER FOCUS"]

— Set the options of the AtlasCopco POWER FOCUS PLC Series CPU Direct communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' AddPLC[A] | THTM) Change PLCIC | [] Delete PLCID]

v ] TOF Setting PLC Setting[ POWER FOCUS ]
{ L. sYs:RD1220X
Option Madule Setting Alizs Name : [PLC1
W FieldBus (0) Interface : | Serial ~
W RFID (0)
v & Device Setting Protocol : | OpenProtocol ~ Comm Manual
ML e String Save Mode : [First LH HL Change
1-w® PLC1: POWER FOCUS I
[] use Redundancy
8 Ethernet (0) AND w
™ Wireless (0) . - -
.4 USBDevice (0) o - hd
Conditior Edi
Primary Option
Timeout m msec
Send Wait msec
Retry 5 =
MID0052 Revision :
MIDO0G 1 Revision :
Apply Close
Items Settings Remarks
Interface Select “Serial”. Refer to "2. External
Protocol Select "OpenProtocol”.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device
and sending the next command request.

MID0052 Revision

Configure the revision for MID0052.

MID0061 Revision

Configure the revision for MID0061.
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* This is a setting method when "Use HMI Setup” in the setting items in "3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Gontroll Panel

oae

¥YNC
Yiewer

Ethernet

|

@ RS-232C O RS-422(4) O RS-485(2) ]

sernal

Serial Port: | COMI

Signal Level

M

Baud Rate: | 9600

)

Data Bit: |8 M
Stop Bit: | 1 v
Parity Bit: | None |+
Flow: [Uff |']

[Auto Searchl [Loopback Test]

=y Diagnost ic File
Manager
[ Apply H Cancel ‘
, [System] Close
OPH OPRX0800 1 08 02:02:06 F

Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C

Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
B [Main Screen > Control Panel > PLC]

@ "‘6 il PLC
Dr iver (COM1) PLC1(POWER FOCUS) v]
@ System

Run Interface | Serial =]
(

q Protocol
]

Timeout 300 [$f msec
= Send Wait msec
- it"-ce . | Retry

{11 o
Ethernet MIDOOE1 Revision :

)
]

l
evision 1 |v

-

Diagnost ic

[ Diagnostic ] [ Apply HCanceI]

[System]

TOPRX — TOPRX0800S 2021-08-31 03:08:46 PH
Items Settings Remarks
Interface Select “Serial”. Refer to "2. External
Protocol Select "OpenProtocol”. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device

and sending the next command request.
MID0052 Revision Configure the revision for MID0052.
MIDO0061 Revision Configure the revision for MID0061.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch "Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

- Refer to the manual of the external device and configure the communication options.
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. ((The cable

diagram described in this section may differ from the recommendations of “AtlasCopco”)

W RS-232C (1:1 connection)

front, front,

D-SUB 9 Pin male

(male, convex)

D-SUB 9 Pin male cTs

(male, convex)

COM PLC
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement-Note 1)
1 5 ) 1 1 1 5
2 g SD 3 2 D g S’
Based on DTR 4 4 Based on
communication 56 > > 56 communication
cable connector DSR 6 6 cable connector
RTS 7
8
9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Address Size (Bit) Read/Write Remarks
START_BIT 1 Read *Note 1)
MID0052_VIN_NUMBER ASCII Read

MID0061_CELL_ID 16 Read

MID0061_CHANNEL_ID 16 Read
MID0061_TORQUE_CONTROLLER_NAME ASCII Read

MID0061_VIN_NUMBER ASCII Read

MID0061_JOB_ID 16 Read *
MID0061_PARAMETER_SET_ID 16 Read

MID0061_BATCH_SIZE 16 Read

MID0061_BATCH_COUNTER 16 Read

MID0061_TIGHTENING_STATUS 16 Read *Note 2)
MID0061_TORQUE_STATUS 16 Read *Note 3)
MID0061_ANGLE_STATUS 16 Read *Note 3)
MID0061_TORQUE_MIN_LIMIT 32 Read *Note 5)
MID0061_TORQUE_MAX_LIMIT 32 Read *Note 5)
MID0061_TORQUE_FINAL_TARGET 32 Read *Note 5)
MID0061_TORQUE 32 Read *Note 5)
MID0061_ANGLE_MIN 32 Read

MID0061_ANGLE_MAX 32 Read
MID0061_FINAL_ANGLE_TARGET 32 Read

MID0061_ANGLE 32 Read

MID0061_TIME_STAMP ASCII Read

MID0061_LAST_CHANGE_TIME ASCII Read

MID0061_BATCH_STATUS 16 Read *Note 4)
MID0061_TIGHTENING_ID 32 Read

*Note 1) SET when communication starts.

*Note 2) 0 : NOK  1:0K

*Note 3) 0. Low/ 1. OK/ 2 .High

*Note 4) 0: NOK 1:0K 2:notused

*Note 5) Must configure to show 2 decimal points at the object properties of the registered address.
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