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1. System configuration

The system configuration of the "PLC-5 Series” of “Rockwell Automation., Inc." is as follows:

Series CPU Link I/F Communication method System setting Cable
3.1 Settings example 1 5.1. Cable table 1

PLC-5/11 RS-232€C (Page 4) (Page 9)
PLC-5/20
PLC-5/30

PLC-5 PLC-5/40 Channel 0
PLC-5/40L
PLC-5/60 RS20 3.2 Settings example 2 5.2. Cable table 2
PLC-5/60L (4 wire) (Page 6) fPage 12

W Connectable configuration

+ 1:1 (one TOP and one external device) connection
TP = —_— |

T
9 ! I
| |
[ s—
(=1
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2. External device selection
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W Select a TOP model and a port, and then select an external device.

Select Device H

PLC Setting[ PLC-5 Series ]

Alias Mame : |PLCL

Interface : | Serial ~

Protocol : | DF1 ~
String Save Mode : |First LH HL Change

[] use Redundancy
AND -

Comm Manual

Primary Option
Timeout msec
Send Wait msec
DF1Mode "
Error Detection Ci

Source ID
Destination ID (Remote)

MNAK Retries

w @] [T
2
ﬁD
5
o
&
¥
b ¢

ENQ Retries 3

ar

@ Back + Ok ® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "Rockwell Automation, Inc”.
PLC Select an external device to connect to TOP.

Select "PLC-5 Series".

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option *
- Change HMI[H] ' AddPLC(A | TR Change Pl [ Delete PLCID]
I 'D- Emp Settng Izux Date [ Time Sync.  Screen Option Unit Convert
A . Ontion Module Setting Project Option = Screen Change  HmiSetup = Global Lock & Touch  Project Style = Splash | PLC Buffer Sync.
-4 FieldBus (0)
v -, Device Setting
\:'.‘ oML (U)g oo p s Initialization Edit
v fa® coM2 (1) Project Setting A
i mM PLC1:PLC-5 Series HMIDisable=0
L g COM3 (0) Project Name=New project
i Ethernet (0) Start Mode=Menu
g Wireless (0) f:;;ﬁ:zg L
W@ USBDevice (0) Latch Set=0n~0
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Contral Panel
System m Devices | . o %
. Serial Port: | COMI =
T .
: - Signal Level
FEE Security  Date/Tine | @ Rg-2320 (O RS-422(4) O RS-485(2)
Baud Rate: 28400 '
o 2| B— i
Ethernet Serial HOM | Stop Bit: 1 v
— Parity Bit: None -
I B % Flow: (ff
L | . Ping
; , S ; Auto Search Loopback Test
Diagnost ic File Fing
Manager
Apply || Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C
RS-232C RS-422 RS-485
RS-422/485
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device. (COM3 supports
only RS-485.)

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

TO,

M [Project > Project Property > Device Setting > COM> "PLC1 : Control/Compact Logix Series"]

— Set the options of the DF1 communication driver in TOP Design Studio.
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Project Option

~ ] TOFP Setting

- 5YS ¢ RD1520%
Option Module Setting
B FieldBus (0)

- RFID (0)

. Device Setting

-rg¥ COM1 (D)

8 Ethernet (0)
™ Wireless (0)
8 USBDevice (0)

- Change HMI[H] ' AddPLC[A] | THTM) Change PLCIC | [] Delete PLCID]

PLC Setting[ PLC-5 Series ]

Alizs Name : [PLC1

Interface : | Serial ~

Protocol : |DF1 ~
String Save Mode : (First LH HL Change

[] use Redundancy
AN

[=]
L

TimeQut 5

Ak

Condition

Primary Option

Send Wait - msec
DF1 Mode Full Duplex  ~

=~

=

=

Error Detection

Destination ID (Remote)

MNAK Retries

EMNQ Retries

Edit

Apply

Comm Manual

Close
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conitkroll Panel

o serial
@ System cfie
Bun

i Serial Port: [CUI#H |v
!IIll Signal Level
‘ @ BS-Z32C O RS-422(4) O RS-485(2)
PLC Security i

Baud Rate: | 38400
¥YHC

l

|

M

Viewer [.EIT-“'.] | o Data Bit: {18 H
M

M

Stop Bit:

Ethernet Serial

Parity Bit: [ Mone

Flow: | (ff

Diagnost ic File
Manager

@)

[Auto Search] lLoopbaCk Testl

l Apply llCanceI l —

Close

[System]

S

|

Items TOP External device Remarks
Signal Level (port) RS-232C RS-422 RS-485 RS-232C

RS-422/485
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit None.
* The above settings are setting examples recommended by the company.
Items Description
Signal Level Select the serial communication method between the TOP and an external device.
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

n
FLC
[l

Ethernet

Diagrost ic

[System]

Driver(COM1)

PLCTCPLC-5 Series) i~

Interface | Serial |
Protocol | DF1 |~
Timeout 300 |3 msec
Send Wait 0 |2 msec
DF 1 Mode Full Dur|+)
Error Det CBCC |+
source |C L=
Dest inati
MNAK Retri
ENQ Retri EN =
l Diagnostic ]

TOP

| Aoply ]I[ Cance! |

ERI2 e B X
Touch Qperation Panel
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting
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Set as below using "“Control/CompactLogix Series” Ladder Software “RSLogix5". For more detailed setting method than that

described in this example, refer to the PLC user manual.

A Do not use duplicate Source ID (prefix) for external devices connected to the same unit network.

1. From the "RSLogix 5" project window, double-click [Channel Configuration] to open the “Channel Configuration” window.

2. From the “Channel Configuration” window, select the [Chan. 0 -System] tab and configure as follows.

Setup Items Setup Description Remarks

Driver DF1 Half Duplex Slave Fix

Baud Rate 38400

Parity NONE

Stop Bits 1

Source ID (Station Address) 0

Protocol Control Control No Handshaking Fix
Error Detection BCC Fix
Embedded Enabled Fix
Duplicate Packet Detect No Check Fix
ACK Timeout 50
NAK Retries 3
ENQ Retries 3

3. Download the configurations with the PLC.
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagrams described in this section may differ from the external device vendor’s recommendations.)

M 1:1 connection RS-232

(A) TOP COM Port (9 pin)

COM External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangement Note 1) name number number name arrangement*Note 1)
1 5 D 1 1 GND | 13 1
o] o RD 2 2 TXD
SD 3 3 RXD | 25 14
G o DTR 4 4 RTS Based on

cor:,:wsj:icc:):ion 6 > I: > €T Cogmunicati?n

cable connector DSR 6 T_ 6 DSR “ ef:;)::ec >

front, i ! ! oM D-SUB 25 Pin

D-SUB 9 Pin male S 8 8 DCD female (female

9 20 DTR '

(male, convex)

concave)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

M 1:1 connection RS-422

(A) TOP COM Port (9 pin)

COM External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangementNote 1)
1 5 RDA 1 14 spa | 13 1
2 2 | e
e o) 3 16 RDA 25 14
& 9 RDB 4 3 RDB Based on
Based on 5 communication
communication
SDA 6 cable connector
cable connector front
7 )
front, . MINI-DIN 25 Pin
D-SUB 9 Pin male female (female,
9
(male, convex) SDB concave)
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

A Device notation => Device Name File Number : Element
Device Bit Address Word Address 32 bits Remarks
Output File 0000:000.00 — ©000:377.15 0000:000 — O000:377
Input File 1001:000.00 - 1001:377.15 1001:000 — 1001:377
Bit File B003:000.00 — B099:999.15 B003:000 — B099:999
Timer File  Coil Done TC003:000.13 — TC099:999.13
Timing TC003:000.14 — TC099:999.14 -
Enable TC003:000.15 — TC099:999.15
Preset - TP003:000 — TP099:999
Accumulated - TA003:000 — TA099:999
Counter Coll Update Acc CC003:000.10 — CC099:999.10 L/H
File Underflow CC003:000.11 — CC099:999.11
Overflow CC003:000.12 — CC099:999.12
Done CC003:000.13 — CC099:999.13 -
Down Enable CC003:000.14 — CC099:999.14
Up Enable CC003:000.15 — CC099:999.15
Preset - CP003:000 — CP099:999
Accumulated - CA003:000 — CA099:999
Integer File N003:000.00 — N099:999.15 N003:000 — N099:999
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