LS Industrial Systems
GLOFA-GM Series
CPU Direct Driver

Supported version  TOP Design Studio V1.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “LS Industrial Systems — GLOFA-GM Series CPU Direct” is as follows:

GMR-CPUA
GMR-CPUB
GM1-CPUA
GM1-CPUB
GM2-CPUA
GM2-CPUB
GM3 GM3-CPUA
GM4-CPUA
GM4 GM4-CPUB
GM4-CPUC 3. TOP communication
GM6-CPUA CPU Direct Vote 1) RS-232C setting , 5. Cable table
GM6 GM6-CPUB 4. External device -
GM6-CPUC setting

G7M-DJ10A
G7M-DJ20A
GM7 G7M-D[J30A
G7M-D[J40A
G7M-DJ60A
G7M-D[20U
G7M-D[30U
G7M-DO40U
G7M-D60U

*Note 1) PC connection loader port

GMR

GM1

GM2

GM7U

W Connection configuration

+ 1:1 (one TOP and one external device) connection
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM1]

Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

vendor Wodel
~
M2I Corporation & XGL/XGR/XEC Series
MITSUBISHI Electric C i
lectric Corporation & XGK/XBM/XBC Series

OMRON Industrial Automation s
&7 GLOFA-GM Series
& MASTER-K(805/1205/2005/3005/10005) Series

MODBUS Organization

& STARVERT Series
SIEMENS AG.

(@ XCODE RFID HF Reader Series IH-1306/1307
Rockwell Automation

GE Fanuc Automation & MASTER-K(500H/1000H) Series
PANASONIC Electric Works (@ MASTER-K 105, 1051 Series
‘YASKAWA Electric Corporation
YOKOGAWA Electric Corporation
Schneider Electric Industries

KDT Systems

RS Autnmation

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ GLOFA-GM Series ]

Alizs Mame @ |PLCL

Interface : | CPU Direct ~
Protocol : | CPU ~ Comm Manual

String Save Mode : |First LH HL Change

[ use Redundancy

AND ~
Condition - Edi
Primary Option
Timeout 300 &|| msec
Send Wait msec
@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “LS Industrial Systems".
PLC Select an external device to connect to TOP.

Interface Protocol

GLOFA-GM Series CPU Direct CPU

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option

-Change HMIH]
D_ TOP Setting
: B0 20%

Date / Time Sync.

' Add PLC[A] | STl Change PLCIC]

[ Delete PLCDI

Screen Option Unit Convert

* {8 Option Module Setting Project Option  Screen Change | HmiSetup || Global Lock & Touch | Project Style || Splash | PLC Buffer Sync.
-4 FieldBus (0)
L.y RFID (0)
M ‘?;’[::VE;;‘T‘[’T)Q Initialization Edit
i - PLC1: GLOFA-GM Series Project Setting
i-fa¥ COM2 (0) HMIDisable=0
¥ COM3 (D) Praject Name=Mew project
Ethernet (1) Start Mode=Menu
L8 Wireless (0) f;aért‘Schr:inoNu.:i
. USBDevice (0) Latch Set=0n0
Communication Error Message=0
Control Panel
- . s Serial
System Devices
Serial Port: @ COM1 =
| /| Signal Level
(@ PS-232C O RE-422(4) O R5-485(2)
PLC SECUrity Oat &,/ T ime
Baud Rate: 33400 ~
ﬁ Data Bit: & <
i- [ ﬁ: —
(I Stop Bit: |1 -
Et hernet Serial HOK | Parity Bit: MNone -
— Flow: [ff
E=] \
} = ) Auto Search  Loopback Test
. Ping
Diagnaost ic File Fing
Manager Apply Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C )
RS-232C Fixed
(CPU port)
Baud Rate 38400 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > "PLC1: GLOFA-GM Series"]

TOP

— Set the option of GLOFA-GM Series CPU Direct communication driver in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

Project Opticn

- Change HIIH] | | | Add PLC () e Change PLCIC]

~ -] TOP Setting

-4 FieldBus (0)
4 RFID (0)
v -\ Device Setting

PP T L)

-{} 5Y5 : RD1520%
~ - Option Module Setting

Protocol : | CPU

-
g COM3 (0)

g™ Wireless (0)

- USBDevice (0)

[ use Redundancy

-4 Etherret (0) AND

Primary Option

Timeout 300

E3 Delete PLCD)

PLC Setting[ GLOFA-GM Series ]

Alias Name : |PLC1

Interface : | CPU Direct ~

b

Siring Save Mode : First LHHL Change
l -4 PLC1 : GLOFA-GM Series I

Send Wait msec

Comm Manual

Retry 5 =
Apply Close
Items Settings Remarks
Interface Select “CPU Direct". Refer to “2. External
Protocol Select "CPU".

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Bun

YHC
Yiewer

Conikroll Panel

- Serial

R Serial Port: l COMA |v T
[ Signal Level

® AS-232C () RS-422(4) () PS-485(2)
1]

Baud Rate: | 38400

l

|

N

, Data Bit: | 8 |

[lmll i Stop Bit: | 1 |
M

-]

Ethernet Serial

Parity Bit: | None

 — Flow: l[]ff
B =

lAuto Searchl [Loopback Testl

Diagnost ic File
Manager

 Aoply | Cancel |

[System] Close f

Items TOP External device Remarks

Signal Level (port) RS-232C )
RS-232C Fixed

(CPU port)

Baud Rate 38400 Fixed

Data Bit 8 Fixed

Stop Bit 1 Fixed

Parity Bit None. Fixed

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

Run

"E} S PLC

@ System | Driver(COMD)

PLCT(GLOFA-GM Ser jes) v]

Interface | CPU Direct R
|il Protocol | CPU R
oL oo Timeout 300 |5 msec
send Wait msec
| Ret B
] & s

Ethernet

L2]

Diagnost ic

[Ty

ERI2 e B X
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[System]

l Diagnostic [Apply“[}ancell

| I |
Items Settings Remarks
Interface Select "CPU Direct”. Refer to "2. External
Protocol Select "CPU". device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module
OK NG
name)
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG 4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

+ CPU Direct port communication interface of the “GLOFA-GM Series” is fixed as the target configuration value of the following

example.
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “LS Industrial Systems Co., Ltd.")

W RS-232C (1:1 connection)

COM1 / COM2 External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) | name number number name | arrangement*Note 1)
(@p)] 1 1 cDh
1 5 1 5
© © RD 2  -  : - : N
(e) O SD 3 3 SD O O
6 9 DTR 4 4 DTR 6 9
Based on G 5 5 G Based on
communication cable DSR 6 6 DSR communication cable
connector front, RTS - - RTS connector front,
D-SUB 9 Pin male D-SUB 9 Pin male
CTS 8 8 CTS
(male, convex) 9 9 (male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Type e Address Area
Bit Word

GM1 | (Input) 1X00.0.0 - 1X63.7.63 IW00.0.0 -1W63.7.3
Q (Output) QX00.0.0 - QX63.7.63 QW00.0.0 - QW63.7.3
M (Internal memory) MX00000 — MX95983 MWO00000 - MW59999

GM2 | (Input) 1X00.0.0 — 1X31.7.63 IW00.0.0 -1W31.7.3
Q (Output) QX00.0.0 - QX31.7.63 QW00.0.0 - QW31.7.3
M (Internal memory) MX00000 — MX95983 MWO00000 - MW59999

GM3, GM4 | (Input) 1X00.0.0 - 1X07.7.63 IW00.0.0 - IW07.7.3
Q (Output) QX00.0.0 - Qx07.7.63 QW00.0.0 - QW07.7.3
M (Internal memory) MX00000 — MX47991 MWO00000 — MW32767

GM6, GM7 | (Input) 1X00.0.0 - 1X07.7.63 IW00.0.0 - IW07.7.3
Q (Output) QX00.0.0 - QX07.7.63 QW00.0.0 - QW07.7.3
M (Internal memory) MX00000 — MX23995 MWO00000 - MW16383

*  Additional description of input/output (IW/QW) address

OO.T.O —> The last digit corresponds to card number

Third digit corresponds to slot number (Slots start from 0 after the CPU)

First two digits correspond to the base number (starts from 0)

* Card number description: cards with 16 points are labeled 0; cards with 32 points are labeled 0 for 0-15 bit, or 1 for 16-31 bit;
cards with 64 points are labeled 0 for 0-15 bit, 1 for 16-31 bit, 2 for 32—-47 bit, and 3 for 48-63 bit.
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