
 

 External device connection manual for TOP Design Studio 1 / 13 

 

YASKAWA Electric Corporation  

Machine Controller MP2000 Series  

Ethernet Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 10 

 Describes how to set up communication for external devices. 

5. Supported addresses Page 14 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “YASKAWA Electric Corporation – MP2000 Series Ethernet” is as follows. 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

MP2000 

MP2300 

MP2200 

Ethernet Port 

on 218IF-01 

Ethernet( UDP ) 

3. TOP communication 

setting 

4.1 Extended MEMOBUS 

4.3 MP Extension 

Twisted pair cable 

*Note 1) 

Ethernet( TCP ) 

Ethernet Port 

on 218IF-02 

Ethernet( UDP ) 

Ethernet( TCP ) 

MP2310 

MP2300S 

Ethernet Connector 

on CPU unit 

Ethernet( UDP ) 
3. TOP communication 

setting 

4.2 Extended MEMOBUS 

4.3 MP Extension 
Ethernet( TCP ) 

Ethernet Port 

on 218IF-01 

Ethernet( UDP ) 

3. TOP communication 

setting 

4.1 Extended MEMOBUS 

4.3 MP Extension 

Ethernet( TCP ) 

Ethernet Port 

on 218IF-02 

Ethernet( UDP ) 

Ethernet( TCP ) 

MP2400 
Ethernet Connector 

on CPU unit 

Ethernet( UDP ) 
3. TOP communication 

setting 

4.2 Extended MEMOBUS 

4.3 MP Extension 
Ethernet( TCP ) 

*Note 1) Twisted pair cable 

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 

 

 

■ Connectable configuration 

 

ㆍ1:1 connection (one TOP and one external device) connection 

 

 

 

ㆍ1:N connection (one TOP and multiple external devices) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 

 
 

 
 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Please select "YASKAWA Electric Corporation". 

PLC Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

MP2000 Series Ethernet Set Users 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 

Supported Protocol 

Extended MEMOBUS RTU MP Extension 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Ethernet ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 
 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Project > Project properties > PLC settings > ETHERNET) > “PLC1 : Mp2000”] 

– Set the options of the communication driver of MP2000 Series Ethernet in TOP Design Studio. 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

① Communication option items when selecting the Extended Memobus RTU 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

HMI Port Enter the Ethernet communication port number of the TOP.  

Data Code Select the data code between the TOP and an external device.  

② Communication option items when selecting the MP Extension Ethernet 

IP Enter the IP address of the external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

  

① 

② 

Extended Momobus RTU 

communication option 

MP Extension communication option 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Ethernet ] 
 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

Communication option items when selecting the Extended Memobus RTU 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

HMI Port Enter the Ethernet communication port number of the TOP.  

Data Code Select the data code between the TOP and an external device.  

Communication option items when selecting the MP Extension Ethernet 

IP Enter the IP address of the external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check whether the port (ETH1/ETH2) settings you want to use are the same as those of the external device in [Control Panel > 

Ethernet]. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module 

name) 
OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 

 



 

 External device connection manual for TOP Design Studio 9 / 13 

4. External device setting 

4.1 Extended MEMOBUS – 218IF-01/02 

Set as below using “MP Series” Ladder Software “MPE720”. For more detailed setting method than that described in this example, 

refer to the PLC user manual. 
 

 
Do not use duplicate IP addresses over the same network. 

 

■ Operation Ⅰ : “PC and PLC connection method” : set communications as follows(Operation Ⅱ, Operation Ⅲ), but before 

connect PC and PLC. 

1. Run “Communication Manager” program. 

( Path : Start → Program → “YE_Applications” → “Communication Manager” ) 

2. Run "Logical Port Setting" to set the port type and details. 

( Path : File → Setting… ) 

3. After PC and PLC are connected, save, and follow below operation. 

■ Operation Ⅱ : “MPE720” Create Project : (root) > [Group Folder] > [Order Folder] > [Controller Folder] Register 

1. To register the device you want to use in “MPE720”, follow “[Group Folder] > 

[Order Folder] > [Controller Folder]” path. 

(Caution) In the "MPE720" left project window, Right–Click,  

and follow the parent path through the [New] entry. 

2.Register the Controller Type for the device you wish to use in the Controller 

Configuration window, which appears when registering a new [Controller Folder] 

3. Double-click the newly registered [Controller Folder] to bring up the [Log on 

to the controller] window and enter "User Name" and "Password" to form project 

folders as shown on the left. 

■ Operation Ⅲ : “Communication Setting” : [Engineering Manager] – [Module Configuration] window  

1. [Definition Folder] – [Module Configuration] double click to bring up [Engineering Manager] – [Module Configuration] window. 

2. In the Module Configuration window, register the appropriate [Rack] – [Slot] location [Module Type]. 

3. Double-click the appropriate [Slot Number] to display the Settings window. The information to be set is as follows. 

 
 

Items Settings Remarks 

Transmission parameter Station Setting IP Address 192.168.0.51 PLC IP address 

Connection parameter Local Port 1024 PLC Port number 

 Node IP Address 192.168.0.50 HMI IP Address 

 Node Port 1025 HMI Port Number 

 Connect Type TCP Set Users 

 Protocol Type Extended MEMOBUS Fixed 

 Code BIN Fixed 
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■ Operation Ⅳ : Ladder Program : MSG-RCV function 

1. Register the [MSG–RCV] function ([Instruction Pallet] menu - [System] tab]) into the [Ladder Works] Software, referring to the 

example below. Refer to the Ladder Software manual for more information. (※Caution: Set the value of [Dev-Type] to "6" for 218IF-

01 and "218IF-02 to "16".) 
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4.2 Extended MEMOBUS - CPU Built-in Ethernet Port 

Set as below using “MP Series” Ladder Software “MPE720”. For more detailed setting method than that described in this example, 

refer to the PLC user manual. 
 

 
Do not use duplicate IP addresses over the same network. 

 

■ Operation Ⅰ : “PC and PLC connection method” : set communications as follows(Operation Ⅱ, Operation Ⅲ), but before 

connect PC and PLC. 

1. Run “Communication Manager” program. 

( Path : Start → Program → “YE_Applications” → “Communication Manager” ) 

2. Run "Logical Port Setting" to set the port type and details. 

( Path : File → Setting… ) 

3. After PC and PLC are connected, save, and follow below operation. 

 

■ Operation Ⅱ : “MPE720” Create Project : (root) > [Group Folder] > [Order Folder] > [Controller Folder] Register 

1. To register the device you want to use in “MPE720”, follow “[Group Folder] > 

[Order Folder] > [Controller Folder]” path. 

(Caution) In the "MPE720" left project window, Right–Click,  

and follow the parent path through the [New] entry. 

2.Register the Controller Type for the device you wish to use in the Controller 

Configuration window, which appears when registering a new [Controller Folder] 

3. Double-click the newly registered [Controller Folder] to bring up the [Log on 

to the controller] window and enter "User Name" and "Password" to form project 

folders as shown on the left. 

 

■ Operation Ⅲ : “Communication Setting” : [Engineering Manager] – [Module Configuration] window  

1. [Definition Folder] – [Module Configuration] double click to bring up [Engineering Manager] – [Module Configuration] window. 

2. In the Module Configuration window, register the appropriate [Rack] – [Slot] location [Module Type]. 

3. Double-click the [Slot Number] which the Ethernet UNIT is connected to display the Settings window.[Transmission Parameter] 

tabsettings information is as follows. 

Items Settings Remarks 

IP Address 192.168.0.51 PLC IP address 

Subnet Mask 255.255.255.0 PLC Subnet Mask 

4.  From [Transmission Parameter] tab – click [Easy Setting], in [Message Communication Easy Setting] window set as follows, Click 

“OK” to save settings information. 

Items Settings Remarks 

MP Series Port No. 1024 PLC Port number 

Communication protocol Type Extended MEMOBUS Fixed 

Connect type TCP Set Users 

code BIN Fixed 

Node Port IP Address 192.168.0.50 HMI IP Address 

Other Device Port No. 1025 HMI Port Number 

5. Double-click [Setting] to set [Automatically Accepted] to "Enable” in the [Automatically Accepted Setting] window and save the 

settings by clicking “OK”. 

 

  



 

 External device connection manual for TOP Design Studio 12 / 13 

4.3 MP Extension - 218IF-01/02 

Set as below using “MP Series” Ladder Software “MPE720”. For more detailed setting method than that described in this example, 

refer to the PLC user manual. 
 

 
Do not use duplicate IP addresses over the same network. 

 

■ Operation Ⅰ : “PC and PLC connection method” : set communications as follows(Operation Ⅱ, Operation Ⅲ), but before 

connect PC and PLC. 

1. Run “Communication Manager” program. 

( Path : Start → Program → “YE_Applications” → “Communication Manager” ) 

2. Run "Logical Port Setting" to set the port type and details. 

( Path : File → Setting… ) 

3. After PC and PLC are connected, save, and follow below operation. 

■ Operation Ⅱ : “MPE720” Create Project : (root) > [Group Folder] > [Order Folder] > [Controller Folder] Register 

1. To register the device you want to use in “MPE720”, follow “[Group Folder] > 

[Order Folder] > [Controller Folder]” path. 

(Caution) In the "MPE720" left project window, Right–Click,  

and follow the parent path through the [New] entry. 

2.Register the Controller Type for the device you wish to use in the Controller 

Configuration window, which appears when registering a new [Controller Folder] 

3. Double-click the newly registered [Controller Folder] to bring up the [Log on 

to the controller] window and enter "User Name" and "Password" to form project 

folders as shown on the left. 

■ Operation Ⅲ : “Communication Setting” : [Engineering Manager] – [Module Configuration] window  

1. [Definition Folder] – [Module Configuration] double click to bring up [Engineering Manager] – [Module Configuration] window. 

2. In the Module Configuration window, register the appropriate [Rack] – [Slot] location [Module Type]. 

3. Double-click the corresponding [Slot Number] to display the setting window. Set the IP address of the external device as follows. 

 
 

Items Settings Remarks 

Transmission Parameters Station Setting IP Address 192.168.0.51 PLC IP address 

4. Set the port number of the external device in [Engineering Manager] - [Edit] - [Local Port: TCP/IP Setting] as follows. 
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

■ Extended Memobus 

Device Bit Address Word Address 32bit Remarks 

MB Coil MB000000 ~ MB65535F MB00000 ~ MB65535 L/H  

IB Discrete Input IB00000 ~ IBFFFFF IB0000 ~ IBFFFF *Note 1) 

IW Input Register - IW0000 ~ IWFFFF *Note 1) 

MW Holding Register - MW00000 ~ MW65535  

*Note 1) Cannot be written 

 

■ MP Extension 

Device Bit Address Word Address 32bit Remarks 

SB 
System Register 

SB00000 ~ SB8191F SB0000 ~ SB8191 L/H  

SW SW0000.0 ~ SW8191.F SW0000 ~ SW8191  

IB 
Input Register 

IB00000 ~ IBFFFFF IB0000 ~ IBFFFF  

IW IW0000.0 ~ IWFFFF.F IW0000 ~ IWFFFF  

OB 
Output Register 

OB00000 ~ OBFFFFF OB0000 ~ OBFFFF *Note 1) 

OW OW0000.0 ~ OWFFFF.F OW0000 ~ OWFFFF *Note 1) 

MB 
Data Register 

MB000000 ~ MB65535F MB00000 ~ MB65535  

MW MW00000.0 ~ MW65535.F MW00000 ~ MW65535  

*Note 1) Cannot be written 


