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1. System configuration
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The system configuration of TOP and “Delta Electronics — DVP Series Computer Link” is as follows:

Series ’ CPU ‘ Link I/F

method

Communication

System setting ‘

DVP
Series

RS-232C

DVP - ES -
CPU built-in port
DVP - ES2 RS_485

3. TOP communication

setting

4. External device

setting

5. Cable table

H Connection configuration

+ 1:1 (one TOP and one external device) connection — configuration which is possible in RS232C/422/485 communication.

=

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422/485 communication.

) (+] S—

_
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM1]
Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor

YASKAWA Electric Corporation &

YOKOGAWA Electric Corporation
Schneider Electric Industries
KDT Systems

RS Automation

HITACHI IES

FATEK Automation Corporation
KOYO Electronic Industries
VIGOR Electric Corporation

COMFILE TECHNOLOGY Inc.

DST ROBOT
BACnet
| & MECAPTON %
4_Back | B Next *® Cancel
Select Device n

PLC Setting[ DVP Series ]

Alizs Mame @ |PLCL

Interface : | Computer Link ~

Protocol : MODBUS ~ Comm Manual
String Save Mode : |First LH HL Change

[ use Redundancy
AND v

Primary Option

Timeout 300 &|| msec
Send Wait msec
Retry 5 =

Slave eguipment address Mo DI
Protocol Mode

@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "DELTA Electronics”.
PLC Select an external device to connect to TOP.

Interface Protocol

DVP Series Computer Link Modbus

Supported Protocol
MODBUS ASCII MODBUS RTU

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting]
— Set the TOP communication interface in TOP Design Studio.

— [Project Option > "Use HMI Setup” Check > Edit > Serial]

Project Option

-Change HMI[HI —Md PLC[A | THITE Change PLCIC]

E3 Delete PLCID)

TOP Setti
I’—mgg-ﬂmlsn — 20X Date / Time Sync. | Screen Option  Unit Convert
- Option Mockie Setting Project Option = Screen Change = HmiSetup  Global Lock & Touch  Project Style  Splash  PLC Buffer Sync.

Initialization | Edit |

8 FicldBus (0)
& Device Setting
< rm coMA (1) R s
8 PLC1 : DVP Series [1] e
5% COM2 (0) HMIDisable=0
5 COM3 (0) Erme: | soam E e
o Ethemet () Start Mode=Menu
& Wireless (0) E;Bt;ic;::g te.=1
W USBDevice (0) Latch Set=0~0

Communication Error Message =0
UUSBErrarMessage=0
StorageErrorMessage=1
DatabaseMessage=1

~

Control Panel

System mDevices :naService :—'"'.'Dption

o Serial Ol
i —
100 {1 serial Port: | cOMT .
FLC Security DatesTime Signal Level
(@ RS-232C ) RS-422(4) (O RS-485(2)
Baud Rate: Q600 w2
L] L]
% J|eEm e Ty _
L Data Bit: 7 -
Et hernet Serial HOM | Stop Bit: 1 -
— Parity Bit: |Even -
=] \
"\ Flow: [(ff
L d Ping
Diagnost ic File Fing Auto Search  Loopback Test
Manager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C
RS-485
Baud Rate 9600
Data Bit 7
Stop Bit 1
Parity Bit Even

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Project > Project Property > Device Setting > COM > “PLC1 : DVP Series"]

TOP ooz e
Touch Qperation Panel

— Set the options of the DELTA Electronics — DVP Series Computer Link communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' AddPLC[A] | THTM) Change PLCIC | [] Delete PLCID]

~ ] TOFP Setting
| L.[J SYS:RD1520%
Option Module Setting Alias Name : |PLC1
B FieldBus (0)

PLC Setting[ DVP Series ]

Interface : | Computer Link ~

Protocol : | MODBUS ~
String Save Mode : (First LH HL Change

[] use Redundancy

8 Ethernet (0)
™ Wireless (0)
4§ USBDevice (0)

i
[a
4

Primary Option

Timeout msec
Send Wait _ msec
Slave equipment address Mo
Protocol Mode

Comm Manual

Apply Close
Items Settings Remarks

Interface Select "Computer Link". Refer to "2. External
Protocol Select "Modbus". device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device

and sending the next command request.

Slave equipment Enter the prefix number of an external device (Slave).
address No
Protocol Mode Select the protocol mode.
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3.2. Communication
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setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

-

YNC
Yiever

System “lfﬂ Devi

Serial Port: |COMI |+

BB Signal Level |

!l.l.l 71 |® Rs-232c O Rs-422(8) O Rs-485(2) |
PLC Secur ity Date/T Baud Rate: | 9600 |

Data Bit: 7

g | N = Stop Bit: | 1

i

Ethernet | Serial Parity Bit: | Even I+

— ~ Flow: | (/1 [~]
m - ®"! | Auto Search| Loopback Test
Diagnost ic “;\-J;e Pi Nb""
r |
Apply  Cancel
[System] Close
—1
Items TOP External device Remarks
Signal Level (port) RS-232C
RS-485
Baud Rate 9600
Data Bit 7
Stop Bit 1
Parity Bit Even

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
B [Main Screen > Control Panel > PLC]

© svsten| orivercon | PLC1(DVP Serjes) |~

Run :
Interface . Computer Link |7
!hlxl Protocol MODBUS [~
PLC § Timeout (300 |2 msec

Send Wait 0 |3 msec
un]  § Retry E_I8

Bibariat Slave eauipment add1 =
Protocol ASCI |~ i A
y

B

Diagnost ic

Diagnost ic | Aeply || Cancel
Items Settings Remarks
Interface Select “Computer Link". Refer to "2. External
Protocol Select “Modbus”. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.

Slave equipment Enter the prefix number of an external device (Slave).
address No
Protocol Mode Select the protocol mode.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Set as below using “DVP Series” Ladder Software "DELTA WPLsoft".

For more detailed setting method than that described in this example, refer to the PLC user manual.

Step 1. Set up communication between WPLsoft and DVP Series PLC under [Options — Communication Setting] in the menu.

F
Communication Setting

—Connection Setup

= Change PLC Type CtrH-AlM i_ T IR523 2 j
= Program Setting » B
i Ci ication Setting
Edit Setup(4) £ T
(] Set Color and Font of Ladder Diagram p COM Port comMi |..| & asco
Modem Connection Data Length 7 vl  RTU (8 bits)
= E Set RTC Parity m
o - Stop Bits 1 - Auto-detect |
- Prompt to Edit Device Comment Ctri+Alt+H
. Baud Rate 9600 vl
DUO! Setting ,
Language Setup » Station Address 1 ﬂ Default |

Ethernet Setting

[ AssignIF | . _|
- o a——

~Band Rate Decided by
(+ PLC Setting
" WPL Setting

r—Setup Responding Time

Times of Auto-retry |3—ﬂ

Time Interval of Auto-retry (sec.) |3 :ll

Cancel

Step 2.Create a ladder program that sets communication parameters after creating a new project or reading PLC data. (Refer to
example)

X Initial value when the communication parameter setting program is not completed: ASCIl, 9600 bps, 7 Data bit, 1 Stop bit, Even
parity, Prefix 1

Step 3. After running [Communication — Transfer Setup] from the menu, the program transmits.

-
Transfer Setup

E Transfer Setup I

Communication Mode
System Secunty » I. IPC =>PLC j
— (¥ R caubFll L [# Program
i St Cir+F12 [~ Device Comment
. ) * Cancel

[ Initialize Device Corrent

[~ Synchronize Project and PLC Password
[~ Betentive Range

™ Default Value

™ RIC

[~ Backup to Flash (EHZ/EHIL/SV)

Step 4. Change the PLC action to RUN to apply the communication settings of the ladder program.
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B Communication setting ladder program example

TO,

For more detailed setting method than that described in this example, refer to the PLC user manual.
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COM1 ASCII COM1 RTU
(9600 bps, 7 Data bit, 1 Stop bit, Even parity) (9600 bps, 8 Data bit, 1 Stop bit, None parity)
M1002 1002
I I IMU\-" Hae 01036 | I I MOy Ha 01036
|SET k17132 |
L SET M1138
EMD
SET 1139
EMD
COM2 ASCII COM2 RTU
(9600 bps, 7 Data bit, 1 Stop bit, Even parity) (9600 bps, 8 Data bit, 1 Stop bit, None parity)
1002 1002
I I MY HaE D120 I I MOV Ha1 D1120
SET k1120 SET Mi1120
END SET M1143
EMD
COM3 ASCII PLC prefix setting
(9600 bps, 7 Data bit, 1 Stop bit, Even parity)
1002
) K1 D111
I I MOy Hag 01109
sET W15 D1121: PLC communication address
K1: 1
END
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TOP 225 -
5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of "DELTA Electronics”)

W RS-232C (1:1 connection)

TOP External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangementNote 1) name number number name arrangement-Note 1)
1 5
Q Q T e
6 9 SD 3 4 RXD e 7 n‘\:_\
e e e
Based on .5 ; {:1. |
communication SG 5 8 SG e
Ry o
cable connector S
front mini-DIN
ront connector
D-SUB 9 Pin male
(male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

W RS-485 (1:1 connection)

TOP External device
Pin Signal Pin Cable connection Signal .
arrangement Note 1) name number name Pin arrangement
1 5 RDA 1 D+
g g 3 D+ D-

Based on RDB 4
communication 5 Based on communication
cable connector SDA 6 cable connector front,

front, 7 Terminal Block 2 Pin
D-SUB 9 Pin male 8
(male, convex) SDB 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

B RS-485 (1:1 connection)

TOP External device
. Signal Cable connection Signal .
Pin arrangement Pin arrangement
name name
+ D+
- D-
G D+ D-

s

Based on communication
+ cable connector front,

Terminal Block 2 Pin

B
1
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

TOP Address

Effective Range

Device Remarks
Bit Address Word Address ES ES2
Step relay S0000 ~ S1023 —_— 0~ 127 0 ~ 1023
Input relay X000 ~ X357 —_— 0~177 0 ~ 357
Output relay Y000 ~ Y357 o 0~177 0 ~ 357
Auxiliary relay MO0000 ~ M4095 MO0000 ~ M4080 0~ 1279 0 ~ 4095
Contact TOOO ~ T255 _—
Timer 0~ 127 0 ~ 255
Current R TO ~ T255
Contact C000 ~ C255 R —
0~ 127 0~ 199
Counter R — C000 ~ C199
Current 235 ~ 255 200 ~ 255
R C200 ~ C255 32 Bit
—_— D0000 ~ D4095 0 ~ 599
Data register 1000 ~ 1143 0 ~ 9999
—_— D4096 ~ D9999
1256 ~ 1311
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