Rockwell Automation, Inc.
SLC-500 Series

Ethernet Driver

Supported version  TOP Design Studio V1.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device".

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Supported addresses Page 10

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “Rockwell Automation, Inc. — SLC-500 Series Ethernet” is as follows:

3. TOP communication

setting
4.1. External device

SLC 5/03
SLC 5/04 1761-NET_ENI Ethernet(TCP)
SLC 5/05

setting 1 Twisted pair cable
3. TOP communication *Note 1)

setting
4.2. External device

setting 2

SLC-500

SLC 5/05 CPU Direct Ethernet(TCP)

*Note 1) Twisted pair cable
- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.
- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a

direct cable.

W Connectable configuration

+ 1:1 connection (one TOP and one external device) connection
(<1

— HuB
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device [ = |

PLC select [Ethernet]

Filter - [ [al] ~] Search
@ Model () Vendor
Vendor Model
. A
M2I Corporation & Control fCompactLogix Series
MITSUBISHI Electric C i
ectric Lorporation & MicroLogix Series

' 5LC-500 Series

LS Industrial Systems
& Control fCompactLogix Series (Import User Tag)

MODBUS Organization

SIEMEMS AG.

GE Fanuc Automation
PANASONIC Electric Works
YASKAWA Electric Corporation
YOKOGAWA Electric Corparation

Schneider Electric Industries

KDT Systems
RS Automation h
4 Eack | B Next ® Cancel
Select Device H
PLC Setting[ SLC-500 Series ]
Alias Name ; |PLC1 BindIP: lAuto v
Interface : |Ethernet ~
Protocol : |Ethernet/Ip ~ Comm Manual

String Save Mode @ |First HL HL Change

[] use Redundancy

Primary Option

g ‘192 :Hlsa :HD :Hﬁl :‘
Ethernet Protocal Tcp

Part a8 =

Timeout 0 =] msec

Send Wait msec

@ Back v oK ® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.

Please select "Rockwell Automation (AB)".

PLC Select the external device to be connected to the TOP.

Interface Protocol

SLC-500 Series Ethernet Ethernet/IP

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Ethernet]

— Set the TOP communication interface in TOP Design Studio.

Project Opticn

- Change HMIH]

“ AddPLC [&] | THITE) Change PLCICI

~| 3 TOP Setting
; . 20

Option Module Setting
-4 FieldBus (0)

-4 RFID (0)

Device Setting

-rg¥ COM1 (0)

COM2 (D)

L1558 COM3 (D)

v g Ethernet (1)

Wireless (1)
- USBDevice (0}

- PLC1: 5LC-500 Series

Date / Time Sync.
Project Option

Hmi Setup Opton

Screen Change

se HMI Setup

Screen Option

E:i Delete PLCD]

Unit Convert

HmiSetup

Global Lock & Touch

Project Style  Splash

Initialization I Edit I

PLC Buffer Sync.

Project Setting

HMIDisable =0

Project Name=New project
Start Mode =Menu

Start Screen Mo.=1

Latch Use =0

Latch Set=0~0
Communication Error Message =0
USBErrorMessage =0
StorageErrorMessage=1
DatabaseMessage=1

~

Control Panel

3 . e | oy
System Devices feal Ethernet >
-Port
- 7 " | |Ethernet Port : ETH1 = 0 -
L l il Link Speed : &uto -
PLC Security Dat e Time WAl Address :  00:00:00:00:00:00
IP Address :|  192.188.0.50
Subnet Mask :  255,255,255.0
; Gateway :| 192 .1668.0.1
i- o t - )
""I" Default Gateway
Ethernet Serial HIOM | DNS (1) ]
DNS (2) ¢
-Ethernet
| el ﬁ Prinary IP © 132.168.0.50  ~
i -
_— Ping Cable Status
Diagnost ic File Fing
Marager Bridge Mode : JUse Bridge
Check duplicate| Apply | Cancel
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting
M [Project > Project Property > Device Setting > ETHERNET > “PLC1 : SLC-500 Series"]
— Set the options of the SLC-500 Series Ethernet communication driver in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

Project Option

- Change HMIH] “ Add PLC[A] | THiTal Change PLCICl | [ Delete PLCID)

: SPSSYES“.’:QD - PLC Setting[ SLC-500 Series ]

#8 Option Module Setting Alias Mame : |PLC1 BindIP : |Auto

- FieldBus (0)

- RFID (0)
Device Setting Protocol : |Ethernet/Ip v

oW COM1(D) String Save Mode : [First HL HL Change
g% coM2 (0)

5% COM3 (0)

Interface : |Ethernet ~

[ use Redundancy

8 PLC1 : 5LC-500 Series
Wireless (0)

Primary Option

v e o
Ethernet Protocol TCP
Port 44318 z

Timeout msec
Send Wait msec

Comm Manual

Apply Close
* The above settings are examples recommended by the company.
Items Settings Remarks
Interface Select “Ethernet”. Refer to "2. External
Protocol Select “Ethernet/IP". device selection”.
IP Enter the IP address of the external device.
Ethernet Protocol | Selects the Ethernet protocol "TCP" between the TOP and an external device. Fixed
Port Enter "44818", which is the Ethernet communication port number of the external device. Fixed
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and
sending the next command request.
Port
Slot No Enter the slot number of the external device.
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

B [ Main Screen > Control Panel > Ethernet ]

®

Run

YHC
Yiewer

Screen
shot

@ System | [Tt Dpt ion
Ethernet Port :| ETHI |»]|0 |~

|
n ! Link Seeed :| Auto M J’D
L MAC Address : 00:15:1D:05:38:C

IP Address :[  192.168.0.50 Sound
Subnet Mask :[ 255.255.255.0
o Gateway | 192 .168.0.1 o —
I = [# Default Gatewaw "y
Ethernet DMS (1) :l
ONS (20 ¢

-Ethernet m

Primary IP : l]EIE.]EEl.O.ED v]

1 ] I

Diagnost ic MRAM
Cable Status ©  ETHI Connected | |*™'¥si®
/ — Bridae Mode ! [lUse Bridae | —7——
[System] [Check duz| icatel l Aep |y [ Cancel ] Close F
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP 192 . 168 . 0 . 0) should match.

*Note 2) Do not use duplicate IP addresses over the same network.

* The above settings are examples recommended by the company.

Items

Description

IP Address

Set an IP address to be used by the TOP to use over the network.

Subnet Mask

Enter the subnet mask of the network.

Gateway

Enter the gateway of the network.
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(2) Communication option setting

B [Main Screen > Control Panel > PLC]

e
o . PLC
@ Systel priver(ETH) | PLCI(SLC-500 Series) |
e Tam=1 | Interface | Ethernet Rd
m Protocol | Ethernet/ lp -
‘ PLC Bind IP [LAuto -]

YNC P 1922 (18812 [0 [2) (51 12

Yiewer
Ethernet TCF
(A0

ﬁ Et hernet Port :@
Timeout 300 13 msec
o3

ceroal m Send Wait
shot
Diagnost ic
=
[System] l Diagnostic HDing Tesi] l App |y “Cancell

* The above settings are examples recommended by the company.

Items Settings Remarks
Interface Select “Ethernet”. Refer to "2. External
Protocol Select “Ethernet/IP". device selection”.
IP Enter the IP address of the external device.
Ethernet Protocol | Selects the Ethernet protocol “TCP" between the TOP and an external device. Fixed
Port Enter "44818", which is the Ethernet communication port number of the external device. Fixed
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and
sending the next command request.
Port
Slot No Enter the slot number of the external device.
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3.3 Communication diagnostics
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W Check the interface setting status between the TOP and external device.

- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.

- Check if the ETH port settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not

- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

OK

Communication setting normal

Time Out Error

Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix OK NG ) )
Other detailed settings oK NG 4. External device setting
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

4.1. External device setting 1 (1761-NET-ENI)

Set as below using [ENI/ENIW Utility] for communication settings.
For more detailed setting method than that described in this example, refer to the PLC user manual.

Step 1. From the [ENI IP Addr] tab of [ENI/ENIW Utility], configure the "IP Address : 192.168.0.51" and other settings.

Step 2. Download settings for 1761-NET-ENI.

4.2. External device setting 1 (CPU Direct)
Set as below using “SLC500 Series” Ladder Software “RSLogix500".

For more detailed setting method than that described in this example, refer to the PLC user manual.

Step 1. Create a new project from "RSLogix500".
Step 2. From the Project tree, go to [Controller] > [Channel Configuration] and select “Open”.

Step 3. From the [Chan — 1 system] tab of [Channel Configuration] dialog box, configure the “IP Address : 192.168.0.51" and other
settings.

Step 4. Download settings.
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5. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

A Device notation

= Device Name : File Number : Element

Device Bit Address Word Address Remarks
Input file 1:00.000/00 — 1:63.255/15 1:00.000 — 1:63.255
Output file 0:00.000/00 - 0:63.255/15 0:00.000 - 0:63.255
Status file S:000/00 — S:163/15 S:000 - S:163
Bit file B003:000/00 — B003:255/15 B003:000 — B003:255
B009:000/00 — B255:255/15 B009:000 — B255:255
Timer file EN Enable
= Timing T004:000/13 — T004:255/15 T004:000 — T004:255
T009:000/13 — T255:255/15 T009:000 — T255:255
DN Done
PRE | Preset TP004:000 — TP004:255
) TP009:000 — TP255:255
ACC | Accumulated TA004:000 — TA004:255
) TA009:000 — TA255:255
Counter file cu Up enable
CcD Down enable
DN Done C005:000/10 — C005:255/15 C005:000 — C005:255
oV Overflow C€009:000/10 — C255:255/15 C009:000 — C255:255
UN Underflow
UA Update Acc
PRE Preset CP005:000 — CP005:255
_ CP009:000 — CP255:255
ACC | Accumulated CA005:000 — CA005:255
) CA009:000 — CA255:255
Control file EN Enable
EU Enable unload
DN Done
EM Empty R006:000/10 — R006:255/15 R006:000 — R006:255
ER Error R009:000/10 — R255:255/15 R009:000 — R255:255
UL Unload
IN Inhibit comp.
FD Found
LEN | Length RLO06:000 — RL006:255
' RL009:000 — RL255:255
POS | Position RP006:000 — RP006:255
) RP009:000 — RP255:255
Integer file NO007:000/10 — N007:255/15 N007:000 — N007:255
N009:000/10 — N255:255/15 N009:000 — N255:255
Floating point file None F008:000 - F255:255
String file None ST009:000 — ST255:255
ASClII file A009:000/00 — A255:255/31 A009:000 — A255:255
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