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FATEK Automation Corporation 

FB Series 

Ethernet Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Cable table Page 10 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 11 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “FATEK Automation Corporation – FB Series Ethernet” is as follows: 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

FBs 

FBs-10MA/MC 

FBs-14MA/MC 

FBs-20MA/MC 

FBs-24MA/MC 

FBs-32MA/MC 

FBs-40MA/MC 

FBs-60MA/MC 

FBs-CBE 

Ethernet 

(UDP) 

3. TOP communication 

setting 

4. External device 

setting 

Twisted pair cable*Note 1) 
Ethernet 

(TCP) 

FBs-CM25E 

FBs-CM55E 

Ethernet 

(UDP) 

3. TOP communication 

setting 

4. External device 

setting 

5.1. Cable table 1 
Ethernet 

(TCP) 

FBs-20MA/MC 

FBs-28MA/MC 

FBs-40MA/MC 

FBe-DTBR-E 

Ethernet 

(UDP) 

3. TOP communication 

setting 

4. External device 

setting 

5.2. Cable table 2 
Ethernet 

(TCP) 

*Note 1) Twisted pair cable 

- Refers to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 

 

 

■ Connectable configuration 

 

ㆍ1:1 connection (one TOP and one external device) connection 

 

 

 

ㆍ1:N connection (one TOP and multiple external devices) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 

 
 

 
 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “FATEK Automation Corporation”. 

PLC Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

FB Series Ethernet Ethernet 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project > Project Property > TOP Setting] → [Project Option > “Use HMI Setup” Check > Edit > Ethernet] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 
 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [Project > Project Property > Device Setting > ETHERNET(1) > “PLC1 : FB Series”] 

– Set the options of the FB Series Ethernet communication driver in TOP Design Studio. 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select “Ethernet”. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

Station No  Enter the prefix of an external device.  

※ If you use external device prefix 0, all devices on the connected track will respond. Use the designated prefix from 1 to 254 to operate only the 

relevant number. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the 

main screen.  

   

(1) Communication interface setting 

■ [Main Screen > Control Panel > Ethernet] 
 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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 (2) Communication option setting 

■ [Main Screen > Control Panel > PLC] 
 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select “Ethernet”. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

Station No  Enter the prefix of an external device.  

※ If you use external device prefix 0, all devices on the connected track will respond. Use the designated prefix from 1 to 254 to operate only the 

relevant number. 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the port (ETH1/ETH2) settings you want to use in [Control Panel > Ethernet] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

Use "Ether_cfg.exe" (Configuration Software of FB Series Ethernet Module) to set up as follows. After setup is complete, download 

(click the [Export] button) and reboot power to the FB Series. 

For more detailed setting method than that described in this example, refer to the PLC user manual. 
 

 
Do not use duplicate IP addresses over the same network. 

 

Step 1. FB Series and “Ether_cfg.exe”connection 

– When running “Ether_cfg.exe”for first time, the appearing“Ethernet adaptor Configuration” window shows [Intranet/Internet/RS232]; 

select 1 of 3 methods and connectFB Series with “Ether_cfg.exe”. 

 
 

Step 2. “Adaptors Properties” window settings : Set the FB Series side settings on the [General] and [Misc.] tabs. 

– [General] tab settings 

 
 

Items Settings Remarks 

IP Address 192.168.0.51 Set Users 

Subnet Mask 255.255.255.0 Set Users 

Gate Way 192.168.0.1 Set Users 

Operation Mode Server Fixed 

Protocol Fatek Fixed 

 

– [Misc] tab settings 

 

 

Items Settings Remarks 

Major Port  (TCP port) 500 Set Users 

Second Port  (UDP port) 500 Set Users 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “FATEK Automation Corporation”) 
 

5.1. Cable table 1 (FBs-CM25E, FBs-CM55E) 
 

■ ETHERNET (1:1 connection) 

ETHERNET 

Cable connection 

FBs-CM25E/FBs-CM55E 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

8-pin male RJ45  

(Male, convex) 

 1  1  

 

(Euro. 4pin con.) 

 2 2  

 3 3  

 4 6  

 5  

 6 

 7 

 8 

 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

 

5.2. Cable table 2 (FBe-DTBR-E) 
 

■ ETHERNET (1:1 connection) 

ETHERNET 

Cable connection 

FBe-DTBR-E(D-SUB 9 pin) 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

8-pin male RJ45  

(Male, convex) 

 1  1  

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

 2 2  

 3 3  

 4 4  

 5 5  

 6 6  

 7 7  

 8 8  

 9 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use.  

 

Device Bit Address Word Address 32 Bits Remarks 

Input relay X000 ~ X255 WX000 ~ WX240 L/H  

Output relay Y000 ~ Y255 WY000 ~ WY240  

Step relay S000 ~ S999 WS000 ~ WS976  

Internal relay M0000 ~ M1911 WM0000 ~ WM1888  

Special relay M1912 ~ M2001 WM1912 ~ WM1976  

Timer(Contact) T000 ~ T255 WT000 ~ WT240  

Counter(Contact) C000 ~ C255 WC000 ~ WC240  

Timer(Current value) TMR000.00 ~ TMR255.15 TMR000 ~ TMR255  

Counter(Current value) 
CTR000.00 ~ CTR199.15 CTR000 ~ CTR199  

––––– CTR200 ~ CTR255  

Data register R00000.00 ~ R65535.15 R00000 ~ R65535  

Data register D00000.00 ~ D65535.15 D00000 ~ D65535  

 

 


