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MITSUBISHI Electric Corporation 

MELSEC FX Series  

Computer Link Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 4 

 Select a TOP model and an external device. 

3. TOP communication setting Page 5 

 Describes how to set the TOP communication. 

4. External device setting Page 10 

 Describes how to set up communication for external devices. 

5. Cable table Page 12 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 14 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSEC FX Computer Link” is as follows. 
 

CPU Link I/F*Note 1) 
Communication 

method 
System setting Cable 

FX3G-14M□ 

FX3G-24M□ 

FX3G-232-BD 

FX3U-232ADP+ FX3G-CNV-ADP 
RS-232C 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table 

FX3G-485-BD 

FX3U-485ADP+FX3G-CNV-ADP 

RS422 

( 4 wire ) 

RS-485 

( 2 wire ) 

FX3G-40M□ 

FX3G-60M□ 

When using channel 1 

FX3G-232-BD (connect to the connector 1 of 

the additional unit) 

FX3U-232ADP + FX3G-CNV-ADP 

RS-232C 

FX3G-485-BD (connect to the connector 1 of 

the additional unit) 

FX3U-485ADP + FX3G-CNV-ADP 

RS422 

( 4 wire ) 

RS-485 

( 2 wire ) 

When using channel 2 

FX3G-232-BD (connect to the connector 2 of 

the additional unit) 

FX3U-232ADP + FX3U-■ADP + FX3G-CNV-

ADP 

RS232C 

FX3G-485-BD (connect to the connector 2 of 

the additional unit) 

FX3U-485ADP + FX3U-■ADP + FX3G-CNV-

ADP 

RS422 

( 4 wire ) 

RS-485 

( 2 wire ) 

FX3UC-□MT/D 

FX3UC-□MT/DSS 

When using channel 1 

FX3U-232ADP RS-232C 

FX3U-485ADP 
RS422 

( 4 wire ) 

 
RS-485 

( 2 wire ) 

When using channel 2 

FX3U-232ADP + FX3U-■ADP RS-232C 

FX3U-485ADP + FX3U-■ADP 
RS422 

( 4 wire ) 

 
RS-485 

( 2 wire ) 

FX3UC-32MT-LT 

FX3U 

When using channel 1 

FX3U-232-BD  

FX3U-232ADP + FX3U-CNV-BD 
RS-232C 

FX3U-485-BD 

FX3U-485ADP + FX3U-CNV-BD 

RS422 

( 4 wire ) 

RS-485 

( 2 wire ) 

When using channel 2 

FX3U-232ADP + FX3U-□BD,  

FX3U-232ADP + FX3U-■ADP + FX3U-CNV-BD 
RS-232C 

FX3U-485ADP + FX3U-□BD 

FX3U-485ADP + FX3U-■ADP + FX3U-CNV-BD 

RS422 

( 4 wire ) 

RS-485 

( 2 wire ) 
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☞ Continued on next page. 

 

CPU Link I/F*Note 1) 
Communication 

method 
System setting Cable 

FX2N 

FX2N-232-BD 

FX2NC-232ADP + FX2N-CNV-BD 
RS-232C 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table 

FX2N-485-BD 

FX0N-485ADP + FX2N-CNV-BD  

FX2NC-485ADP + FX2N-CNV-BD 

RS422 

( 4 wire ) 

RS-485 

( 2 wire ) 

FX1N 

FX1S 

FX1N-232-BD 

FX2NC-232ADP + FX1N-CNV-BD 
RS-232C 

FX1N-485-BD 

FX0N-485ADP + FX1N-CNV-BD 

FX2NC-485ADP + FX1N-CNV-BD 

RS422 

( 4 wire ) 

RS-485 

( 2 wire ) 

FX2NC 

FX1NC 

FX0N 

FX2NC-232ADP RS-232C 

FX0N-485ADP 

FX2NC-485ADP 

RS422 

( 4 wire ) 

RS-485 

( 2 wire ) 

*Note 1) One of ( 232, 422, 485, USB ) is entered in □ in the Link I/F column. 

One of ( 232, 485 ) is entered in ■ in the Link I/F column. 

 

 

■ Connection configuration 

 

ㆍ1:1 (one TOP and one external device) connection – configuration which is possible in RS232C/422/485 communication. 

 

 

ㆍ1:N (one TOP and multiple external devices) connection – configuration which is possible in RS422/485 communication. 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Please select “MITSUBISHI Electric Corporation”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

MELSEC FX Series Computer Link MC Protocol 1C ACPU 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 

 

 

 
 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C RS-422 RS-485 

RS-232C 

RS-422/485 
 

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Project > Project Property > PLC Setting > COM > “PLC1 : MELSEC-FX Series”] 

– Set the options of the MELSEC-FX Series CPU Direct communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Fixed 

Protocol Select “MC Protocol 1C ACPU”. Fixed 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Station Num Enter the prefix of an external device.  

PC No Set the prefix of TOP.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C RS-422 RS-485 

RS-232C 

RS-422/485 
 

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Fixed 

Protocol Select “MC Protocol 1C ACPU”. Fixed 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Station Num Enter the prefix of an external device.  

PC No Set the prefix of TOP.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

Communication setting of MELSEC-FX series has two methods: parameter settings in MELSEC series Ladder Software "GX Developer” 

or data setting in PLC’s “special data register”. For more detailed setting methods than described in this example, refer to the PLC 

user manual. 

 

■ Method 1: Parameter setting in  "GX Developer" 

Step 1. Double-click [Parameter] > [PLC parameter] in the project window to pop-up the [FX Parameter] dialog box. 

Step 2. Select [PC system settings (2)] tab in the [FX Parameter] dialog box, select to use “Operate Communication Setting” and 

then set as follows. 

 
 

Items Selection Remarks 

CH “CH1” or “CH2” 
Select the channel for communication setting. 

(Items that can be set only on FX3UC, FX3U, and FX3G models.) 

Operate Communication Setting Check to use (Fixed) 

Protocol Dedicated protocol (Fixed) 

Data length 8bit  

Parity None  

Stop Bit 1bit  

Transmission Speed 19200  

H/W type Regular/RS-232C  

Sum check Check to use (Fixed) 

Transmission control procedure Form1(without CR,LF) (Fixed) 

Station number setting 00  

Time out judge time 1  

■ Select “RS-485” in “H/W type” for RS-422/485. 

* The above settings are setting examples recommended by the company. 

 

Step 3. [Online] > Transmit the parameter set to [Write to PLC] and reset the PLC.
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■ Method 2: Enter data to “special data register” in PLC. 

 

Enter data to the special data register of MELSEC-FX. After input, reset the power of PLC.  

To set the content set in the setting goal, enter the data as follows. 

Special register items Data 

Channel 1 Channel 2 (FX3UC, FX3U, FX3G.) Setting data(Hexadecimal) Remarks 

D8120 D8420 
6891 RS-232C serial parameter setting data 

6091 RS-422/485 serial parameter setting data 

D8121 D8421 0 PLC station number 

D8129 D8429 1 Time out judge time 
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5. Cable table  

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “Mitsubishi Electric Corporation”) 
 

■ RS-232C (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 CD 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 RD 

SD 3 3 SD 

DTR 4 4 DTR 

SG 5 5 SG 

DSR 6 6 DSR 

RTS 7 7 RTS 

CTS 8 8 CTS 

 9 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDA 

 

 2 SDB 

 3 RDA 

RDB 4 RDB 

SG 5 SG 

SDA 6  

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDA 

 

 2 SDB 

 3 RDA 

RDB 4 RDB 

SG 5 SG 

SDA 6  

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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■ RS-485 (1:1 connection) 

COM 

Cable connection 

PLC 

Pin arrangement 
Signal 

name 

Signal 

name 
Pin arrangement 

 

╋  SDA 

 

— SDB 

SG RDA 

 

RDB 

SG 

 

 

 

■ RS-422(1:N connection) – Refer to 1:1 connection to connect in the following way: 

TOP Cable connection and signal 

direction 

PLC Cable connection and signal 

direction 

PLC 

Signal name Signal name Signal name 

RDA 

 

SDA 

 

SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 

 

 

■ RS-485 (1:N/N:1 connection) – Refer to 1:1 connection to connect in the following way. 

TOP Cable connection and signal 

direction 

PLC Cable connection and signal 

direction 

PLC 

Signal name Signal name Signal name 

RDA  SDA  SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Type Remarks Bit designation address Word designation address 32 bit Property 

Input Bit X0000 – X0377 X0000 – X0360 

L/H*Note 1)
 

*Note 2) Note 3) 

Output Bit Y0000 – Y0377 Y0000 – Y0360 *Note 3) 

STEP relay  Bit S0000 – S8191 S0000 – S8176  

Internal relay Bit M0000 – M7679 M0000 – M7664  

Special relay Bit M8000 – M8511 M8000 – M8496 *Note 4) 

Data register Word D0000.00 – D0999.15 D0000 – D0999  

D1000.00 – D7999.15 D1000 – D7999  

Special register Word D8000.00 – D8511.15 D8000 – D8511 *Note 4) 

Timer - Contact Bit T000 – T511 ––––––––––  

Timer-Current value Word –––––––––– TN000 – TN511  

Counter - Contact Bit C000 – C255 ––––––––––  

Counter-Current value Word –––––––––– CN000 – CN199  

Counter-Current value DWord –––––––––– CN200 – CN255 *Note 5) 

*Note 1) The lower 16BIT data of 32BIT data is saved in the screen registered address, and the upper 16BIT data is saved in the 

address next to the screen registered address. 

   Ex. When saving 32 BIT data hexadecimal data 12345678 in address D00100, it is saved to 16 BIT device address as follows: 

Items 32BIT 16BIT 

Address D00100 D00100 D00101 

Input data 

(hexadecimal) 
12345678 5678 1234 

*Note 2) It has a non-writable area. Please use it with caution. 

*Note 3) When used as a word address, it is used in units of 20 (Octal-decimal). (Ex: X0, X20, X40, …, X160) 

*Note 4) As it may be used as a special area according to the address by the system, it may not be possible to execute Write Data. 

Refer to the manual of the external device for use. 

*Note 5) 32 BIT device 

 


