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1. System configuration

The system configuration of TOP and “Fanuc LTD. Power Mate i Series " is as follows:
Communication
Series CPU System setting Cable
method
3. TOP communication
RS-232C setting 5.1. Cable table 1
. L 4.1. External device setting 1
Fanuc Series Power Mate i Series —
3. TOP communication
RS-422 ;
) setting 5.1. Cable table 1
(4 wire) ; .
4.1. External device setting 1

W Connection configuration

+ 1:1 (one TOP and one external device) connection — configuration which is possible in RS232C/422 communication.

_ b ifTT

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422 communication.
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM2]
Filter : |[AII] v‘ Search : I:I
@ Model (O Vendor
Vendor Model

~
AIBECCE., s

IEC Standard

CAS

AsD

SEHWA CNM
SHINHAN Electronics
BONGSHIN LOADCELL
MINEEEA Co., Ltd.
Azbil Corporation
KORO TECHNOLOGY
ROBOSTAR

Ebmpapst

CaNefvs Autnmatinn Aliance %

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ Fanuc Series ]

Alizs Mame @ |PLCL

Interface : | Serial ~

Protocol : | SNP-X ~ Comm Manual
String Save Mode : |First LH HL Change

[ use Redundancy
AND v

Primary Option

Timeout msec

Send Wait

Retry 5 =

@ Back + OK * Cancel

Settings

Contents

TOP Model

Check the TOP display and process to select the touch model.

External device | Vendor

Select the vendor of the external device to be connected to TOP.

Please select “Fanuc LTD."

PLC

Select an external device to connect to TOP.

Interface Protocol

Fanuc Series Computer Link SNP-X

Supported Protocol
SNP-X

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option

-ChangeHM\[ﬂ]

B Ao PLc &) TR Change PLCIT

tD TOP Setting I
105

~ -l Option Module Setting
H -4 FieldBus (0)

-8 RFID (0)

% Device Setting

--rg® COM1(0)

VI COM2 (1)

1% COM3 (0)
-4 Ethernet (0)
“4g USBDevice (0)

-4 PLC1: Fanuc Series [1]

Date [ Time Sync.

Project Option ~ Screen Change

Use HMI Setup

Screen Option

E3 Delete PLCID)

Unit Convert

HmiSetup

Global Lock & Touch

Project Style = Splash

Initialization | Edit |

PLC Buffer Sync.

Start Mode=Menu

Start Screen Mo, =1

Latch Use=0

Latch Set=0~0

Communication Error Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1

a.

tamMaccane—1

~

Control Panel

Svstem m Devices IR Cervice  I=Eh Option
o Serial Xl
T £~ Serial Port: COMZ M
PLC Security  Date/Time Signal Level
() RE-232C (@) RS-422(4) O RsS-485(2)
Baud Rate: 19200 =
||||||| M K [\__/ Data Bit: & S
Ethernet Serial HOM | Stop Bit: S
Parity Bit: Mone =
B % Flow (0
L A
L;“. Ping Auto Search  Loopback Test
Diagnost ic File Ping
Wanager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
RS-422 RS-422
Baud Rate 19200
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > “PLC1 : Fanuc LTD"]

— Set the options of the Power Mate i Series communication driver in TOP Design Studio.

TOP ooz e
Touch Qperation Panel

Project Option

~ ] TOFP Setting
| L[ 5Y5:RD1520%
Option Module Setting
B FieldBus (0)

- RFID (0)

w Device Setting

W COM1(0)

LC1: Fanuc Series [1]

8 Ethernet (0)
™ Wireless (0)
4§ USBDevice (0)

- Change HMI[H] ' AddPLCIA] | THITal Change PLCIC | [T Delete PLCID)

PLC Setting[ Fanuc Series ]

Alizs Name : [PLC1

Interface : | Serial ~

Protocol : | SNP-X ~
String Save Mode : (First LH HL Change

[] use Redundancy

AND v
e g o
e0 -
Primary Option
Timeout m msec
Send Wait msec
Retry 5 z

Comm Manual

Apply Close
Items Settings Remarks
Interface Select "Computer Link". Refer to “2. External
Protocol Select the serial communication protocol between the TOP and an external device. device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device
and sending the next command request.

SNP ID

Enter SNP ID for external device.
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3.2. Communication setting in TOP

* This is a setting method when "Use HMI Setup” in the setting items in "3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conikroll Panel

serial

R
" Tttt Serial Port: [CUI#H |vl
!lill 7.-;- Signal Level
‘ PLC Date;Ti () RS-2320 @ RS-422(4) O RS-485(2) l
Baud Rate: 19200 N
YHC
Yiewer [|J-|-||] ] - Data Bit: [ g |'l
G | =
:ﬁ Etl:ilr"nlet Serial Stop Bit: [ 1 |'l
= Parity Bit: | None -
BRige" m = ..\N Flow: | 0ff B
sno ! !
Disgrost o MF”B ;i:'gni lAuto Search] lLoopback Testl
anager

 Aeply | Cancel |

[System]

]F'

il

Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C

RS-422 RS-422
Baud Rate 19200
Data Bit 8
Stop Bit 1
Parity Bit None.
* The above settings are setting examples recommended by the company.
Items Description
Signal Level Select the serial communication method between the TOP and an external device.
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

B [Main Screen > Control Panel > PLC]

(») T

@ Svstem| Driwver({COMI) PLC1(Fanuc Series) v]

Aun Interface | Serial Rd
m Protocol | SMP- Rd
‘ PLC Timeout 300 E Msec
vHE send Wait MmSec

pleser | || o et 5=
o
P R T I R

Ethernet

il

Diagnost ic

[System] [ Diagnostic l dop |y “Cancel]
I

Items Settings Remarks
Interface Select “Computer Link". Refer to "2. External
Protocol Select the serial communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.
SNP ID Enter SNP ID for external device. (Configure with TOP Design Studio)
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch "Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information oK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG . .
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
oK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Refer to the vendor’s user manual to identically configure the communication settings of the external device to that of the TOP.
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5. Cable table

TO,

ERI2 e B X
Touch Qperation Panel

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “Power Mate i Series”)

5.1. Cable table

W RS-232C (1:1 connection) User-created cable

TOP External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangementNote 1) name number number name arrangement-Note 1)
CD —
1 5 RD 2 11 sD
2 g DTR 4 3 DR
Based on 56 > L D
communication DSR 6 13 ER Based on

cable connector RTS I 8 56 communication

front, crs 8 s cable connector
15 RS

D-SUB 9 Pin male

(male, convex)

front,
D-SUB 20 Pin male

(male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

W RS-422 (1:1 connection) User-created cable

TOP External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement Note 1)
RDA 1 4 SDA —
1 5 2 3 SDB
g ‘;‘ RDB 4 1 RDB
Based on > 12 5G
communication SDA 6 E 6 RTS+ Based on
cable connector l 8 CTo+ communication
front, 8 E > RTS- cable connector
D-SUB 9 Pin male 9 7 front,
(male, convex) SDB CTS- D-SUB 20 Pin male
(male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

B RS-422 (1:N connection) — Refer to 1:1 connection to connect in the following way.

TOP

Signal name

Cable connection and signal direction

External device

Signal name

RDA

SDA

Cable connection and signal

direction

Terminal external

device

Signal name

RDB

SDB

SDA

SDA

RDA

SDB

SDB

RDB

RDA

SG

ov

RDB

RTS+
[ CTS+

E RTS-
CTS-
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6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Address Word Address 32 BIT
X00000.0-X00127.7 X00000-X00126
X00200.0-X00327.7 X00200-X00326
Input Relay X00400.0-X00527.7 X00400-X00526
X00600.0-X00727.7 X00600-X00726
X01000.0-X01127.7 X01000-X01126
Y00000.0-Y00127.7 Y00000-Y00126
Y00200.0-Y00327.7 Y00200-Y00326
Output Relay Y00400.0-Y00527.7 Y00400-Y00526
Y00600.0-Y00727.7 Y00600-Y00726
Y01000.0-Y01127.7 Y01000-Y01126
Internal Relay R00000.0-R07999.7 R00000-R07998
Keep relay K00000.0-K00099.7 K0000-K00098
Enhancing Relay E0000.0-E09999.7 E00000-E09998
Timer - TO000-T0498
C0000-C0398
Counter -
C5000-C5198
Data table D00000-D09999.7 D00000-D09998

*Note 1) When using a bit address that uses decimals, use a word address in units of “16"
*Note 2) The lower 16 BIT data of 32 BIT data is saved in the address whose screen has been registered, and the upper 16 BIT data
is saved in the address next to the address whose screen has been registered.

Ex. When saving 32BIT data hexadecimal data 12345678 in address D00100, it is saved to 16BIT device address as follows:

Items 32BIT 16BIT
Address D00100 D00100 D00101
Input data
. 12345678 5678 1234
(hexadecimal)
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