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1. System configuration

The system configuration of TOP and “IDEC MicroSmart” is as follows:

Communication

System settin
method y 9 ‘

Series ‘ CPU ’ Link I/F

MicroSmart Port Ethernet . Twisted pair
. FC3/FC4A/FC5A . 3.1 Settings example
Series on CPU unit (TCP) cable*Note 1)

*Note 1) Twisted pair cable
- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.
- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a

direct cable.

B Connection configuration

+ 1:1 connection (one TOP and one external device) connection

ToF -
| = |
m ;:‘

— | HUB '
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [Ethernet]
Filter : |[AII] v‘ Search :

@ Model (O Vendor
Vendor Model

= -
IDEC Corporation " MicroSmart Series

4_Back | B Next *® Cancel

Select Device n
PLC Setting[ MicroSmart Series ]
Alizs Mame : BindIP: Auto v
Interface : | Ethernet ~
Protocol : |Ethernet ~ Comm Manual
String Save Mode : |First LH HL Change
[] use Redundancy
AND ~
Primary Option

: Sae

Ethernet Protocol

Port

Timeout

Send Wait

@ Back « OK M Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "IDEC”
PLC Select an external device to connect to TOP.

Interface Protocol

MicroSmart Ethernet MicroSmartProtocol

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Ethernet]

— Set the TOP communication interface in TOP Design Studio.

Project Option X
-ChangeHMllﬂ] .ma PLC[A] | THIW Change Picicl | [ Delete LCID
ﬂ%ms Date / Time Sync. =~ Screen Option | Unit Convert
b 'ﬁiﬁ;_”lz";du‘éfemng Project Option  Screen Change  HmiSetup = Global Lock & Touch  Project Style  Splash  PLC Buffer Sync.
g RFID (0}
v .\?Eivieoriit?gf Initialization | Edit |
~f§¥ COMZ (D) Project Setting ~
g COM3 (D) HMIDisable=0
v g Ethernet (1) Project Name=New project
-4 PLC1: MicroSmart Series Start Mode=Menu
g USEDevice (0) e
Latch Set=0~0
Communication Errar Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
" o
Svystem Devices @1 Ethernet X
-Port
s e | Ethernet Port :|ETHI * |0 -
I l ? = Link Speed | Auto v
FLC Security DatesTime MAC Address @ 00:00:00:00:00:00
IP hddress :|  192.168.0.50
Subnet Mask :|  255,255.255.0
r Gateway :| 182 .168.0.1
ol )
"I"" '-- [~] Default Gatewaw
Ethernet Serial HIOM | DNS (17 ¢
DNS (2) i
- Ethernet
E— N\ Prinary IP : 192.168.0.50  ~
L ol . Ping
: : s - Cable Status
Diagnost ic File Fing
Manager Bridge Mode ! JUse Bridae
Check duplicate | Apply || Cancel
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR, 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication

M [Project > Project Property > Device Setting > ETHERNET

TOP

option setting
> "PLCT : MicroSmart"]

— Set the options of the MicroSmart communication driver in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

Project Option

- Change HMI[H] ' Ad

dPLC[A] | THTW) ChangePLCICl | [ Delete PLCD]

~ ] TOFP Setting

| L[ 5Y5:RD12105
Option Module Setting
B FieldBus (0)

- RFID (0)

Device Setting

icroSmart Series
USBDevice (0)

PLC Setting[ MicroSmart Series ]

Alizs Name : [PLC1 BndIP: |aute v
Interface : |Ethernet ~
Protocol : |Ethernet ~

String Save Mode : (First LH HL Change

[] use Redundancy

AMD e
e c, -
e0 s
Conditio Edi
Primary Option

P [o2 & s B[+ B[ F]
Ethernet Protocol TCP v
Port 2101 z
Timeout msec
Send Wait msec

Comm Manual

Apply Close
* The above settings are examples recommended by the company.
Items Settings Remarks
Interface Select “Ethernet”. Refer to “2. External
Protocol Select “Ethernet”. device selection”.
IP Enter the IP address of the external device.

Ethernet Protocol

Selects the Ethernet protocol

between the TOP and an external device.

Fixed

Port

_TCP
Enter 2101

, which is the TCP/IP port number of the external device.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external

device and sending the next command request.
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3.2. Communication setting in TOP

TO,
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

®

Bun

YHC
Yiewer

s
i

Ethernet

Diagnost ic

[System]

1 ] I

-Port
Ethernet Port :| ETHI |~| 0 |+|
! Link Seeed :| Auto M
MAC Address : 00:15:1D:05:38: 05
| IP Address :[  192.168.0.50
Subnet Mask [ 255.255.255.0
5 Gateway ! 192.168.0.1
“ [E Default Gateway
DNS (1)
DNS (2)
- Ethernet

Frimary [P l 192.168.0.50

d

Cable Status
Bridae Mode !

ETH1 Connected

[ lUse Bridae

[Check duplicatel l Apop | v [ Cancel ]

Dption

MRAM
hnalysis

Close

"6 Ethernet
@ Swstem
0}

F/

el

Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.1.118 192.168.1.5
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 1. 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

rd

o il PLG

@ System| Oriver(ETH)

B e v]

Run Interface | Ethernet v
!Il' | Protocol | Ethernet v
‘ L Bind IP (Luto -]
. P [ozls e8isf 1 25 15
Viever [-n-] | Ethernet (TCP_|+]
q
samy i Port 2101 3]
] Et hernet
[ E Timeout 1000 5] msec
Ammd
1 Send Wait 0 3 msec
Screen
Diagnost ic
[System] l Diagnostic ]Fing Tesi] [ Apop | v “Cancel l

———

* The above settings are examples recommended by the company.

Items Settings Remarks

Interface Select “Ethernet”. Refer to "2. External
Protocol Select "Ethernet”. device selection”.
IP Enter the IP address of the external device.

Ethernet Protocol Selects the Ethernet protocol ~TCP  between the TOP and an external device. Fixed

Port Enter 2101 , which is the Ethernet communication port number of the

external device.

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

SendWait (ms) Set the waiting time between TOP's receiving a response from an external

device and sending the next command request.
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3.3 Communication diagnostics
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W Check the interface setting status between the TOP and external device.

- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.

- Check if the ETH port settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not

- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

OK

Communication setting normal

Time Out Error

Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix OK NG ) )
Other detailed settings oK NG 4. External device setting
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting
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Set as below using “IDEC PLC Series” “MicroSmart".

For more detailed setting method than that described in this example, refer to the PLC user manual.

A Do not use duplicate IP addresses over the same network.

1. Run the WINDLDR SW.
Go to Configure .>> PLC Select to choose the desired PLC,

Select ETHERNET at communication settings.

-
Communication Settings

Part—————————
" Senial Part

{+ Ethemnet

Ethernet Communication S etting

I IF Address Settings

Connection Setting:
(" Configure the serial port of Web Server Unit befare communication

—Weh Server Unit Seral Port Settings———

Baud Rate: Im
D ata Bits: m
Farity: Im
Stop Bits: m

(:I Raw TCP/IP connection [For HG 3F/4F Ethernet Pass-Through)

WindLDR Commurication S etting:

Timeaut: G000 :II %10 mzec

1 Enable TCPAP Packets Settings

The maximum data size: |8 ill « B4 bytes
Time delay between packets: I'I a ﬂ MEes

Cancel | Default | Help
4.  Select IP Address settings.
- - Bl
IP Address Settings ———— —— o — — |
IP address Pot No.  |MAC address Comment | New
Edit
- -
Input IF address u

IP address:
Part Mo:

MAC address:

[@. 0. 0.0

I21 0 Cancel

Clear

i

ms.

Search Web Server Unit

Configure Web Server Linit

I
I
| Delete |
I
I

Comment:
S

I

ok |  cancel | Help

5. Select "New" and configure the port and IP
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TOR =32 I
5. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be careful not to deviate from the

address range supported by the device you want to use.

Device Contents Bit Address Word Address Remarks

Input 0000 ~ 0627 0000 ~ 0062

Y Output 0000 ~ 0627 0000 ~ 0062
M Internal Relay 0000 ~ 2557 0000 ~ 0254
Special Internal Relay 8000 ~ 8317 0800 ~ 0830

R Shift Register 0000 ~ 0255 0000 ~ 0240
TS Timer(Preset Value) - 0000 ~ 0255
TN Timer(Current Value) - 0000 ~ 0255
CS Counter(Preset Value) - 0000 ~ 0255
CN Counter(Current Value) - 0000 ~ 0255
D Data Register 0000.00 ~ 1999.15 0000 ~ 1999
Special Data Register 8000.00 ~ 8199.15 8000 ~ 8199

Extended Data Register 2000.00 ~ 7999.15 2000 ~ 7999

Does not support Extra Data Register.
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