
1 / 13

SIEMENS AG.

SIMETIC S7 Series 

PROFIBUS DP Slave(PACKET)
Compati

ble 

version

OS Over 4.0

XDesignerPlus Over 4.0.0.0

CONTENTS
Thank you for using M2I’s "Touch Operation Panel(M2I TOP) Series". 

Please read out this manual and make sure to learn connection 

method and process of TOP – External device”

1. System configuration Page 2

It explains device for connection, setup of, cable and structural 

system.

Please choose proper system referring to this point.

2. Selecting TOP model and 

external devices
 Page 3

Select TOP model and external device..

3. Example of system settings Page 4

It explains setup example for communication connection 

between the device and external terminal. 

Select example according to the system you choose in “1. 

System structure”

4. Communication settings details Page 9

It explains the way of configuring TOP communication. 

If external setup is changed, make sure to have same setup of 

TOP with external device by referring to this chapter.

5. Cable diagram Page 10

Explains cable specifications required for access.

Select proper cable specifications according to the system you 

chose in “1. System configuration”.

6. Support address Page 11

Check available addresses to communicate with external devices 

referring to this chapter.
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(1) PROFIBUS communication can be operated through “ABCC-DPV1” PROFIBUS DP Module which is sold separately.

Please use D-Sub 9 pin which is integrated in the module after installing “ABCC-DPV1” PROFIBUS DP Communication Special 

Module in the XTOP Fieldbus slot.

(2) XTOP is possible to connect to PROFIBUS NETWORK as "PROFIBUS DP Slave”.

ㆍPlease download files from the homepage for (SIMETIC S7 Series) settings in the PROFIBUS DP Master side.

For DP Master side settings using the files that are downloaded, please check "page 3 System Settings Example" in this 

manual. 

Series CPU Link I/F Method System settings Cable

SIMETIC

S7

CPU 313C-2 DP

CPU 314C-2 DP 

CPU 315-2 DP

CPU 315-2 PN/DP 

CPU 315F-2 DP

CPU 315F-2 PN/DP

CPU 316-2 DP 

CPU 317-2 PN/DP 

CPU 317F-2 PN/DP 

CPU 319-3 PN/DP 

DP port

on CPU unit
PROFIBUS

3.1 설정 예제 

13.1 Setting 

Example 1

( Page 4 )

5.1 Cable diagram 1

( Page 10 )

CP342-5

CP342-5 FO

CP343-5

PROFIBUS

3.1 설정 예제 

13.1 Setting 

Example 1

( Page 4 )

5.1 Cable diagram 1

( Page 10 )

CPU 412-2 DP

CPU 413-2 DP

CPU 414-2 DP

CPU 414-3 DP

CPU 416-2 DP

CPU 416-3 DP

DP port

on CPU unit
PROFIBUS

3.1 설정 예제 

13.1 Setting 

Example 1

( Page 4 )

5.1 Cable diagram 1

( Page 10 )

CP443-5 Basic

CP443-5 Extended
PROFIBUS

3.1 설정 예제 

13.1 Setting 

Example 1

( Page 4 )

5.1 Cable diagram 1

( Page 10 )

1. System configuration

■ Please confirm informations below for PROFIBUS communication.

■ The system configuration of  “XTOP-PROFIBUS DP Slave Device” and “SIEMENS AG. - PROFIBUS DP Master Device” is as below.

■ Possible Connecting Configuration
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Setting details Contents

TOP Series

Series Version name

XTOP V4.0

Select the name of a TOP series that is to be connected to PLC.

Before downloading the settings, install the OS version specified in the table below according to 

TOP series.

Name Select the model name of TOP product.

External device Manufacturer Select the manufacturer of external devices to be connected to TOP.

Select “SIEMENS AG”.

PLC Select the model series of external devices to be connected to TOP.

Please select “PROFIBUS DP Slave(PACKET)”. 

Please check, in the “1. System configuration”, if the relevant external device is available to set a 

system configuration.

2. Selecting TOP model and external devices
Select the external devices to connect to TOP.
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Details “PROFIBUS DP Master Device” TOP Remark

Operating Mode DP Master DP Slave Mandatory 

Setting

Node Address 2 10 –

Transmission Rate 1.5 Mbps 1.5 Mbps –

Profile DP DP –

■ External device settings

Set options of communication driver for “PROFIBUS DP Slave Device” 

 

-TOP Node Number : Input PROFIBUS DP Slave Node Address which is given to TOP.

3. Example of system settings
For the communication interface setting between TOP and PROFIBUS DP Slave Device, we suggest as below.

3.1 Example of settings 1

The system is set as below.

(1) XDesignerPlus setup

After setting the below details in [Project > Project Settings], download the detailed settings using TOP tool.

Continue on the next page.
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Please download "PROFIBUS.ZIP" file from our homepage.

<Fig. GSD File Install <Fig. 3> Adding complete to H/W Catalog 

Tree

(2) External device settings

Setup as below using SIEMTIC S7 Ladder Software STEP 7. Please reboot the external device after finish downloading configuration 

data.

Please refer to the User's Manual of external devices for more detailed settings.

■ Creating a Project

1. Create a new project in [New Project] at upper bar of main menu of [SIMETIC Manager].

2. Select menu [Insert] > [Station] > [1 SIMETIC 400 Station] or [2 SIMETIC 300 Station]. → Add CPU

■ PLC Program/Software Configuration for transmitting PACKETs : Retrieve “315-2DP.zip” file and copy Block

3. [SIMETIC Manager] Main Menu Tool bar [File] - Select [Retrieve] to open “315-2DP.zip” file.

Overwrite by copy(Keyboard Shortcut :Ctrl + C) and paste (Keyboard Shortcut:Ctrl + V) 6 Blocks of "315-2dp_090924” projects that 

are retrieved to currently working project. 

<Fig. 1> System/Group/Function/Data Block Copy

■ GSD File Install

4. Double click added “[SIMETIC 400(1)]” or [SIMETIC 300(1)] CPU > Relevant CPU [Hardware] ( New [HW Config] window appears.

5. Select Tool bar [Options] - [Install GSD File…] of [HW Config] window menu. (A New [Install GSD Files] window will be appeared.) 

Click [Browse…] from [Install GSD Files] window, select the path of “M2I_1811.GSD”, click [Install] button to start installing. 이 후의 

Click [YES] button when message window pops up to go to next progress, and click [OK] when “Installation was completed 

successfully.” message window pops up, click [OK] button to finish installing.

Continue on the next page.
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<Fig. 4> DP port on CPU unit

<Fig. 5> PROFIBUS Module

Contents setting Descriptions

Address 2 PROFIBUS MASTER Node address

Contents setting Descriptions

Transmission Rate 1.5Mbps Possible to change

Profile DP Fixed

■ PROFIBUS DP Master activation : SIMETIC S7 Series

6. Register modules that are desired to use on current Rack which are installed in the Slot location such as "Power Unit" or etc. to 

[HW Config] window by Dragging & Dropping.

7. Double click slot where the PROFIBIS Port is registered. ("Properties" register/setting window will appear.)

8. ON “Properties” window [General] Tap [Interface] Box, 

click [Properties…] Button (“Properties - PROFIBUS interface” 

window will appear.)

9. Set as below on [Parameter] Tap of “Properties - 

PROFIBUS interface” window.

10. Click [New…] button of "Subnet" Box.

(“Properties-PROFIBUS” window will appear.) 

Click [OK] button when PROFIBUS Subnet information 

registration is complete to save the setting information, 

move to <Fig. 4> or <Fig. 5>.
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11. <Fig. 4> or <Fig. 5> “Properties” window - Set "DP Master" from [Operating Mode] 

Tap.

12. Save the setting information and complete activation process of PROFIBUS DP Master by 

clicking [OK] button.

■ PROFIBUS DP Slave Activation : XTOP Series

<Fig. 8> On PROFIBUS Network, TOP(DP Slave) Information Registration Table

13. From [HW Config] window, register “Anybus CompactCom DPV1(FW 2.x)” that is previously saved to <Fig. 3> H/W Catalogue 

Tree “PROFIBUS DP - Additional Field Devices - General to “PROFIBUS:DP master system” network image by Dragging & Dropping.

14. Double click the registered “Anybus CompactCom 

DPV1(FW 2.x)” image. 

(“Properties - Slave” window will appear.) 

: Set PROFIBUS Slave Node Address on related window. 

When input is complete, click [OK] button to save the 

setting. 

<Fig.7> Properties – Operating Mode

<Fig. 9> PROFIBUS Slave Node Address Setting
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Continue on the next page.
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❶

❷

❸ <Fig. 3> Register the “Universal module” information on H/W Catalogue Tree by Drag & Drop.

<Fig. 10> Universal module Registration Process

Contents Settings Descriptions

I/O Type Out-input Fixed

INPUT Address*주1) 0 [OB1] “FB200”의 “IN0” input detail what registered on <Fig.1>

Length 32 Fixed

Unit Byte Fixed

Consistent over Total length Fixed

OUTPUT Address*주1) 0 [OB1] “FB200”의 “IN1” input detail what registered on <Fig.1>

Length 32 Fixed

Unit Byte Fixed

Consistent over Total length Fixed

15. Register the Universal module information on already saved “Anybus CompactCom DPV1(FW 2.x)” Slave Node.

16. Set as below by double clicking slot where “Universal module” is registered.

<Fig. 11> Properties - Slave I/O Type Setting

* Caution1) If change the Input/Output Address to other value 

than "0", Set the [OB1]'s “IN0/IN1” exactly same.

17. Compile by selecting [Station] > [Save and Compile], and 

download setup details into PLC.
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■ External device settings

Set options of communication driver for “PROFIBUS DP Slave Device”

Details Contents

TOP Note Number -TOP Node Number : Input PROFIBUS DP Slave Node Address which is given to TOP.

No. Contents Comment

❶ Operating Mode Off Not Connected/No Power

Green Connected 

(Data is transmitting)

Green 

Light 

Blinking

Connected (Normal)

Red 

Blinking

Error Status

❷ Situation Off No Power/No reset

Green Reset

Green 

Light 

Blinking

Reset, In Test

Red Error Status

❸
PROFIBUS 

Connecter

D-SUB 9 PIN (Female)

4. Communication settings details
Communication settings are available at XDesignerPlus or TOP main menu. Communication settings must be identical with the 

external devices.

4.1 XDesignerPlus settings details

Select [Project > Project attributes] to show the below window.

■ External device settings

4.2 ABCC-DPV1 (PROFIBUS Option Module) by M2I

You can use it by installing “ABCC-CCL” module in the Field Bus Option Slot of TOP main device. (Basic Serial Port COM1/2 not 

usable)

 ■ ABCC-DPV1(PROFIBUS Option Module) Specification
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ABCC-DPV1(PROFIBUS Option Module)

Cable Connection

“PROFIBUS DP Master Device”

pin arangement 

* caution 1)

Name of 

Signal

Pin 

Number

Pin 

Number

Name of 

Signal

pin arangement 

* caution 1)

Front View of 

D-SUB 9 Pin 

male

(Male, convex)

– 1 1 –

Front View of 

D-SUB 9 Pin 

male 

(Male, convex)

– 2 2 –

 RxD/TxD+
3 3

+RxD/TxD

– 4 4 –

GND 5 5 GND

– 6 6 –

– 7 7 –

RxD/TxD– 8 8 –RxD/TxD

– 9 9 –

5. Cable diagram 
This Chapter is to introduce the Cable diagram for regular communication between TOP and relative devices. (The Cable diagram 

which are going to be introduced in this chapter might be different than what "SIEMENS AG." recommends.)

5.1 Cable diagram 1

■ XTOP + ABCC-DPV1(PROFIBUS Option Module)

*Caution1) Pin arrangement is shown from connecting face in cable connection connecter.
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Bit address Word address 32 bits Remark

Input Relay

* caution1)

I00000.0 –

I00127.7

E00000.0 –

E00127.7

IW00000 –

IW00126

EW00000 –

EW00126

H/L

*Caution3)Caution4)

—

Output Relay

* caution2)

Q00000.0 

–

Q00127.7

A00000.0 –

A00127.7

QW00000 –

QW00126

AW00000 –

AW00126

—

Data Block DB00001 : DBX00000 –

DB65535 : DBX65533.7

DB00001 : DBW00000 –

DB65535 : DBW65532

—

Internal 

Memory

M00000.0 – M00511.7 MW00000 – MW00510 —

6. Support address
Devices that are usable with TOP is as below. 

There might be difference in the range of device (address) by type / series of CPU module TOP series supports the maximum 

address range that external device series use Please refer each CPU module user manual carefully for devices that you desired to use 

to prevent not getting out of range.

*Caution1) Input Device (I,IW) might not be able to input read on the address of IW0 ~ IW2 because depends on the type of CPU, it 
becomes subordinate in the integrated I/O. Please refer to the PLC Manual.
*Caution2) Output Device (Q, QW, QD) can write value only in the Run Mode. Output value will be reset if it's STOP Mode.
*Caution 4) Regarding on Word device, 32 but Data will be saved in the order of from High / Low, 16 bit each.
(Example) VW00000 (32bit data, 0x12345678) è VW00000(16bit, 0x1234) VW00002(16bit, 0x5678)
*Caution4) Checks "Word Swap" function when 32BIT address is being used.


