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Supported version TOP Design Studio V1.4 or higher {Rl
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1. System configuration

The system configuration of TOP and “Giddings&Lewis Motion Control Inc. —Digital MMC Controller” is as follows:

Communication
CPU Link I/F System setting Cable
method

3. TOP communication

o Ethernet setting ) .
MMC Digital MMC ENET Port on MMC . Twisted pair cable*Note 1)
(UDP) 4. External device
setting

*Note 1) Twisted pair cable

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a
direct cable.

B Connectable configuration
+ 1:1 connection (one TOP and one external device) connection

] [UINE -

— | HUB '

+ 1:N connection (one TOP and multiple external devices) connection

D m‘: M*E ......... M*T

| HUB |—
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [Ethernet]
Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor
Vendor
KDT Systems &

RS Automation

FATEK Automation Corporation
DST ROBOT

BACnet

SEMI Organization
EMOTIONTEK

FUII Electric Co., Ltd.

OPTICON

Giddings & Lewis Motion Control

DELTA TAU Data Systems

KEYENCE Corporation

CFYON Terhnolnay %
4_Back | B Next *® Cancel
Select Device [ = |
PLC Setting[ MMC Series ]
Alizs Mame @ |PLCL BindIP: lAuto v
Interface : Ethernet ~
Protocol @ | Ethernet ~

Comm Manual

String Save Mode : |First LH HL Change

[ use Redundancy

AND ~
Condition Edi
Primary Option
jid ‘192 :Hles :HU :H1 :‘ 2
Ethernet Protocol
Timeout msec
Send Wait msec
HMI Station
MMC Station
OID CheckSum 0 - b
@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.

Choose “Giddings & Lewis Motion Control".

PLC Select the external device to be connected to the TOP.

Interface Protocol

MMC Series Ethernet Ethernet

Please check the system configuration in Chapter 1 to see if the external device you want to
connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Ethernet]

— Set the TOP communication interface in TOP Design Studio.

Project Option X
- Change HMI[H] ' Add PLC[A) | THITW Change PLCicl | 5] Delete PLCID)
%m Date / Time Sync. | Screen Option | Unit Convert
e -2ﬁ;_”|;";d”‘é)sem”9 Project Option  Screen Change = HmiSetup | Global Lock & Touch  Project Style  Splash | PLC Buffer Sync.
= RFD (0) Use HMI Setup
v 'fj’fivieozit?gf = Initialization | Edit |
5% COMZ (D) Project Setting ~
g% COM3 (0) HMIDisable=0
v g Ethernet (1) Project Name=New project
-8 PLC1 : MMC Series Start Mode=Menu
-~ Wireless {0) f?t;icsr::g Ne.=1
-4 USBDevice (0) Latch Set=0~0
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
3 . -
System Devices {@ Ethernet %
-Port
— =] Ethernet Port :{ ETH1 =~ 0 v
i l 7 - Link Speed : Auto -
PLLC Security Dat &/Time M4C Address @ 00:00:00:00:00:00
IP Address :|  192.168.0.100
Subnet Mask :  255,255.255.0
. Gateway :| 192 . 166.0.1
[ o
il cEme T/ 1 Default Gatevay
Ethernet Serial HOM I DNS (1) ¢
DNS (2) i
. -Ethernet
- % Prinary IP : 192.168.0.100 -~
L _A . Ping
—_— . Cable Status ¢
Diagnost ic File Ping
Manager Bridge Mode : O lse Bridae
Check duplicate | Apply || Cancel
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.50
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR, 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting

M [ Project > Project Property > PLC Settings > ETHERNET > “PLC1 : MMC Series”]
— Set the options of the Digital MMC Controller Ethernet communication driver in TOP Design Studio.

TO,
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Project Option

~ ] TOFP Setting
| L[ 5Y5:RD1520%
#8 Option Module Setting
- FieldBus (0)
.8 RFID (0)
Device Setting
5% COM1 (0)
£5® COM2 (0)
£5% COM3 (0)
—
[EEEAU
USBDevice {0)

-Change HMI[H] 'Add PLC[A] | THITWl Change PLCIC]

[ Delete PLCID)

PLC Setting[ MMC Series ]

Alizs Name : [PLC1 Bind IP :
Interface : |Ethernet ~
Protocol : |Ethernet ~

String Save Mode : (First LH HL Change

[] use Redundancy

Primary Option

Ak

P |192

Ak

Ethernet Protocol DI

Timeout
Send Wait
Retry g

HMI Station

MMC Station

Import Address

Comm Manual

0OID CheckSum i} -
Apply Close
Items Settings Remarks
Interface Select “Ethernet”. Refer to “2. External
Protocol Select “Ethernet”. device selection”.
IP Enter the IP address of the external device.

Ethernet Protocol

Select the Ethernet protocol between the TOP and an external device.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.

HMI Station Enter the TOP prefix number.
MMC Station Enter the external device prefix number.
MMC Port Enter the Ethernet communication port number of the external device.

OID CheckSum

Required information for communication between external device and TOP.

The *.oid file is automatically entered when imported.

Fixed

XThe Digital MMC Ethernet communication driver imports and creates the *.oid file exported by the Digital MMC program.

For a detailed explanation, please reference [5. Supported addresses].
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3.2. Communication setting in TOP
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* This is a setting method when "Use HMI Setup” in the setting items in "3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting
B [Main Screen > Control Panel > Ethernet]

¥YNC
Yiewer

Scrééh‘"

o
o
@ System
!Inlu Q
PLC S
°
M =
Ethernet
q
Diagnostic
4
[System]

Ethernet:

-Port

Ethernet Port
Link Speed

| ETHI

v

;| Auto

-)Lo :

|
)

MAC Address

00:15:10:00:00: 00

Cable Status
Bridge Mode :

IP Address :| 192.168.0.100 Sound
Subnet Mask :[ 255.255.255.0
Gateway :|  192.168.0.1 —
[ Default Gateway L
DNS (1)
DNS (2) ¢
- Ethernet m

Primary IP : [ 192.168.0.100

]

ETH1 Mot connected
[J Use Bridge

MRAM
Analysis

[Check duplicatel [ App |y 1 Cancel J

TOPRX - TOPRX0800S A  2021-09-01 10:-59:08 AW
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.50
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR 192 . 168 . 0 . 0) should match.

*Note 2) Do not use duplicate IP addresses over the same network.

* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.

(2) Communication option setting
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M [Main Screen > Control Panel > PLC]

s

D 3 — PLC
@ System| Driver(ETH) | PLCI(MYC Series) |-/
tun Interface | Ethernet v A
”' . Protocol | Ethernet |~
‘ e 4 Bind IP [Auto ]
P 19215 (1s818] (0 5] (50 15
¥NC
Yiever ﬁ q Ethernet LDP |~
==y i Port 1025 |5
Ethernet
Timeout 300 3] msec
i Send Wait 0 [2]msec
Bl .. ==
Diagnostic HMI Stati il
MMC Stat i = ~| /
[Sycten] [ Diagnostic H’ing Test] [ Apply ”Cancel ]

TOPRX - TOPRX0800S

| I

2021-09-01 10:59:38 AM

Items Settings Remarks

Interface Select "Ethernet”. Refer to "2. External
Protocol Select "Ethernet”. device selection”.
IP Enter the IP address of the external device.

Ethernet Protocol

Select the Ethernet protocol between the TOP and an external device.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.

HMI Station Enter the TOP prefix number.
MMC Station Enter the external device prefix number.
MMC Port Enter the Ethernet communication port number of the external device.

OID CheckSum

Required information for communication between external device and TOP.

The *.oid file is automatically entered when imported.

Fixed

XThe Digital MMC Ethernet communication driver imports and creates the *.oid file exported by the Digital MMC program.

For a detailed explanation, please reference [5. Supported addresses].
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3.3 Communication diagnostics
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B Check the interface setting status between the TOP and an external device.

- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.

- Check if the ETH port settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not

- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

OK

Communication setting normal

Time Out Error

Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix OK NG ) )
Other detailed settings oK NG 4. External device setting
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Set using Digital MMC Software "PicPro" for communication setup. For detailed setup instructions, see the User's Manual in the
Digital MMC Controller. When setup is complete, download the settings with the appropriate equipment.

A Do not use duplicate IP addresses over the same network.
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5. Supported addresses

TOP Giddings&Lewis Digital MMC Controller Ethernet communication driver imports and creates the MMC's *.oid file.

Step 1. [ Project > Project Property > PLC Settings > ETHERNET > “PLC1 : MMC Series > Import Address” ]

v ] TOP Setting

{3 SYS : TOPRWO700W FLC e ERS S

Vv -\ Device Setting Alias Name : [PLC1 | B Auto
= . - ==
. Import Addres:
5% COM2 (0) po! ress
v 2 Protocol : |Ethernet v Comm Manual
String Save Mode : [First LH HL Change
[[] use Redundancy
ate AND v
T R s A
Out v

Primary Option
¢ 52 & [ @] o & [» &
Ethernet Protocol @
g | Port [1025 &
| Timeout 300 2| msec
Send Wait [o—:| msec
Retry 5 =
HMI Station 0 =
MMC Station 0 =
OID CheckSum 0 B

Step 2.Click “Import File” and choose *.oid file, then click “Check Validate" to import used object information from MMC.

- = - -
83 [mpert MMC Address * _—*- Fae Al:-ﬂg
| monie || ||| e
Data Type ALL hd
l Select/ Unselect I I Delete Error Data I I Delete l I Check Validate I
Name Data Type Comment |~
[] ADD_FR_LENGTH EOOL Address 926 =
[l ADD_RE_LENGTH BOOL Address:928
[ ALARM(D) EOOL Address: 1027
[T ALARM(1) BOOL Address: 1028
[ ALARM(10) EOOL Address: 1037
[T] ALARM(11) EOOL Address: 1038
[ ALARM(12) BOOL Address: 1039
[T] ALARM(12) EOOL Address: 1040
[T ALARM(14) BOOL Address 1041
[ ALARM(15) EOOL Address: 1042
[T ALARM(16) BOOL Address: 1043
[ ALARM(1T) EOOL Address: 1044
[T ALARM(18) BOOL Address: 1045
[ ALARM(19) BOOL Address: 1046
[T] ALARM(2) EOOL Address: 1029
[T ALARM(20) BOOL Address: 1047
[T] ALARMI21) EOOL Address: 1048
[ ALARM(22) BOOL Address: 1049
[ ALARM(23) EOOL Address: 1050
[T ALARM(24) BOOL Address 1051
[ ALARM(25) EOOL Address: 1052
[T] ALARM(26) EOOL Address: 1063
[T ALARM(2T) BOOL Address: 1054
[T] ALARM(28) EOOL Address: 1065
[T ALARM(29) BOOL Address: 1056
[ ALARM(Z) EOOL Address: 1030
[ ALARM(30) BOOL Address: 1057
[T ALARM(21) EOOL Address: 1058 2
I ||
|
=
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X TOP Giddings&Lewis Digital MMC Ethernet communication driver supported data types are as follows.

Numeric Size Bitwise Size Time Size
SINT 1 Byte BOOL 1 Byte TIME 4 Byte
INT 2 Byte BYTE 1 Byte

DINT 4 Byte WORD 2 Byte

USINT 1 Byte DWORD 4 Byte

UINT 2 Byte

UDINT 4 Byte

REAL 4 Byte
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