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1. System configuration

The system configuration of TOP and “TOSHIBA Computer Link" is as follows:

. Communication Communication
NEES .
method setting
RS-232C
T2E
RS-422 3.TOP.
T Series N RS-232C communication
RS-422 setting 5.1. Cable table
T3/T3H RS-422 4. External device
RS-232C setting
V Series S2T/S2E
RS-422

W Connection configuration

+ 1:1 (one TOP and one external device) connection

=

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422/485 communication.

) (] S—

_
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM1]

Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor
SANGII Precision Co., Ltd. L

DEVA

OPTICON

TOHMICHL

Giddings & Lewis Motion Control
DELTA TAU Data Systems
KEYENCE Corporation

Digital Electronics Corparation
HONEYWELL

MISUMI

PARKER HANMIFIN Corporation

TOSHIBA

ATLAS COPCO
TOSHIRA MACHTNE Co.. |t %
4_Back | B Next *® Cancel
Select Device [ = |
PLC Setting[ T/V Series ]
Alizs Mame @ |PLCL
Interface : | Serial ~
Protocol : | TOSHIBA Computer Link pr ~ Comm Manual

String Save Mode : |First LH HL Change

[ use Redundancy

AND ~
Primary Option
Timeout msec
Send Wait msec
Station Num DI
Series
@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “Toshiba".
PLC Select an external device to connect to TOP.
Interface Protocol
TOSHIBA Computer Link Serial TOSHIBA
Computer Link protocol
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option

-Change HMIH | | Add PLC ) STal Change PLCIT

E3 Delete D)

Unit Convert

HmiSetup

Global Lock & Touch

Splash  PLC Buffer Sync.

Initialization | Edit |

Project Style

TOP Settiny -
I —mmmln . cl Date { Time Sync. | Screen Option
* - Option Module Setting Project Option  Screen Change
-4 FieldBus (0)
-4 RFID (0} se HMI Setup
v -igg Device Setting
< e CoML (1) eiagau
- PLC1: TV Series [1] Project Setting
-~ COM2 (0) HMIDisable=0
- gl COM3 (0) Project Mame=New project
-4 Ethernet (0) Start Mode=Menu
-~ Wireless (0) f?t;icsr:ig te-=1
- USBDevice (0) Latch Set=0~0
Communication Error Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1

~

Control Panel

Svstem m Devices

— —
|l (3

FLC Security Date /Tim
] o 22 | ==
Et hernet Serial HOM |
=
e ‘\Pinn

Diagnost ic File Ping

Manager

o Serial

Serial Port:

Signal Level

(® R3-232C O Rs-422(4) O R5-485(2)

Baud Rate:
Data Bit:
Stop Bit:

Parity Bit:

Flow:

Auto Search

>

COMA -
9600 <
g -
1 w
0dd -
0ff

Loopback Test
Apply Cancel

Items TOP External device Remarks
Signal Level (port) RS-232C
RS422
Baud Rate 9600
Data Bit 8
Stop Bit 1
Parity Bit Odd

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > “PLC1 : TOSHIBA Computer Link"]
— Set the options of the TOSHIBA Computer Link communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' AddPLC[A] | THTM) Change PLCIC | [] Delete PLCID]

~ ] TOFP Setting o -
: PLC Setting[ T/V Series
L[ sYs:RD1520% 9L v/ ]
Option Module Setting Alias Name : |PLC1
& FieldBus (0) Interface : | Serial s
- RFID (0)
v & Device Setting Protocol : | TOSHIBA Computer Link pr ~ Comm Manual
M L String Save Mode : [First LH HL Changs
-4l PLC1: TV Series [1]
[] use Redundancy
8 Ethernet (0) AND w
™ Wireless (0) TimeOut 5 -
.4 USBDevice (0) T . i
Conditior Edi
Primary Option
Timeout m msec
Send Wait msec
Retry 5 z
Apply Close
Items Settings Remarks
Interface Select "Computer Link". Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device. device selection”.

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

sending the next command request.

Set the waiting time between TOP’s receiving a response from an external device and

Station No Enter the prefix of an external device.

Series Select T,V Series. (Device address change)
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3.2. Communication setting in TOP

* This is a setting method when "Use HMI Setup” in the setting items in "3.1 TOP Design Studio” is not checked.

M Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conikrel Panel

Serial

Serial Port: lCDhﬂ "

Signal Level
@ RS-Z32C (O RS-422(4) () RS-485(2)

|

PLC Security ]

Baud Rate: l 9600 "l

[,rl..] . Data Bit: |8 N
TN -

Et hernet Serial Stop Bit: l : ‘v]

Parity Bit: | Odd N

Flow: lUff ‘v]

)

Diagnost ic File
Manager

[Auto Searchl [Loopback Test]

_ Apply | Cancel |

[System]

| |

Items TOP | External device Remarks
Signal Level (port) RS-232C
RS-485
Baud Rate 9600
Data Bit 8
Stop Bit 1
Parity Bit Odd

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

B [Main Screen > Control Panel > PLC]

-‘6 70 PILLG
€D svstel oriver(com)  [PLCICTAV Series) -|
fun —— | Interface | Serial R
m Protocol | TOSHIBA Computer Li v/
‘ FLC Timeout 300 5| msec
YN send Wait 0 [ msec
Yiewer [.;"-lll‘l‘] Bl 1 E
. = _— Station b =
: g Series T Ser|~]
screen m
shot
Diagnost ic
[System] [ Diagnostic [ Aop |y ” Cancel ]’

Items Settings Remarks

Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.

Station No Enter the prefix of an external device.

Series Select T,V Series. (Device address change)
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch "Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Set as below using T Series and V Series Software "T-PDS32". For more detailed setting method than that described in this example,
please refer to the PLC user manual.
*Programmer port of RS232C is fixed at [Baud Rate:9600bps, Data Bits:8, Stop Bits:1, Parity:odd].

- RS485 device setting

En'j_

£ 1 Sule

1. From the menu tab, go to [PLC]-> Click [System Parameter]
2. Click [Communication Parameter] at the bottom of [System Parameter]
3. Configure Station No at [ComputerLink Setup], and click [Communication Parameter]

4. From the [Communication Parameter] window, configure to the desired settings.

*If the V Series Model T-PDS32 is not supported, refer to the PLC manual for details on configuration.
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of "Toshiba")

5.1. Cable table

m RS-232C (1:1 connection)

TOP PLC
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement*Note 1)
1 5 Ccb 1 1 CD 5 1
© © RD 2 2 RD © ©
e J i ————— e

Based on bTR 4 T— 4 DTR Based on
communication 3G > l_ > 3G communication
cable connector DSR 6 6 DSR cable connector

front, RTS ’ [ ! RTS front,
D-SUB 9 Pin male | CTS 8 8 €T | D-SUB 9 Pin male
(male, convex) 9 9 (male, convex)
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
TOP PLC
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement*Note 1)
1 5 CD 1 1 8
(@ Q) RD 2 5 XD -
g g SD 3 RTS 3 1%

Based on DTR 4 | ! SG Based on
communication >6 > communication
cable connector DSR 6 T 12 RXD cable connector

front, RTS 7 front,

D-SUB 9 Pin male CTS 8 14 Crs D-SUB 9 Pin female

(male, convex) 9 (female, convex)
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
W RS-422 (1:1 connection)

TOP PLC
Pin Signal Pin Cable connection i
Signal name

arrangement*Note 1) name number

1 5 RDA 1 TXA

Q 2 3 RXA m [

6 9 l_

Based on RDB 4 TERM RXA |:|_
communication G > j RXB L]
cable connector SDA 6 - 5G g [

front, ’ % = D
D-SUB 9 Pin male 8
(male, convex) SDB 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

6.1 T Series
Description Device Bit Address Word Address 32 bits Remarks
Input XwW 000000 ~ 00511F 00000 ~ 00511
Output YW 000000 ~ 00511F 00000 ~ 00511
Auxiliary Relay RW 000000 ~ 00999F 00000 ~ 00999
Special Relay SW 000000 ~ 00255F 00000 ~ 00255
Link Relay Lw 000000 ~ 00255F 00000 ~ 00255
Timer Register T - 00000 ~ 00999
Timer Device T 00000 ~ 00999 - L/HT
Counter Register @ - 00000 ~ 00511
Counter Device C. 00000 ~ 00511 -
Link Register Relay z 000000 ~ 00999F -
Data Register D 00000.0 ~ 08191.15 00000 ~ 08191
Link Register W 00000.0 ~ 02047.15 00000 ~ 02047
File Register F 00000.0 ~ 32767.15 00000 ~ 32767
6.2 V Series
Description Device Bit Address Word Address 32 bits Remarks
| Variable W 000000 ~ 08191F 00000 ~ 08191
Q Variable Qw 000000 ~ 08191F 00000 ~ 08191
System SW 000000 ~ 00511F 00000 ~ 00511 L
Data DW 00000.0 ~ 04095.15 00000 ~ 04095
Data RW 000000 ~ 04095F 00000 ~ 04095
User Register F 00000.0 ~ 32767.15 00000 ~ 32767

*Note 1) The lower 16 BIT data of 32 BIT data is saved in the address whose screen has been registered, and the upper 16 BIT data
is saved in the address next to the address whose screen has been registered.
Ex. When saving 32BIT data hexadecimal data 12345678 in address D00100, it is saved to 16BIT device address as follows:

Items 32BIT 16BIT
Address D00100 D00100 D00101
Input data
. 12345678 5678 1234
(hexadecimal)
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