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1. System configuration

The system configuration of TOP and “ODVA —Ethernet/IP Explicit Messaging Driver” is as follows:

. . Communication Communication
Series CPU Link I/F .
method setting
Ethernet/IP | Explicit 3. TOP ) .
o Ethernet port on the External - Twisted pair
Explicit message . TCP communication
. Device - Cable™ete D
Messaging server- setting

*Note 1) Twisted pair cable
- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.
- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a

direct cable.

W Connectable configuration
+ 1:1 connection (one TOP and one external device) connection

] TE

HUB |

+ 1:N connection (one TOP and multiple external devices) connection

mﬁ' W*T ......... M.—'

HUB —
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [Ethernet]
Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor
ROOTECH L

IDEC Corporation
LENZE

BECKHOFF Automation
FASTECH Co., Ltd.
HYOSUNG

HB TECH

DNP

FANUC Co., Ltd.
BOOSTER

Robots and Design

CoDeSys Automation Alliance

Coonex Cornoration

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ Etherlet/IP Explicit Messaging ]

Alizs Mame @ |PLCL BindIP: lAuto v

Interface : |Ethernet ~

Protocol : |Ethernet/IP Explidt Messai Comm Manual
String Save Mode : |First LH HL Change

[] use Redundancy
AND -

Primary Option
i (92 3| (18 E] o B[ &
Ethernet Protocal Tcp
Part e =
Timeout msec

Send Wait msec
Explicit Request Type ucMM ~

@ Back « OK M Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "ODVA'".
PLC Select the external device to be connected to the TOP.
Interface Protocol
Ethernet/IP Ethernet Ethernet/IP
Explicit Messaging Explicit Messaging

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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TO, (|

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [ Project > Project Property > TOP Setting ] — [ Project Options > “"Use HMI Setup” Check > Edit > Ethernet ]
— Set the TOP communication interface in TOP Design Studio.

Project Option s
- Change HMI[H] . Add PLC[A) | TRITM Change Picicl | [ Delete PLCID)
%mx Date / Time Sync.  Screen Option Unit Convert
he -225;_”|:;d“‘(fnfﬁtﬁ”g Project Option | Screen Change  HmiSetup | Global Lock & Touch | Project Style  Splash || PLC Buffer Sync.
- RFID (0) Use HMI Setup
M "’,[::VEZ;?TS)Q P e tr GOt Initialization | Edit |
% com2(0) Project Setting -~
8% COM3 () HMIDisable=0
v . Ememetsl) ] Zl;;{etﬁ:daarla;;iw project
|| Sseeneet
@ USBDevice (0) Latch Set=0n0
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
. fwl Ethernet X
System Devices
-Port
Ethernet Port @ ETHI - 0 -
1l l 7 - Link Speed : Auto -
MAC Address @ 00:00:00:00:00:00
FLC Security DatesTime
IP Address :|  192.168.0.100
Subnet Mask :  255.255.255.0
Gateway :| 192, 168.0.1
o o - Default Gateway
i |2 - =
DNS (1) 1
Et hernet Zerial HOM | ONS (2) |
— -Ethernet
= % Prinary IP : 192,168.0.100 -~
L_‘] o Ping Cable Status :
Diagnost ic File Ping ; 0 :
e Bridae Hode @ [1lse Bridae _
Check duplicate | Apply | Cancel
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR, 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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TOP

(2) Communication option setting
M [ Project > Project Property > PLC Settings > ETHERNET > "PLC1 : Ethernet/IP Explicit Messaging” ]

— Set the options of the Ethernet/IP Explicit Messaging communication driver in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

Project Option

- Change HMI[H]

W Acd PLC Al Tl Change PLCIC)

[ Delete PLCID)

~ ] TOFP Setting
| L[ 5Y5:RD1520%

Option Module Setting
B FieldBus (0)

PLC Setting[ EtherNet/IP Explicit Messaging ]

4§ USBDevice (0)

Alizs Name : [PLC1 | BndP:[aute
Interface : |Ethernet ~
Protocol : |Ethernet/TP Explicit Messal
String Save Mode : (First LH HL Change
[] use Redundancy
H AND ~
TimeO c, -
e 5 s
Conditior Edi

Primary Option

P [2 | 68 B0 FH [ F
Ethernet Protocol TCP

Port 44318 z

Timeout

UCMM w

Send Wait

Explicit Request Type

Import Address

Comm Manual

Apply Close
Items Settings Remarks
Interface Select “Ethernet”. Refer to "2. External
Protocol Select “Ethernet/IP Explicit Messaging"”. device selection”.
IP Enter the IP address of the external device.
Ethernet Protocol Select the Ethernet protocol between the TOP and an external device. Fixed
Port Enter the Ethernet communication port number of an external device. Fixed
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.
Explicit Request Type | Set Explicit Messaging communication connection type.
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3.2. Communication setting in TOP
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* This is a setting method when "Use HMI Setup” in the setting items in "3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

B [ Main Screen > Control Panel > Ethernet ]

Run

YHC
Yiewer

Screen
shot

Ethernet
@ Swvstem rPort
Ethernet Port | ETHI |~-||0 |+
n ! Link Speed :| Auto M j‘»
n MAC Address © 00:15:10:05:38:C5
PLE 5 IP Address :[  192.168.0.100 Sound
Subnet Mask :[  255.255.255.0
= Gateway | 192 .168.0.1 o —
i = @ Defau |t Gateway ~
Ethernet DNS (1) ¢
| DNS (2) ] _
m Tl - Ethernet m
L Primary IP : [ 192.168.0,100 v]
Diagnost ic MRAM
Cable Status :  ETHI Connected | [Amal¥sis
Bridge Mode : [ Use Bridge
[System] lCheck dup | icate] [ A |y ] Cancel ]

Dption

o |

——‘—

Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting
M [ Main Screen > Control Panel > PLC ]

TO,
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Run

YHC
Yiewer

Screen
shot

h

Ethernet

Diagnost ic

[System]

Oriver(ETH)

Interface
Protocal
Bind IP
P
Ethernet
Port
Timeout

send Wait

[ PLCT1(EtherMets/ IP Explicit Messaging) |«

| Ethernet Rd

| Ethernet/ P Explici =

| Auto Bd
AEASEHISRNSE TS
TP _|+]

IR -

1000 |3 msec

msec

Explicit Reauest Ty | LCMM ~

Diagnostic

Ping Test

| Aeply | Cancel |

Items Settings Remarks
Interface Select "Ethernet”. Refer to "2. External
Protocol Select “Ethernet/IP Explicit Messaging”. device selection”.
IP Enter the IP address of the external device.
Ethernet Protocol Select the Ethernet protocol between the TOP and an external device. Fixed
Port Enter the Ethernet communication port number of an external device. Fixed
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device

and sending the next request command request.
Explicit Request Type | Set Explicit Messaging communication connection type. *Note 1)
*Note 1)
UCMM : Unconnected Message Manger
Connected : Class 3
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3.3 Communication diagnostics
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B Check the interface setting status between the TOP and an external device.

- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.

- Check if the ETH port settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not

- Touch “Communication diagnostics” in [Control Panel > PLC ].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

OK

Communication setting normal

Time Out Error

Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix OK NG ) )
Other detailed settings oK NG 4. External device setting
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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TOR =32 I
4. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

H Support Class

Class Name Class | Class Name Class
(Hex) (Hex)
Identity 01 Message Router 02
DeviceNet 03 Assembly 04
Connection 05 Connection Manager 06
Register 07 Discrete Input Point 08
Discrete Output Point 09 Analog Input Point 0A
Analog Output Point 0B Presence Sensing OE
Parameter OF Parameter Group 10
Group 12 Discrete Input Group 1D
Discrete Output Group 1E Discrete Group 1F
Analog Input Group 20 Analog Output Group 21
Analog Group 22 Position Sensor 23
Position Controller Supervisor 24 Position Controller 25
Block Sequencer 26 Command Block 27
Motor Data 28 Control Supervisor 29
AC/DC Drive 2A | Acknowledge Handler 2B
Overload 2C Softstart 2D
Selection 2E S-Device Supervisor 30
S-Analog Sensor 31 S-Analog Actuator 32
S-Single Stage Controller 33 S-Gas Calibration 34
Trip Point 35 File 37
S-Partial Pressure 38 Connection Configuration F3
Port F4 TCP/IP Interface F5
Ethernet Link F6 Vendor defined -
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H Supported data type

Data Type Byte Size Remarks
BOOL 1 Byte *Note 1)
SINT 1 Byte

INT 2 Byte

DINT 4 Byte

REAL 4 Byte

USINT 1 Byte

UINT 2 Byte

UDINT 4 Byte

BYTE 1 Byte

WORD 2 Byte

DWORD 4 Byte

STRING 1 byte per character
SHORT_STRING 1 byte per character,

1 byte length indicator
STRUCT - *Note 2)

*Note 1) 0 : false (off), 1 : true (on)

*Note 2)

Structural types defined in ODVA and external device documents

TO,

ERI2 e B X
Touch Qperation Panel

For STRUCT, use the same structure member type and array size as in ODVA and external device

documents.

Structure definitions must be made in TOP Design Studio.

H Support Service code

Get_Attribute_Single (0xOE)
Set_Attribute_Single (0x10)
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H TOP Design Studio Address Registration Method
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. In TOP Design Studio, run “Import Addresses" in the PLC communication settings.

PLC Setting[ EtherNet/IP Explicit Messaging ]

Missheme:PLCL | EdPiase -

Interface : Ethernet ~

Protocol : | Ethernet/IP Explicit Messa

String Save Mode : |First LHHL Change

[] use Redundancy

Primary Option
P

Ethernet Protocol
Port

Timeout

Send Wait

Explicit Request Type

AND ~

TimeOut IZI

o]
~
“r
=
-4
“r
o]
O
=
“

e vy g ey

Import Address

Comm Manual

Close

ey e g

8 Import ODVA Address

| Import[l) Il

Export

Search

Keyword :

DataType: |ALL

Check Address

Check Address[C]

Delete Error Data(T]

Search(S]

Select / Unselect(L)

AddlA]

Delete[D]

Edit[E]

Structure[s)

Tag Name

Data Type

Description

Totalcount: 0

Search count :

Close
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“ ODVA Import Address Window Function Description

Export : Export the ODVA address currently registered in TOP Design Studio to a CSV file.
Import : Import the exported ODVA address CSV file from TOP Design Studio.

Structure: Defines structure type. ( Same definition as the structure of the external device.)

Add: Add ODVA address.

When adding an address, set and add the Class ID, Instance ID, Attribute ID, and DataType that you

want to use to communicate with the external device.

iog 'mport Address Edit Screen x

MName : |umuuuu |

Comment : | |
Class : Identity P
0x1 = (Hex)
Instance : |U = |
Attribute : [0 3
Data Type : BOOL hd
Use Array
erath 1 :
OK. Cancel
|
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