HYOSUNG
MODBUS Slave
MODBUS-TCP Driver

Supported version  TOP Design Studio V1.0 or higher {Rl

TOP

"
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Operation Panel (M2l TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and
external device”.
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External device connection manual for TOP Design Studio 1/10



TOR =3 I
1. System configuration

This driver is the “Serial Slave Driver” among the “"MODBUS Protocol” of "HYOSUNG".
Depending on the external device (MODBUS Slave Protocol supported), you may set the “command code”, “protocol frame format”

etc., of the driver separately. In this case, set the detailed settings according to the external device side based on the communication
method.
The system configuration with an external device supported by this driver is as follows:

Series CPU Link I/F Communication method System setting Cable

3. TOP communication

Ethernet  (TCP / UDP settin Twisted pair
MODBUS Slave Device ( ) =nd . P
4. External device cable*Note 1)
setting

*Note 1) Twisted pair cable
- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.
- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a

direct cable.

W Connectable configuration
+ 1:1 connection (one TOP and one external device) connection

] [UINE -

— | HUB '

+ 1:N connection (one TOP and multiple external devices) connection

D M‘: m‘_% ......... M*E

| HUB |—
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [Ethernet]
Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor

~
BINAR Elektronic AB HYOSUNG MODBUS Slave

HONEYWELL

ATLAS COPCO
ROOTECH

IDEC Corporation
LENZE

BECKHOFF Automation
FASTECH Co., Ltd.
ODVA

HE TECH

DNP

FANUC Co., Ltd,

RNOSTFR %

4_Back | B Next *® Cancel

Select Device [ = |

PLC Setting[ HYOSUNG MODBUS Slave ]

Alias Name : |PLC1 BindIP: [Auto ~

Interface : |Ethernet ~

Protocol : |MODBUS TCP(Server) ~

[ use Redundancy

4

Primary Option

Ethernet Protocol
HMI Port
[AccessMemoryRange]
e :
[1 Device] ~
[3 Device] ~
[4Device] ~
[Packet Count System Buffer]
ReadPacketCount o = v
4@ Back « OK ® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "HYOSUNG".
PLC Select an external device to connect to TOP.

Interface Protocol

HYOSUNG MODBUS Slave Ethernet Set Users

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Ethernet]

— Set the TOP communication interface in TOP Design Studio.

Project Opticn

-Change HMIH]

“ Add PLC [A] "m Change PLC[C]

/ -3 TOP Setting
520X

[ Delete PLCID)

FLC

Et her net

Security Dat e/ Time

Serial HOM |

i

Diagnost ic

7

Ping

k
File
Manager

Ping

Date / Time Sync. | Screen Option  Unit Convert
v ODﬁE”IZ"BDd“'[ED)‘SEWW Project Option = Screen Change | HmiSetup | Global Lock & Touch = Project Style  Splash  PLC Buffer Sync.
@8 FieldBus
- i [U)
~ -, Device Setti P— | i |
\"fr;\digmel (g)g Hmi Setup Option Initialization Edit
fom coM2(0) Project Setting ~
-~ fg® COM3 (0) HMIDisable =0
v @ Ethernet (1) Project Name=New project
“.4 PLC1: HYOSUNG MODBLE Start Mode =Menu

g Wireless (0) f:g?g:ig =l

- USBDevice {0) Latch Set=0~0
Communication Error Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1

Control Panel
Svstem |l Devices Service (="' Option
fwl Ethernet x
— ool pLieIe
Ethernet Port : - -
1 l {(— [ ETH1 0
Link Speed @ Auto -

MAC Address :

00:00:00:00:00:00

P 4ddress : 192 .168.0.100

Subnet Mask : 205.255.255.0
Gateway @ 192 .168.0.1

[ Default Gateway
DHS (1)
DHS (2]
-Ethernet
Primary I[P+  192.168.0.100 ~

Cable Status @
Bridge Hode

[lUse Bridae

Check duplicate

Apply | Cancel

* The above settings are examples recommended by the company.

Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting
M [Project > Project Property > Device Setting > Ethernet > “PLC1 : HOYSUNG MODBUS Slave”]
— Set the options of the HOYSUNG MODBUS Serial Slave driver in TOP Design Studio.
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Project Option

- Change HMIH]

' Add PLC [A] "m Change PLC[O

~ [} TOP Setting
- 5YS : RD1520%
Option Module Setting
-4 FieldBus (0)
-8 RFID (0)
Device Setting
g% COM1 (0)
1% COM2 (0)
g% COM3 (0)

B PLC1 : HYOSUNG MODBUS
Wireless (0)
----- W USBDevice (0)

e

PLC Setting[ HYOSUNG MODBUS Slave ]

[ Delete PLCID]

Alizs Name : [PLC1

Interface : |Ethernet ~

Protocol : |MODBUS TCP(Server) ~

[ use Redundancy

AND ~
0L :
Primary Option
Ethernet Protocol
HMI Port 502 =
[AccessMemoryRange]
[0 Device] o
[1 Device] e
[3 Device] e
[4 Device] e
[Packet Count System Buffer]
ReadPacketCount
WritePacketCount
[32Bit Swap]

Unuse w

BindIP : |Auto

10233 =
10233 =
10233 =

10233 =

£ >
Apply Close
Items Settings Remarks
Interface Select “Ethernet”.
— Refer to “2. External
Protocol Select the communication protocol between the TOP and an external ; ;
. device selection”.
device.
Ethernet Protocol TCRUDP
LisenPort Port no
AccessMemoryRange
0 Device 0 Device ADDRESS range setting
1 Device 1 Device ADDRESS range setting
3 Device 3 Device ADDRESS range setting
4 Device 4 Device ADDRESS range setting

PacketCountSystemBuffer

ReadPacketCount

ReadPacket Count

WritePacketCount

WritPacket Count

[32BIT SWAP |

Unuse, Use
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[32BIT SWAP] Switching from Unuse to Use activates the following option.

[32Bit Swap]
Use e
32Bit Swap Mode |Litﬂe Endian With byteswapped(2143) |

SwapAddressRange = 10239 =
Swap Address Count

Swap-SysAddr 1

5YS  |0D00O =\

Swap-SysAddr 2

sYS + | 00000 Sl v

- 32 BIT SWAP MODE
Big Endian Format(4 3 2 1)
Big Endian With byte-swapped(3 4 1 2)
Little Endian Format(1 2 3 4)
Little Endian With byte-swapped(2 1 4 3)
Uploads data to the master using the above 4 types, with a default value of Little Endian With
byte-swapped(2 1 4 3).

- SwapAddressRange
The allowed range for swapping systembuffer. Set range to 1-0

to disable.

- SwapAddressCount

Can be selected individually. Choose between 1-9.
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

B [Main Screen > Control Panel > Ethernet]

Run

YNC
Yiewer

Screen
shot

"ﬁ. Ethernet

@ Systen [ 7O Dpt ion
Ethernet Port : ETHI |+][0 |~

]
! Link Seeed :| Auto ~| J’D
L MAC Address : 00:15:10:05:38:C5

PLC 5 IP Address :| 192.168.0.100 Sound
Subnet Mask :[  255.255.255.0
= Gateway | 192 .168.0. 1 —
I = @ Defau |t Gateway ~
Ethernet OMS (1) ;|
DN (2) ¢

- Ethernet m

Primary IP : [192.158.0.100 -]

Diagnost ic

[ ] Y

HRAH

Cable Status : ETHT Connected Analysis
Bridge Mode : [ Use Bridge

[System] lCheck duplicate] [ dop |y ] Cance| l Close K
4—‘

Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.51

Subnet Mask 255.255.255.0 255.255.255.0

Gateway 192.168.0.1 192.168.0.1

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.

* The above settings are examples recommended by the company.

Items

Description

IP Address

Set an IP address to be used by the TOP to use over the network.

Subnet Mask

Enter the subnet mask of the network.

Gateway

Enter the gateway of the network.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (ETH1/ETH2) settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix OK NG ) )
Other detailed settings oK NG 4. External device setting
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)

External device connection manual for TOP Design Studio 8/ 10



TO BRI HE B X
Touch Qperation Panel

4. External device setting

Refer to the user manual of the external device to set "HYOSUNG MODBUS-TCP Slave (Server) Driver” in the external device I/F.

- Do not use duplicate IP addresses over the same network.
A - Check the contents of the address map on the external device side and use the communication

address according to its contents.
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5. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Bit Address Word Address 32 bits Remarks
Coil 00000.00 - 10239.15 00000 — 10239
Discrete Input 00000.00 - 10239.15 00000 — 10239 U *Note 1)
Input Register 00000.00 - 10239.15 00000 — 10239 *Note 1)
Holding Register 00000.00 - 10239.15 00000 — 10239
*Note 1) Cannot be written (Read-only)
Maximum SYSTEM BUFFER is 10239.
B Summary of "HOYSUNG MODBUS Slave Driver” Support Command (Fnction)
Descriptions Code | Descriptions Code | Descriptions Code
Read Coils 01 Diagnostics 08 Write File Record 15
(Unimplemented) (Unimplemented)
Read Discrete Inputs 02 Get Comm Event Counter 0B Mask Write Register 16
(Unimplemented) (Unimplemented)
Read Holding Registers 03 Get Comm Event Log ocC Read/Write Multiple registers 17
(Unimplemented) (Unimplemented)
Read Input Registers 04 Write Multiple Coils OF Read FIFO Queue 18
(Unimplemented)
Write Single Coill 05 Write Multiple registers 10 Encapsulated I/F Transport 2B
(Unimplemented)
Write Single Register 06 Report Slave ID 1
(Unimplemented)
Read Exception Status 07 Read File Record 14
(Unimplemented) (Unimplemented)
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