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SIEMENS AG.

SIMETIC S7 Series

MPI with PC adapter Driver
Compatible version OS Over 4.0

XDesignerPlus Over 4.0.0.0 

CONTENTS
Thank you for using M2I’s "Touch Operation Panel(M2I TOP) Series". 

Please read out this manual and make sure to learn connection 

method and process of TOP – External device”

1. System configuration Page 2

It explains device for connection, setup of, cable and structural 

system.

Please choose proper system referring to this point.

2. Selecting TOP model and 

external devices
 Page 3

Select TOP model and external device..

3. Example of system settings Page 4

It explains setup example for communication connection 

between the device and external terminal. 

Select example according to the system you choose in “1. 

System structure”

4. Communication settings details Page 7

It explains the way of configuring TOP communication. 

If external setup is changed, make sure to have same setup of 

TOP with external device by referring to this chapter.

5. Cable diagram Page 10

Explains cable specifications required for access.

Select proper cable specifications according to the system you 

chose in “1. System configuration”.

6. Support address Page 11

Check available addresses to communicate with external devices 

referring to this chapter.
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Series CPU Link I/F Method System settings Cable

SIMATIC

S7-300

CPU312IFM

CPU313

CPU314

CPU314IFM

CPU315

CPU315-2 DP

CPU316

CPU316-2 DP

CPU318-2

MPI Port +

PC adapter
RS-485 ( 2 wire )

Setting Example 1

( Page 4 )

Cable Diagram 1

( Page 10 )

SIMATIC

S7-400

CPU412-1

CPU412-2 DP

CPU413-1

CPU413-2 DP

CPU414-1

CPU414-2 DP

CPU414-3 DP

CPU416-1

CPU416-2 DP

CPU416-3 DP

CPU417-4

1. System configuration
TOP와 “SIEMENS AG. - System structure of SIMETIC S7 Series MPI with PC adaptor” is as follows.

■ Connection configuration

ㆍ1:1 connection (TOP 1 vs. external device) 
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Setting details Contents

TOP Series

Series Version name

XTOP / HTOP V4.0

Select the name of a TOP series that is to be connected to PLC.

Before downloading the settings, install the OS version specified in the table below according to 

TOP series.

Name Select the model name of TOP product.

External device Manufacturer Select the manufacturer of external devices to be connected to TOP.

Select SIEMENS AG.

PLC Select the model series of external devices to be connected to TOP.

Please choose SIMETIC S7 MPI(With PC Adapter). 

Please check, in the “1. System configuration”, if the relevant external device is available to set a 

2. Selecting TOP model and external devices
Select the external devices to connect to TOP.
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system configuration.
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Details TOP “SIMETIC S7 Series” Remark

Serial level (port/channel) RS-232C (COM2) RS-232C User settings

Address(PLC Address) ─ 1 User settings

Serial baud rate [BPS] 38400 User settings

Serial data bit [Bit] 8 User settings

Serial stop bit [Bit] 1 User settings

Serial parity bit [Bit] ODD User settings

■  [ Project > Project property > Project > Settings > TOP Name ]

Set the communication interface of TOP tool.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

■ External device settings

Setup communication driver of “SIMETIC S7 MPI(With PC Adapter)”.

- PLC Node Number : External Device Setting Number

- The Highest node : Input Highest Node Address.

3. Example of system settings
The setup of communication interface between TOP and SIEMTIC S7 is recommended as below.

3.1 Example of settings 1

The system is set as below.

((1) XDesignerPlus setup

After setting the below details in [Project > Project Settings], download the detailed settings using TOP tool.
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Setup PLC node address lower than “Highest Node Address”. 

Details Contents

Staion number 2

Transmission rate 187500bps

(2) External device settings

Setup as below using SIEMTIC S7 Ladder Software STEP 7. Please refer the PLC user manual for more detailed information if you 

need. 

1. Create a new project in [New Project] at upper bar of main menu of [SIMETIC Manager].

2. Select menu [Insert] > [Station] > [1 SIMETIC 400 Station] or [2 SIMETIC 300 Station]. → Add CPU

3. Double click added “[SIMETIC 400(1)]” or [SIMETIC 300(1)] CPU > Relevant CPU [Hardware] → New [HW Config] window appears.

4. Open “[SIMATIC 400] > [RACK-400]” or “[SIMATIC 300] > [RACK-300]” at left tree window in [HW Config], select Base unit model, 

and register it using Drag & Drop to the right bottom.

5. Select [SIMATIC 400] > [PS-400] or [PS-300] and then appropriate power supply unit, and drag & drop it to the current Rack.

6. Select [SIMATIC 400] > [CPU-400] or [CPU-300] and then appropriate CPU unit and drag& drop it to the current Rack.

(If [Properties] – PROFIBUS interface DP] windows appears, press [Cancel] to finish). 

7. Double click registered CPU name. → A new relevant CPU [Properties] window appears.

8. Select [Interface] > [Properties] at [General] tap in [Properties] to popup [Properties - MPI interface CPU xxx-xxx ] window.

9. Setup MPI port station [Address] and [Transmission rate] as below at [Properties - MPI interface CPU xxx-xxx ] window’s 

[Parameter] tap. (Transmission speed change: Click [Properties] > [Properties] window [Network Settings] tap)

10. Click "OK" to save the setting information until now.
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Details Contents

Connection to COM1 (Serial Port that recognized the PC Adapter in STEP 7 )

Transmission rate 38400

11. Connect PC - PLC after setting DIP Switch of PC adapter as below.

12. STEP 7 From Main Menu [Options] > [Set PG/PC Interface] > [PC Adapter] > set [Local Connection] Tap.

13. Save all the information by clicking "OK" and compile by selecting [Station] > [Save and Compile], and download setup details 

into PLC. (PLC Setup is up to this part.)

14. Please execute the communication check by connecting to TOP with the connecter that is connected to PC.
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■  [ Project > Project property > Project > Settings > TOP Name ]

Set the communication interface of TOP tool.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

- From right window [ HMI Setup > check Use HMI Setup > PLC Setup ] 

■ External device settings

Setup communication driver of “SIMETIC S7 MPI(With PC Adapter)”.

Details Contents

Signal level External device – select serial communication method between TOPs. (COM1 supplies RS-232C 

only)

Baud rate External device – select serial communication speed between TOPs.

Data bit External device – select serial communication data bit between TOPs.

Stop bit External device – select serial communication stop bit between TOPs.

Parity bit External device – select serial communication parity bit check method between TOPs.

Time out [ x100 mSec ] Set up TOP’s waiting time from external device at [0 - 5000] x 1mSec.

Transmitting Delay Time [ x10 

mSec]

Receiving Wait Time [ x10 

Set up TOP’s waiting time between response receiving – next command request transmission from 

external device at [ 0 – 5000 ] x 1 mSec.

4. Communication settings details
Communication settings are available at XDesignerPlus or TOP main menu. Communication settings must be identical with the 

external devices.

4.1 XDesignerPlus settings details

Select [Project > Project property] to show the below window.

■ Communication Interface Settings
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mSec]

PLC address [0~65535] Address of other device. Select between [0 - 65535].
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PLC setup

PLC Address : 01 Communication Interface 

Timeout : 1000 [mSec] Settings

Delay time of transmission : 0 [mSec]

TOP COM 2/1 : RS – 232C , 38400 , 8 , 1 , ODD

 TOP COM 2/1 setup   communication test

Details Contents

PLC address [0~65535] Address of other device. Select between [0 - 65535].

Timeout [ x1 mSec ] Set up TOP’s waiting time from external device at [0 - 5000] x 1mSec.

Delay time of transmission [ 

x1 mSec ]

Set up TOP’s waiting time between response receiving – next command request transmission 

from external device at [ 0 – 5000 ] x 1 mSec.

TOP COM 2/1 TOP’s Interface setup to external device.

Port Settings

* Serial communication COM 1 Port

 + COM-1 Port Communication Interface 

  - Baud rate : 38400 [BPS] Settings

  - Data bit : 8 [BIT]

  - Stop bit : 1 [BIT]

  - Parity Beat : ODD [BIT]

  - Signal level : RS – 232C

 + COM-2 Port COM-2 Port

  - Baud rate : 38400 [BPS] Communication Interface 

  - Data bit : 8 [BIT] Settings

  - Stop bit : 1 [BIT]

  - Parity Beat : ODD [BIT]

  - Signal level : RS – 232C

Details Contents

Baud rate External device – select serial communication speed between TOPs.

Data bit External device – select serial communication data bit between TOPs.

Stop bit External device – select serial communication stop bit between TOPs.

Parity bit External device – select serial communication parity bit check method between TOPs.

Signal level External device – select serial communication method between TOPs.

4.2 TOP main menu setup item

 - When a buzzer is on during the power reset, touch 1 spot at the upper LCD to move to "TOP Management Main" display.

- Set up driver interface at TOP according to below Step1 → Step2.

(Press “TOP COM 2/1 setup” in Step 1 to change setup at Step 2.)

Step 1. [ PLC setup ] - Setup driver interface.

Step 1–Reference.

Step 2. [ PLC setup ] >[ TOP COM2/COM1 setup ] – Setup relevant port’s serial parameter.

Step 2–Reference.
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OK! Communication setting succeeded

Time Out Error! Communication setting error

- Error in the setting situation of Cable and TOP / External device

(reference : Communication Diagnosis sheet)

Designer Version O.S Version

Details Contents Confirm

System 

configuration

Name of CPU
OK NG

Name of confront port that is 

communicating
OK NG

System Connection Method 1:1 1:N N:1 OK NG

Connection 

Cable

Name of Cable
OK NG

PLC setup Setup address OK NG

Serial baud rate                               [BPS] OK NG

Serial data bit                               [BIT] OK NG

Serial Stop bit                               [BIT] OK NG

Serial parity bit                               [BIT] OK NG

Assigned Address Limit OK NG

TOP setup Setup port COM 1 COM 2 OK NG

Name of Driver OK NG

Confront Address Project Property Setup OK NG

Diagnosing Communication OK NG

Serial baud rate                               [BPS] OK NG

Serial data bit                               [BIT] OK NG

Serial Stop bit                               [BIT] OK NG

Serial parity bit                               [BIT] OK NG

4.3 Communication diagnosis

■ TOP - Confirming interface setting condition between external devices 

- Move to Menu by clicking the top side of LCD screen as resetting the power of TOP.

- Confirms if Port [COM 2 or COM 1] setting that is willing to use in [Communication Settings] matches with the setting of external 

devices.

■ Diagnosis of error of communication status

- PLC Setup > TOP [ COM 2 or COM 1 ] click "Communication Diagnosis" button.

- Diagnosis dialog box will pop up on the screen, you can judge by following information that are shown on box no. 3 section.

■ Communication Diagnosis Sheet 

- Please refer to the information below if you have a problem between external devices and communication connection.
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XTOP COM2

Cable Connection

PC Adaptor

pin arangement * 

caution 1)

Name 

of 

Signal

Pin 

Number

Pin 

Number

Name 

of 

Signal

pin arangement * 

caution 1)

Front View of 

D-SUB 9 Pin male 

(Male, convex)

CD 1 1 CD

Front View of 

MINI-DIN 9 Pin

 (female, concave)

RD 2 2 RD

SD 3 3 SD

DTR 4 4 DTR

SG 5 5 SG

DSR 6 6 DSR

RTS 7 7 RTS

CTS 8 8 CTS

9 9

XTOP COM2

Cable Connection

PC Adaptor

pin arangement * 

caution 1)

Name 

of 

Signal

Pin 

Number

Pin 

Number

Name 

of 

Signal

pin arangement * 

caution 1)

Front View of 

D-SUB 15 Pin 

male(Male convex)

CD 1 1 CD

Front View of 

MINI-DIN 9 Pin

 (female, concave)

RD 2 2 RD

SD 3 3 SD

DTR 4 4 DTR

SG 5 5 SG

DSR 6 6 DSR

RTS 7 7 RTS

CTS 8 8 CTS

9 9

XTOP/ATOP COM 1 Port

Cable Connection

PC Adaptor

pin arangement * 

caution 1)

Name 

of 

Signal

Pin 

Number

Pin 

Number

Name 

of 

Signal

pin arangement * 

caution 1)

5. Cable diagram 

5.1 Cable diagram 1

■ 1 : 1 Connection

(A) XTOP COM 2 Port (9 pin)

*Caution1) Pin arrangement is shown from connecting face in cable connection connecter.

(B) XTOP COM 2 Port (15 pin)

*Caution1) Pin arrangement is shown from connecting face in cable connection connecter.

(C) XTOP/ATOP COM 1 Port ( 6 Pin)
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Front View of 

D-SUB 6 Pin male 

(Male, convex)

1 1 CD

Front View of 

MINI-DIN 9 Pin 

 (female, concave)

RD 2 2 RD

SG
3 3

SD

4 4 DTR

5 5 SG

SD 6 6 DSR

7 RTS

8 CTS

9

*Caution1) Pin arrangement is shown from connecting face in cable connection connecter.
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Bit address Word address 32 bits Remark

Input Relay

* caution1)

I00000.0 –

I00127.7

E00000.0 –

E00127.7

IW00000 –

IW00126

EW00000 –

EW00126

H/L

*caution4caution5)

—

Output Relay

* caution2)

Q00000.0 

–

Q00127.7

A00000.0 –

A00127.7

QW00000 –

QW00126

AW00000 –

AW00126

—

Data Block DB00001 : DBX00000 –

DB65535 : DBX65533.7

DB00001 : DBW00000 –

DB65535 : DBW65532

—

Internal Memory M00000.0 – M00511.7 MW00000 – MW00510 —

Timer*caution3) — T00000 – T00255 Not 

writable

Counter*caution3) — C00000 – 

C00255

Z00000 – 

Z00255

Not 

writable

6. Support address
Devices that are usable with TOP is as below. 

There might be difference in the range of device (address) by type / series of CPU module TOP series supports the maximum 

address range that external device series use Please refer each CPU module user manual carefully for devices that you desired to use 

to prevent not getting out of range.

*Caution1) Input Device (I,IW) might not be able to input read on the address of IW0 ~ IW2 because depends on the type of CPU, it 

becomes subordinate in the integrated I/O. Please refer to the PLC Manual.

*Caution2) Output Device (Q, QW, QD) can write value only in the Run Mode. Output value will be reset if it's STOP Mode.

*Caution3) Device Restricted to Read only

*Caution 4) Regarding on Word device, 32 but Data will be saved in the order of from High / Low, 16 bit each.

(Example) VW00000 (32bit data, 0x12345678) è VW00000(16bit, 0x1234) VW00002(16bit, 0x5678)

*Caution5) Checks "Word Swap" function when 32BIT address is being used.


