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MITSUBISHI Electric Corporation 

MELSEC FX Series  

Ethernet Driver 

MC Protocol 1E 
 Supported version TOP Design Studio V1.3.0 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 10 

 Describes how to set up communication for external devices. 

5. Supported addresses Page 15 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSEC FX Series Ethernet (MC Protocol 1E)” is as follows: 

 

Series CPU Link I/F 
Communication 

method 

Communication 

setting 
Cable 

MELSEC-F 
FX3U 

FX3UC 
FX3U-ENET-L 

Ethernet 

(TCP/UDP) 

3. TOP communication 

setting 

4. External device 

setting 

Twisted pair cable*Note 1) 

*Note 1) Twisted pair cable 

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 

 

■ Connectable configuration 

ㆍ1:1 connection (one TOP and one external device) connection 
 

                      

 

 

ㆍ1:N (one TOP and multiple external devices) connection 
 

                          ∙∙∙    
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 
 

 
 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device. 

Please select “MITSUBISHI Electric Corporation”. 

Model Select external device. 
 

Model Interface Protocol 

MELSEC FX Series Ethernet Set Users 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 

Supported Protocol 

MC Protocol 1E Binary MC Protocol 1E ASCII 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project Property > TOP Setting ] → [ Project Options > “Use HMI Setup” Check > Edit > Ethernet ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 

Items TOP External device Remarks 

IP Address 192.168.0.100 192.168.0.50 *Note *Note 2) 

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

* The above settings are examples recommended by the company. 

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 
 

Items Description 

IP Address Set the IP address of the TOP. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Project > Project Property > PLC Settings > ETHERNET > “PLC1 : MELSEC-FX Series”] 

– Set the options of the MELSEC FX Series Ethernet (MC Protocol 1E) communication driver in TOP Design Studio. 
 

 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

HMI Port Enter the Ethernet communication port number of the TOP.  

PC No Enter the prefix of PLC. *Note 1) 

*Note 1) The PLC number identifies which PLC to connect to on the CC-Link IE controller network, CC-Link IE field network, and MELSECNET/H, 

MELSECNET/10 network. The initial value is 255 (dec) and is 255 or in the range of 0 to 64 when configuring a multi-CPU.
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3.2. Communication setting in TOP  

* This is a setting method when "Use HMI Setup" in the setting items in "3.1 TOP Design Studio" is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main Screen > Control Panel > Ethernet ]  
 

 

 

Items TOP External device Remarks 

IP Address 192.168.0.100 192.168.0.50 *Note *Note 2) 

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

* The above settings are examples recommended by the company. 

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 
 

Items Description 

IP Address Set the IP address of the TOP. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Main Screen > Control Panel > PLC ] 
 

 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

HMI Port Enter the Ethernet communication port number of the TOP.  

PC No Enter the prefix of PLC. *Note 1) 

*Note 1) The PLC number identifies which PLC to connect to on the CC-Link IE controller network, CC-Link IE field network, and MELSECNET/H, 

MELSECNET/10 network. The initial value is 255 (dec) and is 255 or in the range of 0 to 64 when configuring a multi-CPU. 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the port (ETH1/ETH2) settings you want to use in [Control Panel > Ethernet] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

For a more detailed setting method than described in this example, refer to the corresponding vendor’s user manual for the external 

device. 

 

⑴ Setting in GX Developer 

※ FX3U-ENET-L Configuration Tool must be installed. 
 

Step 1. [Tools] → [FX special function utility] → [FX3U-ENET-L Congifuration Tool] 
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Step 2. [Operational settings] 
 

 
 

 

 

Items Contents Set Value Remarks 

Communication 

data code 
Select protocol data type. Binary code 

Select the same protocol 

item at TOP. 

Initial timing 
Set time when communication is 

available. 

Always wait for OPEN 

(Communications possible at 

STOP time) 

Necessary setting 

IP Address Set PLC IP address. 192.168.0.50  

Send frame settings Set frame type. Ethernet(V2.0) Necessary setting 

TCP Existence 

confirmation setting 

Set how TCP protocol communication 

checks connections with other devices. 
Use the Ping  
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Step 3. [Open settings] 
 

 

 

① Set as TCP 
 

 
 

 ② Set as UDP 
 

 

  

PLC 

Port 

number 

PLC 

Port 

number 

TOP 

IP Address 

TOP 

Port 

number 
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⑵ Set in GX Works2 
 

Step 1. [Parameter] → [PLC Parameter] → [Ethernet Port] 
 

 
 

Items Contents Set Value Remarks 

Communication 

data code 
Select protocol data type. Binary code 

Select the same protocol 

item at TOP. 

IP Address Set PLC IP address. 192.168.0.50  

Subnet Mask Pattern Set subnet mask. 255.255.255.0  

Default Router IP 

Address 
Set router IP address. 192.168.0.1  

 

Step 2. [Open Setting] 
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① Set as TCP 

 
 

Items Contents Set Value Remarks 

Protocol Set ethernet protocol. TCP 
Select the same protocol 

item at TOP. 

Open System Set open method. MC Protocol Necessary setting 

Host Station Port No. Set PLC port number. 5000  
 

 ② Set as UDP 

 
 

Items Contents Set Value Remarks 

Protocol Set ethernet protocol. UDP 
Select the same protocol 

item at TOP. 

Open System Set open method. MC Protocol Necessary setting 

Host Station Port No. Set PLC port number. 5000  

Destination 

IP Address 
Set the IP address of the TOP. 192.168.0.100  

Destination Port No. Enter TOP port number. 1025  

 

  

PLC 

Port number 

PLC 

Port number 

TOP 

IP Address 

TOP 

Port 

number 
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 
 

Device Bit Address Word Address Remarks 

Input Relay X000 ~ X377 X000 ~ X360 Input data (hexadecimal) 

Output Relay Y000 ~ Y377 Y000 ~ Y360 Input data (hexadecimal) 

Auxiliary Relay 
M0000 ~ M7679 M0000 ~ M7664  

M8000 ~ M8511 M8000 ~ M8496  

Timer  
Current Value  TN000 ~ TN511  

Contact TS000 ~ TS511 TN000 ~ TN496  

Counter 
Current Value 

 CN000 ~ CN199  

 HCN200 ~ HCN255 32 Bit address 

Contact CS000 ~ CS255 CS000 ~ CS240  

State S0000~S4095 S0000~S4080  

Data Register D0000.0 ~ D8511.F D0000 ~ D8511  

Extended Register R00000.0~R32767.F R00000~R32767  

 


