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SIEMENS AG. 

SIMETIC S7-300/400 Series 

Serial Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

CONTENTS 

We want to thank our customers who use the Touch Operation Panel. 

 

1. System configuration Page 2 

 Describes connectable devices and network configurations. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 10 

 Describes how to set up communication for external devices. 

5. Cable table Page 13 

 Describe the cable specifications required for connection. 

6. Supported addresses Page 14 

 Refer to this section to check the data addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “SIEMENS AG. – S7-300/400 Series RK512” is as follows: 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

SIMETIC 

S7-300 

CPU312 IFM 

CPU313 

CPU314  

CPU314 IFM  

CPU315  

CPU315(F)-2 DP  

CPU315(F)-2 PN/DP  

CPU316  

CPU316-2 DP  

CPU317-2 DP 

CPU317F-2 

CPU318-2  

CPU317-2 PN/DP  

CPU319-3 PN/DP 

CPU614 

CPU388 

CP341 RS-232C 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table 

CP341 
RS-422 ( 4 wire ) 

/ RS-485 

SIMETIC 

S7-400 

CPU412-1 

CPU412-2 DP 

CPU413-1 

CPU413-2 DP 

CPU414-1 

CPU414-2 DP 

CPU414-3 DP 

CPU416-1 

CPU416-2 DP 

CPU416-3 DP 

CPU417-4 

CPU414-3PN/DP  

CPU416-3PN/DP 

CPU417 

CPU486 

CP441-2 

RS-232C 

RS-422 ( 4 wire ) 

/ RS-485 

 

■  Connection configuration 

ㆍ1:1 connection  
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “SIEMENS AG.” 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

S7-300/400 Series Computer Link RK512 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project Property > TOP Setting ] → [ HMI Setup > “Use HMI Setup” Check > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 

 

 

 

 

 

Items TOP External device Remarks 

Signal Level RS-232C  

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit Even  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Project > Project Property > Device Settings > COM > “PLC1 : S7-300/400 Series”] 

– Set the options of the S7-300/400 Series RK512 communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Computer link”. Refer to “2. External 

device selection”. Protocol Select “RK512”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Retry Configure the amount of redelivery attempts from TOP to external device.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main Screen > Control Panel > Serial ]  
 

 

Items TOP External device Remarks 

Signal Level RS-232C  

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit Even  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Main Screen > Control Panel > PLC ]  
 

  

 

Items Settings Remarks 

Interface Select “Computer link”. Refer to “2. External 

device selection”. Protocol Select “RK512”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Retry Configure the amount of redelivery attempts from TOP to external device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial port setting Baud Rate OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial port setting Baud Rate OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  OK NG 6. Supported addresses 
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4. External device setting 
 

For more detailed setting method than that described in this example, refer to the PLC user manual. 

Set as below using SIEMTIC S7 Ladder Software. 
  

Step 1. Create a new project with [New Project] in the top bar of the main menu of [SIMATIC Manager]. 

 

Step 2. Choose Menu [Insert] > [Station] > [1 SIMATIC 400 Station] or [2 SIMATIC 300 Station]. ➔ CPU add 

 

Step 3. Double-click the added "[SIMATIC 400(1)]" or [SIMATIC 300(1)] CPU > Double-click [Hardware] on that CPU.. ➔ [HW 

Config] window newly appears 

 

Step 4. In the left tree panel of the [HW Config] window, open "[SIMATIC 400] > [RACK-400]" or "[SIMATIC 300] > [RACK-300]" to 

select the Base unit model that you use and register by dragging & dropping it to the bottom right of the window. 

 

Step 5. Select [SIMATIC 400] > [PS-400] or [PS-300] to select the power unit used to drag & drop on the current rack. 

 

Step 6. Select [SIMATIC 400] > [CPU-400] or [CPU-300] to select the CPU unit, then drag & drop on the current rack. (If the 

Properties – PROFIBUS interface DP window is new, press the [Cancel] key to exit the window.) 
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Step 7. Double-click on the registered CPU Name. ➔A new [Properties] window for that CPU appears.. 

 

 

Step 8. On the [General] tab of the [Properties] window, select [Interface] > [Properties] to launch the [Properties – protocol] pop-

up window. 

 

 

Step 9. Double-click the [Protocol] box in the middle of the screen to enter the [RK512] protocol detailed settings as shown below. 

 

 

Step 10. In the Project Tree of the [SIMATIC Manager] window, select Registered CPU Name from [HW Config], select [Blocks], and 

double-click [OB1]. (If the [Properties] window pops up, click [ok].)➔ Run Ladder software [LAD/STL/FBD] 
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Step 11. Set parameters in Ladder software [LAD/STL/FBD]. Set one of the examples below according to [Language for Selected 

Blocks] > [STL] or [LAD]. 

[Language for selected Blocks] > [STL] [Language for selected Blocks] > [LAD] 

 

 

(Example) [Libraries] > [CP 341] > [FB7 P_RCV_RK CP341] 

CALL“P_RCV_RK” , DB7 

EN_R 

R 

LADDR 

DB_NO 

DBB_NO 

L_TYP 

L_NO 

L_OFFSET 

L_CF_BYT 

L_CF_BIT 

NDR 

ERROR 

LEN 

STATUS 

:=TRUE 

:=FALSE 

:=256 

:= 

:= 

:= 

:= 

:= 

:= 

:= 

:= 

:= 

:= 

:= 

 

Items Contents 

DB7 The DB number that P_RCV_RK will use to receive communication 

EN_R “EN-R” must be ON to communicate. 

R Reset input 

LADDR Input Start Address Number confirmed in order 12. 

DB_NO Input DB you will use. Only the areas you assign can be read and written through communication. 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “SIEMENS AG.”) 
 

■ RS-232C 

TOP 

 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

    

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 RD 

SD 3 3 SD 

    

SG 5 5 SG 

    

    

    

    

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 

TOP 

 

External device 

Pin arrangement*Note 1) 
Signal 

name 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

+   

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

-   

SG 3 TRX+ 

 

  

5 SG 

  

  

8 TRX– 

  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Bit address Word address Double word address*Note 1)Note 2) R/W Remarks 

Input relay I00000.0 – I16383.7 IW00000 – IW16382 ID00000 – ID16382 R/W 
Cannot be 

written 

Output relay Q00000.0 – Q16383.7 QW00000 – QW16382 QD00000 – QD16382 R/W 
Cannot be 

written 

Data block 
DB00001.DBX00000.0 –

DB00255.DBX00511.7 

DB00001.DBW00000 –

DB00255.DBW00510 

DB00001.DBD00000 –

DB00254.DBD00510 
R/W  

Internal 

memory 
M00000.0 – M08191.7 MW00000 – MW08190 MD00000 – MD08190 R/W 

Cannot be 

written 

Timer T00000.0 – T00255.15 T00000 – T00255 T00000 – T00254 R  

Counter C00000.0 – C00255.15 C00000 – C00255 C00000 – C00254 R  

*Note 1) 32 bits of data are stored in 16 bits in the order of high/low for word addresses. 

(Example) MW00000 (32bit data, 0x12345678) ➔ MW00000(16bit, 0x1234) MW00002(16bit, 0x5678) 

*Note 2) For 32 bit address, style → notation form →check “word swap” function. 

 

 


