AtlasCopco
MT FOCUS Driver

TOP

J

Supported version ~ TOP Design Studio V4.0 or higher {Rl

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

‘ Describes how to set the TOP communication.
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Describes how to set up communication for external devices.
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Check for addresses that can communicate with an external
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1. System configuration

The following driver is “MT FOCUS" of "ATLASCOPCO".
The system configuration with an external device supported by this driver is as follows:

Series CPU Link I/F Communication method System setting Cable

MT FOCUS RS-232C 3. TOP communication setting 5. Cable table

W Connection configuration

+ 1:1 (one TOP and one external device) connection
k[].]

__
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM2]
Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor Model

< Ci ~
FILSEERET & POWER FOCUS
TOSHIBA MACHINE Co., Ltd P
° &% wmrocus

GREEN POWER

ROOTECH

CKD Corparation
CSCAM

IDEC Corporation
HAWE HYDRAULIK
SEHAN Electools
TOHO Electronics Inc.
IAI Corporation

MKP

TEMCOLINE Co., Ltd.

| TNMOT

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ MT FOCUS ]

Alizs Mame @ |PLCL

Interface : | Computer Link ~

Protocol : | MT Focus 400 Link ~ Comm Manual

[ use Redundancy
AND v

Primary Option

@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “AtlasCopco”.
PLC Select an external device to connect to TOP.

Interface Protocol

MT FOCUS Computer Link MT Focus 400 Link

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option X

- Change HMI[H] ' Add PLC[A) | SIMll Change PLCic) | [ Delete PLEID]

I TOP Sett I
v 3 = ."g o5 Date / Time Sync. | Screen Option | Unit Convert

* - Option Modble Setting Project Option = Screen Change = HmiSetup  Global Lock & Touch  Project Style  Splash  PLC Buffer Sync.
H W FieldBus (0)
8 RFID (0) Use HMI Setup I_l
Vv i Device Settin
- ) A P .
% COM1 (0) Initialization Edit
W CoM2 (1) Project Setting ~
- PLC1: MT FOCUS HMIDisable=0
g COM3 (0) Project Name=New project
- Ethernet (0) Start g‘cdﬁ:eng .
- UsBDevice (0) =T
Latch Set=0~0
Communication Error Message =0
USBErrorMessage=0
e 4

Control Panel

System Devices @Service _;"".'Dption

. Serial *
| - |
Serial Port:  COMZ2 <
FLLC Security Dat e/Time

Signal Level
® PS-232C () RsS-42204) () RS-485(2)

' Baud Rate: 39R00
] oo =

L]

Data Bit: & -
Et hernet Serial HOM | Stop Bit: i -
I Parity Bit: MNone v
: % Flow: [(ff
L_ | ‘\F‘inn ]
: : —— : Auto Search Loopback Test
Diagnost ic File FPing
Manager
Apply Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 9600
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > "PLC1: POWER FOCUS"]

TOP ooz e
Touch Qperation Panel

— Set the option of AtlasCopco MT FOCUS PLC Series communication driver in TOP Design Studio.

Project Opticn x
B cvanoe Hi W raaPic iy T ChangePLcicl | [T Delete PLCDI
w3 TOP Setting A
"~ SYS : RDOS10S PLC Setting[ MT FOCUS ]
8 Option Module Setting Alias Name :
Interface : | Computer Link ~
Protocol @ |MT Focus 400 Link ~ Comm Manual
[] use Redundancy
i~ Ethernet (0) AND ~
i USBDevice (0) =
Edi
Primary Option
Decimal Place
Apply Close
Items Settings Remarks
Interface Select "Computer Link". Refer to "2. External
Protocol Select “PC Link".

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.

retry

Retry attempt

Decimal Place

Input data decimal place
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Run

YHC
Yiewer

(i

Ethernet

Diagnost ic

Manager

Conikroll Panel

Serial Port: lCUME “'

Siagnal Level
i RS-232C () RS-422(4) ) BS-485(2)

Baud Rate: | 38400

Data Bit: |8

Parity Bit: | None

|

|
Stop Bit: | | ~

|
Flow: l Ofi f ‘

[System] GTOSE r
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None Fixed

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

¥YNC

Yiewer

ERI2 e B X
Touch Qperation Panel

TO, (|

o — PLG

@ System

)

PLC

i

Ethernet

A

o

B |

Diagnost ic

[System]

Driver(COM2) | PLCI(MT FOCUS) -|
Interface | Computer Link R
Protocol | MT Focus 400 Link |+
Decimal F 3
y
Diagnostic

[ Apply “Cancel]

TOPRX - TOPRX0800S A  2021-08-31 03:23:09 PH
Items Settings Remarks
Interface Select “CPU Direct". Refer to “2. External
Protocol Select “CPU Direct”. device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.

retry

Retry attempt

Decimal Place

Input data decimal place
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information oK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG . .
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
oK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

- Refer to the manual of the external device and configure the communication options.
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. ((The cable

diagram described in this section may differ from the recommendations of “AtlasCopco”)

W RS-232C (1:1 connection)

COM PLC
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) | name number number | name | arrangement*Note 1)
@) 1 1
1 5 1 5
0 [e) RD 2 3 SD o) [e)
O [e) SD 3 2 RD O ()

6 9 DTR 4 4 6 9
Based on G 5 5 G Based on
communication cable DSR 6 6 communication cable
connector front, RTS - connector front,
D-SUB 9 Pin male D-SUB 9 Pin male

CTS 8
(male, convex) 9 (male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Bit Address Word Address 16 bits | Remarks
DATE (SYS)0000.00 — (SYS)0002.00 (SYS)0000 — (SYS)0002 *Note 1)
TIME (SYS)0003.00 - (SYS)0005.00 (SYS)0003 — (SYS)0005 UH *Note 1)
PNR Program number (SYS)0006.00 (SYS)0006 *Note 1)
RES Result string (SYS)0100.00 — (SYS)0125.00 (SYS)0100 — (SYS)0125 *Note 1)
result string on errors (SYS)0200.00 — (SYS)0225.00 (SYS)0200 - (SYS)0225 *Note 1)
Torque in step 1-8 - (SYS)07,11,15,19,23,27,31,35 *Note 3)
holds peak torque. - (SYS)0039 *Note 3)
Angle in step 1-8 - (SYS)09,13,17,21,25,29,33,37 *Note 3)
holds total angle. - (SYS)0041 *Note 3)
state (SYS)0043.00 (SYS)0043 Note D
*Note 2)
Received BIT (SYS)0300.00 (SYS)0300
Torque unit (SYS)070
*Note 1) Cannot be written (Read-only)
*Note 2) 1 = error
2 = ok
3 = unscrew
4 = cancel
*Note 3) 32 bit Device
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