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1. System configuration

The system configuration of TOP and “PELCO: CAMERA" is as follows:

‘ Module Link I/F ‘ Communication method System setting ‘

RS-232C .
PELCO: CAMERA - - 3.1 Settings example 1 4.1. Cable table 1
RS-422,485

B Connection configuration
+ 1:1 connection (one MASTER and one TOP) connection

L
+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422/485 communication.

{J moj | ;'3«] .........
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM2]

Filter : | [all ~ |

@ Model (O Vendor

Vendor Model

~ IS
KOLVER Srl ‘,ﬂ Specira Series

SENGEMUITY

PELCO

FASTECH Co., Ltd.
HYOSUNG

MMEA

AJINEXTEK Co., Ltd.
IEC Standard

CAS

AZD
SEHWA CNM
SHINHAN Electronics
BONGSHIM LOADCELL
FANIIC Ca.. |t Y
M8 Back | W Next *® Cancel
Select Device n

PLC Setting[ EXRS-C1 ]

Alizs Mame : |PLC1

Interface : | Computer Link ~
Protocol : | D-Protocol ~ Comm Manual

String Save Mode @ |First LH HL Change

[J use Redundancy
AND ~
Primary Option
Timeout msec
Send Wait msec
Retry 5 =
4@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.

External device

Vendor Select the vendor of the external device to be connected to TOP.
Select "PELCO".
PLC Select an external device to connect to TOP.

Protocol

Interface

CAMERA Computer Link D-Protocol

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option

- Changs HMIH]

“ AddPLC[A] | THITEl Change PLCIC)

~ [} TOP Setting I

~ - Option Module Setting

Date / Time Sync.

Project Option ~ Screen Change

Screen Option

E3 Delete P

Unit Convert

HmiSetup  Global Lock & Touch  Project Style  Splash

PLC Buffer Sync.

Start Mode=Menu

-4 Ethernet (0)
Start Screen No.=1
- W
9 Wireless (0) Latch Use=0
9 USBDevice (0) Latch Set=0n~0

Communication Error Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1

-4 FieldBus (0)
- RFID (0) Use HMI Setup I_ I
v -igg Device Setti
\T"iVE;MEI [g)g T Initialization Edit
v g8 COM2 (1) Project Setting .
- PLC1: Spectra Series [0] HMIDisable =0
5 COM3 () Project Name =New project

Control Panel
System m[)evices -_naService =% 0Option
s Serial *
S
I l T Serial Port: @ COMZ @
PLLC SECUrity Dat e/Time Shemal Ll
®) R5-232C (O RS-422(4) O RS-485(2)
Baud Rate: 33400 =
.-. e
NI & it:
Data Bit: & ~
Et hernet Serial HOM | )
Stop Bit: |1 -
p— \ Parity Bit: None M
I - % Flow: [ff
h_ el . Ping
Diagnost ic File Fing Auto Search  Loopback Test
Manager
Apply || Cancel
Items TOP External device Remarks
Si | Level t RS-485
ignal Level (port) RS-485
(COM1/COM2)
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit NONE

* The above settings are

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > "PLC1 : PELCO : CAMERA]
Set the options of the communication driver in TOP Design Studio.
m PLC

TO BRI HE B X
Touch Qperation Panel

Driver [PLC1(PELCO)

Interface: [Computer Link v]
Pratocal: [D—Pmtncol v]
TimeOut {ms} 300

Sendiait (ms) 0

Retry 5

Maode 1D 0

Cancel ] [ hpp |y
Items Settings Remarks
Interface Select "Computer Link". Refer to "2.
Protocol Select the communication protocol between the TOP and an external device. External device
selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and
sending the next
command request.
Retry Retry attempts
Node ID Device number
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conikrel Panel

Serial
Run
Serial Port: lCDME "l
Signal Level
‘ ® Rs-232C O RS-422(4) O RS-485(2) l
Baud Rate: | 38400 ~|
YHC
Viewer . SEs Data Bit: |8 ~|
:--. Ethernet Serial Stop Bit: l 1 ‘vl
L] ﬁ . ey,
- Parity Bit: lNOﬂe "l
s | = Flow: | (ff -
il S | N
Diagnost ic File lAuto Searchl [Loopback Testl
Mariager
f ‘ Apply H Cancel l —
[System] Close r
Items TOP External device Remarks
Signal Level (port) RS-485 RS-485
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit none

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

B [Main Screen > Control Panel > PLC]

et

Fo ol PLC
@ Systd Driver(COM2) | PLCI(Spectra Series) ~|
Run ————— | Interface | Computer Link Rd
!ll' | Protocol | D-Protoco| R
‘ PLC Timeout 300 E msec
send Wait 0 |3 msec
YHC
Yiewer [.J-I..‘] Retry E
B M | e 10 N
] Ethernet
4©°]
Emm Al
Screen m
shot
Diagnost ic
[System l Diagnostic l dop |y HCancel l

S —

g N

Items Settings Remarks

Interface Select "Computer Link". Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

SendWait (ms) Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.

Retry Retry attempts

Node ID Device number
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.
(The cable diagram described in this section may differ from the recommendations of “PELCO CAMERA")

m RS-232C (1:1 connection)

TOP External device
Pin Signal Pin Cable connection i
Signal name
arrangement*Note 1) name number
1 5 cD 1
© © RD 2 SD
Q o SD 3 RD
6 9
Based on DTR 4
communication SG 5
cable connector DSR 6
front, RTS 7 SG
D-SUB 9 Pin male CTS 8
(male, convex) 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

W RS-485 (1:1 connection)

TOP External device
Pin Signal Pin Cable connection i
Signal name
arrangement*Note 1) name number
1 5 RDA(+) 1 SDA(+)
© © 2 SDB(-)
Q 9 3 *— RDA(+)
6 9
Based on RDB(-) 4 RDB(-)
communication SG 5 SG
cable connector SDA(+) 6 —*
front, 7
D-SUB 9 Pin male 8
(male, convex) SDB(-) 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

B RS-422 (1:N connection) — Refer to 1:1 connection to connect in the following way.

TOP ) . o External device Cable connection and signal External device
————— Cable connection and signal direction - o -

Signal name Signal name direction Signal name
RDA(+) SDA(+) SDA(+)
RDB(-) SDB(-) SDB(-)
SDA(+) RDA(+) RDA(+)
SDB(-) RDB(-) RDB(-)

SG SG SG

B RS-485 (1:N/N:1 connection) — Refer to 1:1 connection to connect in the following way.

TOP ) . o External device Cable connection and signal External device
———— Cable connection and signal direction - o -

Signal name Signal name direction Signal name
RDA(+) SDA(+) SDA(+)
RDB(-) SDB(-) SDB(-)
SDA(+) [ RDA(+) [ ° RDA(+)
SDB(-) RDB(-) RDB(-)

SG SG SG
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5. Supported addresses
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The devices available in TOP are as follows:
For more details on PELCO CAMERA, refer to the user manual.

Command Bit address range | Word address range ‘ R/W ‘ Device description
STANDARD COMMAND
Uup 0 0 W Camera up
DOWN 0 0 w Camera down
LEFT 0 0 w Camera left
RIGHT 0 0 w Camera right
UPLEFT 0 0 w Camera up,left
UPRIGHT 0 0 w Camera up,right
DOWNLEFT 0 0 w Camera down,left
DOWNRIGHT 0 0 w Camera down,right
ZOOMIN 0 0 w Camera zoomin
ZOOMOUT 0 0 W Camera zoomout
FOCUSFAR 0 0 w Camera focus far
FOCUSNEAR 0 0 w Camera focus near
STOP 0 0 w Camera stop
OPEN 0 0 W Camera open
CLOSE 0 0 w Camera close
ON 0 0 w Camera on
OFF 0 0 w Camera off
PANSPEED 0 0 R/W Camera pan speed
TILTSPEED 0 0 R/W Camera Tilt speed
We recommend using a command that supports the EXTENDED COMMAND (general response)
RUN 0 0 w User command
COMMAND1 0 R/W Create a desired command to use (not used regularly)
COMMAND?2 0 0 R/W Create a desired command to use (not used regularly)
DATA1 0 0 R/W Create a desired value to use (not used regularly)
DATA2 0 0 R/W Create a desired value to use (not used regularly)
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