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YOKOGAWA Electric Corporation 

UT/UP/UM Series 

PC Link Driver 
 Supported version TOP Design Studio V1.4.3.0 or higher  
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We want to thank our customers who use the Touch Operation Panel. 
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1. System configuration 

The system configuration of TOP and “YOKOGAWA Electric Corporation – UT/UP/UM Series Computer Link” is as follows. 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

Temperature 

Controllers 

UT130 

UT150 

UT152 

UT155 

UP150 

Terminal Block  

on the controller 

RS-485 

(2 wire) 

3. TOP communication 

setting 

4.1. External device 

setting 1 

5.1. Cable table 1 

Digital 

Indicating 

Controllers 

UT 321 

UT 351 

UT 420 

UT 450 

UT 520 

UT 551 

UT 750 

US 1000 

UP 351 

UP 550 

UP 750 

UM 331 

UM 351 

UD 310 

UD 320 

UD 351 

Terminal Block  

on the controller 

RS-485 

(2 wire) 

3. TOP communication 

setting 

4.1. External device 

setting 1 

5.2. Cable table 2 

UT2000 

UT2400 

UT2800 

Terminal Block  

on the controller 

RS-422 

(4 wire) 

3. TOP communication 

setting 

4.2. External device 

setting 2 

5.3. Cable table 3 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “YOKOGAWA Electric Corporation”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

UT/UP/UM Series Computer Link PC Link 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 
 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-422 

RS-485 

RS-485 

RS-422 (UT2000) 
 

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit Even  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Project > Project properties > PLC setting > COM > “PLC1 : UT/UP/UM Series”] 

– Set the options of the communication driver of UT/UP/UM Series Computer Link in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select “PC Link”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Station Number Enter the prefix of an external device.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-422 

RS-485 

RS-485 

RS-422 (UT2000) 
 

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit Even  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select “PC Link”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Station Number Enter the prefix of an external device.  

  



 

 External device connection manual for TOP Design Studio 8 / 14 

3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

4.1 External device setting 1 (Temperature Controllers UT100 Series, Digital Indication Controllers) 
  

Use the keys on the front of the controller to set as follows.  

For more detailed setting methods than described in this example, refer to the controller’s user manual. 
 

 
Do not set the same station number between devices on the same unit network. 

 

Step 1. In the [Operating Display] status, press the (SET/ENT) key for more than 3 seconds to move to [Operating Parameter 

Setting Display] screen. 
 

Step 2. Operate (SET/ENT)key to move to [LOC] screen and to set “-1”. 
 

Step 3. Operate (SET/ENT)key to move to [Setup Parameter Setting Display] screen, and then use the (UP/DOWN, SET/ENT) keys to 

substitute the settings below. 
 

Items Settings Settings Remarks 

PSL 0 PC-link communication Fixed 

Adr 1 Station Number  

bPS 9.6 Baud rate : 9600 [BPS]  

PrI Evn Parity bit : Even [BIT]  

StP 1 Stop bit : 1 [BIT]  

dLn 8 Data bit : 8 [BIT]  
 

Step 4. Press the (SET/ENT) key for more than 3 seconds to change to [Operating Display] screen. 
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4.2 External device setting 1 (UT2000 Series) 
 

Set the communication with the dip switch on the controller. 

For more detailed setting methods than described in this example, refer to the controller’s user manual. 
 

 
Do not set the same station number between devices on the same unit network. 

 

Step 1. Turn the Protocol Selection Switch “ON” (PC–link communication). 
 

Step 2. Set the Communication Mode Selection Switch to “2” ( 9600 / 8 / 1 /even). 
 

Step 3. Set the Station No. Switch to “1” ( Station No. 1 ). 
 

Step 4. Reset the power of the product. 

 

※ When the settings are the same as in the above example, set the serial communication parameters of TOP as follows. 

Items TOP UT2000 

Communication speed 9600 bps 9600 bps 

Data Bit 8 bit 8 bit 

Stop Bit 1 bit 1 bit 

Parity Bit Even Even 

Station number 

(communication option) 
–– 1 

 

(Remark) Communication Mode Selection Switch setting table 

Switch number Parity bit 
Communication 

speed 

0 None. 

9600 bps 1 Odd 

2 Even 

3 None. 

4800 bps 4 Odd 

5 Even 

6 None. 

2400 bps 7 Odd 

8 Even 

9 None. 

1200 bps A Odd 

B Even 

C None. 

600 bps D Odd 

E Even 

(Data length: 8 bit / Stop bit: 1 bit) 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this chapter may differ from the recommendations of “YOKOGAWA Electric Corporation”.) 
 

5.1 Cable table 1 (Temperature Controllers) 
 

■ RS-485 (1:1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  RSB(+) 

Terminal block 

 2 RSA(–) 

 3 SG 

RDB 4  

SG 5  

SDA 6  

 7  

 8  

SDB 9  

*Note 1) The pin arrangement is seen from the connecting side of the cable connector. 

 

■ RS-485 (1:1 connection) 

COM 

Cable connection 

External device 

Pin arrangement*Note 1) 
Signal 

name 

Signal 

name 
Pin arrangement 

 

+  RSB(+) 

Terminal block 

- RSA(–) 

SG SG 

 

 

 

 

 

 

 

*Note 1) The pin arrangement is seen from the connecting side of the cable connector. 

 

■ RS-485 1:N connection – Refer to 1:1 connection to connect in the following way. 

TOP 
Cable connection and signal direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA  RSB(+)  RSB(+) 

RDB RSA(–) RSA(–) 

SDA SG SG 

SDB   

SG   
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5.2 Cable table 2 (Digital Indicating Controllers) 
 

■ RS-485 (1:1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDB(+) 

Terminal block 

 2 SDA(–) 

 3 RSB(+) 

RDB 4 RSA(–) 

SG 5 SG 

SDA 6  

 7  

 8  

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 (1:1 connection) 

COM 

Cable connection 

External device 

Pin arrangement*Note 1) 
Signal 

name 

Signal 

name 
Pin arrangement 

 

+  SDB(+) 

Terminal block 

- SDA(–) 

SG RSB(+) 

 

RSA(–) 

SG 

 

 

 

 

*Note 1) The pin arrangement is seen from the connecting side of the cable connector. 

 

■ RS-485 1:N connection – Refer to 1:1 connection to connect in the following way. 

TOP 
Cable connection and signal direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA  SDB(+)  SDA(+) 

RDB SDA(–) SDB(–) 

SDA RSB(+) RDA(+) 

SDB RSA(–) RDB(–) 

SG SG SG 
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5.3 Cable table 3 (UT2000 Series) 
 

■ RS-422 (1:1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDB(+) 

Terminal block 

 2 SDA(–) 

 3 RDB(+) 

RDB 4 RDA(–) 

SG 5 SG 

SDA 6  

 7  

 8  

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 1 : N connection - Refer to 1:1 connection to connect in the following method. 

TOP 
Cable connection and signal direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA 

 

SDB(+)  SDB(+) 

RDB SDA(–) SDA(–) 

SDA RDB(+) RDB(+) 

SDB RDA(–) RDA(–) 

SG SG SG 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

 
The range of available addresses differs depending on the controller model. 

Refer to the detailed materials on the register area attached to the product manual for use. 

 

Device Bit address Word address Remarks 

Internal Relay I0001 – I7072  *Note 1) 

Data Register D0001.00 – D9000.15 D0001 – D9000 *Note 1)*Note 2) 

*Note 1) The address range contains write-only devices and non-usable addresses. Refer to the detailed materials on the register 

area attached to the product manual for use. 

*Note 2) Pay attention to the use of system memory area according to the controller model. 

 


