MITSUBISHI Electric Corporation
MELSEC AnA/AnU Series
CPU Direct Driver

Supported version TOP Design Studio V1.0 or higher {Rl

TOP

"
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We would like to thank our customers for using M2I's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. cable table Page 10

‘ Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSEC AnA/AnU Series CPU Direct” is as follows:

Link I/F Communication method Communication setting
A2A
A3A
A2U
A3U -
3. TOP communication
MELSEC: AU CPU port RS-232C ti 5. Cable tabl
or - settin . Cable table
AnA/AnU A2US P 4g . -
4. External device setting
A2USH
A2U-S1
A2US-S1
A2USH-S1

W Connection configuration

+ 1:1 (one TOP and one external device) connection
k(] .]

_

* Does not support TOPRW products.
* Use TOPR, TOPRX products.
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device [ = |

PLC select [COM2]

Filter - [ [al] ~] Search
@ Model () Vendor

Vendor Model
i A
M2I Corporation & MELSEC Q Series
MITSUBISHI Electric C it
OMRON Industrial Automation
MELSEC AnM/AnS Series

LS Industrial Systems ”,

" MELSEC AnAJAnU Series
MODBUS Organization

& MELSERVO ]2 Series
SIEMEMS AG.

& MELSERVO 13 Series
Rockwell Automation
GE Fanuc Automation & MELSERVO 14 Series
PANASONIC Electric Works & MELSEC FX2N-10/20GM Series
YASKAWA Electric Corporation & MELSEC iQ-F Series
YOKOGAWA Electric Corparation
Schneider Electric Industries
KDT Systems
RS Automation h

4 Eack | B Next ® Cancel

Select Device H

PLC Setting[ MELSEC AnA/AnU Series ]

Alias Name ; |PLC1

Interface : | CPU Direct ~

Protocol : | AnaA CPU ~ Comm Manual
String Save Mode @ |First LH HL Change

[] use Redundancy

Primary Option

Timeout 300 & | msec
send Wait msec
Retry 5 -
@ Back v oK ® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.

Please select “"MITSUBISHI Electric Corporation”.

PLC Select an external device to connect to TOP.

Interface Protocol

MELSEC AnA/AnU Series CPU Direct AnA CPU

Supported Protocol (CPU type)
AnA CPU AnU CPU

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option x
-(hangeHMI[ﬂ] —MGPL([A] TR CrangePLCICl | [ Delete PLCID]
Eg;g%!mmws Date / Time Sync.  Screen Option Unit Convert
v !22"2”‘:;5'”5)5“”9 Project Option | Screen Change | HmiSetup  Global Lock & Touch | Project Style | Splash | PLC Buffer Sync.
. RFD (0)
""v‘-’fi"igielﬂ(’;)g oo Initialization I Edit I
CoM2 (1) Project Setting ~
W PLC1: MELSEC AnAfAnL) HMIDisable=0
: g% COM3 (0) Prcje:tNam_a:Naw project
SES e
Latch Set=0~0
Communication Error Message =0
USBErrarMessage=0
StorageErrorMessage=1
Eat?ba_s_eMessage_zl
Control Panel
System Devices J:na Service =" 0ption
o Serjal X
14 l A~ Serial Port: | COMZ -
PLC Security Date/Time Signal Level
(®) RS-232C O R5-42204) (O A5-485(2)
[.J-I..ll _ Baud Rate: 9600 i
[1] (1] —
% o cEmel ) :
III"" Data Bit: 3 -
Et hernet Serial HOHK | Stop Bit: 1 -
— Parity Bit: 0dd v
— ﬁ Flow: (ff
LA Ping
Diﬂgl'll:lst ic File F‘ing AUtO Search Loopbﬂck Test
Manager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C Fived
ixe
(COM2 port only) (CPU port)
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit Odd Fixed
* The communication interface for Melsec AnA/AnU Series CPU Direct is fixed to the configurations above.
Items Description
Signal Level Select the serial communication method between the TOP and an external device. (Connect to COM2 of TOPR.)
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.

(2) Communication option setting
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M [Project > Project Property > Device Setting > COM2 > "PLCT : MELSEC-AnA/AnU Series"]
— Set the options of the MELSEC AnA/AnU Series CPU Direct communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' AddPLC[A] | THITel Change PLCIC | [ Delete PLCID]

v -3 TOP Setting

PLC Setting[ MELSEC AnA/AnU Series ]

| Comm Manual

[ use Redundancy

4k

Primary Option

Alizs Name  [PLC1 |
. .gmRFD () Interface : | CPU Direct ~
v g Device Setting Protocol : |AnA CPU w
- f® COM1(0) String Save Mode ¢ @ Change

Timeout 300 4| msec

Send Wait msec

Retry g =

CPU Type |A2A,|" A3ZA o

Apply Close
Items Settings Remarks
Interface Select “CPU Direct". Refer to “2. External
Protocol Select "AnA CPU".

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

and sending the next command request.

Set the waiting time between TOP’s receiving a response from an external device

CPU Type Select the CPU type for the external device.
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

B Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the

main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

ConitkrolPanel
o serial

Run = Serial Port: [CUME “'] .
m [ Signal Level
| ® RS-232C O RS-422(4) O RS-485(2) ]
PLC Security Oa Baud Rat [ 9600 ‘ ]
au ate: -
YHC .
. Data Bit: | 8 B
Yiewer [|J-|'l|] f
o o
R L T ] R IR B
[ ] Ethernet Serial . .
1 E Parity Bit: [ 0dd “]
T — il [ 0t f ‘ ]
P —— ow: -
Sc;een m %
t
Sho g q [Auto Search] |L00pback Test‘
Diagnost ic File
Manager
/ | Apply H Cancel ] -
[System] Close r
Items TOP External device Remarks
Signal Level RS-232C RS-232C )
Fixed
(port) (COM2 port only) (CPU port)
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit Odd Fixed

* The communication interface for Melsec AnA/AnU Series CPU Direct is fixed to the configurations above.

Items Description

Signal Level | Select the serial communication method between the TOP and an external device. (Connect to COM2 port of TOPR.)

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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M [Main Screen > Control Panel > PLC]

Run

TO,
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-‘6 il PLC

d

@ System [river(COM2) ‘ PLCT(MELSEC &nAsAnl Series)
Interface | CPU Direct Rd
!ml Protocol _Ané CPU -]
PLC Timeout 300 |3 msec
send Wait msec
T I —
ibormet CPU Type | A2h/ A3A v
Diagnost ic
[System] l DiagnOSt ic

l App |y ]IlCanceI]

Items Settings Remarks
Interface Select “CPU Direct". Refer to “2. External
Protocol Select "AnA CPU". device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a res

ponse from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.

CPU Type

Select the CPU type for the external device.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (COM1/COM?2) settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

The communication interface of MELSEC-AnA/AnU Series CPU Direct is fixed to the target configurations of the following manual

“Communication Interface Settings"”.
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “Mitsubishi Electric Corporation”)

TOP

TOP422C

(e { |

|

A\

Use the exclusive cable “TOP422C” (Sold by M2l Corp.) for connecting TOP and MELSEC-AnA/AnU Series CPU
Direct.

W RS-232C (1:1 connection)

COM2 Cable cross section
Pin Signal Pin Cable connection
Cable color
arrangementNote 1) name number
1 5 CcD 1 Red
Q o SD 3 | Green
6 9 ee
Based on DTR 4 Blue
communication SG > White
cable connector DSR 6 Black TOPA22C
front, RTS 7 .
. 25 pin cable
D-SUB 9 Pin male CTS 8 .
Cable cross section
(male, convex) 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

External device connection manual for TOP Design Studio

10/ 11



TOR =32 I
6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Type Remarks Bit-designated address Word-designated address
Input Bit X0000 — X1FFF X0000 — X1FFO
Output Bit Y0000 — YTFFF Y0000 - YTFFO
STEP relay Bit S0000 - S2047

Special relay Bit FO000 — F2047 FO000 — F2032
LATCH relay Bit L0000 — L8191

Internal relay Bit MO0000 — M8191 MO0000 — M8176
Special relay Bit M9000 - M9255 M9000 — M9240
Timer - Coll Bit TCO00 - TC2047

Timer - Contact Bit TS0000 — TS2047

Timer-Current value Word TNOOO — TN2047
Counter - Coil Bit CC000 - CC1023

Counter - Contact Bit CS000 - CS1023

Counter-Current value Word CNO0O — CN1023
LINK relay Bit BOOOO — B1FFF BOOOO — B1FFF
LINK register Word WO0000.0 - W1FFE.F WO0000 — W1FFF
Data register Word D0000.0 — D8191.15 DO000 - D8191
Special register Word D9000.0 - D9255.15 D9000 - D9255
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