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1. System configuration

The system configuration of TOP and “SHINSUNG E&G Co., Ltd. — MCUL32 Series” is as follows.

) . Communication Communication
Series Link I/F

method setting

3. TOP

communication
MCUL32 PC Comm. Port RS-485 tti 5. Cable tabl
- settin . Cable table
(RJ-11/RJ-12) =l . -

4. External device

setting

W Connectable configuration

+ 1:1 (one TOP and one external device) connection
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM1]

Filter : |[AII] w ‘ Search :
@ Model (O Vendor

Vendor
FANUC Co., Ltd. L

ASI Systems ; ASIC/2 Series

MINEBEA Co., Ltd. ESCO : IGET Rectifier

Azbil Corporation
OKY : DVC
KORO TECHNOLOGY
ILSHINBIO : FD FRONT
ROBOSTAR

SHINSUNG E&G : MCUI

VYRR A S

Ebmpapst

SPEEDTECH : PUI-2000 Series
CoDeSys Automation Alliance

Ophir Optronics Solutions Ltd. JISANG : Rectifier

SERVOMEX ASN : T8H Sensor
Tiger Optics, LLC SNC : Flow Meter

B &R Automation SEORIM : PMC3000

Peripheral Device MEMORY MAP SLAVE

'TPTRTR®

CEES Manloae WILLINGS : MasterK
4 W
& Back | B Next X Cancel
Select Device n
PLC Setting[ SHINSUNG EG : MCUL32 Series ]
Interface : | Serial ~
Protocol : ~ Comm Manual
[ use Redundancy
AND ~
Conditios Edi
Primary Option
Timeout msec ~
Send Wait msec
# Settings for reading of FFU status
Trigger 5Y5 v [oooo0.00 (2|75
Comm. Complete sy - | 00000.01 E ?5
Comm. Error sY5 « |00000.02 : ?5
iimhar Af FFL [an ol e
@ Back + OK * Cancel
Settings Contents
TOP Model Check the display and process of TOP to select the touch model.
External device | Vendor Select the vendor of the external device.

Select "OTHERS Manufacture”.

External device | Select external device.
Select "SHINSUNG E&G: MCUL32 Series".

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.

External device connection manual for TOP Design Studio 3/ 11



3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [ Project > Project properties > TOP settings] — [Project option > Check “Use HMI settings” > Edit > Serial ]

— Set the TOP communication interface in TOP Design Studio.

Project Cption

-Change HMIH]

Option Module Setting
A FieldBus (0)
i W8 RFID (0)
~ g Device Setting
~ 158 COM1 (1)
i L.g PLC1: SHINSUNG E&G : M
W COM2 ()
g8 COM3 (D)
-4 Ethernet (0}
L Wireless (0)
i USEDevice (0)

' AddPLCIAl | TH) Change PLCIC)

Date / Time Sync.
Project Option  Screen Change

Use HMI Setup

Screen Option

HmiSetup

E3 Delete PLCID

Unit Convert

Global Lock & Touch

Splash  PLC Buffer Sync.

Initialization | Edit |

Project Style

Project Setting

HMIDisable =0

Project Name =New project
Start Mode =Menu

Start Screen No, =1

Latch Use=0

Latch Set=0~0
Communication Error Message=0
USBErrorMessage =0
StorageErrorMessage=1
DatabaseMessage=1

-

Control Panel

System m[)evices :uaService ?"'_'Uption

e Serial *
S =
il - .
l Serial Port: | COM1 <
PLLC Securit Oat e/ Time .
! Signal Level
() BS-232C () RS-422(4) (@) RS-485(2)
) Baud Rate: 9800 =
.- 3 B
(] :
Data Bit: |8 M
Et hernet Serial HOK | .
Stop Bit: |1 w7
f Parity Bit: None v
[—Il = % Flow: |G
e ow:
. Ping
Diagnost ic File Fing Auto Search  Loopback Test
Wanager
Apply Cancel
Items TOP External device Remarks
Signal Level (port) RS-485 RS-485
Baud Rate 9600
Data Bit 8
Stop Bit 1
Parity Bit NONE

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Project > Project properties > PLC settings > COM > “PLC1 : SHINSUNG E&G : MCUL32 Series"]
— Set the options of the communication driver of MCUL32 Series in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

Project Option

- Change HMIH]

“ AddPLC[A] | THITal Change PLCIC)

m Delete PLC[D]

TOP Setting

-3 5YS : RD1520%
#8 Option Module Setting
- FieldBus (0)

i L. RFID ()

W - Device Setting

.F"-
g COM3 (0)

-##® Ethernet (0)
Wireless (0)

- PLC1 : SHINSUNG E&G : M

PLC Setting[ SHINSUNG EG : MCUL32 Series ]
Alizs Name : [PLC1 |

Interface : |Serial ~

Protocol : |MCUL32 ~

[ use Redundancy
AND ~

)]
4

Primary Option

Timeout

300 < msec
Send Wait msec
Retry 5 z

MCLL ID

* Settings for reading of FFU status

Trigger

¥

avg «|oo000.00 2T
Comm. Complete avs « |ooo00.01 5 /F5
Comm. Error avs «|oo000.02 57
Mumber of FFU 32 4
v PV W ALST Vosv ¥ mmaAg

FFU Read Data

+ 00100 ElES

5YS

Comm Manual

Apply Close
Items Settings Remarks
Interface Select “Serial". 2. External device
Protocol Select the communication protocol between the TOP and an external device.

selection

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and
sending the next request.

Retry

Configures the number of attempts for communication upon failure.

MCUL ID

Enter the ID of MCUL to be connected.

Setting for FFU status

read

Trigger

Set the address that operates the Read.

Comm. Complete

Set the address that turns ON when communication is normally completed.

Comm. Error

Set the address that turns ON when there is an error in communication.

Number of FFU

Enter the number of FFUs.

PV, ALST, SV, mmAqg

Check FFU data to read status.

FFU Read Data

Set the starting address to save FFU data.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [ Main screen > Control panel > Serial ]

Security

Conitrol

(- i o}

Serial Port

Signal Leve

(O R5-232C O R5-422(4) @ RS-485(2)

Panel

Serial

;| comt
|

Baud Rate: [ 9600 “]
¥HC L
Viewer i B L Data Bit: [ g H
S Stop Bit: | f B
1 ﬁ Et hermet Serial
. Parity Bit: [ Mone H
Amma —
g | = Flow: | (ff =
g;gten m — [ ‘ ]
0 ) g [Auto Search] lLoopback Test]
iagnost ic File
Manager
/
[System] Close r
__-‘
Items TOP External device Remarks
Signal Level (port) RS-485 RS-485
Baud Rate 9600
Data Bit 8
Stop Bit 1
Parity Bit NONE

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Main screen

> Control panel > PLC ]

il

ERI2 e B X
Touch Qperation Panel

=l i

o S0 PLC
@ Systed Driver({COM1) [ PLCTCSHIMSUNG E&G @ MCUL3Z2 Series) v]
Aun Interface | Serial [~]
n. I Protocol | MCUL3Z |-
‘ PLC Timeout 300 |3 msec
e Send Wait msec
Yiewer [IJ-"I:| Fetry
smmy I MCLL 1D =
" ﬁ Ethernet
: a settings for reading of FFU status
Screen m Trigger SYS: 00000, 00:1:16:DEC: R
shat Comm. Complete SYS:00000,01:1:1:DEC: W
Diagnost ic
Comm. Error SYS: 00000, 02:1:1:DEC:
Mumber of FFU |32 lzlv
[System]||  Disenostic |

l App |y ”Cancel]

g BN

Items Settings Remarks
Interface Select “Serial”. 2. External device
Protocol Select the communication protocol between the TOP and an external device. selection
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and
sending the next request.
Retry Configures the number of attempts for communication upon failure.
MCUL ID Enter the ID of MCUL to be connected.
Setting for FFU status read
Trigger Set the address that operates the Read.
Comm. Complete Set the address that turns ON when communication is normally completed.
Comm. Error Set the address that turns ON when there is an error in communication.
Number of FFU Enter the number of FFUs.
PV, ALST, SV, mmAqg Check FFU data to read status.
FFU Read Data Set the starting address to save FFU data.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC ].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Set the equivalent communication settings to that of the TOP by referring to the vendor’s user manual.
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.
(The cable diagram described in this chapter may differ from the recommendations of "SHINSUNG E&G Co., Ltd.")

M RS-485 (1:1 connection)

coM External device
Pin Signal Pin Cable connection Pin Signal
arrangement:note 1) name number number | name
1 5 RDA(+) 1 1
U 2 2
Q S 3 3 +
6 9
RDB(-) 4 4 .
Based on SG 5 5
communication SDA(+) 6 6 Based on
cable connector 7 communication cable
front, 8 connector front,
D-SUB 9 Pin male 9 6 pin male RJ-12
SDB(-)
(male, convex) (Male, convex)
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
W RS-485 (1:1 connection)
coOM External device
. Signal Cable connection Pin Signal
Pin arrangement
name number [ name
+ 1 2
e T
- {;2/

y élsi’""

Based on

o“

SGX

ol |~ |lw(N
1

communication cable
connector front,
6 pin male RJ-12

(Male, convex)

[OEEE,
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6. Operation and processing of data requests

Describes the FFU status read request operation of the MCUL32 Series communication driver, and the processing method of

response data.

The MCUL32 communication driver requests FFU data to the external device (MCUL32) by the bit value of the trigger address.

The trigger address can be set in the communication option setting window.

When the FFU status read trigger bit value is ON, status data is saved as many as the number of FFUs in the order of FFU ID, PV,
AL&ST, SV, pressure (mmAgq) from the address set in FFU Read Data. (Only checked PV, AL&ST, SV, pressure (mmAq) are requested

and processed.)

Ex 1) If FFU Read Data address is set to DO0100, Number of FFU is set to 32, and PV, ALST, SV and mmAq are all checked, the data
is saved as follows.

D00100 : FFU ID 1

D00101: PV value of No.1 FFU

D00102: AL&ST value of No.1 FFU

D00103: SV value of No.1 FFU

D00104: Pressure value (mmAgq) of No.1 FFU

D00105 : FFU ID 2

D00106: PV value of No.2 FFU

D00107: AL&ST value of No.2 FFU

D00108: SV value of No.2 FFU

D00109: Pressure value (mmAgq) of No.2 FFU
D00255 : FFU ID 32

D00256: PV value of No.32 FFU

D00257: AL&ST value of No.32 FFU

D00258: SV value of No.32 FFU

D00259: ressure value (mmAq) of No.32 FFU

Ex 2) If FFU Read Data address is set to D00100, Number of FFU is set to 32, and PV and SV are all checked, the data is saved as
follows.

D00100 : FFU ID 1

D00101: PV value of No.1 FFU

D00102: SV value of No. 1 FFU

D00103 : FFU ID 2

D00104: PV value of No. 2 FFU
D00105: SV value of No. 2 FFU
D00193 : FFU ID 32

D00194: PV value of No. 32 FFU
D00195: SV value of No. 32 FFU
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