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DONGBU ROBOT CO,. LTD 

iM-SIGMA/DTR Series  

Computer Link Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Cable table Page 10 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 11 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “DongBu Robot Co,.Ltd – iM-SIGMA/DTR Series Computer Link” is as follows. 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

iM–SIGMA 

iM–∑2  

iM–∑3  

iM–∑4  

iM–∑5  

iM–∑6  

iM–∑7  

iM–∑8 

Comm Port 

on CPU unit 
RS–232C 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table 

DTR 

DTR2–2210T 

DTR3–2210T 

DTR2–3310T 

DTR3–3310T 

DTR4–3310T 

DTR2–4410T 

DTR3–4410T 

DTR4–4410T 

DTR2–3310S 

DTR3–3310S 

DTR4–3310S 

DTR2–4410S 

DTR3–4410S 

DTR4–4410S 

DTR4–3510S 

DTR2–2210ET 

DTR3–3310ET 

DTR4–4410ET 

DTR3–2205–M 

 

 

■ Connection configuration 

 

ㆍ1:1 (one TOP and one external device) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “Dongbu(DASAROBOT)”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

iM-SIGMA/DTR Series Computer Link Computer Link 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-232C  

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Project > Project properties > PLC settings > COM1 > “PLC1 : iM-SIGMA/DTR Series”] 

– Set the options of the communication driver of DongBu Robot Co,.Ltd – iM-SIGMA/DTR Series Computer Link in TOP 

Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Station Num Enter the prefix of an external device.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-232C  

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select “Computer Link”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Station Num Enter the prefix of an external device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check whether the port (COM1/COM2) settings you want to use are the same as those of the external device in [Control panel > 

Serial]. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

Set as follows using “Operating Loader”. 

For more detailed setting methods than described in this example, refer to the PLC user manual.  
 

■ After selecting [Miscel] item through the path blow, set the “COMM Port” serial parameter settings as follows. 

ㆍ Parameter selecting path 

Screen name iM–Sigma Series  Parameter Editor 

Selection item 1. Program Run  1. Basic  1. Device 

2. Program Edit  2. Advanced  2. Channel 

 3. Parameter Setting  3. Password  3. Amp/Mot 

     4. Gain 

     5. Miscel 
 

ㆍ [Miscel] setting 

Items Settings Remarks 

Option Proface Necessary setting 

Cont ID 0 Station Number 

Baudrate *Note 1) 1 19200 [bps] 

*Note 1) 0 = 9600 bps / 1 = 19200 bps / 2 = 38400 bps / 3 = 57600 bps 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this chapter may differ from the recommendations of “DongBu Robot Co,.Ltd”.) 

 

■ RS-232C (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 CD 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 RD 

SD 3 3 SD 

DTR 4 4 DTR 

SG 5 5 SG 

DSR 6 6 DSR 

RTS 7 7 RTS 

CTS 8 8 CTS 

 9 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

  



 

 External device connection manual for TOP Design Studio 11 / 12 

6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Code Bit Address Word Address Format Remarks 

Input / Output IO 000.0 – 399.7 000 – 398 Address  

Command IO CIO 00.0 – 15.7 ––– Address *Note 2) 

Status STAT 1.0 – 4.7 ––– Channel *Note 3)Note 4) 

Running status RUN 000 – 015 –––  *`Note 5) 

Program No. set PROG ––– 1 – 4 Channel *Note 1)Note 6) 

Error code ERR ––– 1 – 4 Channel *Note 4) 

Speed set SPS ––– 1 – 4 Channel *Note 1) 

Point file No. PFNO ––– PFNO  *Note 6) 

Speed SPD ––– 1:0 – 4:5 Channel : Axis *Note 7) 

Global integer GINT ––– 000 – 255 Address  

Global float GFLT ––– 000 – 255 Address  

Global point  Number + Axis GPNA ––– 0:000 – 6:255 Axis : Point No.  

Global point  Axis + Number GPAN ––– 0:000 – 6:255 Axis : Point No.  

Point file  Number + Axis PFNA ––– 0:000 – 6:999 Axis : Point No. *Note 8) 

Point file  Axis + Number PFAN ––– 0:000 – 6:999 Axis : Point No. *Note 8) 

File move FMOV ––– 1:0:0 – 4:3:99 Channel : Type : File ID *Note 1)Note 9) 

Absolute move AMOV ––– 1:0 – 4:3 Channel : Type *Note 1)Note 9) 

Relative move RMOV ––– 1:0 – 4:3 Channel : Type *Note 1)Note 9) 

Current position CPOS ––– 1:0:0 – 4:2:5 Channel : Type : Axis *Note 10) 

*Note 1) Write-only (data cannot be read) device 

A write-only device cannot be used as a bit or number object (object that executes read). Therefore, to execute writing, set the 

writing operation in [Object properties > Effects and actions tab]. 

*Note 2) The contents of COMMAND IO contact point are as follows. 

Category Bit7 Bit6 Bit5 Bit4 Bit3 Bit2 Bit1 Bit0 

B0 
Select all 

channel 

Select 

channel 1 

Select 

channel 2 

Select 

channel 3 

Select 

channel 4 

Motion 

operation 

Motion 

reset 

Origin 

operation 

B1 
Emergency 

stop 
Stop JogInch JogXY JogSpd JogSpd JogSpd JogSpd 

B2 Not used Error reset JogAxis6+ JogAxis5+ JogAxis4+ JogAxis3+ JogAxis2+ JogAxis1+ 

B3 Not used Not used JogAxis6- JogAxis5- JogAxis4- JogAxis3- JogAxis2- JogAxis1- 

B4 Not used AllSvOn Sv6On Sv5On Sv4On Sv3On Sv2On Sv1On 

B5 Not used AllSvOff Sv6Off Sv5Off Sv4Off Sv3Off Sv2Off Sv1Off 

B6 Not used MpgOn MpgAxis6 MpgAxis5 MpgAxis4 MpgAxis3 MpgAxis2 MpgAxis1 

*Note 3) The corresponding bit information is as follows. 

Bit 7 6 5 4 3 2 1 0 

Contents Servo On CMD Fail ––– 

All 

channels 

With or 

without 

alarm 

Inposition Runnging Org OK 

Current 

channel 

With or 

without 

alarm 

*Note 4) Read-only device( Data cannot be written) 

*Note 5) It displays the operation status for the channel. In this status, the corresponding bit is ON. 

0 Bit 1 Bit 2 Bit 3 Bit 4 Bit 5 Bit 6 Bit 7 Bit 

Channel 1 Servo On Channel 1 Run Channel 1 Orgin Channel 1 Jog Channel 2 Servo On Channel 2 Run Channel 2 Orgin Channel 2 Jog 

8 Bit 9 Bit 10 Bit 11 Bit 12 Bit 13 Bit 14 Bit 15 Bit 

Channel 3 Servo On Channel 3 Run Channel 3 Orgin Channel 1 Jog Channel 4 Servo On Channel 1 Run Channel 4 Orgin Channel 4 Jog 

☞Continued on next page.  
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*Note 6) Writable data range: 00 – 99 

*Note 7) It means motor rotation speed data. When writing, only the channel is valid (ignoring the axis). 

*Note 8) PFNA: Read/Write the axis based on the point file. (Vertical direction of the table, R/W possible without creating a separate point file) 

PFAN: Read/Write the point file based on the axis number. (Horizontal direction of the table, R/W not possible without creating 

a separate point file) 

Axis number Point number 

1 0 1 2 3 4 5 6 …(omit)… 96 97 98 99 

2 0 1 2 3 4 5 6 …(omit)… 96 97 98 99 

3 0 1 2 3 4 5 6 …(omit)… 96 97 98 99 

4 0 1 2 3 4 5 6 …(omit)… 96 97 98 99 

5 0 1 2 3 4 5 6 …(omit)… 96 97 98 99 

6 0 1 2 3 4 5 6 …(omit)… 96 97 98 99 

*Note 9) Move to the designated position (value of DATA1=“GINT231” && value of DATA2=”GINT231”). 

When the movement motion is JOINT or LINEAR, only DATA1 is used, and when the movement motion is ARC or CIRCLE, both 

DATA1 and DATA2 are used. 

– TYPE contents are as follows. 

TYPE Contents 

0 PTP 

1 LINEAR 

2 ARC 

4 CIRCLE 

*Note 10) TYPE contents are as follows. 

TYPE Contents 

0 Encoder pulse 

1 Joint 

2 XY 

 

 


