KEYENCE.
KV KV-700/1000/3000/5000/7000 Series

Computer Link Serial Driver

Supported version TOP Design Studio V4.0 or higher {Rl

TOP

"
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We would like to thank our customers for using M2I's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.

External device connection manual for TOP Design Studio 1/ 1



TO BRI HE B X
Touch Qperation Panel

1. System configuration

The system configuration of TOP and “Keyence KV Series Computer Link” is as follows:

Link I/F Communication method Communication setting
KV-700
KV-1000 series 3. TOP communication
KV Series KV-3000 seri NeoL RS-422 tting 5.1. Cable table 1
- series - settin .1. Cable table
Loader ) NC20L - ) -
KV-5000 series 4. External device setting

KV-7000 series

W Connection configuration

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422 communication.
1]

__ AT T [ilim

—a=
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2. External device selection

W Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM2]
o [ ] e —
@ Model (O Vendor
Vendor Model
~

SAMWONTECH & KU-10/16/24/40
SICK AG. "

' KV-700/1000/3000/5000/7000,/3000
FUJI Electric Co., Ltd.

& Barcode Reader BL Series
SAMGII Precision Co., Ltd,

& KV NANO Series
DEVA
OPTICON

TOHNICHL

Giddings & Lewis Mation Control
DELTA TAU Data Systems
Digital Electronics Corporation
HOMNEYWELL

MISUMI

PARKFR HANNTFTN Cornaration &

M8 Back | W Next *® Cancel

Select Device n

PLC Setting[ KV-700/1000/3000/5000/7000/3000 ]

Alizs Mame @ |PLCL

Interface : | Computer Link ~

Protocol : | KV Mode (Host Link) ~ Comm Manual
String Save Mode : |First LH HL Change

[ use Redundancy
AND v

Primary Option

Timeout 300 &|| msec
Send Wait msec
Retry

Network

@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "KEYENCE > KV-700/1000/3000/5000/7000"
PLC Select an external device to connect to TOP.

Interface Protocol

KEYENCE KV Series Loader Computer Link | Computer Link(KV LINK MODE

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

TO,

ERI2 e B X
Touch Qperation Panel

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option

-Change HMIIE

W AddPLC ) T change PLCIC)

~ [} TOP Setting
H : S
~ 8 Option Module Setting
| FieldBus (0)
-4 RFID (0)
~ -ig Device Setting
fg® COM1 (0}
v g8 COM2 (1)

g COM3 (0)
W Ethernet (0)
&% Wireless (0)

48 USBDevice (0)

.. PLC1 : KV-700/1000/3000|

Date / Time Sync.  Screen Option

Screen Change

Project Option

E3 Delete PLC)

Unit Convert

HmiSetup  Global Lock & Touch Project Style = Splash

Initialization

PLC Buffer Sync.

Project Setting
HMIDisable=0

Project Name =Mew project
Start Mode=Menu

Start Screen Mo, =1

Latch Use=0

Latch Set=0~0
Communication Error Message=0
USBErrorMessage =0
StorageFrrorMessage =1
DatabaseMessage=1

| Edit |
-

Control Panel

Svstem Devices

EDE Service = "_' Option

o Serial
T y(® _
Serial Port: | COMZ o
PLLC Security Dat e/ Time .
Signal Level
() R5-232C (@ RS-422(4) (O RS-485(2)
; Baud Rate: 115200 =
IIIIIII L] L—-—-—-}
(1] :
Data Bit: |8 -
Et hernet Serial HOM |
Stop Bit: 1 =
e Parity Bit: |Even v
= % Flow: [ff
= oW
L_“ . Ping
Diagnost ic File Ping Auto Search | Loopback Test
Manager
App |y Cancel
Items TOP External device Remarks
Signal Level (port) RS-422 RS-422
Baud Rate 115200
Data Bit 8
Stop Bit 1
Parity Bit Even

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > PLC1: Computer Link]

Set the options of the communication driver in TOP Design Studio.

TOP ooz e
Touch Qperation Panel

Project Option

- Change HMIH]

' Add PLC [A] "m Change PLCIC] [ Delete PLCID]

~ [} TOP Setting
| .3 s¥5:RD1520%

B FieldBus (0)
- RFID ()

., Device Setting
-1g% COM1(0)

Option Module Setting

PLC Setting[ Kv-700/1000/3000/5000/7000/8000 ]
Alizs Name : [PLC1 |

Interface : | Computer Link e
Protocol : |KV Mode (Host Link) ~

String Save Mode : |First LH HL Change

P W LR L)

W Ethernet (0)
& Wireless (0)
W USBDevice (0)

PLC1 : KV-700,/1000,3000

J [ use Redundancy

Primary Option
Timeout 200 &1 | msec
Send Wait msec
Retry
Network:

Comm Manual

Apply Close
Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.

Station Num

Enter the Kv mode’s Station Num.

StationNoUse

Determines whether or not the Station Num is going to be used. (0: Disable; 1: Enable)

If the Station Num does not match the plc, the plc does not respond.
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3.2. Communication
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setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conikrel Panel

- ] Serial
@ System G

Serial Port: [CUM1 “'
!hll G Signal Level

FLC
(I

@ R5-232C O RS-422(4) O RS-485(2)
Ethernet Serial

Security

Baud Rate: | 115200

Data Bit: | 8

;

Parity Bit: [ Even

|
|
Stop Bit: | 1 -
|
|

m —E Flow: | (ff -
Disanost i % [Auto Search] lLoopback Test]

Manager

| Apply H Cancel ] —

[System]

o=

el 00
Items TOP External device Remarks
Signal Level (port) RS-422 RS-422
Baud Rate 115200
Data Bit 8
Stop Bit 1
Parity Bit Even

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
B [Main Screen > Control Panel > PLC]

sl
o S| PLE

@ System| Driver(COMZ) ‘ PLC1(KV—?OOHOOO!SOOO!EOOO!?OOO!BOOO)% v]
Run I
Interface | Computer Link R
] Protocol | KY Mode (Host Link)|~
‘ FLC Timeout 300 5] msec
N Send Wait msec
e T I i L=
FE =g 5
Et hernet NEtwork H
Diagnost ic
[System] [ Diagnostic [ App | v HCanceI ]

Items Settings Remarks

Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.

Station Num Enter the Kv mode’s Station Num.

StationNoUse Determines whether or not the Station Num is going to be used. (0: Disable; 1: Enable)

If the Station Num does not match the plc, the plc does not respond.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (COM1/COM2/COM3) settings you want to use in [Control Panel > Serial] are the same as those of the external

device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

OK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

[tems Contents Check Remarks
System How to connect the system oK NG ) )
) ) - 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) OK NG . -
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4.1 KV 5500/5000/3000 series

No additional settings need to be configured for the external device.

4. 2 KV-7000 series

From Extension cassette, configure the operation mode to KV mode (host link), as shown in the figure below.

[E Extension cassette {right}

Extension cassette

T S - -

Interface
Baud rate
Data bit length

Start kit

1 control

EV mode Station Moo

{Port 2)

EV-N11L{RBS5-4Z2ZR/485)
{hoat link)
B5-42ZR /485 (4-wire type)
115200bps
Bbit (%)
1 biti*)
1 bitci*)
Even number (*)
Digakle(*)

O]
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

5.1. Cable table 1

W RS-422 (connection)
(A) TOPR COM Port (9 pin)

CcoOM “HITACHI Series”
Pin Signal Pin Cable connection Pin Signal Pin
arrangementNote 1) name number number name arrangement-Note 1)

1 5 RDA 1 SDB
:
6 9 >

Based on RDB 4 SDA
communication SG >

cable connector SDA 6 RDB
front, 7
D-SUB 9 Pin male 8

(male, convex) SDB 9 RDA

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses

The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Address Word Address Remarks
Data Memory DM0000.00 — DM65534.15 DMO0000 — DM65534
Control Memory CMO0000.00 — CM5999.15 CMO0000 - CM5999
Temporary Memory TM000.00 — TM511.15 TMO000 — TM511
Expansion Data Memory EM00000.00 — EM65534.15 EM00000 — EM65534
File Register — Current Bank FM00000.00 — FM32767.15 FMO00000 - FM32767
Work Memory VM00000.00 — VM59999.15 VMO00000 — VM59999
Link Register W000.00 — W999.15 W000 — W999
Digital Timer TRMO0.00 — TRM7.15 TRMO - TRM7
Index Register Z01 - 712 32bit
Link Register WO0000 — WFFFF
High-Speed Counter Current Value CTHO — CTH1 32bit
High-Speed Counter Comparator CTCO - CTC3 32bit
File Register
— Consecutive Number mode ZF000000 — 2F131071
Input/Output R0O0000 — R99915 R000 — R999
Control Relay CRO000 - CR3915 CROO - CR39
Internal Auxiliary Relay MRO0000 — MR99915 MRO00 - MR999
Latch Relay LRO0000 — LR99915 LROOO - LR999
Link Relay BOOOO — BFFFF
Timer contact TOO0O0 - T511 —
current — TCO00 — TC511 32bit
setting — TS000 — TS511 32bit
Counter contact C000 - C511 —
current — CC000 - CC511 32bit
setting — CS000 — CS511 32bit
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