KEYENCE.

Keyence KV Nano Series

Supported version  TOP Design Studio V1.4 or higher {Rl

TOP

J

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. Cable table Page 9

Describes the cable specifications required for connection.

5. Supported addresses Page 10

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “Keyence KV Series” is as follows:

Link I/F Communication method Communication setting
KV-N14
KV-N24 3. TOP communication
KV-Nano . .
Series KV-N40 CPU Direct RS-232C setting 5.1. Cable table 1
KV-N60 4. External device setting
KV-NC32

W Connection configuration

+ 1:1 (one TOP and one external device) connection
k[].]

| T
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device n

PLC select [COM1]

Filter : [ [all ~] Search
@Model () Vendor

Vendor Model

SANGII Predision Co., Ltd. " (@ KV-10/16/24/40

DEVA (@ KV-700,/1000/3000/5000/7000/3000

OPTICON
Barcode Reader BL Series

TOHMNICHT -
¢ 4 5
' KV NANO Series
Giddings & Lewis Motion Control

DELTA TAU Data Systems
Digital Electronics Corporation
HONEYWELL

MISUMI

PARKER HAMMIFIN Corporation
TOSHIBA

ATLAS COPCO

TOSHTRA MACHTNF Cn._ | +d %

. Eack | B Next ® Cancel

Settings

Contents

TOP Model

Check the TOP display and process to select the touch model.

External device | Vendor

Select the vendor of the external device to be connected to TOP.
Select "KEYENCE > KV Nano Series".

PLC

Select an external device to connect to TOP.

Interface Protocol

KEYENCE KV Nano Series Serial CPU Direct

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
W [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Opticn

[ cranoe Hmi W coapci ST Change PLCIC]

] Delete PLCID)

I‘?_Dm!ﬂllazns Date / Time Sync. = Screen Option  Unit Convert
ODHD_” Module Setting Project Option = Screen Change | HmiSetup | Global Lock & Touch  Project Style | Splash | PLC Buffer Sync.
-4 FieldBus {(J)
H --UBFID(U_) ] use HMI Setup I_l
v \;’_::VE;;EITBQ Hmi Setup Option Initialization Edit
L4 PLC1: KV NANO Series Project Setting "
~-fg® COM2 (1) HMIDisable =0
o Stevodenens
o e S s -1
-4 USBDevice (0) L:tch S:S;nrv(l
Communication Error Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
. | . = .
System m Devices :nﬂ Service (= Option
o Serial *
- -
1§ l 7 . Serial Port: | COM1 2
PLLC Security Dat e/ T ime Siagnal Level
(®) RS-232C () Rs-422(4) () Rs-485(2)
Baud Rate: 115200 S
0 0 e
i el | ) Data Bit: 8 .
Et hernet Serial HOM | Stop Bit: 1 -
Parity Bit: None v
= % Flow: [0ff
L el . Ping
—_— . Auto Search  Loopback Test
Diagnost ic File Fing
Manager
Apply Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 115200
Data Bit 8
Stop Bit 1
Parity Bit Even

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM1 > PLC1 : KV Nano Series]

Set the options of the communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' Add PLC[A] | THiTal Change PICIO | 1] Delete PLCID]

TOP Setting
- 5Y5 : RDOB20S
Option Module Setting
-4 FieldBus (0)
- RFID (0)
W - Device Setting

Vo COML (1)

PLC Setting[ KV NANO Series ]
Alizs Name : [PLC1

Interface : |Serial ~

Protocol : | CPU Direct ~

1w PLC1: KV NANO Series |

String Save Mode : (First LH HL Change

8 Ethernet (0)
® Wireless (0)
9 USBDevice (0)

[ use Redundancy

Primary Option

Timeout 200 &1 | msec
Send Wait msec
Retry 5 z

Comm Manual

Apply Close
Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol

Configure the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and
sending the next command request.

Retry

Configures the number of attempts for response reception by the TOP upon failure.
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conitroll Panel

e

=
!lil | 1 € .
w RS-2320C O RS-422(4) O PS-485(2)
FLC

Serial

Serial Port

Signal Leve

;| comt -
|

Security Date

Baud Rate: | 115200  |-|
¥YHC
Yiewer [.J-I..‘] . _ Data Bit: l g |'l
s | &
ru=u i Stop Bit: |1 -
] Et hernet Serial
. @8 Parity Bit: | Even -
LN BN -
Screen ; Flow: l Of f |vl
shot
_ _ _ ® lAuto Searchl [Loopback Testl
Diagnost ic h'IaFnlalgEer P
[ l Cancel l |
[System] Close f
——‘—
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 115200
Data Bit 8
Stop Bit 1
Parity Bit Even

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

Run

¥YHC

Yiewer

@ System

M

Ethernet

Diagnost ic

[System]

Dr iwver (COMT)

T ‘

Interface | Serial -
Protocol _CPU Direct -]
Timeout 300 5] msec

send Wait msec

Retry =

Diagnostic

TO,

ERI2 e B X
Touch Qperation Panel

O S0 PLC

PLCTCKY MNANO Series)

B
[ ADDIy]lCancel]

_,__....-|IIII||IIII

Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.

Retry

Configures the number of attempts for response reception by the TOP upon failure.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

5.1. Cable table 1

m RS-232C (1:1 connection)

coM1 Main Controller
Pin Signal Pin Cable connection Pin Signal :
Pin arrangement*Note 1)
arrangement*Note 1) name | number number name
RS422 1 1
1 5
) B RXD 2 2 TXD
e} o) TXD 3 —l 3 SG
6 9 RS422 4 4 RXD
Based on G 5 5
communication cable RS422 6 6
connector front,
. 5V I 123456
D-SUB 9 Pin male
GND 8 RJ-12 6-pin connector
(male, convex)
RS422 9

*Note 1) Pin arrangement is depicted as facing the interface of the cable connector in this figure. Unused pins are not connected.
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5. Supported addresses

The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the
address range supported by the device you want to use.

- KV-Nano Support Address

Contents Bit Address Word Address Note
DM Data Memory — 00000 - 32767
C™M Control Memory — 00000 - 8999
™ Temporary Data Memory — 000 - 511
TRM  Digital Trimmer — 0-7 32 Bit
CTH High-speed Counter (Current — 0-3 32 Bit
value)
CTC  High-speed Counter — 0-7 32 Bit
Comparator (Configured
value)
TS Timer (Configured value) — 0000 - 511 32 Bit
(& Counter (Configured value) — 0000 - 255 32 Bit
TC Timer (Current value) — 0000 - 511 32 Bit
CcC Counter (Current value) — 0000 - 255 32 Bit
-(R) Relay 000 — 599.15 000 - 599
CR Control Relay 00 - 89.15 00 -89
T Timer (contact) 0000 - 3999 —
C Counter 0000 — 3999 —
CTC  High-speed Counter — 0-7 Only Read
comparator (contact)
MR Internal Auxiliary Relay 000 - 599.15 000 - 599
LR Latch Relay 000 — 199.15 000 — 199
EM Extension Data Memory — 00000 - 32767
vMm | Work Memory — 0000 — 9999
z Index Register — 1-12 32 Bit
w | Link Register 0-3FFFF 0-3FFF
B | LinkLelay O-1FFFF 0-1FFF
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