NMEA 0183 Driver

Supported version  TOP Design Studio V1.0 or higher {Rl
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1. System configuration

The system configuration of TOP and “NMEA 0183" is as follows:

Series ‘ CPU ‘ Link I/F ‘ Communication method Communication setting

3. TOP communication
NMEA 0183 - - RS-232C setting 5. Cable table

4. External device setting
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device n

PLC select [COM1]

Filter : |[.q||] V‘ Search : l:l

@ Model () Vendor

Vendor Model

AJINEXTEK Co., Ltd.
IEC Standard

CAS

ARD

SEHWA CNM
SHINHAN Electronics
BONGSHIN LOADCELL
FANUC Co., Ltd.
MINEBEA Co., Ltd.

Azbil Corparation

KORQ TECHNOLOGY
ROBOSTAR
Fhmnanst v
‘ Back | . Next ® Cancel
Select Device a

PLC Setting[ NMEAD183 ]

Alias Name : PLC1

Interface : | Computer Link ~

Protocol : | NMEAQ 183 > Comm Manual
String Save Mode : |First LH HL Change

[J use Redundancy

Primary Option
@ Back « oK *® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "NMEA0183".
PLC Select an external device to connect to TOP.

Interface Protocol
NMEA0183 Computer Link NMEA0183

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option X
B cranoe i B ~aopc T changePicicl [ Delete PLCIDI
;'E;!_TOPS#”Q o Date / Time Sync. | Screen Option | Unit Convert
‘:'"I:izﬁsnlz‘;d“'éfﬁﬁﬂg Project Option || Screen Change | HmiSetup | Global Lock & Touch  Project Style | Splash | PLC Buffer Sync.
M E" 2 i\«'g;;elt?;g megenins Initialization Edit
-4 PLC1: NMEAD133 Start Mode=Menu -
i~fg¥ COM2 (0) Start Screen No, =1
COM3 (0) Latch Use=0
Ethernet (0) Latch Set=0n0
g s 0 e
-4 USBDevice (1) StorageErrarMegssagE=1
DatabaseMessage=1
SystemMessage=1
Control Fanel
System [ Devices Ena Service (="' 0ption
e Serial
S =
1 .
Serial Port: | COM1 &
PLC Secur ity Dat &/Time Signal Level
(® R5-232C O RS-422(4) O R5-485(2)
Baud Rate: 4300 "
i & e —/ Data Bit: 8 -
Ethernet Serial HOM Stop Bit: |1 v
Parity Bit: MNone o
— Flow: [Iff
;I \\
| —t Auto Search  Loopback Test
. Ping
Diagnost ic HaFnlalgEer Fing Apply Cance |
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 4800
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Project > Project Property > Device Setting > COM > “PLC1 : NMEA0183"]

— Set the options of the NMEA0183 communication driver in TOP Design Studio.

TOP ooz e
Touch Qperation Panel

Project Option

~ [ TOP Setting
[ 5v5 : RD1520X

T
- PLC1: NMEAD183
=y rae

1% COM3 (D)

Wireless (0)
-4 |USBDevice (0)

Primary Option

Option Module Setting Alias Name :
W FieldBus (0) Interface :
: 8 RFID (0)
v -igg Device Setting Protocol :

String Save Mode :

- Change HMI[H] ' Add PLC[A] | THTM ChangePLCICl | [ Delete PLCD)

PLC Setting[ NMEAO1832 ]

PLC1
Computer Link w
NMEAD183 e

First LH HL Change

[ use Redundancy
Ethernet (0) AND w

Comm Manual

Apply Close
Items Settings Remarks
Interface Select "Computer Link". Refer to "2. External
Protocol Select "NMEA0183". device selection”.
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Control Panel

Serial

Run
Serial Port: [CUW |'
Signal Level
‘ ® FS-232C O RS-422(4) O PS-485(2)

Baud Rate: [ 4300

_‘I'H[: |
Yiewer [I‘J-I"I] L-' Data Bit: [ o |
PEEy ""“l ) Stop Bit: [ 1 |v
] Et hernet Serial
:g Parity Bit: [ MNone |v

= |

il S Flov 106

[Auto Search] lLoopback Testl

Diagnost ic File
Manager

| Apply ” Cancel l —

[System] Close r

——-‘—

Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 4800
Data Bit 8
Stop Bit 1
Parity Bit None.
* The above settings are setting examples recommended by the company.
Items Description
Signal Level Select the serial communication method between the TOP and an external device.
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

Run

| Computer Link

| NMEAQ183

@ Svstel [river(COMI)
Interface
Protocol
(11
Et hernet
Diagnost ic
[System] [ Diagnostic

TO hEQIRE E AT
Touch Qperation Panel

O Tl PLC

| PLCT(NMEAO183)

=
| Aeply || Cancel |

el

Items Settings Remarks
Interface Select "Computer Link". Refer to "2. External
Protocol Select "NMEA0183". device selection”.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Refer to the vendor’s user manual to identically configure the communication settings of the external device to that of the TOP.
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “"NMEA0183")

W RS232C (1:1 connection)

coM External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangementNote 1) name number number name arrangementNote 1)
1 5 CD 1 1 CD 1 5
g S SD 3 3 SD g g
Based on DTR 4 4 DTR Based on
communication G 5 5 G communication
cable connector DSR 6 6 DSR cable connector
front, RTS 7 7 RTS front,
D-SUB 9 Pin male CTS 8 8 CTS D-SUB 9 Pin male
(male, convex) 9 9 (male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Description Device type
ZDA ZDAO01 uTtc FLOAT
ZDA02 Day DEC
ZDAO03 Month DEC
ZDA04 Year DEC
ZDAO05 LocalZoneHours DEC
ZDA06 LocalZoneMinutes DEC
XTE XTEO1 Status1 Character
XTEO2 Status2 Character
XTEO3 MagnitudeOfCrossTrackError FLOAT
XTEO4 DirectionToSteer Character
XTEO5 Modelndicator Character
VTG VTGO1 CourseOverGround FLOAT
VTGO02 CourseOverGroundind Character
VTGO3 CourseOverGroundMagnetic FLOAT
VTGO04 CourseOverGroundMagneticind Character
VTGO5 SpeedOverGroundKnots FLOAT
VTG06 SpeedOverGroundKnotsind Character
VTGO7 SpeedOverGroundKmh FLOAT
VTG08 SpeedOverGroundKmhind Character
VTG09 Modelndicator Character
VHW VHWO1 Heading FLOAT
VHWO02 HeadingInd Character
VHWO03 HeadingMagnetic FLOAT
VHWO04 HeadingMagneticind Character
VHWO05 SpeedKnots FLOAT
VHWO06 SpeedKnotsind Character
VHWO7 SpeedKmh FLOAT
VHWO08 SpeedKmhind Character
VDR VDRO1 Direction FLOAT
VDRO02 Directionind Character
VDRO3 DirectionMagnetic FLOAT
VDRO4 DirectionMagneticind Character
VDRO05 CurrentSpeed FLOAT
VDRO06 Currentspeedind Character
RMC RMCO1 uTC FLOAT
RMC02 Status Character
RMCO03 Latitude FLOAT
RMC04 Latitudelnd Character
RMCO05 Longitude FLOAT
RMCO06 Longitudelnd Character
RMCO07 SpeedOverGround FLOAT
RMCO08 CourseOverGround FLOAT
RMCO09 Date DEC
RMC10 MagneticVariation FLOAT
RMC11 MagneticVariationind Character
RMC12 Modelndicator Character
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Device Description Device type
RMB RMBO1 DataStatus Character
RMBO2 CrossTrackError FLOAT
RMBO3 DirectionToSteer Character
RMB0O4 OriginWaypointID Character
RMBO5 DestinationwaypointID Character
RMBO06 DestinationwaypointLat FLOAT
RMBO7 DestinationwaypointLatind Character
RMBO08 DestinationWaypointLongitude FLOAT
RMBO09 DestinationWaypointLongitudelnd Character
RMB10 RangeToDestination FLOAT
RMB11 BearingToDestination FLOAT
RMB12 DestinationClosingVelocity FLOAT
RMB13 Arrival Status Character
RMB14 Modelndicator Character
MWV MWVO01 WindAngle FLOAT
MWV02 Reference Character
MWVO03 WindSpeed FLOAT
MWV04 WindSpeedind Character
MWVO05 Status Character
MWD MWDO1 WindDirection FLOAT
MWDO02 WindDirectionInd Character
MWDO03 WindDirectionMagnetic FLOAT
MWDO04 WindDirectionMagneticind Character
MWDO05 WindSpeedKnots FLOAT
MWDO06 WindSpeedKnotsind Character
MWDO07 WindSpeedMs FLOAT
MWDO08 WindSpeedMsind Character
MTW MTWO1 Temperature FLOAT
MTWO02 Temperaturelnd Character
HDT HDTO1 Heading FLOAT
HDT02 HeadingInd Character
HDG HDGO1 MagneticHeading FLOAT
HDGO02 MagneticDeviation FLOAT
HDGO03 MagneticDeviationind Character
HDGO04 MagneticVariation FLOAT
HDGO5 MagneticVariation Character
GSA GSAO01 Mode Character
GSA02 Mode Character
GSA03 Mode DEC
GSA04 Mode DEC
GSA05 ID DEC
GSA06 ID DEC
GSA07 ID DEC
GSA08 ID DEC
GSA09 ID DEC
GSA10 ID DEC
GSA11 ID DEC
GSA12 ID DEC
GSA13 ID DEC
GSA14 ID DEC
GSA15 PDOP DEC
GSA16 HDOP FLOAT
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Device Description Device type
GSA17 VDOP FLOAT
GLL GLLO1 Latitude FLOAT
GLLO2 Latitudelnd Character
GLLO3 Longitude FLOAT
GLLO4 Longitudelnd Character
GLLO5 uTtc DEC
GLLO6 Status Character
GLLO7 Modelndicator Character
GGA GGAO1 uTtc FLOAT
GGAO02 Latitude FLOAT
GGAO03 Latitudelnd Character
GGAO4 Longitude FLOAT
GGAO05 Longitudelnd Character
GGAO06 QualityIndicator DEC
GGAOQ7 NumberOfSatellitesinUse DEC
GGAO08 HorizontalDilutionOfPrecision FLOAT
GGA09 Altitude FLOAT
GGA10 Altitudelnd Character
GGAT1 GeoidalSeparation FOLAT
GGA12 GeoidalSeparationind Character
GGA13 AgeOfDifferentialData FOLAT
GGA14 DifferentialReferencelD DEC
DBT DBTO1 WaterDepthFeet FLOAT
DBT02 WaterDepthFeetind Character
DBTO3 WaterDepthMeters FLOAT
DBT04 WaterDepthMetersind Character
DBTO5 WaterDepthFathoms FLOAT
DBT06 WaterDepthFathomsind Character
DPT DPTO1 WaterDepth FLOAT
DPTO2 OffsetFromTransducer FLOAT
DPTO3 MaximumRangeScale FLOAT

* For character devices: must configure max number of rows to 4 or less when registering character tags.
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