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FASTECH 

Ezi-SERVO Plus-R 

Ezi-MOTION Plus-R  
 Supported version TOP Design Studio V1.4.3 or higher  
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We want to thank our customers who use the Touch Operation Panel. 
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1. System configuration 

The system configuration of TOP and “FASTECH – Ezi-SERVO Plus-R Series” is as follows. 

 

Series CPU Link I/F 
Communication 

method 

Communication 

setting 
Cable 

EzM-20 

EzM-28 

EzM-42 

EzM-56 

EzM-60 

EzM-86 

EzS-NDR-20 

EzS-NDR-28 

EzS-NDR-42 

EzS-NDR-56 

EzS-NDR-60 

EzS-NDR-86 

RJ-45 Connector 

on Servo 

RS-485 

(2 wire) 

3. TOP 

communication 

setting 

4. TOP external device 

setting 

5.1. Cable table 1 

 

■ Connection configuration 

 

ㆍ1 : 1 ( one TOP and one external device) connection – Configuration available in RS 485 communication. 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select "FASTECH Co., Ltd." 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

FASTECH : Ezi-Servo Computer Link Ezi-Servo Protocol 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 

Items TOP External device Remarks 

Signal Level (port) RS-485 RS-485  

Baud Rate 115200  

Data Bit 8  

Stop Bit 1  

Parity Bit None  

* The above settings are examples recommended by the company. 

 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 



 

 External device connection manual for TOP Design Studio 5 / 12 

 (2) Communication option setting 

■ [ Project > Project properties > PLC settings > COM > “FASTECH : Ezi-Servo”] 

– Set the options of the Computer Link communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-485 RS-485  

Baud Rate 115200  

Data Bit 8  

Stop Bit 1  

Parity Bit None  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Station Num Set the prefix.  

Protocol Mode Select the version of the communication device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

Spped-related setting of FASTECH Ezi-Servo Plus-R is possible through FASTECH’s terminating switch.  

For more detailed setting methodthan described in this example, refer to Ezi-Servo user manual. 

 

1. Drive ID selection switch (SW1)  

 1) When using multiple modules connected to one Daisy Chain Network, it is used to designate a unique ID 

for each module. 

 2) It is a switch to set the ID of the module, which can designate total 16 numbers from 0 to F (15). 

 

 

2. Communication speed and terminating resistance selection switch (SW2) 

 SW2 sets the RS-485 communication speed with the central controller, and if the corresponding drive module is connected to the 

most end of one network segment, it decides whether to use the terminating resistance. 

SW2.1 decides whether to use the terminating resistance, and SW2.2 ~ SW2.4 is used to set the communication speed as follows. 

 

For high-speed communication, you can use the PCI Bus type RS-485 communcation board. 

SW2.1 SW2.2 SW2.3 SW2.4 Speed Baud[Bps] 

 

X OFF OFF OFF 9600 

X ON OFF OFF 19200 

X OFF ON OFF 38400 

X ON ON OFF 57600 

X OFF OFF ON 115200 *1) 

X ON OFF ON 230400 

X OFF ON ON 460800 

X ON ON ON 921600 

*Note 1) Default setting value. 

  

SW2.1 OFF:  Terminal resistance is OFF 

SW2.1 ON: Terminal resistance is ON 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “FASTECH – Ezi Servo Plus R”.) 

 

5.1. Cable table 1 

 

■ 1 : 1 connection RS-485 

(A) TOP COM Port (9 pin) 

TOP COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  1 GND 

 

Based on 

communication 

cable connector 

front, 

8-pin male RJ45  

(Male, convex) 

 2 2 GND 

 3 3 Data+ 

RDB 4 4 GND 

 5 5 GND 

SDA 6 6 Data- 

 7 7 GND 

 8 8 GND 

SDB 
9 Case Fame 

GND 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 
 

 

TOP COM 

Cable connection 

External device 

Pin arrangement 
Signal 

name 
Signal name 

 

╋  ╋ Data+ 

— — Data- 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Bit/Word Device 

Device Bit Address Word Address Detail R/W 

POSACT - POSACT Current position value R/W 

CURRSPD - CURRSPD Current speed R 

ALMCOD   ALMCOD Alarm status R 

SAT_AXIS SAT_AXIS0.0 – 1.15 SAT_AXIS0 – 1 Status information R 

POSCMD   POSCMD Position follow-up value R/W 

PARA_ - PARA_00 – 40 Parameter R/W 

POSERR - POSERR Position error R 

SAT_PT - SAT_PT PT status information R 

INPUT INPUT0.0 – 0.8 INPUT0 INPUT status information R 

OUTPUT OUTPUT0.0 – 0.8 OUTPUT0 OUTPUT status R/W 

PTINFO_ PTINFO_00.00 - 40.31 PTINFO_00 - 40 PT information R/W 

ABSPOS - ABSPOS Absolute position movement value W 

INCPOS - INCPOS Relative position movement value W 

POSSPD - POSSPD Position movement speed value W 

VELOCITY - VELOCITY Movement speed information W 

PT_NO - PT_NO PT number W 

LM_AMNT - LM_AMNT Quantity of linear interpolation target W 

LM_SLARR - LM_SLARR00 - 15 Array of ID number W 

LM_FEDR - LM_FEDR Speed reference value (Feed Rate) W 

LM_ACCD - LM_ACCD Acceleration/deceleration reference value W 

LM_POS - LM_POS00 - 15 Array of movement position W 

A_ABSPOS - A_ABSPOS Absolute position movement value W 

A_INCPOS - A_INCPOS Relative position movement value W 

A_POSSPD - A_POSSPD Position movement speed value W 

P_STSPD - P_STSPD Push position movement start speed value W 

P_MVSPD - P_MVSPD Push position movement speed value W 

P_MPOS - P_MPOS Push position movement absolute position value W 

P_ACC - P_ACC Push position movement acceleration time W 

P_DEC - P_DEC Push position movement deceleration time W 

P_TQRATE - P_TQRATE Push movement torque ratio W 

P_PMSPD - P_PMSPD Push movement operation speed W 

P_ENDPOS   P_ENDPOS Push motion absolute position value W 

P_STATUS - P_STATUS Push operation status information R 

T_RATIO - T_RATIO Load factor check value R 
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Bit Only Device 

Device Bit Address Word Address Detail R/W 

M_ESTOP M_ESTOP - Motion emergency stop W 

M_INCPOS M_INCPOS - Relative value setting W 

M_JOG M_JOG0 – 1 - JOG operation start W 

M_LIMIT M_LIMIT0 – 1 - LIMIT operation start W 

M_ORIGIN M_ORIGIN - Return to origin W 

MPAUSE MPAUSE - Operation pause R/W 

M_PTRUN M_PTRUN - PT operation W 

M_SGLEPT M_SGLEPT - 
Position table operation for one designated PT 

number 
W 

M_STOP M_STOP - Motion stop W 

ALMRST ALMRST - Alarm reset W 

SVN SVN - Servo On/Off R/W 

R_IOMAP R_IOMAP - IO setpoint request W 

R_ROMPT R_ROMPT - PT information request W 

W_ROMPMT W_ROMPMT - Save parameters W 

W_ROMPT W_ROMPT - Save parameters W 

M_ABSOVE M_ABSOVE - Absolute position value setting W 

M_ABSPOS M_ABSPOS - Operation start setting W 

M_INCOVE M_INCOVE - Relative value setting W 

M_VELOVE M_VELOVE - Speed change W 

A_STOP A_STOP - All stop W 

A_ESTOP A_ESTOP - All emergency stop W 

A_ORGMOV A_ORGMOV - All return to origin W 

A_ABSMOV A_ABSMOV - All move by absolute value W 

A_INCMOV A_INCMOV - All move by relative value W 

M_LINEAR M_LINEAR0 - ABS linear interpolation command W 

M_LINEAR M_LINEAR1 - INC linear interpolation command W 

P_PUSH P_PUSH0 - Push Stop Mod Run W 

P_PUSH P_PUSH1 - Push None-Stop Mod Run W 

 


