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MITSUBISHI Electric Corporation 

MELSEC FX5U Series  

SERIAL(MC Protocol Format1) 
 Supported version TOP Design Studio V1.4.11.31 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Cable table Page 10 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 12 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSEC FX5U- SERIAL” is as follows: 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

MELSEC-

Q 
FX5U CPU port RS-485 

3. TOP communication 

setting 

4. External device 

setting 

5. Cable table 

 

 

■ Connectable configuration 

 

ㆍ1:1 (one TOP and one external device) connection – configuration which is possible in RS–422/485 communication. 

 

 

ㆍ1:N (one TOP and multiple external devices) connection – configuration which is possible in RS–422/485 communication. 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Please select “MITSUBISHI Electric Corporation”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

MELSEC FX Series Computer Link MC Protocol Format1 FX5U 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project Property > TOP Setting ] → [ Project Options > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-485 RS-422/485  

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Project > Project Property > PLC Setting > COM > “PLC1 : MELSEC-FX Series”] 

– Set the options of the MELSEC-FX Series CPU Direct communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Fixed 

Protocol Select “MC Protocol 3C Format1 FX5U”. Fixed 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Station Num Enter the prefix of an external device.  

PC No Set the prefix of TOP.  
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3.2. Communication setting in TOP  

* This is a setting method when "Use HMI Setup" in the setting items in "3.1 TOP Design Studio" is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main Screen > Control Panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-422/485  RS-422/485  

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main Screen > Control Panel > PLC ] 
 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Fixed 

Protocol Select “MC Protocol 3C Format1 FX5U”. Fixed 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Station Num Enter the prefix of an external device.  

PC No Set the prefix of TOP.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

There are two ways to set up communications in the MELSEC-FX series - by setting up parameters in the MELSEC series Ladder 

Software "GX WORK3”, or by setting up data in the PLC's "Special Data Register”. For more detailed setting method than that 

described in this example, refer to the PLC user manual. 

 

■ Method 1: "GX WORK3"Configure Parameter Settings  

Step 1. From project window [Parameter] > double click [PLC parameter] and load pop-up Modul parameter. 

Step 2. Configure the Communication Protocol Type as shown below. 

 
 

Step 3. [Online] > Transmit the parameter set to [Write to PLC] and reset the PLC. 
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5. Cable table  

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “Mitsubishi Electric Corporation”) 
 

■ RS-232C (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 CD 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 RD 

SD 3 3 SD 

DTR 4 4 DTR 

SG 5 5 SG 

DSR 6 6 DSR 

RTS 7 7 RTS 

CTS 8 8 CTS 

 9 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDA 

 

 2 SDB 

 3 RDA 

RDB 4 RDB 

SG 5 SG 

SDA 6  

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDA 

 

 2 SDB 

 3 RDA 

RDB 4 RDB 

SG 5 SG 

SDA 6  

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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■ RS-485 (1:1 connection) 

COM 

Cable connection 

PLC 

Pin arrangement 
Signal 

name 

Signal 

name 
Pin arrangement 

 

╋  SDA 

 

— SDB 

SG RDA 

 

RDB 

SG 

 

 

 

■ RS-422(1:N connection) – Refer to 1:1 connection to connect in the following way: 

TOP Cable connection and signal 

direction 

PLC Cable connection and signal 

direction 

PLC 

Signal name Signal name Signal name 

RDA 

 

SDA 

 

SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 

 

 

■ RS-485 (1:N/N:1 connection) – Refer to 1:1 connection to connect in the following way. 

TOP Cable connection and signal 

direction 

PLC Cable connection and signal 

direction 

PLC 

Signal name Signal name Signal name 

RDA  SDA  SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

Device Bit Address Word Address Word Address NOTE 32 BIT 

Input Relay X0000 – X1777  X0000 – X1760 X***0 *Note 4) 

L/H 

*Note 3) 

Output Relay Y0000 - Y1777  Y0000 - Y1760  Y***0 *Note 4) 

Internal Relay M0000 – M7679 M0000 – M7664 M0000 + 16*n *Note 2) 

Special Relay SM0000 – SM9999 SM0000 – SM9984 SM0000 + 16*n *Note 2) 

Latch Relay L0000 - L7679 L0000 - L7664 L0000 + 16*n *Note 2) 

Annunciator F000 – F127 F000 – F112 F0000 + 16*n *Note 2) 

Step Relay S0000 – S4095 S0000 - S4080 S0000 + 16*n *Note 2) 

Link Relay B000 – B0FF (HEX) B000 – B0F0 (HEX) B***0 *Note 1) 

Special Link Relay SB000 - SB0FF (HEX) SB000 - SB0F0 (HEX) SB***0 *Note 1) 

Timer  

(contact) 
TS000 – TS511   

Timer  

(coil) 
TC000 - TC511   

Aggregate Timer  

(contact) 
SS000 – SS015   

Aggregate Timer 

 (coil) 
SC000 – SC015   

Counter  

(contact) 
CS000 - CS255   

Counter  

(coil) 
CC000 - CC255   

Timer  

(current value) 

 TN000 - TN511  

Aggregate Timer  

(current value) 
 SN000 – SN015  

Counter  

(current value) 
 CN000 – CN255  

Data Register D0000.00 – D7999.15 D0000 – D7999  

Special Data  

Register 
SD00000.00–SD11999.15 SD00000 – SD11999  

Link register W000.00~W1FF.15 W000~W1FF  

File registers R00000.00~R32767.15 R00000~R32767  

Link special register SW000.00~SW1FF.15 SW000~SW1FF.  

*Note 1) For bit addresses with hexadecimal “0~F” notations, use the initial 0 bit as the word address 

*Note 2) When using a bit address that uses decimals, use a word address in units of “16” 

*Note 3) The lower 16 BIT data of 32 BIT data is saved in the address whose screen has been registered, and the upper 16 BIT data 

is saved in the address next to the address whose screen has been registered. 

   Ex. When saving 32BIT data hexadecimal data 12345678 in address D00100, it is saved to 16BIT device address as follows: 

Items 32BIT 16BIT 

Address D00100 D00100 D00101 

Input data 

(hexadecimal) 
12345678 5678 1234 

*Note 4) Used with units of 20 (octal) when used as a word address. (Ex: X0, X20, X40, …, X160) 

 


