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IEC 60870-5-101  

Driver 

 
 Supported version TOP Design Studio V1.0 or higher  

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. Cable table Page 9 

 Describes the cable specifications required for connection. 

5. Communication setting Page 10 

 Refer to this section to check the addresses which can 

communicate with an external device. 

6. Device Page 12 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “IEC 60870-5-101” is as follows: 

 

Series Link I/F Communication method Communication setting Cable 

IEC 60870-5-101 - RS–232C 
3. TOP communication 

setting 
5.1. Cable table 1 

 

■ Connection configuration 

 

ㆍ1:1 (one TOP and one external device) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “IEC Standard”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

IEC 60870-5-101 IEC101 IEC60870-5-101 prtocotol 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project > Project Property > TOP Setting] → [Project Option > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 
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Items TOP External device Remarks 

Signal Level (port) RS-232C RS-232C Fixed 

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit NONE  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 

 

 (2) Communication option setting 

■ [ Project > Project Property > Device Setting > COM1 > “IEC 60870-5-101”] 

– Set the options of the Computer Link communication driver in TOP Design Studio. 

  
 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Main Screen > Control Panel > Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-232C Fixed 

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit NONE  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Main Screen > Control Panel > PLC] 
 

  

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

 

Items Description 

Common Address of ASDU Common Address of ASDU. 

Size of Link Address Select the Link Address Size. [1 or 2 Bytes] 

Size of ASDU Address Select the size of ASDU Address [1 or 2 Bytes] 

Size of Object Information Select the Size of Object Information address[1 or 2 or 3 Bytes] 

Size of Cause of Transmission Select the Size of Cause of Transmission [1 or 2 Bytes] 

Link Address Select the Link Address of the External Device/PLC 

Common Address of ASDU Address Select the Common ASDU Address of the External Device/PLC 

Name Address Object Information Name 

Start Address Address Object Information Start Address 

Range Address Object Information Range. 

Clock Sync.Interval Select the Time Interval (in minutes) to send Clock Synchronization 
command. 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module 

name) 
OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “IEC60870-5-101”) 

 

4.1. Cable table 1 
 

■ 1:1 connection  

COM Port (9 pin) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin number 

 

Based on 

communication cable 

connector front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 CD 

RD 2 2 RD 

SD 3 3 SD 

DTR 4 4 DTR 

SG 5 5 SG 

DSR 6 6 DSR 

RTS 7 7 RTS 

CTS 8 8 CTS 

 9 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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(5) Communication interface setting 
 

Network configuration 

- Multi-point-party line  

 

Physical layer 

Transmission speed 

-2400 bit/s 

-4800 bit/s 

-9600 bit/s 

-19200 bit/s (NOT Defined in 870-5-101) 

 

Linked layer 

Link transmission  

-  Unbalanced 

 

Address field of the link 

-  One octet 

-  Two octets 

 

Frame length  

-  255 Maximum length L (number of octets)  

 

Application layer 

Common address of ASDU  

-  One octet  

-  Two octets  

 

Information object address  

-  One octet  

-  Two octets  

-  Three octets  

 

Cause of transmission  

-  One octet  

-  Two octets 
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ASDUs 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Process information in monitor direction Name 

<1>    Single-point information  M_SP_NA_1  

<3>    Double-point information  M_DP_NA_1  

<5>    Step position information  M_ST_NA_1  

<11>   Measured value, scaled value  M_ME_NB_1  

<15>   Integrated totals  M_IT_NA_1  

<30>   Single-point information with time tag CP56Time2a  M_SP_TB_1  

<31>   Double-point information with time tag CP56Time2a  M_DP_TB_1  

<32>   Step position information with time tag CP56Time2a  M_ST_TB_1  

<35>   Measured value, scaled value with time tag CP56Time2a  M_ME_TE_1  

<37>   Integrated totals with time tag CP56Time2a  M_IT_TB_1  

Process information in control direction Name 

<45>   Single command  C_SC_NA_1  

<46>   Double command  C_DC_NA_1  

<47>   Regulating step command  C_RC_NA_1  

<48>   Set point command, normalized value  C_SE_NA_1  
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6. Device 
 

Device Name Description Range R/W 

SP Single Point Information 0–1999 Read only 

DP Double-Point Information 2000–3999 Read only 

ME Measured Value 4000–5999 Read only 

SC Single Command 6000–7999 Write only 

IT Integrated Totals 8000–9999 Read only 

ST Step Position Information 10000–11999 Read only 

SE Set Point Command 12000–13999 Write only 

DC Double Command 14000–15999 Write only 

RC Regulating Step Command 16000–17999 Write only 

(“Address range can be edited at PLC option. (User setting)[0–16777215](3 Byte) range settings should not overlap. ) 

 

Device 
Name 

Sub Category / Element 
Description Data 

Type 
Category Element 

 
 
 
 
 
 
 

 
SP 

 
 
 
 

SIQ 

SPI 
Single Point Information 0: OFF 
1: ON 

 

*1 

BL 
0: Not Blocked 
1: Blocked *1 

SB 
0: Not Substituted 
1: Substituted *1 

NT 
0: Topical 
1: Not Topical *1 

IV 
0: Valid 
1: Invalid *1 

 
 

 
TIME 

IV Valid *1 

SU Summer Time *1 

MSEC Milliseconds *2 

MIN Minute *2 

HOUR Hour *2 

DAY Day *2 

MONTH Month *2 

YEAR Year *2 

 
 

 
 
 
 

DP 

 
 

DIQ 

BL Blocked / Not Blocked *1 
SB Substituted / Not Substituted *1 
NT Topical / Not Topical *1 
IV Valid / Invalid *1 
DPI Double Point Information *2 

 
 

 
TIME 

IV Valid *1 

SU Summer Time *1 

MSEC Milliseconds *2 

MIN Minute *2 

HOUR Hour *2 

DAY Day *2 

MONTH Month *2 

YEAR Year *2 

 
 
 
 
 
 

ST 

VTI 
T Transient *1 
VAL Value *2 

 
 

QDS 

OV Overflow / No Overflow *1 
BL Blocked / Not Blocked *1 
SB Substituted / Not Substituted *1 
NT Topical / Not Topical *1 
IV Valid / Invalid *1 

 
 

 
TIME 

IV Valid *1 

SU Summer Time *1 

MSEC Milliseconds *2 

MIN Minute *2 

HOUR Hour *2 

DAY Day *2 

MONTH Month *2 

YEAR Year *2 
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Device 
Name 

Sub Category / Element 
Description Data 

Type 
Category Element 

 
 
 
 
 

 
ME 

 
 

QDS 

OV Overflow / No Overflow *1 

BL Blocked / Not Blocked *1 

SB Substituted / Not Substituted *1 

NT Topical / Not Topical *1 

IV Valid / Invalid *1 

VA VAL Measured Value *2 

 
 

 
TIME 

IV Valid *1 

SU Summer Time *1 

MSEC Milliseconds *2 

MIN Minute *2 

HOUR Hour *2 

DAY Day *2 

MONTH Month *2 

YEAR Year *2 

 
 
 
 
 
 

IT 

 
 

BCR 

VAL Counter value *2 

SQ Sequence *2 

CY 
(Carry) Counter Overflow / No 
Overflow *1 

CA 
Counter Adjusted / Not 
Adjusted *1 

IV Counter value Valid / Invalid *1 

 
 

 
TIME 

IV Valid *1 

SU Summer Time *1 

MSEC Milliseconds *2 

MIN Minute *2 

HOUR Hour *2 

DAY Day *2 

MONTH Month *2 

YEAR Year *2 

SC SCO SCS Single command state *1 

DC DCO DCS Double command state *2 

RC RCO RCS Regulating step command state *2 

SE VA VAL Value (Normalized / Scaled /short floating point) *2 
*1 Bit Address Only 
*2 Word Address Only 


